Subject: Possible addition to S-BFD use-case draft?

From: "Nobo Akiya (nobo)" <[email-masked]>
Date: Wed, 5 Mar 2014 16:06:07 +0000

Hi S-BFD use-case draft authors,

Document reads nicely, thank you!

I'd like to propose a possible addition to the S-BFD use-case draft.

BFD MPLS (RFC5884) states:

[snip]
   If there are multiple alternate paths from an ingress LSR to an
   egress LSR for an LDP IP FEC, LSP Ping traceroute MAY be used to
   determine each of these alternate paths.  A BFD session SHOULD be
   established for each alternate path that is discovered.
[snip]

Above implies that a BFD session should be bootstrapped per alternate (i.e. ECMP) path, but RFC does not have further details no how to create/maintain multiple BFD MPLS sessions per FEC. Questions I have are:
* How should egress de-multiplex the bootstrap request per alternate path?
* If/when number of alternate paths changes or hash key changes:
    - how should ingress delete BFD sessions on egress?
    - re-bootstrapping set of sessions can be [relatively] inefficient as that can consume time/resources.

Alternative is to use S-BFD for multiple alternate paths for a FEC, which eliminates the concerns raised from above questions ... and much simpler to implement and operate.

If you think this will be useful, perhaps we can add this in ...

http://tools.ietf.org/html/draft-aldrin-bfd-seamless-use-case-00#section-3.8

or a new sub-section can be created?

Of course action resulting from this multiple path failure detection is another question itself, but at least we can detect this more efficiently.

-Nobo
[as individual contributor]

---

From: Sam Aldrin <[email-masked]>
Date: Thu, 6 Mar 2014 11:27:23 +0000

Hi Nobo, 

I am presuming s-bfd can do this because label stack imposed has entropy label, and head end know/discovered all possible paths correct? 

If yes, I have few questions. Will email after ietf.

If no, could u explain more?

Sam

Sent from my iPhone

> On Mar 5, 2014, at 4:06 PM, "Nobo Akiya (nobo)" <[email-masked]> wrote:
>

---

From: "Nobo Akiya (nobo)" <[email-masked]>
Date: Thu, 6 Mar 2014 13:29:52 +0000

Hi Sam,

Thanks for comments.
Please see in-line.

> -----Original Message-----
> From: Sam Aldrin [mailto:[email-masked]]
> Sent: Thursday, March 06, 2014 6:27 AM
> To: Nobo Akiya (nobo)
> Cc: Sam Aldrin ([email-masked]); Bhatia, Manav (Manav)
> ([email-masked]); Gregory Mirsky
> ([email-masked]); Nagendra Kumar Nainar (naikumar);
> [email-masked]; [email-masked]
> Subject: Re: Possible addition to S-BFD use-case draft?
> 
> Hi Nobo,
> 
> I am presuming s-bfd can do this because label stack imposed has entropy
> label, and head end know/discovered all possible paths correct?

Correct. Entropy label is what I have in mind, although other entropies (hash keys) are possible in certain scenarios (ex: destination IP addresses, if network employs 3-tuple hashing).

> If yes, I have few questions. Will email after ietf.

Sure. As long as you don't ask about how entropies are discovered or what action should be taken if S-BFD on one of the ECMP paths fails. I know that you know the former one very well. The latter ... if you have good ideas, email me :)

-Nobo

> > Above implies that a BFD session should be bootstrapped per alternate
> (i.e. ECMP) path, but RFC does not have further details no how to
> create/maintain multiple BFD MPLS sessions per FEC. Questions I have are:
> > Alternative is to use S-BFD for multiple alternate paths for a FEC, which
> eliminates the concerns raised from above questions ... and much simpler
> to implement and operate.
> >
> > Of course action resulting from this multiple path failure detection is
> another question itself, but at least we can detect this more efficiently.
> >
> > -Nobo

---

From: Jeffrey Haas <[email-masked]>
Date: Thu, 13 Mar 2014 14:27:27 -0400

Nobo,

> Alternative is to use S-BFD for multiple alternate paths for a FEC, which eliminates the concerns raised from above questions ... and much simpler to implement and operate.

My impression is that the alternate paths are known via MPLS traceroute and
thus the BFD packet can have the appropriate label stack added.

-- Jeff (not terribly clueful here)

---

From: "Nobo Akiya (nobo)" <[email-masked]>
Date: Thu, 13 Mar 2014 20:12:35 +0000

Hi Jeff,

> From: Jeffrey Haas [mailto:[email-masked]]
> Sent: Thursday, March 13, 2014 2:27 PM
> To: Nobo Akiya (nobo)
> My impression is that the alternate paths are known via MPLS traceroute
> and thus the BFD packet can have the appropriate label stack added.

Yes, known via MPLS traceroute. Say this produces 8 ECMP paths. How do you bootstrap (and maintain) 8 BFD over MPLS sessions on this LSP?

-Nobo

---

From: "Nobo Akiya (nobo)" <[email-masked]>
Date: Thu, 13 Mar 2014 20:53:05 +0000

> From: Sam Aldrin [mailto:[email-masked]]
> Sent: Thursday, March 13, 2014 4:47 PM
> To: Nobo Akiya (nobo)
> Cc: Jeffrey Haas; Bhatia, Manav (Manav) (manav.bhatia@alcatel-
> lucent.com); Gregory Mirsky ([email-masked]); Nagendra
> Kumar Nainar (naikumar); [email-masked]; rtg-
> [email-masked]
> Sent from my iPad
> > On Mar 13, 2014, at 1:12 PM, "Nobo Akiya (nobo)" <[email-masked]>
> wrote:
> >
> > Hi Jeff,
> >
> >>>    - re-bootstrapping set of sessions can be [relatively]
> >>> inefficient as that
> >> can consume time/resources.
> >>>
> >> eliminates the concerns raised from above questions ... and much
> >> simpler to implement and operate.
> >>
> >> My impression is that the alternate paths are known via MPLS
> >> traceroute and thus the BFD packet can have the appropriate label stack
> added.
> >
> > Yes, known via MPLS traceroute. Say this produces 8 ECMP paths. How do
> you bootstrap (and maintain) 8 BFD over MPLS sessions on this LSP?
> Paths identified by MPLS trace route are not unique with label stack because
> Dst local host address also uniquely identifies the path. If the same is used
> for BFD, do you plan to use local host as Dst address as well?

Agree. I think Jeff meant (label stack with unique EL).

Yes BFD over MPLS mandates usage of locahost (or v4 localhost mapped v6), see RFC5884.

Whether MPLS traceroute discovered entropy can be used by BFD to traverse expected path is a separate question. But assuming that it _is_ possible (whether EL or non-EL w/ 3-tuple hashing), then how do we do BFD over MPLS per ECMP paths of LSP was my question, and implying that S-BFD is much better fit for this job :)

-Nobo