Subject: Question on DHCP

From: "Snyder, Brian" <[email-masked]>
Date: Thu, 13 Mar 2014 18:38:32 +0000

Hi all.

I suspect the answer is NO, as I have seen no other mention of DHCP hooks in the RFC or configuration guides, but thougth I'd double check.

If say the router was receiving it's WAN interface via DHCP, and then say OSPF was peered, I know how BFD could shut down the OSPF peer if a link went down in between.  Is it possible or considered to hook up the receipt of the dynamic IP address to the BFD state as well?  So if BFD control flow failed, one could trigger DHCP to try and reacquire an IP address on that interface?    If the answer is NO as I suggest, would this list have any potential ideas on how to go about doing so  (there are likely lots of router tricks I am unfamiliar with ;)).

Regards,
Brian

---

From: Jeffrey Haas <[email-masked]>
Date: Thu, 13 Mar 2014 14:51:44 -0400

Brian,

> If say the router was receiving it's WAN interface via DHCP, and then say OSPF was peered, I know how BFD could shut down the OSPF peer if a link went down in between.  Is it possible or considered…

At one point, support for DHCP was a WG chartered item.  However, work never
proceeded on it.

There's no reason why CPE couldn't establish a low-speed BFD session with
the BNG for the purpose you're wanting.  I'm not sure any specific
standardization requirements are necessary, unless the goal is to seed BFD
Discriminator values for such sessions as part of DHCP handshake.

-- Jeff

---

From: "Snyder, Brian" <[email-masked]>
Date: Thu, 13 Mar 2014 18:53:25 +0000

Sure. We could do it ourselves in our code, but if big guys like Cisco or Juniper don't support this, then we can only go so far on our own ;)  If I understand your message correctly , no standardization of this functionality has occurred - so likely no one supports it.  Correct?

Forgive my ignorance, I'm kinda new to talking on these types of groups, but how would one go about getting this 'back on the docket' so to speak?

Thanks,
brian

-----Original Message-----
From: Jeffrey Haas [mailto:[email-masked]] 
Sent: Thursday, March 13, 2014 2:52 PM
To: Snyder, Brian
Cc: [email-masked]
Subject: Re: Question on DHCP

Brian,

> If say the router was receiving it's WAN interface via DHCP, and then say OSPF was peered, I know how BFD could shut down the OSPF peer if a link went down in between.  Is it possible or considered…

At one point, support for DHCP was a WG chartered item.  However, work never proceeded on it.

There's no reason why CPE couldn't establish a low-speed BFD session with the BNG for the purpose you're wanting.  I'm not sure any specific standardization requirements are necessary, unless the goal is to seed BFD Discriminator values for such sessions as part of DHCP handshake.

-- Jeff

---

From: Marc Binderberger <[email-masked]>
Date: Thu, 13 Mar 2014 11:54:54 -0700

Hello Brian,

don't think this is a problem to be solved within the BFD protocol - 
which this list is for. Sounds more like a router-specific question.

Difficult to make statements about what routers can do - it's 
implementation specific, details are usually closed and proprietary. 
Generally speaking: the "BFD process" could implement an API to inform 
when a particular session changes state. In your case the "DHCP 
process" could use such an API to learn about the BFD session on the 
interface going down.

Again, this is an implementation specific aspect, not related to the 
BFD protocol itself.

Regards, Marc

On Thu, 13 Mar 2014 18:38:32 +0000, Snyder, Brian wrote:
> Hi all.
>  
> I suspect the answer is NO, as I have seen no other mention of DHCP 
> hooks in the RFC or configuration guides, but thougth I’d double 
> check.
>  
>  
> If say the router was receiving it’s WAN interface via DHCP, and then 
> say OSPF was peered, I know how BFD could shut down the OSPF peer if 
> a link went down in between.  Is it possible or considered to hook up 
> the receipt of the dynamic IP address to the BFD state as well?  So 
> if BFD control flow failed, one could trigger DHCP to try and 
> reacquire an IP address on that interface?    If the answer is NO as 
> I suggest, would this list have any potential ideas on how to go 
> about doing so  (there are likely lots of router tricks I am 
> unfamiliar with ;)).
>  
> Regards,
> Brian

---

From: Jeffrey Haas <[email-masked]>
Date: Thu, 13 Mar 2014 14:57:42 -0400

> Sure. We could do it ourselves in our code, but if big guys like Cisco or Juniper don't support this, then we can only go so far on our own ;)  If I understand your message correctly , no standardi…

The fact that there was previously a WG item suggested that someone was
interested in it, but no standardization happened in BFD.  As I said, this
is mostly a matter of simply using standard BFD with the potential case of
an interesting bootstrap scenario - and that may be not necessary.

Since the necessary standardization hooks are either unnecessary or very low
and within scope of the existing protocol, we may not know about them.

> Forgive my ignorance, I'm kinda new to talking on these types of groups, but how would one go about getting this 'back on the docket' so to speak?

BFD and DHCP are standardized in IETF.  The use cases you're concerned with
may be getting standardized in other bodies such as the Broadband Forum.
I'm not active in that organization and don't have a helpful pointer.
Sorry.

-- Jeff

---

From: Santosh P K <[email-masked]>
Date: Thu, 13 Mar 2014 19:23:49 +0000

Hello Brain,
	WT-146 broadband document recommends use of BFD for DHCP. 

Thanks
Santos  P K 

> From: Rtg-bfd [mailto:[email-masked]] On Behalf Of Jeffrey Haas
> Sent: Friday, March 14, 2014 12:28 AM
> To: Snyder, Brian
> Cc: [email-masked]
> > Sure. We could do it ourselves in our code, but if big guys like Cisco or Juniper
> don't support this, then we can only go so far on our own ;)  If I understand your
> message correctly , no standardization of this functionality has occurred - so
> likely no one supports it.  Correct?
> 
> interested in it, but no standardization happened in BFD.  As I said, this is mostly
> a matter of simply using standard BFD with the potential case of an interesting
> bootstrap scenario - and that may be not necessary.
> 
> > Forgive my ignorance, I'm kinda new to talking on these types of groups, but
> how would one go about getting this 'back on the docket' so to speak?
>