Subject: RE: New Version Notification for draft-vgovindan-l2vpn-evpn-bfd-01.txt

From: "Nobo Akiya (nobo)" <[email-masked]>
Date: Wed, 5 Mar 2014 16:06:21 +0000

[chair hat on]

Thanks for bring this draft to our attention.

All, please review and provide comments.

One point of the draft which I would like to point out & seek input/comments from BFDers ...

Draft uses LSP ping to bootstrap sessions on egress, for EVPN FEC.
Draft leaves room for bootstrapping/running BFD session per ECMP path, for EVPN FEC.

Do we want these texts to remain, which allows EVPN layer to monitor ECMP paths of MPLS layer?
Or do we want ECMP monitor to be left at MPLS layer?

Comments?

-Nobo

> -----Original Message-----
> From: Rtg-bfd [mailto:[email-masked]] On Behalf Of Vengada
> Prasad Govindan (venggovi)
> Sent: Friday, February 14, 2014 6:25 AM
> To: [email-masked]
> Cc: Samer Salam (ssalam); Ali Sajassi (sajassi)
> Subject: FW: New Version Notification for draft-vgovindan-l2vpn-evpn-bfd-
> 01.txt
> 
> Hello all,
>   FYI, the latest revision of the following draft may be of interest to the
> members of the BFD WG as well.
> Thanks
> Prasad
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: Friday, February 14, 2014 12:03 PM
> To: Samer Salam (ssalam); Samer Salam (ssalam); Vengada Prasad
> Govindan (venggovi); Vengada Prasad Govindan (venggovi); Ali Sajassi
> (sajassi); Ali Sajassi (sajassi)
> Subject: New Version Notification for draft-vgovindan-l2vpn-evpn-bfd-
> 01.txt
> 
> 
> A new version of I-D, draft-vgovindan-l2vpn-evpn-bfd-01.txt
> has been successfully submitted by Vengada Prasad Govindan and posted
> to the IETF repository.
> 
> Name:		draft-vgovindan-l2vpn-evpn-bfd
> Revision:	01
> Title:		Proactive fault detection in EVPN
> Document date:	2014-02-14
> Group:		Individual Submission
> Pages:		9
> URL:            http://www.ietf.org/internet-drafts/draft-vgovindan-l2vpn-
> evpn-bfd-01.txt
> Status:         https://datatracker.ietf.org/doc/draft-vgovindan-l2vpn-evpn-
> bfd/
> Htmlized:       http://tools.ietf.org/html/draft-vgovindan-l2vpn-evpn-bfd-01
> Diff:           http://www.ietf.org/rfcdiff?url2=draft-vgovindan-l2vpn-evpn-
> bfd-01
> 
> Abstract:
>    This document proposes a proactive, in-band network OAM mechanism
> to
>    detect connectivity faults that affect unicast and multi-destination
>    paths in an EVPN network. The multi-destination paths are used by
>    Broadcast, unknown Unicast and Multicast (BUM) traffic. The
>    mechanisms proposed in the draft use the principles of the widely
>    adopted Bidirectional Forwarding Detection (BFD) protocol.
> 
> 
> 
> 
> Please note that it may take a couple of minutes from the time of
> submission until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat

---

From: Gregory Mirsky <[email-masked]>
Date: Wed, 5 Mar 2014 22:57:41 +0000

Hi Nobo, et. al,
I am not convinced that there's strong requirement to monitor, and I'd stress "monitor", ECMP path from an arbitrary head-end PE. I think that there's requirement to traverse or verify ECMP paths. And to verify/traverse S-BFD or LSP Ping may be used. At the same time monitoring of ECMP should be between end-points of ECMP a'la LAG monitoring in micro-BFD. I'm not sure if we can call this "link layer" but since ECMP is an example of Composite Link, saying that ECMP should be monitored at link layer may be not too far off.

	Regards,
		Greg

-----Original Message-----
From: Rtg-bfd [mailto:[email-masked]] On Behalf Of Nobo Akiya (nobo)
Sent: Wednesday, March 05, 2014 8:06 AM
To: Vengada Prasad Govindan (venggovi); [email-masked]
Cc: Samer Salam (ssalam); Ali Sajassi (sajassi)
Subject: RE: New Version Notification for draft-vgovindan-l2vpn-evpn-bfd-01.txt

[chair hat on]

Comments?

-Nobo

> Subject: FW: New Version Notification for 
> draft-vgovindan-l2vpn-evpn-bfd- 01.txt
> 
> Hello all,
>   FYI, the latest revision of the following draft may be of interest 
> to the members of the BFD WG as well.
> Thanks
> Prasad

---

From: "Nobo Akiya (nobo)" <[email-masked]>
Date: Thu, 6 Mar 2014 00:10:51 +0000

Hi Greg,

Thanks for comments.
Please see in-line.

> From: Gregory Mirsky [mailto:[email-masked]]
> Sent: Wednesday, March 05, 2014 5:58 PM
> To: Nobo Akiya (nobo); Vengada Prasad Govindan (venggovi); rtg-
> [email-masked]
> I am not convinced that there's strong requirement to monitor, and I'd
> stress "monitor", ECMP path from an arbitrary head-end PE. I think that
> there's requirement to traverse or verify ECMP paths.

Yes it would be great to see more requirements around this.

For this draft (EVPN BFD) purpose, I believe the question is, on which layer. If MPLS network has ECMP, then verifying of ECMP should be done at MPLS network layer, not at VPN layer traversing over MPLS network.

http://datatracker.ietf.org/doc/draft-salam-l2vpn-evpn-oam-req-frmwk/?include_text=1

[snip]
   - all paths. For MPLS/IP networks with ECMP, monitoring of all
   unicast paths between MEPs (on non-adjacent nodes) may not be
   possible, since the per-hop ECMP hashing behavior may yield
   situations where it is impossible for a MEP to pick flow entropy
   characteristics that result in exercising the exhaustive set of ECMP
   paths. Monitoring of all ECMP paths between MEPs (on non-adjacent
   nodes) is not a requirement for E-VPN OAM.
[snip]

Which is more reason I question the presence of ECMP support in draft-vgovindan-l2vpn-evpn-bfd-01. My opinion would be, it's safer to take out the texts to allow running BFD for EVPN per ECMP on MPLS layer. If required in future, write an extension draft. I believe authors of draft-vgovindan-l2vpn-evpn-bfd wants to hear more opinion from this list.

> And to verify/traverse S-BFD or LSP Ping may be used.

Agree.

> At the same time
> monitoring of ECMP should be between end-points of ECMP a'la LAG
> monitoring in micro-BFD. I'm not sure if we can call this "link layer" but
> since ECMP is an example of Composite Link, saying that ECMP should be
> monitored at link layer may be not too far off.

I agree that ECMP branch node is in the best position to take action, although I do not want to exclude running the "monitor" from head-end PE (or any other device for that matter), until, as you said, we see more requirements and use-cases around this.

-Nobo

---

From: Sam Aldrin <[email-masked]>
Date: Thu, 6 Mar 2014 11:22:52 +0000

Comments inline.

Sent from my iPhone

> On Mar 6, 2014, at 12:10 AM, "Nobo Akiya (nobo)" <[email-masked]> wrote:
> 
> Hi Greg,
> 
> Thanks for comments.
> Please see in-line.
> 
In addition I would also like to see how these requirements feed into use case/real scenario.
>   nodes) is not a requirement for E-VPN OAM.
Being co-author of the requirements draft, I feel this is very important. Maintaining layering boundary when and oam is used should be carefully considered when designing solution.
> Which is more reason I question the presence of ECMP support in draft-vgovindan-l2vpn-evpn-bfd-01. My opinion would be, it's safer to take out the texts to allow running BFD for EVPN per ECMP on MP…
I concur. 
> I agree that ECMP branch node is in the best position to take action, although I do not want to exclude running the "monitor" from head-end PE (or any other device for that matter), until, as you s…
Before we say 'this' is a requirement, use case has to be in place or explained with existing solutions in mind as solution option. Only if there are gaps, solution has to be proposed, IMO. Otherwise we will be putting cart before the donkey.

Sam