Subject: RE: AD review of draft-ietf-bfd-tc-mib

From: "Nobo Akiya (nobo)" <[email-masked]>
Date: Sun, 13 Apr 2014 23:07:37 +0000

Hi Adrian,

Also thank you so much for thorough review of this document!
Please see comments/reply in-line.

> -----Original Message-----
> From: Rtg-bfd [mailto:[email-masked]] On Behalf Of Adrian Farrel
> Sent: Sunday, December 29, 2013 2:59 PM
> To: [email-masked]
> Cc: [email-masked]
> Subject: AD review of draft-ietf-bfd-tc-mib
> 
> Hi authors of draft-ietf-bfd-tc-mib,
> 
> I am doing my AD review of this document having received the publication
> request. The purpose of my review is to clear up any issues that might
> otherwise show up during IETF last call or IESG review.
> 
> During my review I have found a number of minor issues with the MIB
> module. I don't think any substantially change the definitions, but I do think
> that some editorial work is needed. I believe there will be knock- on
> editorial changes to draft-ietf-bfd-mib, but nothing of substance that will
> impact that document.
> 
> I will put this document into "Revised I-D State", but I would be happy to
> discuss any of these points if you think that changes are not needed.
> 
> Thanks for the work.
> 
> Adrian
> 
> ===
> 
> Tom may want to update his coordinates.

Done.

> 
> ---
> 
> I think the Abstract should note that the TCs defined here are maintained by
> IANA as this is an important feature.
> 
> BUT...
> 
> I don't see why all of these TCs are in an IANA module. It seems that a
> number of them would not be updated by IANA upon the allocation of new
> protocol code points. I believe the following should be moved to their own
> module and out of the IANA module...
> 
> IANAbfdSessIndexTC
> IANAbfdIntervalTC
> IANAbfdMultiplierTC
> IANAbfdCtrlDestPortNumberTC (unless you propose to define explicit
>                              enumerations) IANAbfdCtrlSourcePortNumberTC
> 
> I am suspicious of some of the other TCs as well. Really, an IANA module
> should be used for TCs that mirror registries. Do the other TCs actually
> mirror registries? If so you should say which. If not, then you should
> probably move them out of the IANA module as well.

True. We have split them up into BFD TC and IANA maintained TC.

> 
> ---
> 
> Could you swap Sections 1 and 2 so that the document begins with the
> Introduction.

Done.

> 
> ---
> 
> A number of TCs could usefully have Reference clauses so that the meaning
> of the TC is more clearly understood.

Done.

-Nobo, on behalf of authors

---

From: "Adrian Farrel" <[email-masked]>
Date: Mon, 14 Apr 2014 08:24:11 +0100

Hi again,

All changes look good.

Thanks for the work,
Adrian

---

From: Thomas Nadeau <[email-masked]>
Date: Mon, 14 Apr 2014 05:21:38 -0400

Cool. Thx for looking.

Tom

> On Apr 14, 2014, at 3:24 AM, "Adrian Farrel" <[email-masked]> wrote:
> 
> Hi again,
> 
> All changes look good.
> 
> Thanks for the work,
> Adrian
> 
>