Subject: New version notification for draft-akiya-bfd-seamless-base-03.txt

From: "MALLIK MUDIGONDA (mmudigon)" <[email-masked]>
Date: Thu, 17 Apr 2014 12:50:12 +0000

Hello BFD WG Members,

We have published a new version of Seamless BFD draft, draft-akiya-bfd-seamless-base-03. Several sections have been updated for improving readability. It also has a few technical changes as well. Please review the draft and get back to us with your comments.

Thanks

Regards
Mallik

---

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Tue, 29 Apr 2014 04:48:53 +0000

Section 2 says

"Each protocol instance (e.g. OSPF/IS-IS) allocates one or more BFD
   discriminators on its network node..."

I don't see the BFD clients as the "allocators". BFD owns its discriminator space and will therefore have to do the allocation. Further, there are certainly use cases where there is no need for a "per client discriminator" - so the suggestion that "each protocol instance" has to have a unique discriminator isn't accurate.

I understand that in some cases a protocol identifier (e.g. router-id) might be used either as the public discriminator or as a seed for the public discriminator - but that is not at all the same thing as acting as the allocator. I also understand IGPs may be used to advertise the public discriminators - but again this is not "allocating".

I think all mention of BFD clients should be removed from this section and you should simply say "BFD on a network node allocates ..."

   Les

From: Rtg-bfd [mailto:[email-masked]] On Behalf Of MALLIK MUDIGONDA (mmudigon)
Sent: Thursday, April 17, 2014 5:50 AM
To: [email-masked]
Subject: New version notification for draft-akiya-bfd-seamless-base-03.txt

Hello BFD WG Members,

Thanks

Regards
Mallik

---

From: "Nobo Akiya (nobo)" <[email-masked]>
Date: Thu, 1 May 2014 00:27:21 +0000

Hi Les,

That's a good point. Like you said, with certain cases, application might request S-BFD discriminator allocation, to BFD, with specific value, but this is still BFD allocating the discriminator. And apps can certain share the same S-BFD discriminator if for same purpose. So I agree, section 2 should get reworded to clarify these.

-Nobo

From: Rtg-bfd [mailto:[email-masked]] On Behalf Of Les Ginsberg (ginsberg)
Sent: Tuesday, April 29, 2014 12:49 AM
To: MALLIK MUDIGONDA (mmudigon); [email-masked]
Subject: RE: New version notification for draft-akiya-bfd-seamless-base-03.txt

Section 2 says

   Les

From: Rtg-bfd [mailto:[email-masked]] On Behalf Of MALLIK MUDIGONDA (mmudigon)
Sent: Thursday, April 17, 2014 5:50 AM
To: [email-masked]<mailto:[email-masked]>
Subject: New version notification for draft-akiya-bfd-seamless-base-03.txt

Hello BFD WG Members,

Thanks

Regards
Mallik