Subject: Proposed BFD Charter -08

From: Jeffrey Haas <[email-masked]>
Date: Wed, 7 May 2014 16:52:31 -0400

Working Group,

The following charter is proposed to be -08.  The existing charter is here:
http://datatracker.ietf.org/doc/charter-ietf-bfd/

Changes:
Update to reflect that there are still MIBs that are in-charter that aren't
done, in particular the bfd mpls MIB.  The authentication MIB extension is
still covered by 2b.

Remove the charter item for MPLS-TP.  I believe this work is done, but am
copying the MPLS chairs to confirm.

Remove BFD on LAG.  While there had been some discussion about providing for
bootstrapping mechanisms for it, they have failed to gain traction several
times.  Thus, I think we're done on this.

Add the S-BFD charter item.

Proposed milestones for S-BFD work:
Use Case document: November 2014
S-BFD base: March 2015
S-BFD for IP: July 2015
S-BFD for SR: July 2015
S-BFD alert discriminator: July 2015

Please provide comments ASAP.  Since I don't really expect any of this to be
controversial, the intent is for our AD to take this to the next telechat
which takes place next week.

-- Jeff

---------------------------8<----- cut here ---->8---------------------------

The BFD Working Group is chartered to standardize and support the
bidirectional forwarding detection protocol (BFD) and its extensions.  A
core goal of the working group is to standardize BFD in the context of 
IP routing, or protocols such as MPLS that are based on IP routing, in a 
way that will encourage multiple, inter-operable vendor implementations.  
The Working Group will also provide advice and guidance on BFD to other 
working groups or standards bodies as requested.

BFD is a protocol intended to detect faults in the bidirectional path
between two forwarding engines, including physical interfaces,
subinterfaces, data link(s), and to the extent possible the forwarding
engines themselves, with potentially very low latency. It operates
independently of media, data protocols, and routing protocols. An
additional goal is to provide a single mechanism that can be used for
liveness detection over any media, at any protocol layer, with
a wide range of detection times and overhead, to avoid a proliferation
of different methods.

Important characteristics of BFD include:

- Simple, fixed-field encoding to facilitate implementations in 
  hardware.

- Independence of the data protocol being forwarded between two systems.
  BFD packets are carried as the payload of whatever encapsulating 
  protocol is appropriate for the medium and network.

- Path independence: BFD can provide failure detection on any kind of 
  path between systems, including direct physical links, virtual 
  circuits, tunnels, MPLS LSPs, multihop routed paths, and 
  unidirectional links (so long as there is some return path, of 
  course).

- Ability to be bootstrapped by any other protocol that automatically 
  forms peer, neighbor or adjacency relationships to seed BFD endpoint 
  discovery.

The working group is currently chartered to complete the following work items:

1. Develop the MIB modules for BFD and submit them to the IESG for 
publication as a Proposed Standard.

2a. Provide a generic keying-based cryptographic authentication 
mechanism for the BFD protocol in discussion with the KARP working 
group.  This mechanism  will support authentication through a key 
identifier for the BFD session's Security Association rather than 
specifying new authentication extensions.  

2b. Provide extensions to the BFD MIB in support of the generic keying-
based cryptographic authentication mechanism.

2c. Specify cryptographic authentication procedures for the BFD protocol
using HMAC-SHA-256 (possibly truncated to a smaller integrity check 
value but not beyond commonly accepted lengths to ensure security) using 
the generic keying-based cryptographic authentication mechanism.

3. Provide an extension to the BFD core protocol in support of point-to-
multipoint links and networks.

4. Provide an informational document to recommend standardized timers 
and timer operations for BFD when used in different applications.

5. Define a mechanism to perform single-ended path (i.e. continuity)
verification based on the BFD specification.  Allow such a mechanism to work
both proactively and on-demand, without prominent initial delay.  Allow the
mechanism to maintain multiple sessions to a target entity and between the same
pair of network entities. In doing this work, the WG will work closely with at
least the following other WGs: ISIS, OSPF, SPRING.

The working group will maintain a relationship with the KARP and MPLS 
working groups, and will communicate with the IEEE with respect to BFD
over LAGs.
commit 85577b8dd7f7d7b98d65507cc4473e39df18dcb3
Author: Jeffrey Haas <[email-masked]>
Date:   Wed May 7 16:40:37 2014 -0400

    Proposed -08

diff --git a/bfd-charter.txt b/bfd-charter.txt
index 12f6950..0d691d8 100644
--- a/bfd-charter.txt
+++ b/bfd-charter.txt
@@ -35,9 +35,9 @@ Important characteristics of BFD include:
   forms peer, neighbor or adjacency relationships to seed BFD endpoint 
   discovery.
 
-The working group is chartered to complete the following work items:
+The working group is currently chartered to complete the following work items:
 
-1. Develop the MIB module for BFD and submit it to the IESG for 
+1. Develop the MIB modules for BFD and submit them to the IESG for 
 publication as a Proposed Standard.
 
 2a. Provide a generic keying-based cryptographic authentication 
@@ -57,16 +57,16 @@ the generic keying-based cryptographic authentication mechanism.
 3. Provide an extension to the BFD core protocol in support of point-to-
 multipoint links and networks.
 
-4. Assist the MPLS working group in the standardization of the BFD 
-protocol for MPLS-TP.  The preferred solution will be interoperable with 
-the current BFD specification.
-
-5. Provide one or more mechanisms to run BFD over Link Aggregation Group
-Interfaces.
-
-6. Provide an informational document to recommend standardized timers 
+4. Provide an informational document to recommend standardized timers 
 and timer operations for BFD when used in different applications.
 
+5. Define a mechanism to perform single-ended path (i.e. continuity)
+verification based on the BFD specification.  Allow such a mechanism to work
+both proactively and on-demand, without prominent initial delay.  Allow the
+mechanism to maintain multiple sessions to a target entity and between the same
+pair of network entities. In doing this work, the WG will work closely with at
+least the following other WGs: ISIS, OSPF, SPRING.
+
 The working group will maintain a relationship with the KARP and MPLS 
 working groups, and will communicate with the IEEE with respect to BFD
 over LAGs.

---

From: Gregory Mirsky <[email-masked]>
Date: Wed, 7 May 2014 20:55:51 +0000

Hi Jeff,
I think there will be use of S-BFD for MPLS as well. Can we add it with July 2015 target?

	Regards,
		Greg

-----Original Message-----
From: Rtg-bfd [mailto:[email-masked]] On Behalf Of Jeffrey Haas
Sent: Wednesday, May 07, 2014 1:53 PM
To: [email-masked]; Adrian Farrel
Cc: [email-masked]
Subject: Proposed BFD Charter -08

Working Group,

Changes:
Update to reflect that there are still MIBs that are in-charter that aren't done, in particular the bfd mpls MIB.  The authentication MIB extension is still covered by 2b.

Remove the charter item for MPLS-TP.  I believe this work is done, but am copying the MPLS chairs to confirm.

Remove BFD on LAG.  While there had been some discussion about providing for bootstrapping mechanisms for it, they have failed to gain traction several times.  Thus, I think we're done on this.

Please provide comments ASAP.  Since I don't really expect any of this to be controversial, the intent is for our AD to take this to the next telechat which takes place next week.

-- Jeff

The BFD Working Group is chartered to standardize and support the bidirectional forwarding detection protocol (BFD) and its extensions.  A core goal of the working group is to standardize BFD in the context of IP routing, or protocols such as MPLS that are based on IP routing, in a way that will encourage multiple, inter-operable vendor implementations.  
The Working Group will also provide advice and guidance on BFD to other working groups or standards bodies as requested.

BFD is a protocol intended to detect faults in the bidirectional path between two forwarding engines, including physical interfaces, subinterfaces, data link(s), and to the extent possible the forwarding engines themselves, with potentially very low latency. It operates independently of media, data protocols, and routing protocols. An additional goal is to provide a single mechanism that can be used for liveness detection over any media, at any protocol layer, with a wide range of detection times and overhead, to avoid a proliferation of different methods.

1. Develop the MIB modules for BFD and submit them to the IESG for publication as a Proposed Standard.

2a. Provide a generic keying-based cryptographic authentication mechanism for the BFD protocol in discussion with the KARP working group.  This mechanism  will support authentication through a key identifier for the BFD session's Security Association rather than specifying new authentication extensions.  

2b. Provide extensions to the BFD MIB in support of the generic keying- based cryptographic authentication mechanism.

2c. Specify cryptographic authentication procedures for the BFD protocol using HMAC-SHA-256 (possibly truncated to a smaller integrity check value but not beyond commonly accepted lengths to ensure security) using the generic keying-based cryptographic authentication mechanism.

3. Provide an extension to the BFD core protocol in support of point-to- multipoint links and networks.

4. Provide an informational document to recommend standardized timers and timer operations for BFD when used in different applications.

5. Define a mechanism to perform single-ended path (i.e. continuity) verification based on the BFD specification.  Allow such a mechanism to work both proactively and on-demand, without prominent initial delay.  Allow the mechanism to maintain multiple sessions to a target entity and between the same pair of network entities. In doing this work, the WG will work closely with at least the following other WGs: ISIS, OSPF, SPRING.

The working group will maintain a relationship with the KARP and MPLS working groups, and will communicate with the IEEE with respect to BFD over LAGs.

---

From: Jeffrey Haas <[email-masked]>
Date: Wed, 7 May 2014 16:57:40 -0400

> I think there will be use of S-BFD for MPLS as well. Can we add it with July 2015 target?

It seemed likely, but there was no I-D in the tracker that I noticed for it.
Adding milestones is trivial and doesn't have to be part of the charter
process.  Let's add it once the document exists. :-)

(As our AD points out, getting milestones actually *done* is the harder
thing.)

-- Jeff

---

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 7 May 2014 22:14:37 +0100

Hi,

Millstones are easy to add and change. The chairs can just do it and I tick the
box.

Just focus on the charter text itself.

A

> From: Jeffrey Haas [mailto:[email-masked]]
> Sent: 07 May 2014 21:58
> To: Gregory Mirsky
> Cc: Jeffrey Haas; [email-masked]; Adrian Farrel; [email-masked]
> Subject: Re: Proposed BFD Charter -08
> 
> > I think there will be use of S-BFD for MPLS as well. Can we add it with July
2015
> target?

---

From: "Nobo Akiya (nobo)" <[email-masked]>
Date: Wed, 7 May 2014 21:59:17 +0000

Thanks for proposing the new charter Jeff.

One comment on the last sentence of the charter.

> working groups, and will communicate with the IEEE with respect to BFD

I believe the latter portion of the sentence (i.e. ", and will communicate ....") can also be removed, since we've removed the BFD on LAG from current charter item.

-Nobo