Subject: Re: [RTG-DIR] RTG-DIR Review: draft-ietf-bfd-mib-19.txt

From: Jeffrey Haas <[email-masked]>
Date: Mon, 12 May 2014 15:11:04 -0400

Keyur,

Thanks for the review.  Please check the recently published -20 and see if
your comments are otherwise addressed.  There's overlap with the mib-doctors
review.

Further comments below:

On Mon, May 12, 2014 at 07:05:07PM +0000, Keyur Patel (keyupate) wrote:
> Hello,
> 
> 
> 
> I have been selected as the Routing Directorate reviewer for this draft.
> 
> The Routing Directorate seeks to review all routing or routing-related drafts as they pass through IETF last call and IESG review. The purpose of the review is to provide assistance to the Routing ADs.
> 
> For more information about the Routing Directorate, please see http://www.ietf.org/iesg/directorate/routing.html
> 
> 
> 
> Although these comments are primarily for the use of the Routing ADs, it would be helpful if you could consider them along with any other IETF Last Call comments that you receive, and strive to resolve them through discussion or by updating the draft.
> 
> 
> Document: draft-ietf-bfd-mib-19.txt
> 
> Reviewer: Keyur Patel
> 
> Review date: 11-May-14
> 
> IETF LC End Date: 28-April-14
> 
> 
> Summary:
> 
> This document is basically ready for publication, but has nits that should be considered
> prior to publication.
> 
> Major Issues:
> No major issues found.
> 
> Minor Issues:
> 1 minor issue found.
> 
> Section 6: It says:
> "bfdAdminStatus - Improper change of bfdAdminStatus, from
>       enabled(1) to disabled(2), can cause significant disruption of the
>       connectivity to those portions of the Internet reached via all the
>       applicable remote BFD peers."

I believe this is addressed in -20.

> 
> I am not sure if bfdAdminStatus has a significant impact on security.Maybe the current text can be augmented to clarify any specific case that authors have in mind?
> 
> Nits:
> 
> Section 4.2: s/pair of nodes/pair of systems.

This one may be arguable since BFD in the context in question may be between
devices that are components rather than full-fledged systems.

> 
> Section 4.5: It says:
> "The BFD Session IP Mapping Table maps, given bfdSessInterface,..."
> change to:
> "The BFD Session IP Mapping Table maps a given bfdSessInterface,..."

We'll leave this one to the RFC editor since they also audit for grammar
style compliance.  

> Section 5: s/up/Up, s/down/Down, s/adminDown/AdminDown
> Section 6: s/up/Up, s/down/Down, s/adminDown/AdminDown

These are correct in their current form based on MIB styling for such
things.  I know it offends OO coders. :-)

-- Jeff

---

From: "Keyur Patel (keyupate)" <[email-masked]>
Date: Mon, 12 May 2014 19:05:07 +0000

Hello,

Reviewer: Keyur Patel

Review date: 11-May-14

Summary:

Major Issues:
No major issues found.

Minor Issues:
1 minor issue found.

Section 6: It says:

Nits:

Section 4.5: It says:

Regards,
Keyur