Subject: S-BFD UDP Port Early Allocation Request

From: "Nobo Akiya (nobo)" <[email-masked]>
Date: Mon, 16 Jun 2014 12:06:27 +0000

Hi Jeff,

Authors/contributors of draft-ietf-bfd-seamless-base would like to request early allocation of the S-BFD UDP port number.

As per RFC7120, please consider this as the request to initiate the early allocation process.

Code point:

  Service Name (REQUIRED)
    s-bfd
  Transport Protocol(s) (REQUIRED)
    udp
  Assignee (REQUIRED)
    IESG <[email-masked]>
  Contact (REQUIRED)
    BFD Chairs <[email-masked]>
  Description (REQUIRED)
    Seamless Bidirectional Forwarding Detection (S-BFD)
  Reference (REQUIRED)
    draft-ietf-bfd-seamless-base
  Port Number (OPTIONAL)
    7784

Thanks!

-Nobo, as author of draft-ietf-bfd-seamless-base

---

From: Jeffrey Haas <[email-masked]>
Date: Mon, 16 Jun 2014 15:28:57 -0400

+alia

Nobo,

A few comments:

> As per RFC7120, please consider this as the request to initiate the early allocation process.

Tentatively, I believe the constraints for RFC 7120 have been met and that
the appropriate policy is covered for the requested service port.

I do have a minor concern that, similar to other applications of BFD that
there may be multiple ports required for the S-BFD application depending on
transport.  While the case in the base draft is reasonably clear, the
various application drafts haven't yet reached maturity for us to be ready
to consider adopting them.

Do you believe the above is incorrect?

Secondly, this is a reminder that such a request starts a timer: Upon
assignment, the temporary reservation is good for one year with the
possibility of a single one-year extension.  Do you believe we're ready to
start that timer?

(I'd hope so, given the milestones we've set thus far, but my meta concern
about the application documents is the driving factor.)

-- Jeff

---

From: "Nobo Akiya (nobo)" <[email-masked]>
Date: Mon, 16 Jun 2014 20:31:30 +0000

Hi Jeff,

> -----Original Message-----
> From: Jeffrey Haas [mailto:[email-masked]]
> Sent: Monday, June 16, 2014 3:29 PM
> To: Nobo Akiya (nobo)
> Cc: Jeffrey Haas ([email-masked]); Jeff Haas ([email-masked]); rtg-
> [email-masked]; [email-masked]; Alia Atlas
> Subject: Re: S-BFD UDP Port Early Allocation Request
> 
> +alia
> 
> Nobo,
> 
> A few comments:
> 
> > Authors/contributors of draft-ietf-bfd-seamless-base would like to
> request early allocation of the S-BFD UDP port number.
> >
> there may be multiple ports required for the S-BFD application depending
> on transport.  While the case in the base draft is reasonably clear, the
> various application drafts haven't yet reached maturity for us to be ready to
> consider adopting them.
> 

That's a very fair question. It is my belief that one port will suffice for S-BFD on all transports, rather I strongly believe this is preferred to keep S-BFD transport agnostic.

> possibility of a single one-year extension.  Do you believe we're ready to

Because folks are starting to implement this, we need a common port number. Indeed this request will start the timer, but that's necessary at this point. Let us proceed to start the timer and aim to progress the draft before the timer expiry.

> about the application documents is the driving factor.)

Recently, I've re-published the s-bfd-ip/s-bfd-sr document with following note in the abstract.

   Note: this document needs to be updated to align with changes in the
   S-BFD base document.

If all goes well with S-BFD base document, the two documents can get converted to short informational documents or something else. We need a bit more time to sort this out.

s-bfd-alert-discrim document, on the other hand, may get a bit more interesting. I've received some off-list comments about wanting something similar, particularly to handle simple and/or control-plane-less environments. But this has more to do with discriminators, not ports. I was planning to grab some of you folks in Toronto or get folks to gather at your "bar office hour" to start some conversations on this topic :)

All this to say, I hope above satisfies the requirements, and we can proceed with early IANA allocation of the S-BFD port.

Thanks!

-Nobo

---

From: Jeffrey Haas <[email-masked]>
Date: Mon, 16 Jun 2014 16:38:14 -0400

Nobo,

> Because folks are starting to implement this, we need a common port number. Indeed this request will start the timer, but that's necessary at this point. Let us proceed to start the timer and aim t…

I think given the above, we have sufficient cause to advance early
allocation.  It's now up to the ADs. 

-- Jeff

---

From: Alia Atlas <[email-masked]>
Date: Mon, 16 Jun 2014 16:52:13 -0400

Since BFD is one of Adrian's WGs, I'm assuming that he'll handle it.
If not, I can send email too :-)

Alia

On Mon, Jun 16, 2014 at 4:38 PM, Jeffrey Haas <[email-masked]> wrote:

> > That's a very fair question. It is my belief that one port will suffice
> for S-BFD on all transports, rather I strongly believe this is preferred to
> keep S-BFD transport agnostic.
> >
> > >
> > Because folks are starting to implement this, we need a common port
> number. Indeed this request will start the timer, but that's necessary at
> this point. Let us proceed to start the timer and aim to progress the draft
> before the timer expiry.
>