Subject: BFD stability draft

From: Mahesh Jethanandani <[email-masked]>
Date: Mon, 21 Jul 2014 16:37:57 -0400

Following up on the chairs request to post the motivation behind the draft.

While developing BFD in software, we ran into issues of trying to figure why a particular BFD session failed. The emphasis is on a particular BFD session. Yes, there are other methods for detecting loss and delay in the network, but packet drops in the network do not help diagnose a particular BFD session.

The second emphasis is that this draft is written for BFD engine itself and to measure its stability. We are aware that there are other methods to measure LM/DMM in the network, and are happy to add in the draft that when BFD detects instability in the network, it can launch a LM/DMM session if there is further interest in measuring network performance.

Again, we welcome folks to review the draft and provide comments on this mailing list.

http://tools.ietf.org/html/draft-ashesh-bfd-stability-00

Mahesh Jethanandani
[email-masked]

---

From: Binny Jeshan <[email-masked]>
Date: Tue, 22 Jul 2014 15:33:47 +0530

I'd be interested to follow-up closely on this Draft. By the way, how do
you think TWAMP can be re-used?

On 22 July 2014 02:07, Mahesh Jethanandani <[email-masked]> wrote:

> While developing BFD in software, we ran into issues of trying to figure
> why a *particular* BFD session failed. The emphasis is on a particular
> BFD session. Yes, there are other methods for detecting loss and delay in
> the network, but packet drops in the network do not help diagnose a
> particular BFD session.
>
> The second emphasis is that this draft is written for BFD engine itself
> and to measure its stability. We are aware that there are other methods to
> measure LM/DMM in the network, and are happy to add in the draft that when
> BFD detects instability in the network, it can launch a LM/DMM session if
> there is further interest in measuring network performance.
>
> *Mahesh Jethanandani*