Subject: FW: New Version Notification for draft-vgovindan-mpls-extended-bfd-disc-tlv-00.txt

From: "Vengada Prasad Govindan (venggovi)" <[email-masked]>
Date: Fri, 4 Jul 2014 15:32:47 +0000

Hello all,
  We have posted a new draft outlining a proposal to extend the BFD Discriminator TLV of the MPLS ping to bootstrap multiple BFD sessions for a <MPLS FEC, LSP> tuple. Please let us know your questions, comments, suggestions about this draft.
Thanks
Prasad

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Friday, July 04, 2014 6:41 PM
To: Nobo Akiya (nobo); Vengada Prasad Govindan (venggovi); Nobo Akiya (nobo); Vengada Prasad Govindan (venggovi)
Subject: New Version Notification for draft-vgovindan-mpls-extended-bfd-disc-tlv-00.txt

A new version of I-D, draft-vgovindan-mpls-extended-bfd-disc-tlv-00.txt
has been successfully submitted by Vengada Prasad Govindan and posted to the IETF repository.

Name:		draft-vgovindan-mpls-extended-bfd-disc-tlv
Revision:	00
Title:		Label Switched Path (LSP) Ping Extended Bidirectional Forwarding Detection (BFD) Discriminator TLV
Document date:	2014-07-04
Group:		Individual Submission
Pages:		8
URL:            http://www.ietf.org/internet-drafts/draft-vgovindan-mpls-extended-bfd-disc-tlv-00.txt
Status:         https://datatracker.ietf.org/doc/draft-vgovindan-mpls-extended-bfd-disc-tlv/
Htmlized:       http://tools.ietf.org/html/draft-vgovindan-mpls-extended-bfd-disc-tlv-00

Abstract:
   This document defines an extended Bidirectional Forwarding Detection
   (BFD) discriminator TLV for the Multiprotocol Label Switching (MPLS)
   Label Switched Path (LSP) Ping mechanism, to allow bootstrapping of
   multiple BFD sessions for a given FEC.

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Gregory Mirsky <[email-masked]>
Date: Mon, 7 Jul 2014 21:29:25 +0000

Hi Prasad,
this is very interesting proposal and I think that the MPLS WG will be interested in the discussion. Couple comments and questions:
•       I believe that monitoring of ECMP segments on link layer is more efficient comparing to e2e monitoring. The document suggests otherwise. Could you give scenarios or use cases that support usefulness of multiple BFD sessions between the same peers, given that you need to control mapping of BFD sessions to a particular path;
•       another use case to support multiple BFD sessions between the same peers is OAM redundancy. What you see as the main benefit there? How to manage detection times among multiple BFD sessions?
•       have you looked at Section 2.2.1<http://tools.ietf.org/html/draft-ietf-mpls-lsp-ping-mpls-tp-oam-conf-06> of the draft-ietf-mpls-lsp-ping-mpls-tp-oam-conf and Section 3.3<http://tools.ietf.org/html/draft-ietf-ccamp-rsvp-te-mpls-tp-oam-ext-12> of the draft-ietf-ccamp-rsvp-te-mpls-tp-oam-ext

   Regards,
        Greg

-----Original Message-----
From: Rtg-bfd [mailto:[email-masked]] On Behalf Of Vengada Prasad Govindan (venggovi)
Sent: Friday, July 04, 2014 8:33 AM
To: [email-masked]
Subject: FW: New Version Notification for draft-vgovindan-mpls-extended-bfd-disc-tlv-00.txt

Hello all,

-----Original Message-----
From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]
Sent: Friday, July 04, 2014 6:41 PM
To: Nobo Akiya (nobo); Vengada Prasad Govindan (venggovi); Nobo Akiya (nobo); Vengada Prasad Govindan (venggovi)
Subject: New Version Notification for draft-vgovindan-mpls-extended-bfd-disc-tlv-00.txt

Abstract:

The IETF Secretariat

---

From: "Nobo Akiya (nobo)" <[email-masked]>
Date: Wed, 9 Jul 2014 01:23:42 +0000

Hi Greg, Prasad, et al,

> From: mpls [mailto:[email-masked]] On Behalf Of Gregory Mirsky
> Sent: Monday, July 07, 2014 5:29 PM
> To: Vengada Prasad Govindan (venggovi); [email-masked]
> Cc: [email-masked]
> Subject: Re: [mpls] New Version Notification for draft-vgovindan-mpls-
> extended-bfd-disc-tlv-00.txt
> 
> Hi Prasad,
> this is very interesting proposal and I think that the MPLS WG will be
> interested in the discussion. Couple comments and questions:
> • I believe that monitoring of ECMP segments on link layer is more efficient
> comparing to e2e monitoring. The document suggests otherwise. Could you
> give scenarios or use cases that support usefulness of multiple BFD sessions
> between the same peers, given that you need to control mapping of BFD
> sessions to a particular path;

A bit of a background on this document.

EVPN is very keen on wanting to use BFD per EL (or subset of the ELs) to meet their requirements. These are described in:

draft-salam-l2vpn-evpn-oam-req-frmwk
draft-vgovindan-l2vpn-evpn-bfd

With that said, I fully agree that there is going to be a huge impact to BFD scale if we are to proceed down this path, and this should be considered/discussed in a group that includes BFD folks.

Note that the format of the draft-vgovindan-mpls-extended-bfd-disc-tlv is kept generic so that multiple sessions are abstracted by "Instance Identifier" rather than boostrapped BFD sessions being strictly tied to something else (like EL value). So the draft-vgovindan-mpls-extended-bfd-disc-tlv was created as result of EVPN requirement but draft-vgovindan-mpls-extended-bfd-disc-tlv itself is a generic document.

> • another use case to support multiple BFD
> sessions between the same peers is OAM redundancy. What you see as the
> main benefit there? How to manage detection times among multiple BFD
> sessions?

How many sessions a node bootstraps for a same FEC/path to the remote node, why and how those sessions are related is a local matter. Perhaps that should be stated in the document.

> • have you looked at Section 2.2.1 of the draft-ietf-mpls-lsp-ping-mpls-tp-
> oam-conf and Section 3.3 of the draft-ietf-ccamp-rsvp-te-mpls-tp-oam-ext

Thanks for the pointer. Yes we can certainly extend those TLVs instead if that is the consensus.

The other aspect of draft-vgovindan-mpls-extended-bfd-disc-tlv that will be beneficial to get-feedback/discuss is Appendix A in the document, whether or not we are happy with implicit assumption of bootstrapped BFD session being deleted [sometime after] those sessions go down.

Thanks!

-Nobo

>   We have posted a new draft outlining a proposal to extend the BFD
> Discriminator TLV of the MPLS ping to bootstrap multiple BFD sessions for a
> <MPLS FEC, LSP> tuple. Please let us know your questions, comments,
> suggestions about this draft.
> Thanks
> Prasad
> 
> To: Nobo Akiya (nobo); Vengada Prasad Govindan (venggovi); Nobo Akiya
> (nobo); Vengada Prasad Govindan (venggovi)
> Title:          Label Switched Path (LSP) Ping Extended Bidirectional Forwarding
> Detection (BFD) Discriminator TLV Document date:  2014-07-04
> Please note that it may take a couple of minutes from the time of
> submission until the htmlized version and diff are available at tools.ietf.org.
> 
> The IETF Secretariat
> 
>