Subject: Status of bfd proxy document from IETF 90.

From: "Snyder, Brian" <[email-masked]>
Date: Wed, 6 Aug 2014 20:47:56 +0000

WG,

I wanted to follow up and report some status of this document that I presented in Toronto.   (http://tools.ietf.org/html/draft-snyder-bfd-proxy-connections-monitored-links-00 )

As you may recall, due to time constraints there was not time to field any questions related to the document.  I did also present this same paper to the MANET group and it caused quite a bit of discussion there.  Probably because there was another document in the same space as requiring some changes for satellite market.  I believe it was generally considered a pretty novel approach to solving the problem and used BFD to solve a new use case that DLEP wasn't as optimized for.  It started a discussion about using BFD "underneath" of DLEP as well.  It could be a useful way to recognizing/speeding up L3 state notification in the radio/router link as well as through other L2 networks.  I am planning on studying DLEP further and attempting a proof of concept of DLEP in our radio gear as well as continuing with the BFD proxy approach.

As for how it relates specifically to BFD I think the use case described in #4 in the following document ( http://datatracker.ietf.org/doc/draft-zhang-bfd-new-use-cases/?include_text=1 ) could also be solved via the proxy idea put forth in this paper.

With all this in mind, the authors current plan is to revise this document as a generic BFD proxy framework.  While we tried to keep it more generic, we feel the satellite focus as it's currently written will hamper it's viability and interest.  With this plan in mind, we would be happy to answer any comments that may have been on your mind and/or generally get feedback to the interest in this approach.

Thanks,

Brian

---

From: Mingui Zhang <[email-masked]>
Date: Thu, 7 Aug 2014 08:21:39 +0000

Hi Brian,

I think a generic BFD proxy framework document will be helpful. It can cover those use cases that can be handled by the proxy method. Requirements and guidelines can be developed therein.

Thanks,
Mingui

From: Rtg-bfd [mailto:[email-masked]] On Behalf Of Snyder, Brian
Sent: Thursday, August 07, 2014 4:48 AM
To: [email-masked]
Subject: Status of bfd proxy document from IETF 90.

WG,

Thanks,

Brian