Subject: RE: draft-ietf-bfd-seamless-base-03

From: "Nobo Akiya (nobo)" <[email-masked]>
Date: Thu, 6 Nov 2014 22:31:05 +0000

Hi Santosh,

Good question.

> Sent: Thursday, November 06, 2014 9:16 AM
>
> In SBFD base draft we say
> 
> " The usage of the "Required Min Echo RX Interval" field is described
>    in Section 7.2.2 and Section 7.3.2.  Because of the stateless nature
>    of SBFDReflector sessions, a value specified the "Required Min Echo
>    RX Interval" field in both directions is not very meaningful.  Thus
>    it is RECOMMENDED that the "Required Min Echo RX Interval" field
>    simply be set to zero in both directions."
> 
> 
> I understand that SBFD initiator sending echo Min RX interval as zero makes
> sense as reflector will never send echo packet. But SBFD initiator may send
> echo packet and if SBFD reflector has a policy that it can't loop back the
> packet on the same interface where it received or a global config says it can
> only entertain x rate of packets then do we need to communicate that to
> Initiator? I am ask this because in BFD for SR it is using echo and control to
> detect path going down.

Just to clarify, there is no requirement that that SBFDReflector must loop back S-BFD echo packets on the same interface which it received from.

However, I do agree that it would be beneficial for SBFDReflector to indicate that it is capable of looping backing S-BFD echo packets or not via the use of "Required Min Echo RX Interval" field in the S-BFD control packets it replies.

Although I do not think SBFDReflector should keep track of how much/many S-BFD echo packets it's looping back and reflect some suggested value in the "Required Min Echo RX Interval" field in the S-BFD control packets it replies.

In summary, I think we should clarify this by updating above texts to something along the line of:

If (SBFDReflector is hosted on a device that supports looping back of S-BFD echo packets) {
    MUST set non-zero value in the "Required Min Echo RX Interval" field of reply packets.
} else {
    MUST set zero in the "Required Min Echo RX Interval" field of reply packets.
}

What do you think?

Thanks!

-Nobo

---

From: "MALLIK MUDIGONDA (mmudigon)" <[email-masked]>
Date: Fri, 7 Nov 2014 05:47:46 +0000

Hi Nobo,

Sounds perfect.

Thanks

Regards
Mallik

From: "Nobo Akiya (nobo)" <[email-masked]<mailto:[email-masked]>>
Date: Friday 7 November 2014 4:01 AM
To: Santosh P K <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: RE: draft-ietf-bfd-seamless-base-03

Hi Santosh,

Good question.

What do you think?

Thanks!

-Nobo

---

From: Santosh P K <[email-masked]>
Date: Fri, 7 Nov 2014 21:53:09 +0000

Hello Nobo,
    This looks perfect. Thanks a lot.

Thanks
Santosh P K

Sent from my Xiaomi

On Nov 7, 2014 4:01 AM, "Nobo Akiya (nobo)" <[email-masked]> wrote:
Hi Santosh,

Good question.

What do you think?

Thanks!

-Nobo

---

From: "Nobo Akiya (nobo)" <[email-masked]>
Date: Sat, 8 Nov 2014 00:15:45 +0000

Hi Mallik, Santosh,

Many thanks for your input. Will cook up a proper text and put it in the next revision.

Thanks!

-Nobo

From: Santosh P K [mailto:[email-masked]]
Sent: Friday, November 07, 2014 4:53 PM
To: Nobo Akiya (nobo)
Cc: rtg-bfd
Subject: RE: draft-ietf-bfd-seamless-base-03

Hello Nobo,

Thanks
Santosh P K

Sent from my Xiaomi
On Nov 7, 2014 4:01 AM, "Nobo Akiya (nobo)" <[email-masked]<mailto:[email-masked]>> wrote:
Hi Santosh,

Good question.

What do you think?

Thanks!

-Nobo