Subject: Questions on draft-ashesh-bfd-stability-00.txt

From: "D'SOUZA, KEVIN L" <[email-masked]>
Date: Fri, 27 Mar 2015 23:08:28 +0000

Dear Ashesh and team,

This is the first time I am posting to this list so please bear with me if I am in error....
I have a few comments/questions on your draft:

1)     Could you clarify if interop will be supported between these features and a BFD instantiation that does not support these features

2)     Can you specify that these features will be optional for an implementation and some method should be provided to turn this capability off if needed

3)     Can you clarify in the scope the relationship between the measurements that one would obtain with this method vs other traditional methods to measure such criteria (e.g., CFM, TWAMP).  My concern is if this feature produces measurements that are different from the traditional methods, then it would be difficult to reconcile them in a production environment

4)     How would this impact the scale of the BFD protocol?

Thanks

Kevin

---

From: Santosh P K <[email-masked]>
Date: Sat, 28 Mar 2015 14:44:59 +0000

Hello Kevin,
     Thanks for your comments. Please see my inline reply. 

>1) Could you clarify if interop will be supported between these features and a BFD instantiation that does not support these features

Yes, it should have a backward compatibility. We will update document on backward compatibility section with use cases. 

> 2) Can you specify that these features will be optional for an implementation and some method should be provided to turn this capability off if needed

This is optional and it might be turned off by configuration? I think this is implementation detail but we could have recommendation in draft. 

>3) Can you clarify in the scope the relationship between the measurements that one would obtain with this method vs other traditional methods to measure >such criteria (e.g., CFM, TWAMP).  My concern is if this feature produces measurements that are different from the traditional methods, then it would be >difficult to reconcile them in a production environment

BFD will not replace CFM or TWAMP and it is not equipped to do so. We are updating the document with use cases and other recommendation please stayed tuned. 

> 4) How would this impact the scale of the BFD protocol?

Do you mean scale impact in steady state? 

Thanks
Santosh P K

---

From: "D'SOUZA, KEVIN L" <[email-masked]>
Date: Mon, 30 Mar 2015 13:38:15 +0000

Hi Santosh,

Thanks for your responses. Will look the updated version.
On my last question, yes it is about scale impact in steady state.

Kevin

-----Original Message-----
From: Santosh P K [mailto:[email-masked]] 
Sent: Saturday, March 28, 2015 10:45 AM
To: D'SOUZA, KEVIN L; [email-masked]'
Subject: RE: Questions on draft-ashesh-bfd-stability-00.txt

Hello Kevin,

Thanks
Santosh P K

---

From: Ashesh Mishra <[email-masked]>
Date: Mon, 30 Mar 2015 10:29:21 -0700

Hi Kevin,
In steady state, there will be a scale impact of enabling stability measurement. However, it can be fairly small if the implementation is efficient. In our prototype, we saw less than 3% impact on CPU performance (and hence, little-to-no impact on scale) when we enabled this measurement (we monitored both, timestamps and sequence numbers). 
Best,Ashesh

> From: [email-masked]
> To: [email-masked]; [email-masked]
> Date: Mon, 30 Mar 2015 13:38:15 +0000
> 
> Hi Santosh,
>