Subject: Re: I-D Action: draft-ashesh-bfd-stability-02.txt

From: Marc Binderberger <[email-masked]>
Date: Sat, 2 May 2015 18:57:45 -0700

Hello authors of BFD stability,

the diff says not much has changes since v01 (?!).
Anyway, let me provide some feedback :-)

"Sequence Number"

- what happens when the counter wraps? Are you okay to start at zero again - 
but zero has a special meaning. Wrapping back to "1"?  The draft should 
define what comes after 2^32 - 1.

- would is make sense to have the mechanism always running, including 
Down/Init packets? The Down-Init-Up can happen rapidly, what about deugging 
packet loss during this sequence?

"Security Consideration"

- I don't think that saying "well, it's either us or crypto-authentication" 
is a good statement for IETF. Especially with the effort to make 
authentication more realistic for BFD (like draft-mahesh-bfd-authentication) 
it's not forward-looking. You could at least outline how every existing 
authentication could be "cloned" to have the new fields you introduce, to 
allow for both packet loss counting and authentication.

Kevin asked in his email:

> 2) Can you specify that these features will be optional for an 
implementation
> and some method should be provided to turn this capability off if needed

I support this idea. There are implementations that drop BFD packets with the 
A bit set (as no authentication is supported in the implementation). I'm also 
not sure how quickly hardware-based BFD implementations can be upgraded. So 
for backward compatibility it would be good to be able to turn it off.

Regards, Marc

On Thu, 23 Apr 2015 10:58:50 -0700, [email-masked] wrote:
> 
> A New Internet-Draft is available from the on-line Internet-Drafts 
> directories.
> 
> 
>         Title           : BFD Stability
>         Authors         : Ashesh Mishra
>                           Mahesh Jethanandani
>                           Ankur Saxena
>                           Santosh Pallagatti
>                           Mach Chen
> 	Filename        : draft-ashesh-bfd-stability-02.txt
> 	Pages           : 5
> 	Date            : 2015-04-23
> 
> Abstract:
>    This document describes extensions to the Bidirectional Forwarding
>    Detection (BFD) protocol to measure BFD stability.  Specifically, it
>    describes a mechanism for detection of BFD frame loss.
> 
> 
> 
> The IETF datatracker status page for this draft is:
> https://datatracker.ietf.org/doc/draft-ashesh-bfd-stability/
> 
> There's also a htmlized version available at:
> http://tools.ietf.org/html/draft-ashesh-bfd-stability-02
> 
> A diff from the previous version is available at:
> http://www.ietf.org/rfcdiff?url2=draft-ashesh-bfd-stability-02
> 
> 
> Please note that it may take a couple of minutes from the time of submission
> until the htmlized version and diff are available at tools.ietf.org.
> 
> Internet-Drafts are also available by anonymous FTP at:
> ftp://ftp.ietf.org/internet-drafts/
> 
> _______________________________________________
> I-D-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/i-d-announce
> Internet-Draft directories: http://www.ietf.org/shadow.html
> or ftp://ftp.ietf.org/ietf/1shadow-sites.txt
>

---

From: Santosh P K <[email-masked]>
Date: Sun, 3 May 2015 12:57:58 +0000

Marc,
    Thanks for your comments. Draft was expiring and hence we updated draft without any changes. This week we will upload document with changes we have discussed.

Thanks
Santosh P K

sent from handheld device.
On May 3, 2015 7:27 AM, Marc Binderberger <[email-masked]> wrote:
Hello authors of BFD stability,

"Sequence Number"

"Security Consideration"

implementation

Regards, Marc