Subject: issues about draft-ietf-bfd-rfc5884-clarifications-02

From: [email-masked]
Date: Wed, 15 Jul 2015 17:21:09 +0800

hi authors

It is neccessary to address the case that different ingress LSR establish 
BFD session with the same egress LSR, with same FEC, same local 
descriminator.
I think it is very useful to introduce a BFD Initiator TLV to LSP ping 
echo request message, to distinguish different ingress LSR. So that 
ingress allocate LD based on tuple <FEC, LSP> as defined in this draft, 
but egress allocate LD based on tuple <Initiator, FEC, RD>.

thanks
deccan
--------------------------------------------------------
ZTE Information Security Notice: The information contained in this mail (and any attachment transmitted herewith) is privileged and confidential and is intended for the exclusive use of the addressee(s).  If you are not an intended recipient, any disclosure, reproduction, distribution or other dissemination or use of the information contained is strictly prohibited.  If you have received this mail in error, please delete it and notify us immediately.
--------------------------------------------------------
ZTE Information Security Notice: The information contained in this mail (and any attachment transmitted herewith) is privileged and confidential and is intended for the exclusive use of the addressee(s).  If you are not an intended recipient, any disclosure, reproduction, distribution or other dissemination or use of the information contained is strictly prohibited.  If you have received this mail in error, please delete it and notify us immediately.

---

From: "S. Davari" <[email-masked]>
Date: Wed, 15 Jul 2015 07:42:12 -0700

Hi

Why can't the ingress allocate different LD to each of those BFD sessions?

Regards,
Shahram

> On Jul 15, 2015, at 7:30 AM, "[email-masked]" <[email-masked]> wrote:
> 
> 
> hi authors 
> 
> It is neccessary to address the case that different ingress LSR establish BFD session with the same egress LSR, with same FEC, same local descriminator. 
> I think it is very useful to introduce a BFD Initiator TLV to LSP ping echo request message, to distinguish different ingress LSR. So that ingress allocate LD based on tuple <FEC, LSP> as defined in this draft, but egress allocate LD based on tuple <Initiator, FEC, RD>. 
> 
> thanks 
> deccan 
> 
>

---

From: "MALLIK MUDIGONDA (mmudigon)" <[email-masked]>
Date: Thu, 16 Jul 2015 06:16:10 +0000

Hi,

I think the question is 2 different ingress LSRs using the same FEC, LSP, Discriminator values. Discriminator values can be the same for 2 different ingress LSRs and if the other values are same we can always use the Source address to differentiate. Am I missing something?

Regards
Mallik

From: "S. Davari" <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, 15 July 2015 20:12
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: issues about draft-ietf-bfd-rfc5884-clarifications-02

Hi

Regards,
Shahram

On Jul 15, 2015, at 7:30 AM, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>> wrote:

hi authors

thanks
deccan

---

From: [email-masked]
Date: Thu, 16 Jul 2015 09:07:50 +0800

Hi Shahram

Different ingress LSR allocate LD independently, and always automatically. 
It is not a static configuration.

Thanks
Deccan

"S. Davari" <[email-masked]> 
2015-07-15 下午 10:42

收件人
"[email-masked]" <[email-masked]>
抄送
"[email-masked]" <[email-masked]>
主题
Re: issues about draft-ietf-bfd-rfc5884-clarifications-02

Hi

Regards,
Shahram

On Jul 15, 2015, at 7:30 AM, "[email-masked]" <
[email-masked]> wrote:

hi authors 

thanks 
deccan 

--------------------------------------------------------
ZTE Information Security Notice: The information contained in this mail 
(and any attachment transmitted herewith) is privileged and confidential 
and is intended for the exclusive use of the addressee(s).  If you are not 
an intended recipient, any disclosure, reproduction, distribution or other 
dissemination or use of the information contained is strictly prohibited. 
If you have received this mail in error, please delete it and notify us 
immediately.

--------------------------------------------------------
ZTE Information Security Notice: The information contained in this mail 
(and any attachment transmitted herewith) is privileged and confidential 
and is intended for the exclusive use of the addressee(s).  If you are not 
an intended recipient, any disclosure, reproduction, distribution or other 
dissemination or use of the information contained is strictly prohibited. 
If you have received this mail in error, please delete it and notify us 
immediately.

---

From: [email-masked]
Date: Thu, 16 Jul 2015 15:30:15 +0800

Hi Mallik

Source address is also a good method. But it is better to form as 
standard.

thanks

"MALLIK MUDIGONDA (mmudigon)" <[email-masked]> 
2015-07-16 下午 02:16

收件人
"S. Davari" <[email-masked]>, "[email-masked]" 
<[email-masked]>
抄送
"[email-masked]" <[email-masked]>
主题
Re: issues about draft-ietf-bfd-rfc5884-clarifications-02

Hi,

I think the question is 2 different ingress LSRs using the same FEC, LSP, 
Discriminator values. Discriminator values can be the same for 2 different 
ingress LSRs and if the other values are same we can always use the Source 
address to differentiate. Am I missing something?

Regards
Mallik

From: "S. Davari" <[email-masked]>
Date: Wednesday, 15 July 2015 20:12
To: "[email-masked]" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: Re: issues about draft-ietf-bfd-rfc5884-clarifications-02

Hi

Regards, 
Shahram

hi authors 

thanks 
deccan

---

From: Santosh P K <[email-masked]>
Date: Fri, 17 Jul 2015 03:48:14 +0000

Hello Deccan, MALLIK and Shahram,
     I want to understand why do we need this? When BFD bootstrapping is completed then we use local discr (BFD packet your discr) as a key which will be unique with in the local system. Please take a look at below section of RFC 5880.

https://tools.ietf.org/html/rfc5880#section-6.3

We don’t need to really use any other fields as we would have exchanged the discr using LSP ping. I might have misunderstood your question and would like to be corrected.

Thanks
Santosh P K

From: Rtg-bfd [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Thursday, July 16, 2015 1:00 PM
To: MALLIK MUDIGONDA (mmudigon)
Cc: [email-masked]; S. Davari
Subject: 答复: Re: issues about draft-ietf-bfd-rfc5884-clarifications-02

Hi Mallik

Source address is also a good method. But it is better to form as standard.

thanks

"MALLIK MUDIGONDA (mmudigon)" <[email-masked]<mailto:[email-masked]>>

2015-07-16 下午 02:16

收件人

"S. Davari" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>

抄送

"[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>

主题

Hi,

Regards
Mallik

Hi

Regards,
Shahram

hi authors

thanks
deccan

---

From: Santosh P K <[email-masked]>
Date: Fri, 17 Jul 2015 04:51:54 +0000

Sharam,
   True but here it is 5884 and for 5884 (MPLS BFD) we do bootstrapping using LSP ping and that exchange discr right? So you should ideally not receive any BFD packet with your_disc = 0.

Thanks
Santosh P K

From: S. Davari [mailto:[email-masked]]
Sent: Friday, July 17, 2015 9:51 AM
To: Santosh P K
Cc: [email-masked]; MALLIK MUDIGONDA (mmudigon); [email-masked]
Subject: Re: issues about draft-ietf-bfd-rfc5884-clarifications-02

Hi Santosh

I think the issue is the first BFD packet that has your Desc =0. Question is how to differentiate them when they are from different ingress LSR.

Regards,
Shahram

On Jul 16, 2015, at 8:48 PM, Santosh P K <[email-masked]<mailto:[email-masked]>> wrote:
Hello Deccan, MALLIK and Shahram,
     I want to understand why do we need this? When BFD bootstrapping is completed then we use local discr (BFD packet your discr) as a key which will be unique with in the local system. Please take a look at below section of RFC 5880.

Thanks
Santosh P K

From: Rtg-bfd [mailto:[email-masked]] On Behalf Of [email-masked]<mailto:[email-masked]>
Sent: Thursday, July 16, 2015 1:00 PM
To: MALLIK MUDIGONDA (mmudigon)
Cc: [email-masked]<mailto:[email-masked]>; S. Davari
Subject: 答复: Re: issues about draft-ietf-bfd-rfc5884-clarifications-02

Hi Mallik

thanks

2015-07-16 下午 02:16

收件人

抄送

主题

Hi,

Regards
Mallik

Hi

Regards,
Shahram

hi authors

thanks
deccan

---

From: "MALLIK MUDIGONDA (mmudigon)" <[email-masked]>
Date: Fri, 17 Jul 2015 05:14:38 +0000

Hi,

The question is even with LSP ping, how to de-mutiplex if all the parameters are the same. That’s where the source address comes into picture.

Thanks

Regards
Mallik

From: Santosh P K <[email-masked]<mailto:[email-masked]>>
Date: Friday, 17 July 2015 10:21
To: "S. Davari" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Mallik Mudigonda <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: RE: issues about draft-ietf-bfd-rfc5884-clarifications-02

Sharam,

Thanks
Santosh P K

From: S. Davari [mailto:[email-masked]]
Sent: Friday, July 17, 2015 9:51 AM
To: Santosh P K
Cc: [email-masked]<mailto:[email-masked]>; MALLIK MUDIGONDA (mmudigon); [email-masked]<mailto:[email-masked]>
Subject: Re: issues about draft-ietf-bfd-rfc5884-clarifications-02

Hi Santosh

Regards,
Shahram

Thanks
Santosh P K

Hi Mallik

thanks

2015-07-16 下午 02:16

收件人

抄送

主题

Hi,

Regards
Mallik

Hi

Regards,
Shahram

hi authors

thanks
deccan

---

From: Santosh P K <[email-masked]>
Date: Fri, 17 Jul 2015 05:27:01 +0000

Mallik,
   When a BFD packet is received with your_disc as non-zero then we use only that as demux entity. Your_discr is a value allocated by local router and should be unique across the system. So where is the question of having any other field to be used as demux? Are you talking about same discr for BFD session for same LSP in case of ECMP? Can you please explain more in detail what is the scenario? I might have missed some basic thing here.

Thanks
Santosh P K

From: MALLIK MUDIGONDA (mmudigon) [mailto:[email-masked]]
Sent: Friday, July 17, 2015 10:45 AM
To: Santosh P K; S. Davari
Cc: [email-masked]; [email-masked]
Subject: Re: issues about draft-ietf-bfd-rfc5884-clarifications-02

Hi,

Thanks

Regards
Mallik

Sharam,

Thanks
Santosh P K

Hi Santosh

Regards,
Shahram

Thanks
Santosh P K

Hi Mallik

thanks

2015-07-16 下午 02:16

收件人

抄送

主题

Hi,

Regards
Mallik

Hi

Regards,
Shahram

hi authors

thanks
deccan

---

From: Gregory Mirsky <[email-masked]>
Date: Fri, 17 Jul 2015 07:19:45 +0000

Hi  Malik,
I cannot see scenario when bootstrapping LSP Ping has the same source IP address and BFD Discriminator. Something must be different. Consider two nodes with ECMP – A and B. A bootstraps two FD sessions with two LSP Pings. True, IP Source addresses are the same in both as well as FEC. But Discriminators will be different as they must e unique within the same node. Right? If the case of three nodes when two set BFD sessions to the same FEC on the third and accidentally pick the same Discriminator, then IP source addresses must be different between them. Am I missing something?

                Regards,
                                Greg

From: Rtg-bfd [mailto:[email-masked]] On Behalf Of MALLIK MUDIGONDA (mmudigon)
Sent: Thursday, July 16, 2015 10:15 PM
To: Santosh P K; S. Davari
Cc: [email-masked]; [email-masked]
Subject: Re: issues about draft-ietf-bfd-rfc5884-clarifications-02

Hi,

Thanks

Regards
Mallik

Sharam,

Thanks
Santosh P K

Hi Santosh

Regards,
Shahram

Thanks
Santosh P K

Hi Mallik

thanks

2015-07-16 下午 02:16

收件人

抄送

主题

Hi,

Regards
Mallik

Hi

Regards,
Shahram

hi authors

thanks
deccan

---

From: "MALLIK MUDIGONDA (mmudigon)" <[email-masked]>
Date: Fri, 17 Jul 2015 07:30:32 +0000

Hi,

Yes, for P2P the LSP should be different for the ingress routers which should help identify a session. For MP2P sessions, we will have the same parameters for all ingresses and so Source should be able to identify an appropriate session.

Regards
Mallik

From: "S. Davari" <[email-masked]<mailto:[email-masked]>>
Date: Friday, 17 July 2015 12:45
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: Santosh P K <[email-masked]<mailto:[email-masked]>>, Mallik Mudigonda <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: 答复: RE: issues about draft-ietf-bfd-rfc5884-clarifications-02

Peng

I think you are assuming mp2p LSP. Since for P2P
LSP we won't have this problem. Right?

Regards,
Shahram

On Jul 17, 2015, at 12:03 AM, [email-masked]<mailto:[email-masked]> wrote:

Hi Santosh

For example, there are two diferrent ingress (LSR1 & LSR2) want to establish BFD session with the same egress (LSR3) for same FEC (3.3.3.9/32). PLease see the following steps.

step1: LSR1 construct an LSP echo request message, including LSR1-LD (100) and FEC (3.3.3.9/32)
step2: LSR3 received the echo request message, if FEC validation check succeed, it will NEW a BFD entity, allocate LSR3-LD (200) based on tuple <FEC, LSR1-LD>.
       Now LSR3 can send a BFD control packet with MD=200 YD=100.
step3: LSR2 also construct an LSP echo request message, including LSR2-LD (100) and FEC (3.3.3.9/32)
step4: LSR3 received the echo request message, if FEC validation check succeed, it will match to the above already existing BFD session, because tuple <FEC, LSR2-LD> equal <FEC, LSR1-LD>

thanks
Deccan

Santosh P K <[email-masked]<mailto:[email-masked]>>

2015-07-17 下午 01:27

收件人
        "MALLIK MUDIGONDA (mmudigon)" <[email-masked]<mailto:[email-masked]>>, "S. Davari" <[email-masked]<mailto:[email-masked]>>
抄送
        "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
主题
        RE: issues about draft-ietf-bfd-rfc5884-clarifications-02

Mallik,

Thanks
Santosh P K

Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>

Hi,

Thanks

Regards
Mallik

Sharam,

Thanks
Santosh P K

Hi Santosh

Regards,
Shahram

Thanks
Santosh P K

Hi Mallik

thanks

2015-07-16 下午 02:16

收件人

Hi,

Regards
Mallik

Hi

Regards,
Shahram

hi authors

thanks
deccan

---

From: "MALLIK MUDIGONDA (mmudigon)" <[email-masked]>
Date: Fri, 17 Jul 2015 07:40:23 +0000

Hi truncated the message and resending with only the latest conversations

Regards
Mallik

From: Mallik Mudigonda <[email-masked]<mailto:[email-masked]>>
Date: Friday, 17 July 2015 13:07
To: Gregory Mirsky <[email-masked]<mailto:[email-masked]>>, Santosh P K <[email-masked]<mailto:[email-masked]>>, "S. Davari" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: issues about draft-ietf-bfd-rfc5884-clarifications-02

Hi Greg,

Precisely. Can <FEC, LSP> be the same between LSP echo messages sent from 2 different ingresses? I am not sure of this. So there may not be a problem with p2p even if 2 ingresses have the same FEC and Discriminator because the LSP must be different.  I agree that two sessions from the same ingress must use a different discriminator, so no issues. So in p2p cases either LSP or discriminator will be different. Am I right? In the case of mp2p all of these can be the same in which case source address differentiates. Does this make sense?

Thanks

Regards
Mallik

From: Gregory Mirsky <[email-masked]<mailto:[email-masked]>>
Date: Friday, 17 July 2015 12:49
To: Mallik Mudigonda <[email-masked]<mailto:[email-masked]>>, Santosh P K <[email-masked]<mailto:[email-masked]>>, "S. Davari" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: RE: issues about draft-ietf-bfd-rfc5884-clarifications-02

Hi  Malik,

                Regards,
                                Greg

Hi,

Thanks

Regards
Mallik

---

From: "S. Davari" <[email-masked]>
Date: Thu, 16 Jul 2015 21:21:15 -0700

Hi Santosh

Regards,
Shahram

> On Jul 16, 2015, at 8:48 PM, Santosh P K <[email-masked]> wrote:
> 
> "S. Davari" <[email-masked]>, "[email-masked]" <[email-masked]>
> 抄送

---

From: [email-masked]
Date: Fri, 17 Jul 2015 15:03:47 +0800

Hi Santosh

For example, there are two diferrent ingress (LSR1 & LSR2) want to 
establish BFD session with the same egress (LSR3) for same FEC 
(3.3.3.9/32). PLease see the following steps.

step1: LSR1 construct an LSP echo request message, including LSR1-LD (100) 
and FEC (3.3.3.9/32)
step2: LSR3 received the echo request message, if FEC validation check 
succeed, it will NEW a BFD entity, allocate LSR3-LD (200) based on tuple 
<FEC, LSR1-LD>.
       Now LSR3 can send a BFD control packet with MD=200 YD=100.
step3: LSR2 also construct an LSP echo request message, including LSR2-LD 
(100) and FEC (3.3.3.9/32)
step4: LSR3 received the echo request message, if FEC validation check 
succeed, it will match to the above already existing BFD session, because 
tuple <FEC, LSR2-LD> equal <FEC, LSR1-LD>

thanks
Deccan

Santosh P K <[email-masked]> 
2015-07-17 下午 01:27

收件人
"MALLIK MUDIGONDA (mmudigon)" <[email-masked]>, "S. Davari" 
<[email-masked]>
抄送
"[email-masked]" <[email-masked]>, "[email-masked]" 
<[email-masked]>
主题
RE: issues about draft-ietf-bfd-rfc5884-clarifications-02

Mallik,
   When a BFD packet is received with your_disc as non-zero then we use 
only that as demux entity. Your_discr is a value allocated by local router 
and should be unique across the system. So where is the question of having 
any other field to be used as demux? Are you talking about same discr for 
BFD session for same LSP in case of ECMP? Can you please explain more in 
detail what is the scenario? I might have missed some basic thing here. 

Thanks
Santosh P K

Hi,
 
The question is even with LSP ping, how to de-mutiplex if all the 
parameters are the same. That’s where the source address comes into 
picture. 
 
Thanks
 
Regards
Mallik
 
From: Santosh P K <[email-masked]>
Date: Friday, 17 July 2015 10:21
To: "S. Davari" <[email-masked]>
Cc: "[email-masked]" <[email-masked]>, Mallik Mudigonda <
[email-masked]>, "[email-masked]" <[email-masked]>
Subject: RE: issues about draft-ietf-bfd-rfc5884-clarifications-02
 
Sharam,
   True but here it is 5884 and for 5884 (MPLS BFD) we do bootstrapping 
using LSP ping and that exchange discr right? So you should ideally not 
receive any BFD packet with your_disc = 0. 
 
Thanks
Santosh P K 

Hi Santosh
 
I think the issue is the first BFD packet that has your Desc =0. Question 
is how to differentiate them when they are from different ingress LSR.

Regards,
Shahram

On Jul 16, 2015, at 8:48 PM, Santosh P K <[email-masked]> wrote:
Hello Deccan, MALLIK and Shahram, 
     I want to understand why do we need this? When BFD bootstrapping is 
completed then we use local discr (BFD packet your discr) as a key which 
will be unique with in the local system. Please take a look at below 
section of RFC 5880. 

We don’t need to really use any other fields as we would have exchanged 
the discr using LSP ping. I might have misunderstood your question and 
would like to be corrected. 

Thanks
Santosh P K 
 
From: Rtg-bfd [mailto:[email-masked]] On Behalf Of 
[email-masked]

Hi Mallik 

thanks 

收件人
"S. Davari" <[email-masked]>, "[email-masked]" <
[email-masked]>
抄送
"[email-masked]" <[email-masked]>
主题
Re: issues about draft-ietf-bfd-rfc5884-clarifications-02

Hi, 

Regards 
Mallik 

Hi 

Regards, 
Shahram 

hi authors

thanks 
deccan

---

From: "S. Davari" <[email-masked]>
Date: Fri, 17 Jul 2015 00:15:03 -0700

Peng

Regards,
Shahram

> On Jul 17, 2015, at 12:03 AM, [email-masked] wrote:
> 
> 
> Hi Santosh 
> 
> "MALLIK MUDIGONDA (mmudigon)" <[email-masked]>, "S. Davari" <[email-masked]>
> 抄送
> "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
> 主题
> Cc: "[email-masked]" <[email-masked]>, Mallik Mudigonda <[email-masked]>, "[email-masked]" <[email-masked]>

---

From: Santosh P K <[email-masked]>
Date: Fri, 17 Jul 2015 09:47:47 +0000

Hmm ok so this question is during bootstrapping time when LSP ping echo packet is received with BFD discriminator TLV not when BFD packet is received. In that case source IP address can be used.

Thanks
Santosh P K

From: [email-masked] [mailto:[email-masked]]
Sent: Friday, July 17, 2015 12:34 PM
To: Santosh P K
Cc: S. Davari; MALLIK MUDIGONDA (mmudigon); [email-masked]
Subject: 答复: RE: issues about draft-ietf-bfd-rfc5884-clarifications-02

Hi Santosh

thanks
Deccan

2015-07-17 下午 01:27

收件人

抄送

主题

Mallik,

Thanks
Santosh P K

Hi,

Thanks

Regards
Mallik

Sharam,

Thanks
Santosh P K

Hi Santosh

Regards,
Shahram

Thanks
Santosh P K

Hi Mallik

thanks

2015-07-16 下午 02:16

收件人

抄送

主题

Hi,

Regards
Mallik

Hi

Regards,
Shahram

hi authors

thanks
deccan

---

From: Gregory Mirsky <[email-masked]>
Date: Sat, 18 Jul 2015 09:59:01 +0000

Hi Shahram,
if BFD session uses IP/UDP encapsulation then LSP Ping bootstrap should be used. Thus the first BFD control packet would not have Your Discriminator == 0. On the other hand ACH encapsulation unlikely to be used in p2mp as this is not MPLS-TP construct.

                Regards,
                                Greg

From: Rtg-bfd [mailto:[email-masked]] On Behalf Of S. Davari
Sent: Friday, July 17, 2015 6:21 AM
To: Santosh P K
Cc: [email-masked]; [email-masked]
Subject: Re: issues about draft-ietf-bfd-rfc5884-clarifications-02

Hi Santosh

Regards,
Shahram

Thanks
Santosh P K

Hi Mallik

thanks

2015-07-16 下午 02:16

收件人

抄送

主题

Hi,

Regards
Mallik

Hi

Regards,
Shahram

hi authors

thanks
deccan

---

From: Gregory Mirsky <[email-masked]>
Date: Sat, 18 Jul 2015 10:02:57 +0000

Hi Shahram,
but mp2p with IP/UDP encapsulation of BFD session would not have the problem either if it will use LSP Ping bootstrap because source IP addresses, I expect, would be different. After bootstrap demultiplexing will be by Your Discriminator for each p2p BFD session of the same mp2p LSP. Would you agree?

                Regards,
                                Greg

From: Rtg-bfd [mailto:[email-masked]] On Behalf Of S. Davari
Sent: Friday, July 17, 2015 9:15 AM
To: [email-masked]
Cc: [email-masked]
Subject: Re: 答复: RE: issues about draft-ietf-bfd-rfc5884-clarifications-02

Peng

Regards,
Shahram

Hi Santosh

thanks
Deccan

2015-07-17 下午 01:27

收件人

抄送

主题

Mallik,

Thanks
Santosh P K

Hi,

Thanks

Regards
Mallik

Sharam,

Thanks
Santosh P K

Hi Santosh

Regards,
Shahram

Thanks
Santosh P K

Hi Mallik

thanks

2015-07-16 下午 02:16

收件人

抄送

主题

Hi,

Regards
Mallik

Hi

Regards,
Shahram

hi authors

thanks
deccan

---

From: "S. Davari" <[email-masked]>
Date: Sat, 18 Jul 2015 06:32:10 -0700

Agree.

Regards,
Shahram

> On Jul 18, 2015, at 3:02 AM, Gregory Mirsky <[email-masked]> wrote:
> 
> Hi Shahram,