Subject: Re: [Lime] Call for Adoption: draft-tissa-lime-yang-oam-model-06

From: Mahesh Jethanandani <[email-masked]>
Date: Mon, 24 Aug 2015 17:41:50 -0700

Agree with Greg.

I have particular concern about this statement in the draft:

All implementations that follow the YANG framework presented in this
   document MUST implement the generic YANG model presented here.

This seems to stipulate a requirement that neither YANG as a language nor any existing technology requires, except maybe CFM itself. Where is this stipulation coming from and why is it a MUST?

> On Aug 24, 2015, at 4:19 PM, Varma, Eve L (Eve) <[email-masked]> wrote:
> 
> I concur with Greg’s concerns.
>  
> Best regards,
> Eve
>  
> From: Lime [mailto:[email-masked] <mailto:[email-masked]>] On Behalf Of Gregory Mirsky
> Sent: Friday, August 21, 2015 12:33 PM
> To: Carlos Pignataro (cpignata); [email-masked] <mailto:[email-masked]>
> Cc: [email-masked] <mailto:[email-masked]>
> Subject: Re: [Lime] Call for Adoption: draft-tissa-lime-yang-oam-model-06
>  
> I do not support adoption of this document as WG item.
>  
> I believe that until Applicability of Generic YANG Data Model for layer Independent OAM Management demonstrates that the proposed model indeed is common among OAM technologies developed at IETF, e.g. IP, IP/MPLS, MPLS-TP, and TRILL, beyond just YANG customization mechanisms adopting this draft as WG item is premature. And the applicability document has not demonstrated that yet as you can see from the attached comments to the  Applicability of the draft-tissa-lime-yang-oam-model and couple more generic notes:
> Operations, Administration and Maintenance address Fault Management and Performance Monitoring of the FCAPS. If the scope of the document does not include both then I suggest not to refer to is as OAM but perhaps On-demand Continuity Check and Connectivity Verification, i.e. ping and traceroute, Common YANG model;
> section 4 is more about general YANG extensibility than of the proposed OAM YANG data model;
> IP/MPLS OAM not being separated from MPLS-TP OAM;
> Performance Monitoring arbitrary being left outside the scope for some technologies, e.g. Ethernet;
> often Service OAM being presented as Transport OAM, e.g. VPLS, NVO3.
>  
>  
> Regards,
>         Greg
>  
> From: Lime [mailto:[email-masked] <mailto:[email-masked]>] On Behalf Of Carlos Pignataro (cpignata)
> Sent: Saturday, August 08, 2015 1:12 PM
> To: [email-masked] <mailto:[email-masked]>
> Cc: [email-masked] <mailto:[email-masked]>
> Subject: [Lime] Call for Adoption: draft-tissa-lime-yang-oam-model-06
>  
> LIME,
> 
> This email starts a two-week poll on adopting draft-tissa-lime-yang-oam-model-06 [1] as a LIME working group item.
> 
> Please send comments to the list and state if you support adoption or not (in the later case, please also state the reasons).
> 
> This poll runs until ** August 24th, 2015 **.
> 
> We are also polling for knowledge of any IPR that applies to this draft, to ensure that IPR has been disclosed in compliance with IETF IPR rules (see RFCs 3979, 4879, 3669 and 5378 for more details).
> 
> *If you are listed as a document author or contributor*, please respond to this email and indicate whether or not you are aware of any relevant IPR.
> 
> The draft will not be adopted until a response has been received from each author and contributor.
> 
> If you are not listed as an author or contributor, then please explicitly respond only if you are aware of any IPR that has not yet been disclosed in conformance with IETF rules.
> 
> Thank you,
> 
> Ron Bonica / Carlos Pignataro
> LIME co-chairs
> 
> [1] http://datatracker.ietf.org/doc/draft-tissa-lime-yang-oam-model/ <http://datatracker.ietf.org/doc/draft-tissa-lime-yang-oam-model/>
>  
> _______________________________________________
> Lime mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/lime <https://www.ietf.org/mailman/listinfo/lime>
Mahesh Jethanandani
[email-masked]

---

From: Mahesh Jethanandani <[email-masked]>
Date: Wed, 26 Aug 2015 14:10:54 -0700

[Adding BFD mailing list back because this decision affects them]

Tom,

I was hoping for a rational that went beyond  “and you shall …”

Something along the lines of why /lime/bfd is better than /lime -> /bfd. Or why almost all configuration models for BFD that currently work just fine, now have to start supporting CFM like semantics in Maintenance Domain (MD), Maintenance Association (MA) or Maintenance Endpoint (MEP) configuration to realize a BFD session.

You might find a similar discussion around the devices YANG model germane to this thought process. In particular, the thread titled "issue Y34 - root node" on the netmod mailing list.

Cheers.

> On Aug 24, 2015, at 6:10 PM, Tom Taylor <[email-masked]> wrote:
> 
> It comes from making the making the draft Standards Track. If you claim to implement the ultimate RFC, this is a logical consequence, just as for any other Standards Track RFC.
> 
> Tom Taylor
> 
> On 24/08/2015 8:41 PM, Mahesh Jethanandani wrote:
>> Agree with Greg.
>> 
>> This seems to stipulate a requirement that neither YANG as a language
>> nor any existing technology requires, except maybe CFM itself. Where is
>> this stipulation coming from and why is it a MUST?
>> 
> 
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lime

Mahesh Jethanandani
[email-masked]

---

From: Qin Wu <[email-masked]>
Date: Thu, 27 Aug 2015 01:56:21 +0000

Hi, Mahesh:
-----邮件原件-----
发件人: Lime [mailto:[email-masked]] 代表 Mahesh Jethanandani
发送时间: 2015年8月27日 5:11
收件人: Tom Taylor
抄送: [email-masked]; [email-masked]
主题: Re: [Lime] Call for Adoption: draft-tissa-lime-yang-oam-model-06

Tom,

[Qin]: See 
http://www.ietf.org/mail-archive/web/netmod/current/msg12986.html
http://www.ietf.org/mail-archive/web/netmod/current/msg13113.html

What device YANG model is applied to this WG is about the following substructure:
     +--rw device
          +--rw logical-network-elements
                +--rw networking-instances
                   +--rw networking-instance* [networking-instance-name]
                      +--rw oam-protocols
                      |  +--rw bfd
                      |  +--rw cfm
                      |  +--rw twamp
Rather than the example quoted in Y-34 (http://www.ietf.org/mail-archive/web/netmod/current/msg12986.html)
   +--rw device
          +--rw info
          |  +--rw device-type?   enumeration
          +--rw hardware
          +--rw interfaces
          |  +--rw interface* [name]
          |     ...
          +--rw qos

So In my understanding, device model is more focusing on discussing organizing different type of models in a
  comprehensive structure. For the same type of models(e.g., OAM type), we can find common structure to make different technology specific OAM models with same type (i.e.,OAM type)work together. The relationship between these models are described as several models are extension to one base model.

The debate on Y-34 is about whether we should add new top level node (device) on top of another existing top level node(e.g., interface). Device and interface are of two different types, 

One interesting proposal raised by Lada in http://www.ietf.org/mail-archive/web/netmod/current/msg12986.html is:
"Extend YANG so that a *specific* schema tree can be grafted at a given data node."
One example given by Lada in the discussion is:
"
I believe there are other use cases in the existing modules. For
example, the ietf-routing module could simply define the data model for
a single routing instance (i.e. without "routing-instance" list at the
top), and it can be then used without changes on simple devices, and
more complex router implementations can graft it as a subtree under
"routing-instance", "networking-instance" or whatever.

"
I think this is something more relevant to what we are doing. I think we should consider to take this approach.

Cheers.

>> nor any existing technology requires, except maybe CFM itself. Where 
>> is this stipulation coming from and why is it a MUST?
>> 
> 

Mahesh Jethanandani
[email-masked]