Subject: RE: Taking BFD to full standard (was Re: IETF 94 candidate minutes)

From: Alexander Vainshtein <[email-masked]>
Date: Wed, 18 Nov 2015 12:47:18 +0000

Jeff and all,
Does not moving to full standard require an implementation survey and posting its results as a draft (to be progressed to an Informational RFC)?

The example I have in mind is with LDP progressing to Draft Standard. 
The survey form has been issued in August 2002, and RFCs 5036 (LDP as a Draft Standard) and 5038 (2002 Survey results) have been only published in 2007, so it took quite some time:-).
 
I know that IETYF tries to speed up the process - but does this mean that we can now skip the formalities of Implementation Survey?

Regards,
Sasha

Office: +972-39266302
Cell:      +972-549266302
Email:   [email-masked]

-----Original Message-----
From: Rtg-bfd [mailto:[email-masked]] On Behalf Of Jeffrey Haas
Sent: Wednesday, November 18, 2015 12:32 PM
To: Marc Binderberger
Cc: [email-masked]
Subject: Taking BFD to full standard (was Re: IETF 94 candiate minutes)

Marc,

On Tue, Nov 17, 2015 at 10:55:21PM -0800, Marc Binderberger wrote:
> > [Jeff Haas]: BFD has been pretty stable for several years. We 
> > potentially can take BFD to full standard then. This needs to do 
> > errata, implementation reports, etc. Question to WG - do you think 
> > that BFD should be considered to be full standard?
> > [Answer]
> > 0 hands.
> > [Jeff Haas]
> > I will take the question to the mailing list.
> 
> 
> Being a full standard, does this has any implications for BFD?  Will 
> there be more IETF-hoops to jump through for future protocol work?  Or 
> is it more a natural step for a stable "Proposed Standard" to be recognized as a Standard?

No additional hoops for future work.  It is just recognition of stability.
It should be noted that of all of the RFC series, there are less than 100 full standard document sets.

But that said, part of the work of moving to full standard is taking care of any open issues in the specs.  With regard to the based RFC 5880, this really covers two items:

- Demand mode, no one implements this.
- The M-bit, for multipoint.  We're trying to get that implemented. :-)

It's perhaps arguable that the fast authentication mechanism and the better cryptographic functionality drafts are part of the suite we'd want to take with us if we went to full standard.

-- Jeff

---

From: Jeffrey Haas <[email-masked]>
Date: Wed, 18 Nov 2015 09:20:21 -0500

Sasha,

> Does not moving to full standard require an implementation survey and posting its results as a draft (to be progressed to an Informational RFC)?

An implementation survey is likely still required.  Whether it would be
required to be published as an RFC is an open question.  The IESG has been
moving away from certain "process" documents needing to be published as an
RFC; for example, use case documents and problem statements.

> I know that IETYF tries to speed up the process - but does this mean that we can now skip the formalities of Implementation Survey?

The stage of Draft standard was removed by RFC 6410.  Even with this
reduction in process, very few RFCs have looked for a status increase.

-- Jeff