Subject: PALS Working Group Last Call for draft-ietf-pals-seamless-vccv-01

From: "Andrew G. Malis" <[email-masked]>
Date: Mon, 8 Feb 2016 10:16:53 -0500

This is the PALS Working Group Last Call for draft-ietf-pals-seamless-vccv-01.
You can find the draft at:

*https://tools.ietf.org/html/draft-ietf-pals-seamless-vccv-01
<https://tools.ietf.org/html/draft-ietf-pals-seamless-vccv-01>*

Because of the subject matter, this WG LC has been copied to the BFD WG
list as well. Please, submit comments to the PALS list only.

This last call will run for two weeks, ending on February 22.

We would appreciate even just responses that you've read the draft and
support publication, even if you don't have any specific comments. Of
course, more extensive comments are invited. especially from BFD and/or
VCCV experts.

Thanks,
Andy and Stewart

---

From: "Srihari Raghavan (srihari)" <[email-masked]>
Date: Tue, 9 Feb 2016 07:13:01 +0000

Support adoption of the draft, after going through the same.

Thanks
Srihari
From: Rtg-bfd <[email-masked]<mailto:[email-masked]>> on behalf of "Andrew G. Malis" <[email-masked]<mailto:[email-masked]>>
Date: Monday, 8 February 2016 8:46 pm
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: PALS Working Group Last Call for draft-ietf-pals-seamless-vccv-01

This is the PALS Working Group Last Call for draft-ietf-pals-seamless-vccv-01. You can find the draft at:

https://tools.ietf.org/html/draft-ietf-pals-seamless-vccv-01

Because of the subject matter, this WG LC has been copied to the BFD WG list as well. Please, submit comments to the PALS list only.

We would appreciate even just responses that you've read the draft and support publication, even if you don't have any specific comments. Of course, more extensive comments are invited. especially from BFD and/or VCCV experts.

Thanks,
Andy and Stewart

---

From: Alexander Vainshtein <[email-masked]>
Date: Tue, 9 Feb 2016 09:29:53 +0000

Andy and all,
After reading the draft I do not support its progression in its present state.

The main reason for that is that two important issues are denoted as TBD in the draft:

1.       S-BFD Reflector Demultiplexing (Section 2.2.2.1).  This issue should be really easy to resolve IMHO (unless I am missing something important), since:

a.       Demultiplexing of S-BFD packets is described in detail in Section 7.1 of the Base S-BFD draft<https://tools.ietf.org/html/draft-ietf-bfd-seamless-base-05>

b.      Additionally, I would expect that just one S-BFD session per PW is required. Unfortunately the draft does not say anything about this issue

2.       S-BFD Reflector advertisement of target discriminators using LDP (Section 2.2.2.3).

a.       From my POV leaving this issue unresolved effectively means that S-BFD cannot be used with signaled PWs over an MPLS PSN, since the draft states (in Section 2.2.2, 1st para) that “When as pseudowire signaling protocol such as LDP or L2TPv3 is in use the S-BFD Reflector advertises its target discriminators using  that signaling protocol”

b.      It should be noticed that advertisement of target discriminators using L2TP is resolved in the document. So closing the issue with LDP should not be too complicated.
I also find it strange that Section 2.2.2 refers to a TBD Section of the Base S-BFD draft for the definition of setting the BFD Protocol fields by the S-BFD Reflector. To the best of my understanding references to two different sections of the base S-BFD draft (7.3.2 and 7.8) should be used there.

I will review the draft again once the current gaps are closed.

Regards,
Sasha

Office: +972-39266302
Cell:      +972-549266302
Email:   [email-masked]

From: Pals [mailto:[email-masked]] On Behalf Of Andrew G. Malis
Sent: Monday, February 08, 2016 5:17 PM
To: [email-masked]
Cc: [email-masked]
Subject: [Pals] PALS Working Group Last Call for draft-ietf-pals-seamless-vccv-01

Thanks,
Andy and Stewart

---

From: "Andrew G. Malis" <[email-masked]>
Date: Mon, 22 Feb 2016 19:12:43 -0500

This ends the WG last call. Carlos, please upload a new revision to reflect
received comments and clear out the TBDs.

Thanks,
Andy

---

From: "Carlos Pignataro (cpignata)" <[email-masked]>
Date: Tue, 23 Feb 2016 00:47:20 +0000

Thanks, Andy!

I just uploaded a new revision which should address all the comments received and summarize all the discussion held.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-pals-seamless-vccv/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-pals-seamless-vccv-02

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-pals-seamless-vccv-02

Thanks!

- Carlos.

From: Rtg-bfd <[email-masked]<mailto:[email-masked]>> on behalf of "Andrew G. Malis" <[email-masked]<mailto:[email-masked]>>
Date: Monday, February 22, 2016 at 7:12 PM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: PALS Working Group Last Call for draft-ietf-pals-seamless-vccv-01

This ends the WG last call. Carlos, please upload a new revision to reflect received comments and clear out the TBDs.

Thanks,
Andy

On Mon, Feb 8, 2016 at 10:16 AM, Andrew G. Malis <[email-masked]<mailto:[email-masked]>> wrote:
This is the PALS Working Group Last Call for draft-ietf-pals-seamless-vccv-01. You can find the draft at:

Thanks,
Andy and Stewart

---

From: Alexander Vainshtein <[email-masked]>
Date: Tue, 1 Mar 2016 01:08:47 +0000

Hi all,
I have read the -02 revision and my original concerns are successfully resolved. In particular I accept the authors' decision not to address signaling of the discriminator values using via LDP leaving that to a separate document.

I apologize for a delayed response.

Thumb typed on my cellphone
Regards,
Sasha

-------- Original Message --------
From: "Carlos Pignataro (cpignata)" <[email-masked]>
Date: Mon, February 22, 2016 6:47 PM -0600
To: "Andrew G. Malis" <[email-masked]>, [email-masked]
CC: [email-masked]
Subject: Re: PALS Working Group Last Call for draft-ietf-pals-seamless-vccv-01

Thanks, Andy!

Thanks!

- Carlos.

Thanks,
Andy

Thanks,
Andy and Stewart

---

From: "Andrew G. Malis" <[email-masked]>
Date: Mon, 29 Feb 2016 22:19:26 -0500

Sasha,

Thanks! Now the ball’s in my court. :-)

Cheers,
Andy

On Mon, Feb 29, 2016 at 8:08 PM, Alexander Vainshtein <
[email-masked]> wrote:

> I just uploaded a new revision which should address all the comments
> received and summarize all the discussion held.
>
> — Carlos.
> From: Rtg-bfd <[email-masked]> on behalf of "Andrew G. Malis" <
> [email-masked]>
> To: "[email-masked]" <[email-masked]>
> Cc: "[email-masked]" <[email-masked]>
> This ends the WG last call. Carlos, please upload a new revision to
> reflect received comments and clear out the TBDs.
>
> Thanks,
> Andy
>
>