Subject: Replace "seamless" with "stateless"

From: Manav Bhatia <[email-masked]>
Date: Tue, 3 May 2016 05:22:30 +0530

Hi,

Does it make sense to change "seamless BFD" with "stateless BFD" in the
documents? Its very convoluted to explain whats "seamless" about S-BFD.

We called it "seamless" because it was simple and largely stateless.

Any suggestions?

Cheers, Manav

---

From: Sam Aldrin <[email-masked]>
Date: Mon, 2 May 2016 17:16:01 -0700

Think there was some discussion during the extension of the charter for this work item. Not sure what the conclusion was exactly. IIRC, we found the cool term 'seamless' and tried to fit in SBFD work into that definition, rather than finding a term fitting the definition.

Not sure if stateless is complete enough, but I have no opinion either way. On the contrary, someone asked if S means SDN :D

Sam

Sent from my iPhone

> On May 2, 2016, at 4:52 PM, Manav Bhatia <[email-masked]> wrote:
> 
> Hi,
> 
> Does it make sense to change "seamless BFD" with "stateless BFD" in the documents? Its very convoluted to explain whats "seamless" about S-BFD.
>

---

From: Manav Bhatia <[email-masked]>
Date: Tue, 3 May 2016 09:55:28 +0530

I agree that stateless may not be complete enough, and just highlights one
aspect of SBFD -- however, its better than "seamless", which i grudgingly
concede, may sound pretty nifty, but means and conveys almost nothing.

I dont think its too late into the WG cycle to change the name -- heck, all
it needs is a DISCUSS from one of the IESG members ! :-)

If the WG consensus is that "seamless" succinctly captures the essence of
SBFD then we could leave it as is. However, i propose that we replace it
with something more meaningful, that hopefully starts with "S" so that its
still "SBFD" because you dont want all developers out there to rename their
variables and function names now.

Cheers, Manav

On Tue, May 3, 2016 at 5:46 AM, Sam Aldrin <[email-masked]> wrote:

> Think there was some discussion during the extension of the charter for
> this work item. Not sure what the conclusion was exactly. IIRC, we found
> the cool term 'seamless' and tried to fit in SBFD work into that
> definition, rather than finding a term fitting the definition.
>
> Not sure if stateless is complete enough, but I have no opinion either
> way. On the contrary, someone asked if S means SDN :D
>
> Sam
>
> Sent from my iPhone
>

---

From: "Les Ginsberg (ginsberg)" <[email-masked]>
Date: Tue, 3 May 2016 06:14:43 +0000

This was debated at length 2 years ago and somehow we ended up with “seamless”.
While I am no way invested in “seamless” – the IGP drafts have already proceeded to IESG review – and in the case of the OSPF draft at least, the word “seamless” is used multiple times. So you would have to insure “seamless” is expunged everywhere it needs to be.
Given this wasn’t shot down 2 years ago it seems rather late in the game to make such a change. Can’t we simply live with what we have?

If nothing else it will make a great story to tell your overly nerdy grandchildren. ☺

   Les

From: Rtg-bfd [mailto:[email-masked]] On Behalf Of Manav Bhatia
Sent: Monday, May 02, 2016 9:25 PM
To: Sam Aldrin
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: Replace "seamless" with "stateless"

I agree that stateless may not be complete enough, and just highlights one aspect of SBFD -- however, its better than "seamless", which i grudgingly concede, may sound pretty nifty, but means and conveys almost nothing.

I dont think its too late into the WG cycle to change the name -- heck, all it needs is a DISCUSS from one of the IESG members ! :-)

If the WG consensus is that "seamless" succinctly captures the essence of SBFD then we could leave it as is. However, i propose that we replace it with something more meaningful, that hopefully starts with "S" so that its still "SBFD" because you dont want all developers out there to rename their variables and function names now.

Cheers, Manav

On Tue, May 3, 2016 at 5:46 AM, Sam Aldrin <[email-masked]<mailto:[email-masked]>> wrote:
Think there was some discussion during the extension of the charter for this work item. Not sure what the conclusion was exactly. IIRC, we found the cool term 'seamless' and tried to fit in SBFD work into that definition, rather than finding a term fitting the definition.

Sam

Sent from my iPhone

> On May 2, 2016, at 4:52 PM, Manav Bhatia <[email-masked]<mailto:[email-masked]>> wrote:
>
> Hi,
>

---

From: "Carlos Pignataro (cpignata)" <[email-masked]>
Date: Tue, 3 May 2016 09:26:22 +0000

I'm with Les -- that ship has sailed almost exactly two years ago, when we had a most thorough and lengthy discussion about it:
https://www.ietf.org/mail-archive/web/rtg-bfd/current/msg02051.html

I, for one, use "S-BFD" (as there are really many fitting qualifiers that start with "S". The docs explain the why for the "seamless" name, and the seam being removed.

Thanks!

Thumb typed by Carlos Pignataro.
Excuze typofraphicak errows

On May 3, 2016, at 02:14, Les Ginsberg (ginsberg) <[email-masked]<mailto:[email-masked]>> wrote:

This was debated at length 2 years ago and somehow we ended up with "seamless".
While I am no way invested in "seamless" - the IGP drafts have already proceeded to IESG review - and in the case of the OSPF draft at least, the word "seamless" is used multiple times. So you would have to insure "seamless" is expunged everywhere it needs to be.
Given this wasn't shot down 2 years ago it seems rather late in the game to make such a change. Can't we simply live with what we have?

If nothing else it will make a great story to tell your overly nerdy grandchildren. :)

   Les

From: Rtg-bfd [mailto:[email-masked]] On Behalf Of Manav Bhatia
Sent: Monday, May 02, 2016 9:25 PM
To: Sam Aldrin
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: Replace "seamless" with "stateless"

Cheers, Manav

Sam

Sent from my iPhone

---

From: Manav Bhatia <[email-masked]>
Date: Tue, 3 May 2016 15:08:18 +0530

I am also with Les -- it'll make a great story to tell the kids some day on
what we were sniffing when we came up with "seamless" ! :-)

Matter closed. Lets move on to addressing the IESG comments now.

Cheers, Manav

On Tue, May 3, 2016 at 2:56 PM, Carlos Pignataro (cpignata) <
[email-masked]> wrote:

> I'm with Les -- that ship has sailed almost exactly two years ago, when we
> had a most thorough and lengthy discussion about it:
> I, for one, use "S-BFD" (as there are really many fitting qualifiers that
> start with "S". The docs explain the why for the "seamless" name, and the
> seam being removed.
>
> Thanks!
>
> On May 3, 2016, at 02:14, Les Ginsberg (ginsberg) <[email-masked]>
> wrote:
>
> While I am no way invested in “seamless” – the IGP drafts have already
> proceeded to IESG review – and in the case of the OSPF draft at least, the
> word “seamless” is used multiple times. So you would have to insure
> “seamless” is expunged everywhere it needs to be.
>
> Given this wasn’t shot down 2 years ago it seems rather late in the game
> to make such a change. Can’t we simply live with what we have?
>
>
>
> If nothing else it will make a great story to tell your overly nerdy
> grandchildren. J
>
>
>
>    Les
>
>
>
>
>
>
>
> *From:* Rtg-bfd [mailto:[email-masked]
> <[email-masked]>] *On Behalf Of *Manav Bhatia
> *Sent:* Monday, May 02, 2016 9:25 PM
> *To:* Sam Aldrin
> *Cc:* [email-masked]; [email-masked];
> [email-masked]
> *Subject:* Re: Replace "seamless" with "stateless"
>
>
>
> I dont think its too late into the WG cycle to change the name -- heck,
> all it needs is a DISCUSS from one of the IESG members ! :-)
>
>
>

---

From: Jeffrey Haas <[email-masked]>
Date: Wed, 11 May 2016 12:22:53 -0400

> Matter closed. Lets move on to addressing the IESG comments now.

For the record, the reason I believe we eventually left it as "seamless" was
some amount of name similarity with the suite of stuff working its way
through MPLS as "seamless MPLS".  

And while these things make for interesting stories, it does mean some level
of repeatedly explaining them to English as a second language speakers.
(And don't get me started on the definition of "ephemeral" as was used in
I2RS...)

-- Jeff (who already has to explain to ESL speakers why some English
speakers giggle about the name 'BFD')