Subject: Re: [nvo3] FW: New Version Notification for draft-spallagatti-bfd-vxlan-03.txt

From: "Bocci, Matthew (Nokia - GB)" <[email-masked]>
Date: Mon, 23 May 2016 15:15:15 +0000

Folks

Please could you direct any discussion on this draft to the NVO3 working
group list.

Regards

Matthew

On 18/04/2016, 07:54, "nvo3 on behalf of Vengada Prasad Govindan
(venggovi)" <[email-masked] on behalf of [email-masked]> wrote:

>Hello all,
>  The authors request comments on the draft below.
>Thanks
>Prasad
>
>-----Original Message-----
>From: [email-masked] [mailto:[email-masked]]
>Sent: Saturday, April 16, 2016 11:33 AM
>To: MALLIK MUDIGONDA (mmudigon) <[email-masked]>; Basil Saji
><[email-masked]>; Greg Mirsky <[email-masked]>; Vengada
>Prasad Govindan (venggovi) <[email-masked]>; Juniper Networks
><[email-masked]>; Sudarsan Paragiri <[email-masked]>;
>Santosh Pallagatti <[email-masked]>; [email-masked]
><[email-masked]>
>Subject: New Version Notification for draft-spallagatti-bfd-vxlan-03.txt
>
>
>A new version of I-D, draft-spallagatti-bfd-vxlan-03.txt
>has been successfully submitted by Vengada Prasad Govindan and posted to
>the IETF repository.
>
>Name:		draft-spallagatti-bfd-vxlan
>Revision:	03
>Title:		BFD for VXLAN
>Document date:	2016-04-15
>Group:		Individual Submission
>Pages:		9
>URL:            
>https://www.ietf.org/internet-drafts/draft-spallagatti-bfd-vxlan-03.txt
>Status:         
>https://datatracker.ietf.org/doc/draft-spallagatti-bfd-vxlan/
>Htmlized:       https://tools.ietf.org/html/draft-spallagatti-bfd-vxlan-03
>Diff:           
>https://www.ietf.org/rfcdiff?url2=draft-spallagatti-bfd-vxlan-03
>
>Abstract:
>   This document describes use of Bidirectional Forwarding Detection
>   (BFD) protocol for VXLAN .
>
>
>                  
>        
>
>
>Please note that it may take a couple of minutes from the time of
>submission until the htmlized version and diff are available at
>tools.ietf.org.
>
>The IETF Secretariat
>
>_______________________________________________
>nvo3 mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/nvo3

---

From: Greg Mirsky <[email-masked]>
Date: Mon, 23 May 2016 12:47:23 -0700

+BFD WG and RTGWG OOAM DT

Hi Anoop,
thank you for your review and the question. The scope of this draft is only
for the VXLAN. The Overlay OAM Desing Team is working on the Requirements,
Gap Analysis and, if there will be required, enhancements and/or new OAM
protocols for BIER, NSH, VXLAN-GPE, GENEVE, and GUE, as defined in its
charter. Would appreciate you review and comments of the two documents the
OOAM-DT already presented in BA meeting:

   - OOAM Requirements
   - OAM for Overlay Networks: Gap analysis

In the latter you'll find the example to demonstrate applicability of BFD
Async mode in BIER domain. As we've discussed, other BFD may be applied to
other overlay networks that I've listed above even though their method of
indication OAM payload may be different from BIER. Would you agree, or
suggest to have another example of BFD?

Regards, Greg

On Mon, May 23, 2016 at 12:26 PM, Anoop Ghanwani <[email-masked]>
wrote:

> Authors,
>
> In section 4.1, you have this:
> >>>
>
>    Next Protocol Field in GPE header MUST be set to IPv4 or IPv6.
> ...
>    The BFD packet MUST be carried inside the inner MAC frame of the
>    VxLAN packet.  The inner MAC frame carrying the BFD payload has the
>    following format:
>
> >>>
>
> These two statements seem to contradict each other.  If the GPE header
> indicates IPv4 or IPv6, then how can the BFD packet be encapsulated within
> a MAC frame?
>
> Can you please clarify?
>
> Thanks,
> Anoop
>
>
> On Mon, May 23, 2016 at 8:15 AM, Bocci, Matthew (Nokia - GB) <
> [email-masked]> wrote:
>
>> Folks
>>
>> >Htmlized:
>> https://tools.ietf.org/html/draft-spallagatti-bfd-vxlan-03
>> >Diff:

---

From: Greg Mirsky <[email-masked]>
Date: Mon, 23 May 2016 12:49:00 -0700

Now with the correct OOAM-DT address

On Mon, May 23, 2016 at 12:47 PM, Greg Mirsky <[email-masked]> wrote:

> thank you for your review and the question. The scope of this draft is
> only for the VXLAN. The Overlay OAM Desing Team is working on the
> Requirements, Gap Analysis and, if there will be required, enhancements
> and/or new OAM protocols for BIER, NSH, VXLAN-GPE, GENEVE, and GUE, as
> defined in its charter. Would appreciate you review and comments of the two
> documents the OOAM-DT already presented in BA meeting:
>
>    - OOAM Requirements

---

From: Shahram Davari <[email-masked]>
Date: Mon, 23 May 2016 13:17:39 -0700

Greg,

I am wondering why you are not using Ethernet-OAM over VXLAN rather than
encapsulating BFD in UDP/IP/Ethernet and then encapsulating it in VXLAN?

Thx

Shahram

*From:* Rtg-bfd [mailto:[email-masked]] *On Behalf Of *Greg Mirsky
*Sent:* Monday, May 23, 2016 12:49 PM
*To:* Anoop Ghanwani
*Cc:* [email-masked]; [email-masked]; [email-masked]
*Subject:* Re: [nvo3] FW: New Version Notification for
draft-spallagatti-bfd-vxlan-03.txt

Hi Anoop,

   - OOAM Requirements

Regards, Greg

Authors,

In section 4.1, you have this:

...

   following format:

Can you please clarify?

Thanks,

Anoop

Folks

Regards

Matthew

---

From: Gregory Mirsky <[email-masked]>
Date: Mon, 23 May 2016 20:22:44 +0000

Because this is IETF ☺

From: Rtg-bfd [mailto:[email-masked]] On Behalf Of Shahram Davari
Sent: Monday, May 23, 2016 1:18 PM
To: Greg Mirsky; Anoop Ghanwani
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: RE: [nvo3] FW: New Version Notification for draft-spallagatti-bfd-vxlan-03.txt

Greg,

I am wondering why you are not using Ethernet-OAM over VXLAN rather than encapsulating BFD in UDP/IP/Ethernet and then encapsulating it in VXLAN?

Thx
Shahram

From: Rtg-bfd [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Greg Mirsky
Sent: Monday, May 23, 2016 12:49 PM
To: Anoop Ghanwani
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [nvo3] FW: New Version Notification for draft-spallagatti-bfd-vxlan-03.txt

On Mon, May 23, 2016 at 12:47 PM, Greg Mirsky <[email-masked]<mailto:[email-masked]>> wrote:
+BFD WG and RTGWG OOAM DT

Hi Anoop,
thank you for your review and the question. The scope of this draft is only for the VXLAN. The Overlay OAM Desing Team is working on the Requirements, Gap Analysis and, if there will be required, enhancements and/or new OAM protocols for BIER, NSH, VXLAN-GPE, GENEVE, and GUE, as defined in its charter. Would appreciate you review and comments of the two documents the OOAM-DT already presented in BA meeting:

  *   OOAM Requirements
  *   OAM for Overlay Networks: Gap analysis
In the latter you'll find the example to demonstrate applicability of BFD Async mode in BIER domain. As we've discussed, other BFD may be applied to other overlay networks that I've listed above even though their method of indication OAM payload may be different from BIER. Would you agree, or suggest to have another example of BFD?

Regards, Greg

On Mon, May 23, 2016 at 12:26 PM, Anoop Ghanwani <[email-masked]<mailto:[email-masked]>> wrote:
Authors,

In section 4.1, you have this:

...

   following format:

These two statements seem to contradict each other.  If the GPE header indicates IPv4 or IPv6, then how can the BFD packet be encapsulated within a MAC frame?

Can you please clarify?

Thanks,
Anoop

On Mon, May 23, 2016 at 8:15 AM, Bocci, Matthew (Nokia - GB) <[email-masked]<mailto:[email-masked]>> wrote:
Folks

Regards

Matthew

On 18/04/2016, 07:54, "nvo3 on behalf of Vengada Prasad Govindan
(venggovi)" <[email-masked]<mailto:[email-masked]> on behalf of [email-masked]<mailto:[email-masked]>> wrote:

>From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]<mailto:[email-masked]>]
>To: MALLIK MUDIGONDA (mmudigon) <[email-masked]<mailto:[email-masked]>>; Basil Saji
><[email-masked]<mailto:[email-masked]>>; Greg Mirsky <[email-masked]<mailto:[email-masked]>>; Vengada
>Prasad Govindan (venggovi) <[email-masked]<mailto:[email-masked]>>; Juniper Networks
><[email-masked]<mailto:[email-masked]>>; Sudarsan Paragiri <[email-masked]<mailto:[email-masked]>>;
>Santosh Pallagatti <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
><[email-masked]<mailto:[email-masked]>>
>tools.ietf.org<http://tools.ietf.org>.
>
>The IETF Secretariat
>
>[email-masked]<mailto:[email-masked]>

_______________________________________________
nvo3 mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/nvo3

_______________________________________________
nvo3 mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/nvo3

---

From: "Larry Kreeger (kreeger)" <[email-masked]>
Date: Mon, 23 May 2016 20:42:07 +0000

Hello Authors,

First, when referencing VXLAN GPE I would prefer it not be shortened to
³GPE² but use the full ³VXLAN GPE² to be sure it is not ambiguous.

Second, I agree with Anoop¹s comment about using the next protocol of
IPv4/v6.  When directly encapsulating these protocols, there is no
Ethernet header present.

Third, in both these cases (L2 being encapsulated or IP being
encapsulated), I am concerned that since this draft is using the VTEP
(underlay) address space within the inner frames/packets, there could be a
collision between the VTEP addresses and the tenant¹s addresses.  As it
stands with VXLAN, it is perfectly acceptable for tenants to overlap MAC
or IP addresses with the VTEPs.  With this draft, I believe it will be
broken.

 - Larry

---

From: Shahram Davari <[email-masked]>
Date: Mon, 23 May 2016 13:46:51 -0700

Haha!

Regards,
Shahram

> On May 23, 2016, at 1:22 PM, Gregory Mirsky <[email-masked]> wrote:
> 
> Because this is IETF J
>  
> From: Rtg-bfd [mailto:[email-masked]] On Behalf Of Greg Mirsky
> OOAM Requirements
> OAM for Overlay Networks: Gap analysis
> On Mon, May 23, 2016 at 12:26 PM, Anoop Ghanwani <[email-masked]> wrote:
> Authors,
>  
> On Mon, May 23, 2016 at 8:15 AM, Bocci, Matthew (Nokia - GB) <[email-masked]> wrote:
> Folks
>

---

From: Shahram Davari <[email-masked]>
Date: Mon, 23 May 2016 14:22:34 -0700

Greg,

On a serious note, Ethernet OAM seems a much better fit here, since we are
talking about Layer 2 connectivity.

If that is not acceptable by IETF then I have the following questions:

1)      We know that the outer IP addresses are the addresses of
originating and terminating VTEP. Then Why the inner IP Address is also the
Address of VTEP? Shouldn’t the inner IP addresses represent the originating
and terminating OAM processor?

2)      Similarly shouldn’t the inner MAC should represent the MAC address
of the OAM processor?

3)      Why don’t we define a new Ethertype so we can encapsulate BFD
directly over inner L2? The draft requires multiple IP and UDP headers,
that makes processing very complex.

Thanks

Shahram

*From:* Gregory Mirsky [mailto:[email-masked]]
*Sent:* Monday, May 23, 2016 1:23 PM
*To:* Shahram Davari; Greg Mirsky; Anoop Ghanwani
*Cc:* [email-masked]; [email-masked]; [email-masked]
*Subject:* RE: [nvo3] FW: New Version Notification for
draft-spallagatti-bfd-vxlan-03.txt

Because this is IETF J

*From:* Rtg-bfd [mailto:[email-masked] <[email-masked]>]
*On Behalf Of *Shahram Davari
*Sent:* Monday, May 23, 2016 1:18 PM
*To:* Greg Mirsky; Anoop Ghanwani
*Cc:* [email-masked]; [email-masked]; [email-masked]
*Subject:* RE: [nvo3] FW: New Version Notification for
draft-spallagatti-bfd-vxlan-03.txt

Greg,

Thx

Shahram

Hi Anoop,

   - OOAM Requirements

Regards, Greg

Authors,

In section 4.1, you have this:

...

   following format:

Can you please clarify?

Thanks,

Anoop

Folks

Regards

Matthew

---

From: Anoop Ghanwani <[email-masked]>
Date: Mon, 23 May 2016 14:35:27 -0700

Hi Greg,

I think Larry has covered the points I was trying to bring up...if there's
a MAC header present, then the VXLAN GPE next header has to indicate
"Ethernet" rather than "IPv4" or "IPv6".

Thanks,
Anoop

---

From: Shahram Davari <[email-masked]>
Date: Mon, 23 May 2016 14:36:10 -0700

Anoop is correct.

Thx
SD

*From:* nvo3 [mailto:[email-masked]] *On Behalf Of *Anoop Ghanwani
*Sent:* Monday, May 23, 2016 2:35 PM
*To:* Greg Mirsky
*Cc:* [email-masked]; [email-masked]; [email-masked]
*Subject:* Re: [nvo3] FW: New Version Notification for
draft-spallagatti-bfd-vxlan-03.txt

Hi Greg,

Thanks,

Anoop

Hi Anoop,

   - OOAM Requirements

Regards, Greg

Authors,

In section 4.1, you have this:

...

   following format:

Can you please clarify?

Thanks,

Anoop

Folks

Regards

Matthew

---

From: Gregory Mirsky <[email-masked]>
Date: Mon, 23 May 2016 21:46:44 +0000

Hi Anoop, Larry, Shahram, et. al,
thank you for the correction. We’ll address it in the next update.

                Regards,
                                Greg

From: Rtg-bfd [mailto:[email-masked]] On Behalf Of Anoop Ghanwani
Sent: Monday, May 23, 2016 2:35 PM
To: Greg Mirsky
Cc: [email-masked]; [email-masked]; [email-masked]
Subject: Re: [nvo3] FW: New Version Notification for draft-spallagatti-bfd-vxlan-03.txt

Hi Greg,

I think Larry has covered the points I was trying to bring up...if there's a MAC header present, then the VXLAN GPE next header has to indicate "Ethernet" rather than "IPv4" or "IPv6".

Thanks,
Anoop

Hi Anoop,

  *   OOAM Requirements

Regards, Greg

In section 4.1, you have this:

...

   following format:

Can you please clarify?

Thanks,
Anoop

Regards

Matthew

---

From: Anoop Ghanwani <[email-masked]>
Date: Mon, 23 May 2016 16:11:36 -0700

Thanks Greg.

Perhaps what you meant to say was that the Ethertype in the inner MAC
header must be either IPv4 or IPv6.

Anoop

On Mon, May 23, 2016 at 2:46 PM, Gregory Mirsky <[email-masked]

> *From:* Rtg-bfd [mailto:[email-masked]] *On Behalf Of *Anoop
> Ghanwani
>

---

From: Gregory Mirsky <[email-masked]>
Date: Mon, 23 May 2016 23:19:43 +0000

Hi Anoop,
thank you for the suggestion, it does make lots of sense. Frankly, need to refresh my memory on this draft.
Would appreciate your review and comments on the work by OOAM-DT.

                Regards,
                                Greg

From: [email-masked] [mailto:[email-masked]] On Behalf Of Anoop Ghanwani
Sent: Monday, May 23, 2016 4:12 PM
To: Gregory Mirsky
Cc: [email-masked]; [email-masked]
Subject: Re: [nvo3] FW: New Version Notification for draft-spallagatti-bfd-vxlan-03.txt

Thanks Greg.

Perhaps what you meant to say was that the Ethertype in the inner MAC header must be either IPv4 or IPv6.

Anoop

On Mon, May 23, 2016 at 2:46 PM, Gregory Mirsky <[email-masked]<mailto:[email-masked]>> wrote:
Hi Anoop, Larry, Shahram, et. al,
thank you for the correction. We’ll address it in the next update.

                Regards,
                                Greg

From: Rtg-bfd [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Anoop Ghanwani

Sent: Monday, May 23, 2016 2:35 PM
To: Greg Mirsky
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [nvo3] FW: New Version Notification for draft-spallagatti-bfd-vxlan-03.txt

Hi Greg,

Thanks,
Anoop

Hi Anoop,

  *   OOAM Requirements

Regards, Greg

In section 4.1, you have this:

...

   following format:

Can you please clarify?

Thanks,
Anoop

Regards

Matthew