Subject: Re: [bess] I-D Action: draft-ietf-bess-mvpn-fast-failover-01.txt

From: "Reshad Rahman (rrahman)" <[email-masked]>
Date: Thu, 21 Jul 2016 12:46:07 +0000

I second the comments made by Greg, Ccing BFD WG since BFD multipoint is
used for failure detection and BGP is being extended to carry BFD
discriminator.

Regards,
Reshad.

On 2016-07-07, 10:23 AM, "BESS on behalf of [email-masked]"
<[email-masked] on behalf of [email-masked]> wrote:

>
>A New Internet-Draft is available from the on-line Internet-Drafts
>directories.
>This draft is a work item of the BGP Enabled ServiceS of the IETF.
>
>        Title           : Multicast VPN fast upstream failover
>        Authors         : Thomas Morin
>                          Robert Kebler
>	Filename        : draft-ietf-bess-mvpn-fast-failover-01.txt
>	Pages           : 18
>	Date            : 2016-07-07
>
>Abstract:
>   This document defines multicast VPN extensions and procedures that
>   allow fast failover for upstream failures, by allowing downstream PEs
>   to take into account the status of Provider-Tunnels (P-tunnels) when
>   selecting the upstream PE for a VPN multicast flow, and extending BGP
>   MVPN routing so that a C-multicast route can be advertized toward a
>   standby upstream PE.
>
>
>
>The IETF datatracker status page for this draft is:
>https://datatracker.ietf.org/doc/draft-ietf-bess-mvpn-fast-failover/
>
>There's also a htmlized version available at:
>https://tools.ietf.org/html/draft-ietf-bess-mvpn-fast-failover-01
>
>A diff from the previous version is available at:
>https://www.ietf.org/rfcdiff?url2=draft-ietf-bess-mvpn-fast-failover-01
>
>
>Please note that it may take a couple of minutes from the time of
>submission
>until the htmlized version and diff are available at tools.ietf.org.
>
>Internet-Drafts are also available by anonymous FTP at:
>ftp://ftp.ietf.org/internet-drafts/
>
>_______________________________________________
>BESS mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/bess

---

From: "Reshad Rahman (rrahman)" <[email-masked]>
Date: Fri, 22 Jul 2016 21:06:56 +0000

Since BGP may be used to exchange discriminators for EVPN also, would it
make sense to have a sepaarte BESS draft just for BFD discriminator
exchange?

Regards,
Reshad.

---

From: Gregory Mirsky <[email-masked]>
Date: Sat, 23 Jul 2016 06:19:33 +0000

Hi Reshad,
I absolutely agree and encourage new draft that defines the BGP-BFD Attribute and its relationship with BFD Discriminator TLV in LSP Ping (RFC 5884). And another question to the authors of draft-ietf-bess-mvpn-fast-failover, Do you see scenarios where draft-ietf-bfd-multipoint-active-tail can be used?

	Regards,
		Greg

-----Original Message-----
From: Reshad Rahman (rrahman) [mailto:[email-masked]] 
Sent: Friday, July 22, 2016 11:07 PM
To: [email-masked]; [email-masked]
Cc: Gregory Mirsky <[email-masked]>; [email-masked]; [email-masked]
Subject: Re: [bess] I-D Action: draft-ietf-bess-mvpn-fast-failover-01.txt

Since BGP may be used to exchange discriminators for EVPN also, would it make sense to have a sepaarte BESS draft just for BFD discriminator exchange?

Regards,
Reshad.

On 2016-07-21, 2:46 PM, "BESS on behalf of Reshad Rahman (rrahman)"
<[email-masked] on behalf of [email-masked]> wrote:

>I second the comments made by Greg, Ccing BFD WG since BFD multipoint 
>is used for failure detection and BGP is being extended to carry BFD 
>discriminator.
>
>Regards,
>Reshad.
>
>
>
>>submission until the htmlized version and diff are available at 
>>tools.ietf.org.
>>