Subject: Re: The BFD WG has placed draft-spallagatti-bfd-vxlan in state "Call For Adoption By WG Issued"

From: "Carlos Pignataro (cpignata)" <[email-masked]>
Date: Wed, 3 Jan 2018 14:08:36 +0000

Hi,

I read through draft-spallagatti-bfd-vxlan-06 and support its adoption as a BFD WG document.

I do have some comments and questions, which might require follow-up but neither of which is blocking on adoption. These questions can be discussed by the WG after a potential adoption.

1. References: The references should be appropriately split into Normative and Informative. For example, [I-D.ietf-bfd-multipoint] is not Normative.

2. S-BFD: I wonder given the work on this document and request for a dedicated MAC address, I wonder if it might make sense to also include S-BFD over VxLAN in this. It feels it might be a small incremental effort only, especially since support for BFD over UDP is specified.

3. “to enable continuity monitoring between Network Virtualization Edges (NVEs)” -> A visual on the actual termination points of the BFD sessions and what is being monitored will help.

4. "TTL: This MUST be set to 1.” -> I wonder if the value of using GTSM for this, since it’s within a tunnel only, was considered. Seems like using 255 and GTSM might be a better option.

5. Echo -> Any particular reason why Echo is outside scope? Seems it can be made work just fine.

Thanks!

—
Carlos Pignataro, [email-masked]<mailto:[email-masked]>

“Sometimes I use big words that I do not fully understand, to make myself sound more photosynthesis."

On Dec 21, 2017, at 10:15 AM, IETF Secretariat <[email-masked]<mailto:[email-masked]>> wrote:

The BFD WG has placed draft-spallagatti-bfd-vxlan in state
Call For Adoption By WG Issued (entered by Jeffrey Haas)

The document is available at
https://datatracker.ietf.org/doc/draft-spallagatti-bfd-vxlan/

Comment:
The authors of draft-spallagatti-bfd-vxlan have asked for adoption of their
draft by the BFD working group.  The BFD working group is chosen because the
document has implications on base RFC 5880 procedures.

Given the nature of the document, co-review and coordinated working group
last call with the nvo3 Working Group is expected.

The last date for comments for this adoption is January 20.  This extended
period is intended to accommodate end of year holidays.

A final note is that adoption is contingent upon our AD confirming this is
within current WG charter, or permitting us otherwise to re-charter
appropriately.

---

From: Jeffrey Haas <[email-masked]>
Date: Wed, 3 Jan 2018 10:49:25 -0500

Working Group,

As a reminder, we have an active adoption call for the BFD for vxlan
document.  We've seen support for it on the list, but a few more people
offering commentary from outside of the author's list would be helpful. :-)

-- Jeff

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Sat, 20 Jan 2018 00:00:31 +0000

Hi Jeff, 
I finally read this draft and support WG adoption (even though I’m NOT a fan of VXLAN, I realize it is a popular deployment scenario). 
Thanks,
Acee 

On 1/3/18, 10:45 AM, "Rtg-bfd on behalf of Jeffrey Haas" <[email-masked] on behalf of [email-masked]> wrote:

    Working Group,

    -- Jeff

---

From: Santosh P K <[email-masked]>
Date: Sat, 20 Jan 2018 08:28:35 +0530

As author of this draft I support this draft to. E adopted as working group
draft.

On Jan 20, 2018 5:31 AM, "Acee Lindem (acee)" <[email-masked]> wrote:

> Hi Jeff,
> I finally read this draft and support WG adoption (even though I’m NOT a
> fan of VXLAN, I realize it is a popular deployment scenario).
> Thanks,
> Acee
>
> On 1/3/18, 10:45 AM, "Rtg-bfd on behalf of Jeffrey Haas" <
> [email-masked] on behalf of [email-masked]> wrote:
>
>     Working Group,
>

---

From: Jeffrey Haas <[email-masked]>
Date: Wed, 24 Jan 2018 13:10:29 -0500

Working Group,

draft-spallagatti-bfd-vxlan has been adopted by the working group.  (And I'm
only four days late in replying to the long adoption!)

Authors, please resubmit as draft-ietf-bfd-vxlan.

Also, Authors, since my impression is that there are already multiple
interoperable implementations of the draft, please consider pushing hard to
reach the point where we can publish this ASAP. :-)

If the implementations are already publicly done, please unicast me and I'll
add them to the BFD status page on the wiki.

-- Jeff