Subject: Eric Rescorla's No Objection on draft-ietf-bfd-yang-16: (with COMMENT)

From: Eric Rescorla <[email-masked]>
Date: Wed, 04 Jul 2018 15:33:17 -0700

Eric Rescorla has entered the following ballot position for
draft-ietf-bfd-yang-16: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-bfd-yang/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Rich version of this review at:
https://mozphab-ietf.devsvcdev.mozaws.net/D6374

COMMENTS
S 2.1.4.
>              Minimum TTL of incoming BFD control packets.
>   
>   2.1.4.  MPLS Traffic Engineering Tunnels
>   
>      For MPLS-TE tunnels, BFD is configured under the MPLS-TE tunnel since
>      the desired failure detection parameters is a property of the MPLS-TE

"parameters are"

S 2.8.
>   
>   2.8.  BFD over LAG hierarchy
>   
>      A "lag" node is added under the "bfd" node in control-plane-protocol.
>      The configuration and operational state data for each BFD LAG session
>      is under this "lag" node.

There seems to be a lot of replication (e.g., number of sessions). Is
it possible to somehow refactor this so that's common?

---

From: "Reshad Rahman (rrahman)" <[email-masked]>
Date: Thu, 5 Jul 2018 12:39:05 +0000

Hi,

Thanks for the review, please see inline <RR>.

On 2018-07-04, 6:33 PM, "Eric Rescorla" <[email-masked]> wrote:

    

    
    COMMENTS
    S 2.1.4.
    
    "parameters are"
    
<RR> Change made, will be in the next rev.
    
    S 2.8.

    <RR> There is replication in that the different modules have similar information as you pointed out. But this is done via groupings, so the information such as number of sessions, number of sessions up etc is defined once and used in multiple locations.

Regards,
Reshad.

---

From: Eric Rescorla <[email-masked]>
Date: Thu, 5 Jul 2018 05:45:37 -0700

On Thu, Jul 5, 2018 at 5:39 AM, Reshad Rahman (rrahman) <[email-masked]>
wrote:

>     <RR> There is replication in that the different modules have similar
> information as you pointed out. But this is done via groupings, so the
> information such as number of sessions, number of sessions up etc is
> defined once and used in multiple locations.
>

Yes, but can't you incorporate the definitions by references so that the
diagrams are easier to read?

-Ekr

Regards,

---

From: "Reshad Rahman (rrahman)" <[email-masked]>
Date: Thu, 5 Jul 2018 13:10:24 +0000

Inline <RR2>.

From: Eric Rescorla <[email-masked]>
Date: Thursday, July 5, 2018 at 8:46 AM
To: "Reshad Rahman (rrahman)" <[email-masked]>
Cc: The IESG <[email-masked]>, Jeffrey Haas <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: Eric Rescorla's No Objection on draft-ietf-bfd-yang-16: (with COMMENT)

On Thu, Jul 5, 2018 at 5:39 AM, Reshad Rahman (rrahman) <[email-masked]<mailto:[email-masked]>> wrote:
Hi,

On 2018-07-04, 6:33 PM, "Eric Rescorla" <[email-masked]<mailto:[email-masked]>> wrote:

    COMMENTS
    S 2.1.4.

    "parameters are"

    S 2.8.

Yes, but can't you incorporate the definitions by references so that the diagrams are easier to read?

<RR2> The pyang tool does this for real references (leafref) but not in the grouping case (which is reuse and not reference). Even though there is replication in the tree diagrams, I believe there is benefit in seeing the complete tree for each module.

Regards,
Reshad.

-Ekr

Regards,
Reshad.

---

From: Eric Rescorla <[email-masked]>
Date: Thu, 5 Jul 2018 06:18:42 -0700

On Thu, Jul 5, 2018 at 6:10 AM, Reshad Rahman (rrahman) <[email-masked]>
wrote:

> Inline <RR2>.
>
>
>
> *From: *Eric Rescorla <[email-masked]>
> *Date: *Thursday, July 5, 2018 at 8:46 AM
> *To: *"Reshad Rahman (rrahman)" <[email-masked]>
> *Cc: *The IESG <[email-masked]>, Jeffrey Haas <[email-masked]>, "
> [email-masked]" <[email-masked]>, "[email-masked]" <
> [email-masked]>, "[email-masked]" <[email-masked]>
> *Subject: *Re: Eric Rescorla's No Objection on draft-ietf-bfd-yang-16:
> (with COMMENT)
>
>
>
>
>
>
>
> <RR2> The pyang tool does this for real references (leafref) but not in
> the grouping case (which is reuse and not reference). Even though there is
> replication in the tree diagrams, I believe there is benefit in seeing the
> complete tree for each module.
>

Well, this is a comment so you're free to ignore it, but IMO it makes it
very hard to read these.

-Ekr

---

From: Jeffrey Haas <[email-masked]>
Date: Tue, 10 Jul 2018 19:30:50 -0400

[Note that I'm making this comment for posterity so that the IESG doesn't
ask the same thing of other draft authors.]

> Well, this is a comment so you're free to ignore it, but IMO it makes it

The fundamental issue here is one of clear representation of a node being
instantiated vs. the semantic idea that we're seeing a template (grouping)
instantiated.

At the moment, pyang output is showing that when you use a grouping, you get
an actual node in the tree.  Given that things like augmentations cannot be
done to groupings as a logical entity and have impact everywhere, this is
perhaps an important detail, if annoying.

The proper place to pursue a fix to this is asking for a bis on RFC 8340.

-- Jeff

---

From: Eric Rescorla <[email-masked]>
Date: Tue, 10 Jul 2018 18:26:32 -0700

> The proper place to pursue a fix to this is asking for a bis on RFC 8340.

As I already said, it's a comment, so feel free to ignore it.

-Ekr