Subject: Warren Kumari's Discuss on draft-ietf-bfd-yang-16: (with DISCUSS and COMMENT)

From: Warren Kumari <[email-masked]>
Date: Wed, 04 Jul 2018 10:17:24 -0700

Warren Kumari has entered the following ballot position for
draft-ietf-bfd-yang-16: Discuss

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-bfd-yang/

----------------------------------------------------------------------
DISCUSS:
----------------------------------------------------------------------

Don't panic, this should be an easy DISCUSS to clear, but I think it important
for interoperability.

In multiple places, you have:
             +--ro number-of-sessions?
             +--ro number-of-sessions-up?
             +--ro number-of-sessions-down?
             +--ro number-of-sessions-admin-down?

I'm a little confused by the meaning of the counters, and didn't see them
clearly defined anywhere. Apologies if I missed it...

Are "number-of-sessions-admin-down" included in "number-of-sessions-down"?
Is 'number-of-sessions' always equal to 'number-of-sessions-up' +
'number-of-sessions-down', or is it always equal to 'number-of-sessions-up' +
'number-of-sessions-down' + 'number-of-sessions-admin-down', or are there other
cases?

E.g: I have created 10 sessions (because I have 10 interfaces). 5 of them are
down because there is no peer, 3 of them I've configured to be down (admin
down), and so 2 of them are up.

What should be in each of:
number-of-sessions?
number-of-sessions-up?
number-of-sessions-down?
number-of-sessions-admin-down?

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

Thank you.

I also had a few minor nits:
Nits:
Section 1:
"The YANG modules in this document conform to the Network Management Datastore
Architecture (NMDA) Network Management Datastore Architecture [RFC8342]. " The
Department of Redundancy Department called and wants some of their words back
please :-)

Section 2:
"Since BFD is used for liveliness detection of various forwarding
   paths, there is no uniform key to identify a BFD session.  So the BFD
   data model is split in multiple YANG modules where each module
   corresponds to one type of forwarding path."
I think this would be more readable as:
"... to identify a BFD session, and so the BFD..."  (hey, I said it was a nit)

---

From: "Reshad Rahman (rrahman)" <[email-masked]>
Date: Wed, 4 Jul 2018 17:49:52 +0000

Hi Warren,

Thanks for the review. 
In your example below
                 +--ro number-of-sessions (10)
                 +--ro number-of-sessions-up (2)
                 +--ro number-of-sessions-down (5)
                 +--ro number-of-sessions-admin-down (3)

There is a description on Page 37 of rev-16 of the draft, I can add to it as follows, is this sufficient?
      leaf number-of-sessions {
        type yang:gauge32;
        description "Number of BFD sessions.";
      }
      leaf number-of-sessions-up {
        type yang:gauge32;
        description "Number of BFD sessions currently in up state (as defined in [RFC5880]).";
      }
      leaf number-of-sessions-down {
        type yang:gauge32;
        description "Number of BFD sessions currently in down or init state (as defined in [RFC5880]).";
      }
      leaf number-of-sessions-admin-down {
        type yang:gauge32;
        description
          "Number of BFD sessions currently in admin-down state (as defined in [RFC5880]).";
      }

I will fix the nits in the next rev.

Regards,
Reshad.   

On 2018-07-04, 1:17 PM, "Warren Kumari" <[email-masked]> wrote:

    

    

    

    Thank you.

    Section 2:

---

From: Warren Kumari <[email-masked]>
Date: Wed, 4 Jul 2018 14:02:47 -0400

> as follows, is this sufficient?

​Thank you, I checked there, and I don't *think* that this quite covers it.
The below *implies* that ​admin-down is not counted in
'number-of-sessions-down'
(which is only 'down or init' state), but I think it could be clearer.

Perhaps:
leaf number-of-sessions-down {
        type yang:gauge32;
        description "Number of BFD sessions currently in down or init state
(and not admin-down) (as defined in [RFC5880]).";
}

Does that work, or is it too long?
W

>     Please refer to
> https://www.ietf.org/iesg/statement/discuss-criteria.html

-- 
I don't think the execution is relevant when it was obviously a bad idea in
the first place.
This is like putting rabid weasels in your pants, and later expressing
regret at having chosen those particular rabid weasels and that pair of
pants.
   ---maf

---

From: "Reshad Rahman (rrahman)" <[email-masked]>
Date: Wed, 4 Jul 2018 18:05:36 +0000

I’m fine with adding “(and not admin-down)” to make it more explicit. Updated descriptions will be in the next rev.

Regards,
Reshad.

From: Warren Kumari <[email-masked]>
Date: Wednesday, July 4, 2018 at 2:03 PM
To: "Reshad Rahman (rrahman)" <[email-masked]>
Cc: The IESG <[email-masked]>, "[email-masked]" <[email-masked]>, Jeffrey Haas <[email-masked]>, "[email-masked]" <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: Warren Kumari's Discuss on draft-ietf-bfd-yang-16: (with DISCUSS and COMMENT)

On Wed, Jul 4, 2018 at 1:49 PM Reshad Rahman (rrahman) <[email-masked]<mailto:[email-masked]>> wrote:
Hi Warren,

Thanks for the review.
In your example below

​Thank you, I checked there, and I don't *think* that this quite covers it.
The below *implies* that ​admin-down is not counted in 'number-of-sessions-down' (which is only 'down or init' state), but I think it could be clearer.

Perhaps:
leaf number-of-sessions-down {
        type yang:gauge32;
        description "Number of BFD sessions currently in down or init state (and not admin-down) (as defined in [RFC5880]).";

}

Regards,
Reshad.

On 2018-07-04, 1:17 PM, "Warren Kumari" <[email-masked]<mailto:[email-masked]>> wrote:

    Thank you.

    Section 2:

--
I don't think the execution is relevant when it was obviously a bad idea in the first place.
This is like putting rabid weasels in your pants, and later expressing regret at having chosen those particular rabid weasels and that pair of pants.
   ---maf

---

From: Warren Kumari <[email-masked]>
Date: Wed, 4 Jul 2018 14:17:26 -0400

On Wed, Jul 4, 2018 at 2:05 PM Reshad Rahman (rrahman) <[email-masked]>
wrote:

> I’m fine with adding “(and not admin-down)” to make it more explicit.
> Updated descriptions will be in the next rev.
>

​Thanks! DISCUSS cleared.
W​

>
>
> Regards,
>
> Reshad.
>
>
>
> *From: *Warren Kumari <[email-masked]>
> *Date: *Wednesday, July 4, 2018 at 2:03 PM
> *To: *"Reshad Rahman (rrahman)" <[email-masked]>
> *Cc: *The IESG <[email-masked]>, "[email-masked]" <
> [email-masked]>, Jeffrey Haas <[email-masked]>, "
> [email-masked]" <[email-masked]>, "[email-masked]" <
> [email-masked]>
> *Subject: *Re: Warren Kumari's Discuss on draft-ietf-bfd-yang-16: (with
> DISCUSS and COMMENT)
>
>
>
>
>
>
>
> 'number-of-sessions-down' (which is only 'down or init' state), but I think
> it could be clearer.
>
>
>
> Perhaps:
>
>         description "Number of BFD sessions currently in down or init
> state (and not admin-down) (as defined in [RFC5880]).";
>
> }
>
>
>