Subject: Re: BFD WG adoption for draft-haas-bfd-large-packets

From: "Albert Fu (BLOOMBERG/ 120 PARK)" <[email-masked]>
Date: Tue, 23 Oct 2018 17:23:01 -0000

(* Resending smaller message *)

Hi Acee,

Please see comments in-line. 

Thanks,

Albert

From: [email-masked] At: 10/23/18 13:02:49To:  Albert Fu (BLOOMBERG/ 120 PARK ) ,  [email-masked],  [email-masked]
Subject: Re: BFD WG adoption for draft-haas-bfd-large-packets

Hi Albert,  

From: "Albert Fu (BLOOMBERG/ 120 PARK)" <[email-masked]>
Reply-To: Albert Fu <[email-masked]>
Date: Tuesday, October 23, 2018 at 12:45 PM
To: "[email-masked]" <[email-masked]>, "Les Ginsberg (ginsberg)" <[email-masked]>, Acee Lindem <[email-masked]>
Subject: Re: BFD WG adoption for draft-haas-bfd-large-packets 

Hi Acee,  

You are right in that this issue does not happen frequently, but when it does, it is time consuming to troubleshoot and causes unnecessary network downtime  to some applications (e.g. between two end hosts, some applications worked fine, but others would intermittently fail when they tried to send large size packets over the failing ECMP path). 
  
So you’re saying there is a problem where the data plane interfaces do not support the configured MTU due to a SW bug? I hope these are not our routers 😉

AF> There's no bug.  

1) The issue we have seen is with the Telco network. The router can happily transmit and receive up to configured interface MTU, but the Telco circuit fails to support it. One example is when Telco uses L2VPN to deliver the P2P service to us, but due to some faults, traffic was re-routed to a mis-configured path that did not support our MTU size (e.g. MTU on Telco PE router was not increased to account for MPLS headers for the L2VPN service).

2) AFAIK, the OSPF MTU detection is based on checking MTU value in the DBD packet, The actual OSPF packet size may be smaller and may not detect data plane issue in Telco network during OSPF session establishment.

I believe the OSPF MTU detection is a control plane mechanism to check config, and may not necessary detect a data plane MTU issue (since OSPF does not support  padding). Also, most of our issues occurred after routing adjacency had been established, and without any network alarms. 
  
Right. However, if the interface is flapped when the MTU changes, OSPF would detect dynamic MTU changes (e.g., configuration), that the control plane is aware of. 

AF> We have encountered the MTU issue without any interface flaps on our routers (no config change on our routers). The MTU issue occurred within the Telco network. Note also some Telco providers that provide WAN circuit spanning several countries may make use of smaller local providers to provide the last mile.  We have seen issues with the smaller providers.

Thanks, 
Acee

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Tue, 23 Oct 2018 17:51:51 +0000

From: "Albert Fu (BLOOMBERG/ 120 PARK)" <[email-masked]>
Reply-To: Albert Fu <[email-masked]>
Date: Tuesday, October 23, 2018 at 1:23 PM
To: "Les Ginsberg (ginsberg)" <[email-masked]>, Acee Lindem <[email-masked]>, "[email-masked]" <[email-masked]>
Subject: Re: BFD WG adoption for draft-haas-bfd-large-packets

Hi Acee,

Thanks,

Albert

From: [email-masked] At: 10/23/18 13:02:49
To: Albert Fu (BLOOMBERG/ 120 PARK ) <mailto:[email-masked]> , [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>
Subject: Re: BFD WG adoption for draft-haas-bfd-large-packets
Hi Albert,

Hi Acee,

AF> There's no bug.

1)  The issue we have seen is with the Telco network. The router can happily transmit and receive up to configured interface MTU, but the Telco circuit fails to support it. One example is when Telco uses L2VPN to deliver the P2P service to us, but due to some faults, traffic was re-routed to a mis-configured path that did not support our MTU size (e.g. MTU on Telco PE router was not increased to account for MPLS headers for the L2VPN service).
Ok – in this case, you’d need to exercise the data plane with maximum size packets. And make the MTU part of the SLA you secure from the provider.
Thanks, Acee

Thanks,
Acee