Subject: Re: BFD WG adoption for draft-haas-bfd-large-packets

From: "Acee Lindem (acee)" <[email-masked]>
Date: Tue, 23 Oct 2018 17:04:51 +0000

Hi Albert,

Resending due to a related problem – message was too big for IETF filter and I pruned part of the thread at the end.

From: "Albert Fu (BLOOMBERG/ 120 PARK)" <[email-masked]>
Reply-To: Albert Fu <[email-masked]>
Date: Tuesday, October 23, 2018 at 12:45 PM
To: "[email-masked]" <[email-masked]>, "Les Ginsberg (ginsberg)" <[email-masked]>, Acee Lindem <[email-masked]>
Subject: Re: BFD WG adoption for draft-haas-bfd-large-packets

Hi Acee,

You are right in that this issue does not happen frequently, but when it does, it is time consuming to troubleshoot and causes unnecessary network downtime to some applications (e.g. between two end hosts, some applications worked fine, but others would intermittently fail when they tried to send large size packets over the failing ECMP path).

So you’re saying there is a problem where the data plane interfaces do not support the configured MTU due to a SW bug? I hope these are not our routers 😉

I believe the OSPF MTU detection is a control plane mechanism to check config, and may not necessary detect a data plane MTU issue (since OSPF does not support padding). Also, most of our issues occurred after routing adjacency had been established, and without any network alarms.

Right. However, if the interface is flapped when the MTU changes, OSPF would detect dynamic MTU changes (e.g., configuration), that the control plane is aware of.

Thanks,
Acee

Thanks
Albert

From: [email-masked] At: 10/23/18 12:30:55
To: Albert Fu (BLOOMBERG/ 120 PARK ) <mailto:[email-masked]> , [email-masked]<mailto:[email-masked]>, [email-masked]<mailto:[email-masked]>
Subject: Re: BFD WG adoption for draft-haas-bfd-large-packets
Hi Albert, Les,

I tend to agree with Les that BFD doesn’t seem like the right protocol for this. Note that if you use OSPF as your IGP and flap the interface when the MTU changes, you’ll detect MTU mismatches immediately due to OSPF’s DB exchange MTU negotiation. Granted, control plane detection won’t detect data plane bugs resulting in MTU fluctuations but I don’t see this as a frequent event.

Thanks,
Acee

From: Rtg-bfd <[email-masked]> on behalf of "Albert Fu (BLOOMBERG/ 120 PARK)" <[email-masked]>
Reply-To: Albert Fu <[email-masked]>
Date: Tuesday, October 23, 2018 at 11:44 AM
To: "[email-masked]" <[email-masked]>, "Les Ginsberg (ginsberg)" <[email-masked]>
Subject: RE: BFD WG adoption for draft-haas-bfd-large-packets

Hi Les,

Given that it takes relative lengthy time to troubleshoot the MTU issue, and the associated impact on customer traffic, it is important to have a reliable and fast mechanism to detect the issue.

I believe BFD, especially for single hop control-plane independent situation (btw, this covers majority of our BFD use case), is indeed an ideal and reliable solution for this purpose. It is also closely tied with the routing protocols, and enable traffic to be diverted very quickly.

The choice of BFD timer is also one of the design tradeoffs - low BFD detection timer will cause more network churns. We do not need extremely aggressive BFD timer to achieve fast convergence. For example, with protection, we can achieve end to end sub-second convergence by using relatively high BFD interval of 150ms.

In the case where the path will be used for a variety of encapsulations (e.g. Pure IP and L3VPN traffic), we would set the BFD padding to cater for the largest possible payload. So, in our case, our link needs to carry a mix of pure IP (1500 max payload) and MPLS traffic (1500 + 3 headers), we would set the padding so that the total padded BFD packet size is 1512 bytes.

As you rightly pointed out, ISIS routing protocol does support hello padding, but since this is a control plane process, we can not use aggressive timer. The lowest hello interval the can be configured is 1s, so with default multiplier of 3, the best we can achieve is 3s detection time.

What we would like is a simple mechanism to validate that a link can indeed carry the expected max payload size before we put it into production. If an issue occurs where this is no longer the case (e.g. due to outages or re-routing within the Telco circuit), we would like a reliable mechanism to detect this, and also divert traffic around the link quickly. I feel BFD is a good method for this purpose.

Thanks
Albert

---

From: "Nagendra Kumar Nainar (naikumar)" <[email-masked]>
Date: Tue, 23 Oct 2018 17:29:42 +0000

Hi,

In scenarios involving L2 provider in between, I remember seeing such issues where the provider may silently drop frames of certain size that is less than MTU defined on the interfaces. If control plane like OSPF is stable, there is no way to detect using control plane.

Thanks,
Nagendra

From: Rtg-bfd <[email-masked]> on behalf of "Acee Lindem (acee)" <[email-masked]>
Date: Tuesday, October 23, 2018 at 1:05 PM
To: Albert Fu <[email-masked]>, "[email-masked]" <[email-masked]>, "Les Ginsberg (ginsberg)" <[email-masked]>
Subject: Re: BFD WG adoption for draft-haas-bfd-large-packets

Hi Albert,

Hi Acee,

Thanks,
Acee

Thanks
Albert

Thanks,
Acee

Hi Les,

Thanks
Albert