Subject: BFD WG adoption for draft-haas-bfd-large-packets

From: "Reshad Rahman (rrahman)" <[email-masked]>
Date: Sat, 17 Nov 2018 13:58:25 +0000

Hi authors.,

This document has passed adoption as a BFD WG document.

Please resubmit the doc as draft-ietf-bfd-large-packets. Please also note that while there was strong support for adopting the document, the following points/questions were raised and should be discussed further within the WG as the document progresses:

  1.  Is there necessity to send all packets as large packets or alternatively can that be done periodically?
  2.  Authors should consider adding some text wrt use of BFD echo in the document

Also, there was a suggestion made to use BFD for PMTUD (as opposed to the BFD session failing when expected MTU isn’t met). My take on this is that it falls out of our charter but the PMTUD use-case should be considered if/when we recharter, I’d like to hear your thoughts on this.

Regards,
Reshad.

From: Rtg-bfd <[email-masked]> on behalf of "Reshad Rahman (rrahman)" <[email-masked]>
Date: Wednesday, October 17, 2018 at 9:06 PM
To: "[email-masked]" <[email-masked]>
Subject: BFD WG adoption for draft-haas-bfd-large-packets

Hello BFD WG,

We have received an adoption request for “BFD encapsulated in large packets”.

https://datatracker.ietf.org/doc/draft-haas-bfd-large-packets/

The adoption call will end on Friday Nov 9th.

Please send email to the list indicating “yes/support”  or “no/do not support”. If you do not support adoption, please state your reasons.

Regards,
Reshad & Jeff.

---

From: Jeffrey Haas <[email-masked]>
Date: Wed, 21 Nov 2018 17:12:31 -0500

Reshad,

>   2.  Authors should consider adding some text wrt use of BFD echo in the document

The intent is to do the draft-ietf-bfd republish next week and include text
to address these.

> Also, there was a suggestion made to use BFD for PMTUD (as opposed to the BFD session failing when expected MTU isn’t met). My take on this is that it falls out of our charter but the PMTUD use-cas…

We believe that this is currently out of scope for the work.  However, as I
have discussed with Albert, it's not unusual for BFD features to be used in
unexpected ways.  If there continues to be interest in discussing this, it
might be worth adding an appendix covering this use case.

-- Jeff (speaking as an individual contributor)