Subject: Re:[nvo3] BFD over VXLAN: Trapping BFD Control packet at VTEP

From: <[email-masked]>
Date: Tue, 8 Oct 2019 10:28:29 +0800 (CST)

Hi Anoop,

Sorry for the late response, I just come back from vacation.

The use case is that the network between the VM and the NVE is an MPLS network, within which the packet is forwarded basing on MPLS label, but not Ethernet MAC address and/or 802.1Q VLAN. When two such kind of MPLS networks need to communicate with each other, through a Geneve tunnel, the encap I illustrated would be used.

Best Regards,

Xiao Min

原始邮件

发件人：AnoopGhanwani <[email-masked]>
收件人：肖敏10093570;
抄送人：Greg Mirsky <[email-masked]>;[email-masked] <[email-masked]>;[email-masked] <[email-masked]>;[email-masked] <[email-masked]>;[email-masked] <[email-masked]>;rtg-bfd WG <[email-masked]>;Joel M. Halpern <[email-masked]>;[email-masked] <[email-masked]>;
日 期 ：2019年09月28日 05:36
主 题 ：Re: [nvo3] BFD over VXLAN: Trapping BFD Control packet at VTEP

Hi Xiao Min,

Thanks for the details about the encap but the use case is not clear.  It might help if you explain why its necessary to map a physical Ethernet port and/or 802.1Q VLAN to the same VNI as an MPLS packet without an L2 header.

Thanks,
Anoop

On Thu, Sep 26, 2019 at 7:50 PM <[email-masked]> wrote:

Hi Anoop,

Due to the fact that a variety of Tunnels could be used under the NVO3 architecture, as an example, below figure illustrates the format of MPLS packet over Geneve Tunnel.

 0 1 2 3
 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
 +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
 | |
 ~ Outer Ethernet Header ~
 | |
 +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
 | |
 ~ Outer IPvX Header ~
 | |
 +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
 | |
 ~ Outer UDP Header ~
 | |
 +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
 | |
 ~ Geneve Header ~
 | |
 +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+<-+
 | | |
 ~ MPLS Label Stack ~ M
 | | P
 +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+ L
 | | S
 | |
 ~ Payload ~ P
 | | K
 | | T
 +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+<-+
 | FCS |
 +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

Note that in NVO3 working group Greg and I have submitted an individual draft draft-xiao-nvo3-bfd-geneve, which is used to address BFD over Geneve.

The intention is to make the two drafts draft-ietf-bfd-vxlan and draft-xiao-nvo3-bfd-geneve aligned, that is to say, we try to define the identical mechanism for the common part of BFD over VxLAN Tunnel and BFD over Geneve Tunnel. For the common part, draft-xiao-nvo3-bfd-geneve would reference to draft-ietf-bfd-vxlan, and for the other part specific to Geneve, we'll define the specific mechanism in draft-xiao-nvo3-bfd-geneve.

Hope that clarifies.

Best Regards,

Xiao Min

原始邮件

发件人：AnoopGhanwani <[email-masked]>
收件人：肖敏10093570;
抄送人：Greg Mirsky <[email-masked]>;[email-masked] <[email-masked]>;[email-masked] <[email-masked]>;[email-masked] <[email-masked]>;[email-masked] <[email-masked]>;rtg-bfd WG <[email-masked]>;Joel M. Halpern <[email-masked]>;[email-masked] <[email-masked]>;[email-masked] <[email-masked]>;
日 期 ：2019年09月26日 23:16
主 题 ：Re: [nvo3] BFD over VXLAN: Trapping BFD Control packet at VTEP

Hi Xiao Min,
I think we would need more detail around the use case below.  What does the MPLS packet over Tunnel look like?

Thanks,
Anoop

On Wed, Sep 25, 2019 at 11:37 PM <[email-masked]> wrote:

Hi Anoop,

Thanks for your comments.

Considering a scenario where TS1 has an MPLS access (i.e. MPLS-Packet over Tunnel between NVEs) to VNI1, TS3 has an Ethernet access (i.e. MAC-Frame over Tunnel between NVEs) to VNI1, then how can TS1 and TS3 share one VAP?

Best Regards,

Xiao Min

原始邮件

发件人：AnoopGhanwani <[email-masked]>
收件人：肖敏10093570;
抄送人：Greg Mirsky <[email-masked]>;[email-masked] <[email-masked]>;[email-masked] <[email-masked]>;[email-masked] <[email-masked]>;[email-masked] <[email-masked]>;rtg-bfd WG <[email-masked]>;Joel M. Halpern <[email-masked]>;[email-masked] <[email-masked]>;[email-masked] <[email-masked]>;
日 期 ：2019年09月26日 08:36
主 题 ：Re: [nvo3] BFD over VXLAN: Trapping BFD Control packet at VTEP

_______________________________________________
nvo3 mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/nvo3

Some people may argue that all Tenant Systems connecting to the same Virtual Network MUST share one VAP, if that's true, then VAP1 and VAP3 should merge into one VAP and my explanation doesn't work. Copying to NVO3 WG to involve more experts, hope for your clarifications and comments.  

I would be one of those that would argue that they MUST share on VAP if they connect to the same Virtual Network.  IMO, the NVO3 arch doc should have been clearer about this.

Thanks,
Anoop

On Tue, Sep 24, 2019 at 7:40 PM <[email-masked]> wrote:

Hi Santosh,

With regard to the question whether we should allow multiple BFD sessions for the same VNI or not, IMHO we should allow it, more explanation as follows...

Below is a figure derived from figure 2 of RFC8014 (An Architecture for Data-Center Network Virtualization over Layer 3 (NVO3)).

 | Data Center Network (IP) |
 | |
 +-----------------------------------------+
 | |
 | Tunnel Overlay |
 +------------+---------+ +---------+------------+
 | +----------+-------+ | | +-------+----------+ |
 | | Overlay Module | | | | Overlay Module | |
 | +---------+--------+ | | +---------+--------+ |
 | | | | | |
 NVE1 | | | | | | NVE2
 | +--------+-------+ | | +--------+-------+ |
 | |VNI1 VNI2 VNI1 | | | | VNI1 VNI2 VNI1 | |
 | +-+-----+----+---+ | | +-+-----+-----+--+ |
 |VAP1| VAP2| | VAP3 | |VAP1| VAP2| | VAP3|
 +----+-----+----+------+ +----+-----+-----+-----+
 | | | | | |
 | | | | | |
 | | | | | |
 -------+-----+----+-------------------+-----+-----+-------
 | | | Tenant | | |
 TSI1 | TSI2| | TSI3 TSI1| TSI2| |TSI3
 +---+ +---+ +---+ +---+ +---+ +---+
 |TS1| |TS2| |TS3| |TS4| |TS5| |TS6|
 +---+ +---+ +---+ +---+ +---+ +---+
To my understanding, the BFD sessions between NVE1 and NVE2 are actually initiated and terminated at VAP of NVE.

If the network operator want to set up one BFD session between VAP1 of NVE1 and VAP1of NVE2, at the same time another BFD session between VAP3 of NVE1 and VAP3 of NVE2, although the two BFD sessions are for the same VNI1, I believe it's reasonable, so that's why I think we should allow it.

Of course, in RFC8014 it also says:

"Note that two different Tenant Systems (and TSIs) attached to a common NVE can share a VAP (e.g., TS1 and TS2 in Figure 2) so long as they connect to the same Virtual Network."
Some people may argue that all Tenant Systems connecting to the same Virtual Network MUST share one VAP, if that's true, then VAP1 and VAP3 should merge into one VAP and my explanation doesn't work. Copying to NVO3 WG to involve more experts, hope for your clarifications and comments.

Best Regards,

Xiao Min

---

From: Anoop Ghanwani <[email-masked]>
Date: Mon, 7 Oct 2019 21:15:04 -0700

Hi Xiao Min,

Is there a draft that describes MPLS over Geneve?  It sounds like the NVE
is an MPLS router in this case and if you're using the same VNI as you
switch MPLS, then it's a one-armed router.  That doesn't change how BFD
needs to be run between NVEs.

Anoop

On Mon, Oct 7, 2019 at 7:28 PM <[email-masked]> wrote:

> The use case is that the network between the VM and the NVE is an MPLS
> network, within which the packet is forwarded basing on MPLS label, but not
> Ethernet MAC address and/or 802.1Q VLAN. When two such kind of MPLS
> networks need to communicate with each other, through a Geneve tunnel, the
> encap I illustrated would be used.
>
>
> Best Regards,
>
> Xiao Min
> 原始邮件
> *发件人：*AnoopGhanwani <[email-masked]>
> *收件人：*肖敏10093570;
> *抄送人：*Greg Mirsky <[email-masked]>;[email-masked] <
> [email-masked]>;[email-masked] <
> [email-masked]>;[email-masked] <[email-masked]>;
> [email-masked] <[email-masked]>;rtg-bfd WG <
> [email-masked]>;Joel M. Halpern <[email-masked]>;
> [email-masked] <[email-masked]>;
> *日 期 ：*2019年09月28日 05:36
> *主 题 ：**Re: [nvo3] BFD over VXLAN: Trapping BFD Control packet at VTEP*
> Hi Xiao Min,
>
> Thanks for the details about the encap but the use case is not clear.  It
> might help if you explain why its necessary to map a physical Ethernet port
> and/or 802.1Q VLAN to the same VNI as an MPLS packet without an L2 header.
>
> Thanks,
> Anoop
>
>> Due to the fact that a variety of Tunnels could be used under the NVO3 architecture,
>> as an example, below figure illustrates the format of MPLS packet over
>> Geneve Tunnel.
>>
>>     0                   1                   2                   3
>> Note that in NVO3 working group Greg and I have submitted an individual
>> draft draft-xiao-nvo3-bfd-geneve, which is used to address BFD over Geneve.
>>
>> The intention is to make the two drafts draft-ietf-bfd-vxlan and
>> draft-xiao-nvo3-bfd-geneve aligned, that is to say, we try to define the
>> identical mechanism for the common part of BFD over VxLAN Tunnel and BFD
>> over Geneve Tunnel. For the common part, draft-xiao-nvo3-bfd-geneve would
>> reference to draft-ietf-bfd-vxlan, and for the other part specific to
>> Geneve, we'll define the specific mechanism in draft-xiao-nvo3-bfd-geneve.
>>
>>
>> Hope that clarifies.
>>
>>
>> Best Regards,
>>
>> Xiao Min
>> 原始邮件
>> *发件人：*AnoopGhanwani <[email-masked]>
>> *收件人：*肖敏10093570;
>> *抄送人：*Greg Mirsky <[email-masked]>;[email-masked] <
>> [email-masked]>;[email-masked] <
>> [email-masked]>;[email-masked] <[email-masked]>;
>> [email-masked] <[email-masked]>;rtg-bfd WG <
>> [email-masked]>;Joel M. Halpern <[email-masked]>;
>> [email-masked] <[email-masked]>;[email-masked] <
>> [email-masked]>;
>> *日 期 ：*2019年09月26日 23:16
>> *主 题 ：**Re: [nvo3] BFD over VXLAN: Trapping BFD Control packet at VTEP*
>> Hi Xiao Min,
>>> Considering a scenario where TS1 has an MPLS access (i.e. MPLS-Packet
>>> over Tunnel between NVEs) to VNI1, TS3 has an Ethernet access (i.e.
>>> MAC-Frame over Tunnel between NVEs) to VNI1, then how can TS1 and TS3 share
>>> one VAP?
>>>
>>>
>>> Best Regards,
>>>
>>> Xiao Min
>>> 原始邮件
>>> *发件人：*AnoopGhanwani <[email-masked]>
>>> *收件人：*肖敏10093570;
>>> *抄送人：*Greg Mirsky <[email-masked]>;[email-masked] <
>>> [email-masked]>;[email-masked] <
>>> [email-masked]>;[email-masked] <[email-masked]>;
>>> [email-masked] <[email-masked]>;rtg-bfd WG <
>>> [email-masked]>;Joel M. Halpern <[email-masked]>;
>>> [email-masked] <[email-masked]>;[email-masked] <
>>> [email-masked]>;
>>> *日 期 ：*2019年09月26日 08:36
>>> *主 题 ：**Re: [nvo3] BFD over VXLAN: Trapping BFD Control packet at VTEP*
>>> Some people may argue that all Tenant Systems connecting to the same
>>> Virtual Network MUST share one VAP, if that's true, then VAP1 and VAP3
>>> should merge into one VAP and my explanation doesn't work. Copying to NVO3
>>> WG to involve more experts, hope for your clarifications and comments.
>>> >>>
>>>
>>> I would be one of those that would argue that they MUST share on VAP if
>>> they connect to the same Virtual Network.  IMO, the NVO3 arch doc should
>>> have been clearer about this.
>>>
>>> Thanks,
>>> Anoop
>>>
>>>> With regard to the question whether we should allow multiple BFD
>>>> sessions for the same VNI or not, IMHO we should allow it, more explanation
>>>> as follows...
>>>>
>>>> Below is a figure derived from figure 2 of RFC8014 (An Architecture
>>>> for Data-Center Network Virtualization over Layer 3 (NVO3)).
>>>>
>>>> To my understanding, the BFD sessions between NVE1 and NVE2 are
>>>> actually initiated and terminated at VAP of NVE.
>>>>
>>>> If the network operator want to set up one BFD session between VAP1 of
>>>> NVE1 and VAP1of NVE2, at the same time another BFD session between VAP3 of
>>>> NVE1 and VAP3 of NVE2, although the two BFD sessions are for the same
>>>> VNI1, I believe it's reasonable, so that's why I think we should allow
>>>> it.
>>>>
>>>>
>>>> Some people may argue that all Tenant Systems connecting to the same
>>>> Virtual Network MUST share one VAP, if that's true, then VAP1 and VAP3
>>>> should merge into one VAP and my explanation doesn't work. Copying to NVO3
>>>> WG to involve more experts, hope for your clarifications and comments.
>>>>
>>>>
>>>> Best Regards,
>>>>
>>>> Xiao Min
>>>>
>>>
>>>
>>
>

---

From: <[email-masked]>
Date: Tue, 8 Oct 2019 15:29:03 +0800 (CST)

Hi Anoop,

I don't know such a draft that describes MPLS over Geneve, but I believe the following figure derived from figure 1 of RFC8014 would help, in the following figure Tenant System1, Tenant System2, Tenant System3 and Tenant System4 are assumed belonging to the same VNI, so two BFD sessions for the same VNI need to be run between NVE1 and NVE2.

 +--------+
 +----| Tenant |
 ( ' ) | System1|
 ................ ( MPLS ) +--------+
 . . +--+-+ ( _ )
 . .--|NVE1|---+
 . . | |
 . . +--+-+
 . . |
 . L3 Overlay . ( ' )
 . Network . (Ethernet)
 . . ( _ )
 . . |
 ................ +--------+
 | | Tenant |
 +----+ | System2|
 |NVE2| +--------+
 | |--------+
 +----+ |
 | |
 ( ' ) ( ' )
 ( MPLS ) (Ethernet)
 ( _ ) ( _ )
 | |
 +--------+ +--------+
 | Tenant | | Tenant |
 | System3| | System4|
 +--------+ +--------+

Best Regards,

Xiao Min

原始邮件

日 期 ：2019年10月08日 12:15

Hi Xiao Min,
Is there a draft that describes MPLS over Geneve?  It sounds like the NVE is an MPLS router in this case and if you're using the same VNI as you switch MPLS, then it's a one-armed router.  That doesn't change how BFD needs to be run between NVEs.

Anoop

Hi Anoop,

Best Regards,

Xiao Min

原始邮件

Hi Xiao Min,

Thanks,
Anoop

Hi Anoop,

 0 1 2 3

Hope that clarifies.

Best Regards,

Xiao Min

原始邮件

Hi Xiao Min,

Thanks,
Anoop

Hi Anoop,

Best Regards,

Xiao Min

原始邮件

Thanks,
Anoop

Hi Santosh,

Best Regards,

Xiao Min

---

From: Anoop Ghanwani <[email-masked]>
Date: Tue, 8 Oct 2019 15:28:10 -0700

Hi Xiao Min,

The picture doesn't have enough information to explain why they are in the
same VNI, and exactly how forwarding happens between the MPLS and non-MPLS
parts.

Anoop

On Tue, Oct 8, 2019 at 12:31 AM <[email-masked]> wrote:

> Hi Anoop,
>
>
> I don't know such a draft that describes MPLS over Geneve, but I believe
> the following figure derived from figure 1 of RFC8014 would help, in the
> following figure Tenant System1, Tenant System2, Tenant System3 and Tenant
> System4 are assumed belonging to the same VNI, so two BFD sessions for the
> same VNI need to be run between NVE1 and NVE2.
>
>                                             +--------+
>                                        +----| Tenant |
>                                      ( ' )  | System1|
> *日 期 ：*2019年10月08日 12:15
>>>> [email-masked] <[email-masked]>;rtg-bfd WG
>>>> <[email-masked]>;Joel M. Halpern <[email-masked]>;
>>>>> VNI1, I believe it's reasonable, so that's why I think we should
>>>>> allow it.
>>>>>
>>>>>

---

From: "Joel M. Halpern" <[email-masked]>
Date: Tue, 8 Oct 2019 18:30:44 -0400

I will add that from the point of view of VxLAN 9which is the topic), I 
would expect the MPLS packet to arrive in an Ethernet frame, and for 
VxLAN to forward that Ethernet frame.  The VTEP would not seem to even 
need to be aware that the content is MPLS.

Yours,
Joel

On 10/8/2019 6:28 PM, Anoop Ghanwani wrote:
> Hi Xiao Min,
> 
> The picture doesn't have enough information to explain why they are in 
> the same VNI, and exactly how forwarding happens between the MPLS and 
> non-MPLS parts.
> 
> Anoop
> 
> On Tue, Oct 8, 2019 at 12:31 AM <[email-masked] 
> <mailto:[email-masked]>> wrote:
> 
>     Hi Anoop,
> 
> 
>     I don't know such a draft that describes MPLS over Geneve, but I
>     believe the following figure derived from figure 1 of RFC8014 would
>     help, in the following figure Tenant System1, Tenant System2, Tenant
>     System3 and Tenant System4 are assumed belonging to the same VNI, so
>     two BFD sessions for the same VNI need to be run between NVE1 and NVE2.
> 
>                                                  +--------+
>                                             +----| Tenant |
>                                           ( ' )  | System1|
>     *发件人：*AnoopGhanwani <[email-masked]
>     <mailto:[email-masked]>>
>     *收件人：*肖敏10093570;
>     *抄送人：*Greg Mirsky <[email-masked]
>     <mailto:[email-masked]>>;[email-masked]
>     <mailto:didutt@gmail..com> <[email-masked]
>     <mailto:[email-masked]>>;[email-masked]
>     <mailto:[email-masked]>
>     <[email-masked]
>     <mailto:[email-masked]>>;[email-masked]
>     <mailto:[email-masked]> <[email-masked]
>     <mailto:[email-masked]>>;[email-masked]
>     <mailto:[email-masked]> <[email-masked]
>     <mailto:[email-masked]>>;rtg-bfd WG <[email-masked]
>     <mailto:[email-masked]>>;Joel M. Halpern <[email-masked]
>     <mailto:[email-masked]>>;[email-masked]
>     <mailto:[email-masked]> <tsridhar@vmware..com
>     <mailto:[email-masked]>>;
>     *日 期 ：*2019年10月08日 12:15
>     Is there a draft that describes MPLS over Geneve?  It sounds like
>     the NVE is an MPLS router in this case and if you're using the same
>     VNI as you switch MPLS, then it's a one-armed router.  That doesn't
>     change how BFD needs to be run between NVEs.
> 
>     Anoop
> 
>     On Mon, Oct 7, 2019 at 7:28 PM <[email-masked]
>     <mailto:[email-masked]>> wrote:
> 
>         Hi Anoop,
> 
> 
>         The use case is that the network between the VM and the NVE is
>         an MPLS network, within which the packet is forwarded basing on
>         MPLS label, but not Ethernet MAC address and/or 802.1Q VLAN.
>         When two such kind of MPLS networks need to communicate with
>         each other, through a Geneve tunnel, the encap I illustrated
>         would be used.
> 
> 
>         Best Regards,
> 
>         Xiao Min
> 
>         原始邮件
>         *发件人：*AnoopGhanwani <[email-masked]
>         <mailto:[email-masked]>>
>         *收件人：*肖敏10093570;
>         *抄送人：*Greg Mirsky <[email-masked]
>         <mailto:[email-masked]>>;[email-masked]
>         <mailto:[email-masked]> <[email-masked]
>         <mailto:[email-masked]>>;[email-masked]
>         <mailto:[email-masked]>
>         <[email-masked]
>         <mailto:[email-masked]>>;[email-masked]
>         <mailto:[email-masked]> <[email-masked]
>         <mailto:[email-masked]>>;[email-masked]
>         <mailto:[email-masked]>
>         <[email-masked]
>         <mailto:[email-masked]>>;rtg-bfd WG
>         <[email-masked] <mailto:[email-masked]>>;Joel M. Halpern
>         <[email-masked]
>         <mailto:[email-masked]>>;[email-masked]
>         <mailto:[email-masked]> <[email-masked]
>         <mailto:[email-masked]>>;
>         *日 期 ：*2019年09月28日 05:36
>         Thanks for the details about the encap but the use case is not
>         clear.  It might help if you explain why its necessary to map a
>         physical Ethernet port and/or 802.1Q VLAN to the same VNI as an
>         MPLS packet without an L2 header.
> 
>         Thanks,
>         Anoop
> 
>         On Thu, Sep 26, 2019 at 7:50 PM <[email-masked]
>         <mailto:[email-masked]>> wrote:
> 
>             Hi Anoop,
> 
> 
>             Due to the fact that a variety of Tunnels could be used
>             under the NVO3 architecture, as an example, below figure
>             illustrates the format of MPLS packet over Geneve Tunnel.
> 
>                  0                   1                   2                   3
>             Note that in NVO3 working group Greg and I have submitted an
>             individual draft draft-xiao-nvo3-bfd-geneve, which is used
>             to address BFD over Geneve.
> 
>             The intention is to make the two drafts draft-ietf-bfd-vxlan
>             and draft-xiao-nvo3-bfd-geneve aligned, that is to say, we
>             try to define the identical mechanism for the common part of
>             BFD over VxLAN Tunnel and BFD over Geneve Tunnel. For the
>             common part, draft-xiao-nvo3-bfd-geneve would reference to
>             draft-ietf-bfd-vxlan, and for the other part specific to
>             *发件人：*AnoopGhanwani <[email-masked]
>             <mailto:[email-masked]>>
>             *收件人：*肖敏10093570;
>             *抄送人：*Greg Mirsky <[email-masked]
>             <mailto:[email-masked]>>;[email-masked]
>             <mailto:[email-masked]> <[email-masked]
>             <mailto:[email-masked]>>;[email-masked]
>             <mailto:[email-masked]>
>             <[email-masked]
>             <mailto:[email-masked]>>;[email-masked]
>             <mailto:[email-masked]> <[email-masked]
>             <mailto:[email-masked]>>;[email-masked]
>             <mailto:[email-masked]>
>             <[email-masked]
>             <mailto:[email-masked]>>;rtg-bfd WG
>             <[email-masked] <mailto:[email-masked]>>;Joel M. Halpern
>             <[email-masked]
>             <mailto:[email-masked]>>;[email-masked]
>             <mailto:[email-masked]> <[email-masked]
>             <mailto:[email-masked]>>;[email-masked]
>             <mailto:[email-masked]> <[email-masked]
>             <mailto:[email-masked]>>;
>             *日 期 ：*2019年09月26日 23:16
>             I think we would need more detail around the use case
>             below.  What does the MPLS packet over Tunnel look like?
> 
>             Thanks,
>             Anoop
> 
>             On Wed, Sep 25, 2019 at 11:37 PM <[email-masked]
>             <mailto:[email-masked]>> wrote:
> 
>                 Hi Anoop,
> 
> 
>                 Considering a scenario where TS1 has an MPLS access
>                 (i.e. MPLS-Packet over Tunnel between NVEs) to VNI1, TS3
>                 has an Ethernet access (i.e. MAC-Frame over Tunnel
>                 between NVEs) to VNI1, then how can TS1 and TS3 share
>                 one VAP?
> 
> 
>                 Best Regards,
> 
>                 Xiao Min
> 
>                 原始邮件
>                 *发件人：*AnoopGhanwani <[email-masked]
>                 <mailto:[email-masked]>>
>                 *收件人：*肖敏10093570;
>                 *抄送人：*Greg Mirsky <[email-masked]
>                 <mailto:[email-masked]>>;[email-masked]
>                 <mailto:[email-masked]> <[email-masked]
>                 <mailto:[email-masked]>>;[email-masked]
>                 <mailto:[email-masked]>
>                 <[email-masked]
>                 <mailto:[email-masked]>>;[email-masked]
>                 <mailto:[email-masked]> <[email-masked]
>                 <mailto:[email-masked]>>;[email-masked]
>                 <mailto:[email-masked]>
>                 <[email-masked]
>                 <mailto:[email-masked]>>;rtg-bfd WG
>                 <[email-masked] <mailto:[email-masked]>>;Joel M.
>                 Halpern <[email-masked]
>                 <mailto:[email-masked]>>;[email-masked]
>                 <mailto:[email-masked]> <[email-masked]
>                 <mailto:[email-masked]>>;[email-masked]
>                 <mailto:[email-masked]> <[email-masked]
>                 <mailto:[email-masked]>>;
>                 *日 期 ：*2019年09月26日 08:36
>                 [email-masked] <mailto:[email-masked]>
>                 Some people may argue that all Tenant Systems connecting
>                 to the same Virtual Network MUST share one VAP, if
>                 that's true, then VAP1 and VAP3 should merge into one
>                 VAP and my explanation doesn't work. Copying to NVO3 WG
>                 to involve more experts, hope for your clarifications
>                 and comments.
>                  >>>
> 
>                 I would be one of those that would argue that they MUST
>                 share on VAP if they connect to the same Virtual
>                 Network.  IMO, the NVO3 arch doc should have been
>                 clearer about this.
> 
>                 Thanks,
>                 Anoop
> 
>                 On Tue, Sep 24, 2019 at 7:40 PM <[email-masked]
>                 <mailto:[email-masked]>> wrote:
> 
>                     Hi Santosh,
> 
> 
>                     With regard to the question whether we should allow
>                     multiple BFD sessions for the same VNI or not, IMHO
>                     we should allow it, more explanation as follows...
> 
>                     Below is a figure derived from figure 2 of RFC8014
>                     (An Architecture for Data-Center Network
>                     Virtualization over Layer 3 (NVO3)).
> 
>                     To my understanding, the BFD sessions between NVE1
>                     and NVE2 are actually initiated and terminated at
>                     VAP of NVE.
> 
>                     If the network operator want to set up one BFD
>                     session between VAP1 of NVE1 and VAP1of NVE2, at the
>                     same time another BFD session between VAP3 of NVE1
>                     and VAP3 of NVE2, although the two BFD sessions are
>                     for the same VNI1, I believe it's reasonable, so
>                     that's why I think we should allow it.
> 
> 
>                     Some people may argue that all Tenant Systems
>                     connecting to the same Virtual Network MUST share
>                     one VAP, if that's true, then VAP1 and VAP3 should
>                     merge into one VAP and my explanation doesn't work.
>                     Copying to NVO3 WG to involve more experts, hope for
>                     your clarifications and comments.
> 
> 
>                     Best Regards,
> 
>                     Xiao Min
> 
> 
> 
> 
> 
>

---

From: <[email-masked]>
Date: Wed, 9 Oct 2019 14:09:00 +0800 (CST)

Hi Anoop,

In this use case there is no forwarding happens between the MPLS and non-MPLS parts, would this use case be prohibited?

If the answer is yes, then I agree that all Tenant Systems attached to a common NVE MUST share a VAP so long as they connect to the same VN, although in RFC8014 it uses "can" but not "MUST". As a result, we should not allow multiple BFD sessions for the same VNI between two NVEs.

If the answer is no, then we should allow multiple BFD sessions for the same VNI between two NVEs. I personally lean to this answer.

Best Regards,

Xiao Min

原始邮件

日 期 ：2019年10月09日 06:28

Hi Xiao Min,
The picture doesn't have enough information to explain why they are in the same VNI, and exactly how forwarding happens between the MPLS and non-MPLS parts.

Anoop

Hi Anoop,

 +--------+
 +----| Tenant |
 ( ' ) | System1|

Best Regards,

Xiao Min

原始邮件

Hi Xiao Min,

Anoop

Hi Anoop,

Best Regards,

Xiao Min

原始邮件

Hi Xiao Min,

Thanks,
Anoop

Hi Anoop,

 0 1 2 3

Hope that clarifies.

Best Regards,

Xiao Min

原始邮件

Hi Xiao Min,

Thanks,
Anoop

Hi Anoop,

Best Regards,

Xiao Min

原始邮件

Thanks,
Anoop

Hi Santosh,

Best Regards,

Xiao Min

---

From: <[email-masked]>
Date: Wed, 9 Oct 2019 14:33:11 +0800 (CST)

Hi Joel,

I fully agree to your analysis.

One major difference between VxLAN and Geneve (or VxLAN-GPE) is that VxLAN doesn't support multi-protocol payload, and VxLAN only supports payload of Ethernet frame. Although VxLAN specification was developed outside NVO3 WG, I believe VxLAN may also fall within the NVO3 architecture, and we try to align "BFD for VxLAN" and "BFD for Geneve".

Best Regards,

Xiao Min

原始邮件

发件人：JoelM.Halpern <[email-masked]>
收件人：Anoop Ghanwani <[email-masked]>;肖敏10093570;
抄送人：[email-masked] <[email-masked]>;[email-masked] <[email-masked]>;rtg-bfd WG <[email-masked]>;
日 期 ：2019年10月09日 06:31
主 题 ：Re: [nvo3] BFD over VXLAN: Trapping BFD Control packet at VTEP

Yours,
Joel

---

From: Anoop Ghanwani <[email-masked]>
Date: Wed, 9 Oct 2019 14:32:31 -0700

Hi Xiao Min,

Normally, I think of a VNI as a broadcast domain.  The only way I can make
sense of the picture below is to have a separate VNI for each MPLS
interface on the NVE.

Anoop

On Tue, Oct 8, 2019 at 11:09 PM <[email-masked]> wrote:

> Hi Anoop,
>
>
> In this use case there is no forwarding happens between the MPLS and
> non-MPLS parts, would this use case be prohibited?
>
> If the answer is yes, then I agree that all Tenant Systems attached to a
> common NVE MUST share a VAP so long as they connect to the same VN,
> although in RFC8014 it uses "can" but not "MUST". As a result, we should
> not allow multiple BFD sessions for the same VNI between two NVEs.
>
> If the answer is no, then we should allow multiple BFD sessions for the
> same VNI between two NVEs. I personally lean to this answer.
>
>
> Best Regards,
>
> Xiao Min
> 原始邮件
> *日 期 ：*2019年10月09日 06:28
>>> Thanks for the details about the encap but the use case is not clear.
>>> It might help if you explain why its necessary to map a physical Ethernet
>>> port and/or 802.1Q VLAN to the same VNI as an MPLS packet without an L2
>>> header.
>>>
>>> Thanks,
>>> Anoop
>>>
>>>>> [email-masked] <[email-masked]>;rtg-bfd
>>>>> WG <[email-masked]>;Joel M. Halpern <[email-masked]>;
>>>>> I would be one of those that would argue that they MUST share on VAP
>>>>> if they connect to the same Virtual Network.  IMO, the NVO3 arch doc should
>>>>>> If the network operator want to set up one BFD session between VAP1
>>>>>> of NVE1 and VAP1of NVE2, at the same time another BFD session between VAP3
>>>>>> of NVE1 and VAP3 of NVE2, although the two BFD sessions are for the
>>>>>> same VNI1, I believe it's reasonable, so that's why I think we
>>>>>> should allow it.
>>>>>>
>>>>>>

---

From: <[email-masked]>
Date: Thu, 10 Oct 2019 14:04:17 +0800 (CST)

Hi Anoop,

Normally, it is. While Tenant Systems connect to NVE through IP routing network or MPLS forwarding network, it is not.

Best Regards,

Xiao Min

原始邮件

发件人：AnoopGhanwani <[email-masked]>
收件人：肖敏10093570;
抄送人：[email-masked] <[email-masked]>;[email-masked] <[email-masked]>;rtg-bfd WG <[email-masked]>;
日 期 ：2019年10月10日 05:33
主 题 ：Re: [nvo3] BFD over VXLAN: Trapping BFD Control packet at VTEP

Hi Xiao Min,
Normally, I think of a VNI as a broadcast domain.  The only way I can make sense of the picture below is to have a separate VNI for each MPLS interface on the NVE.

Anoop

Hi Anoop,

Best Regards,

Xiao Min

原始邮件

Hi Xiao Min,

Anoop

Hi Anoop,

 +--------+
 +----| Tenant |
 ( ' ) | System1|

Best Regards,

Xiao Min

原始邮件

Hi Xiao Min,

Anoop

Hi Anoop,

Best Regards,

Xiao Min

原始邮件

Hi Xiao Min,

Thanks,
Anoop

Hi Anoop,

 0 1 2 3

Hope that clarifies.

Best Regards,

Xiao Min

原始邮件

Hi Xiao Min,

Thanks,
Anoop

Hi Anoop,

Best Regards,

Xiao Min

原始邮件

Thanks,
Anoop

Hi Santosh,

Best Regards,

Xiao Min

---

From: Anoop Ghanwani <[email-masked]>
Date: Thu, 10 Oct 2019 00:40:26 -0700

Hi Xiao Min,

In those cases, the term "VN" is used to talk about multiple IP interfaces
in a VRF.  The different interfaces would have to be different VNIs.

In the mixed case (with MPLS and L2 hitting the NVE at different VAPs), I'm
not sure how it would work in the same VNI.  If you think it's important, I
think it may be worth writing it up.  If there's enough merit in the use
case, we can figure out how to run multiple BFD sessions on the same VNI.

Anoop

On Wed, Oct 9, 2019 at 11:06 PM <[email-masked]> wrote:

> Hi Anoop,
>
>
> Normally, it is. While Tenant Systems connect to NVE through IP routing
> network or MPLS forwarding network, it is not.
>
>
> Best Regards,
>
> Xiao Min
> 原始邮件
> *抄送人：[email-masked] <[email-masked]>;
> [email-masked] <[email-masked]>;rtg-bfd WG <[email-masked]>;
> *日 期 ：*2019年10月10日 05:33
>>> Is there a draft that describes MPLS over Geneve?  It sounds like the
>>> NVE is an MPLS router in this case and if you're using the same VNI as you
>>>>> Due to the fact that a variety of Tunnels could be used under the NVO3
>>>>> architecture, as an example, below figure illustrates the format of
>>>>> MPLS packet over Geneve Tunnel.
>>>>>
>>>>>     0                   1                   2                   3
>>>>> individual draft draft-xiao-nvo3-bfd-geneve, which is used to address BFD
>>>>> over Geneve.
>>>>>
>>>>> I think we would need more detail around the use case below.  What
>>>>> does the MPLS packet over Tunnel look like?
>>>>>
>>>>> Thanks,
>>>>> Anoop
>>>>>

---

From: <[email-masked]>
Date: Thu, 10 Oct 2019 19:59:32 +0800 (CST)

Hi Anoop,

Please see my response inline with [XM].

原始邮件

日 期 ：2019年10月10日 15:47

Hi Xiao Min,
In those cases, the term "VN" is used to talk about multiple IP interfaces in a VRF.  The different interfaces would have to be different VNIs.

[XM] To be clear, I interpret VNI as Virtual Network Identifier that should be present within VxLAN/Geneve header. Do you mean in the case multiple Tenant Systems connect to multiple NVEs through IP routing network, different NVEs must encapsulate different Virtual Network Identifiers?

In the mixed case (with MPLS and L2 hitting the NVE at different VAPs), I'm not sure how it would work in the same VNI.  If you think it's important, I think it may be worth writing it up.  If there's enough merit in the use case, we can figure out how to run multiple BFD sessions on the same VNI.

[XM] As to the mixed case, I don't know whether there's enough merit, I just raise it for discussion because it seems not being prohibited from the NVO3 architecture point of view.

Anoop

Best Regards,

Xiao Min

Hi Anoop,

Best Regards,

Xiao Min

原始邮件

Hi Xiao Min,

Anoop

On Tue, Oct 8, 2019 at 11:09 PM <[email-masked]> wrote:

Hi Anoop,

Best Regards,

Xiao Min

原始邮件

发件人：AnoopGhanwani <[email-masked]>
收件人：肖敏10093570;
抄送人：Greg Mirsky <[email-masked]>;[email-masked] <[email-masked]>;[email-masked] <[email-masked]>;[email-masked] <[email-masked]>;[email-masked] <[email-masked]>;rtg-bfd WG <[email-masked]>;Joel M. Halpern <[email-masked]>;[email-masked] <[email-masked]>;
日 期 ：2019年10月09日 06:28
主 题 ：Re: [nvo3] BFD over VXLAN: Trapping BFD Control packet at VTEP

Hi Xiao Min,

Anoop

Hi Anoop,

 +--------+
 +----| Tenant |
 ( ' ) | System1|

Best Regards,

Xiao Min

原始邮件

发件人：AnoopGhanwani <anoop@alumni...duke.edu>
收件人：肖敏10093570;
抄送人：Greg Mirsky <[email-masked]>;didutt@gmail...com <[email-masked]>;[email-masked] <[email-masked]>;[email-masked] <[email-masked]>;[email-masked] <[email-masked]>;rtg-bfd WG <[email-masked]>;Joel M. Halpern <[email-masked]>;[email-masked] <[email-masked]>;
日 期 ：2019年10月08日 12:15
主 题 ：Re: [nvo3] BFD over VXLAN: Trapping BFD Control packet at VTEP

Hi Xiao Min,

Anoop

Hi Anoop,

Best Regards,

Xiao Min

原始邮件

发件人：AnoopGhanwani <[email-masked]>
收件人：肖敏10093570;
抄送人：Greg Mirsky <[email-masked]>;[email-masked] <[email-masked]>;[email-masked] <[email-masked]>;[email-masked] <[email-masked]>;[email-masked] <[email-masked]>;rtg-bfd WG <[email-masked]>;Joel M. Halpern <jmh@joelhalpern...com>;[email-masked] <[email-masked]>;
日 期 ：2019年09月28日 05:36
主 题 ：Re: [nvo3] BFD over VXLAN: Trapping BFD Control packet at VTEP

Hi Xiao Min,

Thanks,
Anoop

Hi Anoop,

 0 1 2 3

Hope that clarifies.

Best Regards,

Xiao Min

原始邮件

发件人：AnoopGhanwani <[email-masked]>
收件人：肖敏10093570;
抄送人：Greg Mirsky <[email-masked]>;[email-masked] <[email-masked]>;[email-masked] <[email-masked]>;[email-masked] <[email-masked]>;[email-masked] <[email-masked]>;rtg-bfd WG <[email-masked]>;Joel M. Halpern <[email-masked]>;[email-masked] <tsridhar@vmware...com>;[email-masked] <[email-masked]>;
日 期 ：2019年09月26日 23:16
主 题 ：Re: [nvo3] BFD over VXLAN: Trapping BFD Control packet at VTEP

Hi Xiao Min,

Thanks,
Anoop

Hi Anoop,

Best Regards,

Xiao Min

原始邮件

Thanks,
Anoop

Hi Santosh,

Best Regards,

Xiao Min

---

From: Anoop Ghanwani <[email-masked]>
Date: Thu, 10 Oct 2019 14:33:38 -0700

Hi Xiao Min,

Can you provide more detail on your scenario?  I'm having trouble figuring
it out from the description below.  I need to know what subnets the tenants
are in.

Anoop

On Thu, Oct 10, 2019 at 5:00 AM <[email-masked]> wrote:

> *日 期 ：*2019年10月10日 15:47
> [XM] To be clear, I interpret VNI as Virtual Network Identifier that
> should be present within VxLAN/Geneve header. Do you mean in the case
> multiple Tenant Systems connect to multiple NVEs through IP routing
> network, different NVEs must encapsulate different Virtual Network
> Identifiers?
>
> In the mixed case (with MPLS and L2 hitting the NVE at different VAPs),
> I'm not sure how it would work in the same VNI.  If you think it's
> important, I think it may be worth writing it up.  If there's enough merit
> in the use case, we can figure out how to run multiple BFD sessions on the
> same VNI.
>
> [XM] As to the mixed case, I don't know whether there's enough merit, I
> just raise it for discussion because it seems not being prohibited from the
> NVO3 architecture point of view.
>
>
> Anoop
>
>
> Best Regards,
>
> Xiao Min
>
>
>> Normally, I think of a VNI as a broadcast domain.  The only way I can
>> make sense of the picture below is to have a separate VNI for each MPLS
>> interface on the NVE.
>>
>> Anoop
>>
>> On Tue, Oct 8, 2019 at 11:09 PM <[email-masked]
>> <[email-masked]>> wrote:
>>
>>> Hi Anoop,
>>>
>>>
>>> [email-masked] <[email-masked]> <
>>> [email-masked]>;rtg-bfd WG <[email-masked]>;Joel M.
>>> Halpern <[email-masked]>;[email-masked] <[email-masked]>;
>>> *日 期 ：*2019年10月09日 06:28
>>>> believe the following figure derived from figure 1 of RFC8014 would help,
>>>> in the following figure Tenant System1, Tenant System2, Tenant System3 and
>>>> Tenant System4 are assumed belonging to the same VNI, so two BFD sessions
>>>> for the same VNI need to be run between NVE1 and NVE2.
>>>>
>>>>                                             +--------+
>>>>                                        +----| Tenant |
>>>>                                      ( ' )  | System1|
>>>> *发件人：*AnoopGhanwani <anoop@alumni...duke.edu <[email-masked]>>
>>>> *收件人：*肖敏10093570;
>>>> *抄送人：*Greg Mirsky <[email-masked]>;didutt@gmail...com
>>>> <[email-masked]> <[email-masked]>;[email-masked] <
>>>>> WG <[email-masked]>;Joel M. Halpern <jmh@joelhalpern...com
>>>>> <[email-masked]>>;[email-masked] <[email-masked]>;
>>>>> *日 期 ：*2019年09月28日 05:36
>>>>>> Due to the fact that a variety of Tunnels could be used under the
>>>>>> NVO3 architecture, as an example, below figure illustrates the
>>>>>> format of MPLS packet over Geneve Tunnel.
>>>>>>
>>>>>>     0                   1                   2                   3
>>>>>> *抄送人：*Greg Mirsky <[email-masked]>;[email-masked]
>>>>>> <didutt@gmail...com> <[email-masked]>;[email-masked]
>>>>>> <[email-masked]>;[email-masked] <[email-masked]>;
>>>>>> [email-masked] <tsridhar@vmware...com <[email-masked]>>;
>>>>>> [email-masked] <[email-masked]>;
>>>>>> *日 期 ：*2019年09月26日 23:16
>>>>>>> Considering a scenario where TS1 has an MPLS access (i.e.
>>>>>>> MPLS-Packet over Tunnel between NVEs) to VNI1, TS3 has an Ethernet access
>>>>>>> (i.e. MAC-Frame over Tunnel between NVEs) to VNI1, then how can TS1 and TS3
>>>>>>> share one VAP?
>>>>>>>
>>>>>>>
>>>>>>> Best Regards,
>>>>>>>
>>>>>>> Xiao Min
>>>>>>> 原始邮件
>>>>>>>> Below is a figure derived from figure 2 of RFC8014 (An
>>>>>>>> Architecture for Data-Center Network Virtualization over Layer 3 (NVO3)
>>>>>>>> ).
>>>>>>>>
>>>>>>>> of NVE1 and VAP3 of NVE2, although the two BFD sessions are for
>>>>>>>> the same VNI1, I believe it's reasonable, so that's why I think we
>>>>>>>> should allow it.
>>>>>>>>
>>>>>>>>
>>>>>>>> Some people may argue that all Tenant Systems connecting to the
>>>>>>>> same Virtual Network MUST share one VAP, if that's true, then VAP1 and VAP3

---

From: <[email-masked]>
Date: Fri, 11 Oct 2019 17:18:02 +0800 (CST)

Hi Anoop,

In the use case illustrated in below figure, do you think Tenant System1 and Tenant System2 can be within the same VN? do you think NVE1 and NVE2 can encapsulate the same VNI in the packets sent from Tenant System1 and Tenant System2?

 ................
 . . +--+-+
 . .--|NVE1|
 . . | |
 . . +--+-+
 . . |
 . L3 Overlay . ( ' )
 . Network .(IP Routing)
 . . ( _ )
 . . |
 +----+ | System1|
 |NVE2| +--------+
 | |
 +----+
 |
 ( ' )
 (IP Routing)
 ( _ )
 |
 +--------+
 | Tenant |
 | System2|
 +--------+

Best Regards,

Xiao Min

原始邮件

日 期 ：2019年10月11日 05:33

Hi Xiao Min,
Can you provide more detail on your scenario?  I'm having trouble figuring it out from the description below.  I need to know what subnets the tenants are in.

Anoop

Hi Anoop,

原始邮件

Hi Xiao Min,

Anoop

Best Regards,

Xiao Min

Hi Anoop,

Best Regards,

Xiao Min

原始邮件

Hi Xiao Min,

Anoop

Hi Anoop,

Best Regards,

Xiao Min

原始邮件

Hi Xiao Min,

Anoop

Hi Anoop,

 +--------+
 +----| Tenant |
 ( ' ) | System1|

Best Regards,

Xiao Min

原始邮件

Hi Xiao Min,

Anoop

Hi Anoop,

Best Regards,

Xiao Min

原始邮件

Hi Xiao Min,

Thanks,
Anoop

Hi Anoop,

 0 1 2 3

Hope that clarifies.

Best Regards,

Xiao Min

原始邮件

Hi Xiao Min,

Thanks,
Anoop

Hi Anoop,

Best Regards,

Xiao Min

原始邮件

Thanks,
Anoop

Hi Santosh,

Best Regards,

Xiao Min

---

From: Anoop Ghanwani <[email-masked]>
Date: Fri, 11 Oct 2019 08:59:24 -0700

Hi Xiao Min,

Unless they are in the same broadcast domain (which does not appear to the
case) they would not be in the same VNI.

Anoop

On Fri, Oct 11, 2019 at 2:18 AM <[email-masked]> wrote:

> Hi Anoop,
>
>
> In the use case illustrated in below figure, do you think Tenant System1
> and Tenant System2 can be within the same VN? do you think NVE1 and NVE2
> can encapsulate the same VNI in the packets sent from Tenant System1 and
> Tenant System2?
>
>             ................
>             .              .  +--+-+
>             .              .--|NVE1|
>             .              .  |    |
>             .              .  +--+-+
>             .              .     |
>             .  L3 Overlay  .   ( ' )
>             .    Network   .(IP Routing)
>             .              .   ( _ )
>             .              .     |
> *日 期 ：*2019年10月11日 05:33
>> In those cases, the term "VN" is used to talk about multiple IP
>> interfaces in a VRF.  The different interfaces would have to be different
>> VNIs.
>>
>>>> If the answer is yes, then I agree that all Tenant Systems attached to
>>>> a common NVE MUST share a VAP so long as they connect to the same VN,
>>>> If the answer is no, then we should allow multiple BFD sessions for
>>>> the same VNI between two NVEs. I personally lean to this answer.
>>>>
>>>>
>>>> Best Regards,
>>>>
>>>> Xiao Min
>>>> 原始邮件
>>>> Halpern <[email-masked]>;[email-masked] <[email-masked]
>>>> >;
>>>> *日 期 ：*2019年10月09日 06:28
>>>>>> The use case is that the network between the VM and the NVE is an
>>>>>> MPLS network, within which the packet is forwarded basing on MPLS label,
>>>>>> but not Ethernet MAC address and/or 802.1Q VLAN. When two such kind of MPLS
>>>>>> clear.  It might help if you explain why its necessary to map a physical
>>>>>> Ethernet port and/or 802.1Q VLAN to the same VNI as an MPLS packet without
>>>>>> an L2 header.
>>>>>>
>>>>>> Thanks,
>>>>>> Anoop
>>>>>>
>>>>>>> <didutt@gmail...com> <[email-masked]>;
>>>>>>> [email-masked] <[email-masked]>;
>>>>>>> [email-masked] <[email-masked]>;[email-masked] <
>>>>>>> Halpern <[email-masked]>;[email-masked] <
>>>>>>> tsridhar@vmware...com <[email-masked]>>;[email-masked] <
>>>>>>> [email-masked]>;
>>>>>>> *日 期 ：*2019年09月26日 23:16
>>>>>>>> I would be one of those that would argue that they MUST share on
>>>>>>>> VAP if they connect to the same Virtual Network.  IMO, the NVO3 arch doc
>>>>>>>> should have been clearer about this.
>>>>>>>>
>>>>>>>> Thanks,
>>>>>>>> Anoop
>>>>>>>>
>>>>>>>>> If the network operator want to set up one BFD session between
>>>>>>>>> VAP1 of NVE1 and VAP1of NVE2, at the same time another BFD session between
>>>>>>>>> VAP3 of NVE1 and VAP3 of NVE2, although the two BFD sessions are
>>>>>>>>> for the same VNI1, I believe it's reasonable, so that's why I
>>>>>>>>> think we should allow it.
>>>>>>>>>
>>>>>>>>>

---

From: <[email-masked]>
Date: Sat, 12 Oct 2019 09:52:01 +0800 (CST)

Hi Anoop,

Thanks for your reply to my question.

It's clear that we have different views on this case, could you please direct me to the text(if any) of RFC/draft that supports your statement?

Any thoughts from others?

Best Regards,

Xiao Min

原始邮件

日 期 ：2019年10月12日 00:00

Hi Xiao Min,
Unless they are in the same broadcast domain (which does not appear to the case) they would not be in the same VNI.

Anoop

Hi Anoop,

 ................
 . . +--+-+
 . .--|NVE1|
 . . | |
 . . +--+-+
 . . |
 . L3 Overlay . ( ' )
 . Network .(IP Routing)
 . . ( _ )
 . . |

Best Regards,

Xiao Min

原始邮件

Hi Xiao Min,

Anoop

Hi Anoop,

原始邮件

Hi Xiao Min,

Anoop

Best Regards,

Xiao Min

Hi Anoop,

Best Regards,

Xiao Min

原始邮件

Hi Xiao Min,

Anoop

Hi Anoop,

Best Regards,

Xiao Min

原始邮件

Hi Xiao Min,

Anoop

Hi Anoop,

 +--------+
 +----| Tenant |
 ( ' ) | System1|

Best Regards,

Xiao Min

原始邮件

Hi Xiao Min,

Anoop

Hi Anoop,

Best Regards,

Xiao Min

原始邮件

Hi Xiao Min,

Thanks,
Anoop

Hi Anoop,

 0 1 2 3

Hope that clarifies.

Best Regards,

Xiao Min

原始邮件

Hi Xiao Min,

Thanks,
Anoop

Hi Anoop,

Best Regards,

Xiao Min

原始邮件

Thanks,
Anoop

Hi Santosh,

Best Regards,

Xiao Min