Subject: draft-xiao-nvo3-bfd-geneve-00

From: Santosh P K <[email-masked]>
Date: Thu, 3 Oct 2019 19:42:51 +0530

Hello Authors,
    Below are the comments on the draft.

"[Ed.Note]: Use of O bit is still being discussed in the NVO3 WG, so
   the value is undetermined."

[SPK] In some of the implementation that are using BFD over GENEVE
have already started using O bit to indicate this is OAM packet and
these packets are not being forwarded. We may need to set this in the
GENEVE header for compatibility and have extra information for the new
implementation. Any thoughts?

 "Since multiple BFD sessions may be running between two NVEs, and multiple
BFD sessions may be originating or terminating at one NVE, there needs to
be a mechanism for demultiplexing received BFD packets to the proper
session."

[SPK] BFD VXLAN https://tools.ietf.org/html/draft-ietf-bfd-vxlan-07 drafts
there is good discussion going on if we need to define the motivation of
the draft on what problem it solves if we have BFD per VNI. There are
concerns about the scalability for the same. While we can still have BFD
for subset of VNI or we can have BFD per VNI at sedate interval/demand mode
and may use P/F sequence to poll when required. We can define supporting
use case or when P/F sequence can be really used for example it can be used
when data traffic for a given VNI has not been received for some duration.
There should also be an option to run BFD session for management VNI along
with BFD for per VNI.

 "Since multiple BFD sessions may be running between two NVEs, and multiple
BFD sessions may be originating or terminating at one NVE, there needs to
be a mechanism for demultiplexing received BFD packets to the proper
session."

[SPK] Above section in subtle way tries to talk about multiple BFD session
between same pair but again we need to be clear on what is the motivation?

These are my initial thoughts and would like to see good discussion over
this draft. Please do let me know if you think we need to address them.

Thanks
Santosh P K

---

From: <[email-masked]>
Date: Fri, 11 Oct 2019 17:03:06 +0800 (CST)

Hi Santosh,

Many thanks for your comments.

Please see my response inline with [XM].

原始邮件

发件人：SantoshPK <[email-masked]>
收件人：[email-masked] <[email-masked]>;rtg-bfd WG <[email-masked]>;
日 期 ：2019年10月04日 01:22
主 题 ：draft-xiao-nvo3-bfd-geneve-00,

Hello Authors,    Below are the comments on the draft. 

"[Ed.Note]: Use of O bit is still being discussed in the NVO3 WG, so
 the value is undetermined."
[SPK] In some of the implementation that are using BFD over GENEVE have already started using O bit to indicate this is OAM packet and these packets are not being forwarded. We may need to set this in the GENEVE header for compatibility and have extra information for the new implementation. Any thoughts? 
[XM] Fully agree. In the next revision, will change this sentence to "O bit SHOULD be set to 1, which indicates this packet contains a control message."

 "Since multiple BFD sessions may be running between two NVEs, and multiple BFD sessions may be originating or terminating at one NVE, there needs to be a mechanism for demultiplexing received BFD packets to the proper session."

[SPK] BFD VXLAN https://tools.ietf.org/html/draft-ietf-bfd-vxlan-07 drafts there is good discussion going on if we need to define the motivation of the draft on what problem it solves if we have BFD per VNI. There are concerns about the scalability for the same. While we can still have BFD for subset of VNI or we can have BFD per VNI at sedate interval/demand mode and may use P/F sequence to poll when required. We can define supporting use case or when P/F sequence can be really used for example it can be used when data traffic for a given VNI has not been received for some duration. There should also be an option to run BFD session for management VNI along with BFD for per VNI. 

[XM] My thoughts are that BFD sessions should be originated and terminated at VAP which is defined in RFC8014, and it's still undetermined that whether all Tenant Systems attached to a common NVE MUST share a VAP so long as they connect to the same VN, which will result in the decision whether we should allow multiple BFD sessions for the same VNI, in this respect, we can align the statements for both draft-ietf-bfd-vxlan and this draft, alternatively, considering the major difference between VxLAN and Geneve that Geneve supports multi-protocol payload, we can also make different statements for draft-ietf-bfd-vxlan and this draft. Lastly, I don't see much benefit to employ P/F sequence here, certainly I'm open to further discussion on it.

 "Since multiple BFD sessions may be running between two NVEs, and multiple BFD sessions may be originating or terminating at one NVE, there needs to be a mechanism for demultiplexing received BFD packets to the proper session."

[SPK] Above section in subtle way tries to talk about multiple BFD session between same pair but again we need to be clear on what is the motivation?

[XM]  As said above, I tend to believe BFD sessions should be originated and terminated at VAP, and usually one NVE owns multiple VAPs. In addition, I believe the recent discussion over draft-ietf-bfd-vxlan clarifies much of the things in this draft too. 

These are my initial thoughts and would like to see good discussion over this draft. Please do let me know if you think we need to address them. 

[XM] Thanks again for your good thoughts. I agree that we need to address them, in one way or another.

Thanks
Santosh P K 

Best Regards,

Xiao Min