Subject: Fwd: New Version Notification for draft-ietf-bfd-stability-06.txt

From: Santosh P K <[email-masked]>
Date: Mon, 13 Jul 2020 16:42:40 +0530

Hello All,
    A new version of draft for BFD-stablity is here for review. Changes
include addressing shepherd comments as provided here.
https://datatracker.ietf.org/doc/draft-ietf-bfd-stability/shepherdwriteup/.
Please also see attached diff.

Thanks
Santosh P K

---------- Forwarded message ---------
From: <[email-masked]>
Date: Mon, Jul 13, 2020 at 4:41 PM
Subject: New Version Notification for draft-ietf-bfd-stability-06.txt
To: Mach Chen <[email-masked]>, Ankur Saxena <[email-masked]>,
Peng Fan <[email-masked]>, Mahesh Jethanandani <[email-masked]>,
Ashesh Mishra <[email-masked]>, Santosh Pallagatti <
[email-masked]>

A new version of I-D, draft-ietf-bfd-stability-06.txt
has been successfully submitted by Santosh Pallagatti and posted to the
IETF repository.

Name:           draft-ietf-bfd-stability
Revision:       06
Title:          BFD Stability
Document date:  2020-07-13
Group:          bfd
Pages:          6
URL:
https://www.ietf.org/internet-drafts/draft-ietf-bfd-stability-06.txt
Status:         https://datatracker.ietf.org/doc/draft-ietf-bfd-stability/
Htmlized:       https://tools.ietf.org/html/draft-ietf-bfd-stability-06
Htmlized:
https://datatracker.ietf.org/doc/html/draft-ietf-bfd-stability
Diff:
https://www.ietf.org/rfcdiff?url2=draft-ietf-bfd-stability-06

Abstract:
   This document describes extensions to the Bidirectional Forwarding
   Detection (BFD) protocol to measure BFD stability.  Specifically, it
   describes a mechanism for detection of BFD packet loss.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: "Reshad Rahman (rrahman)" <[email-masked]>
Date: Fri, 24 Jul 2020 02:43:02 +0000

Hi Santosh,

Thanks for addressing the comments.

General: NULL authentication TLV is still used, should be replaced with NULL authentication type or section as appropriate.
Be consistent for Null v/s NULL (NULL Auth is used in bfd-optimizing-authentication)

Introduction
s/detect lost packet/detect lost packets/

Section 3 Use Cases:
s/any BFD packet loss if loss/any BFD packet loss if the loss/
s/BFD implementation/BFD implementations/
Where the text says “failure of a link”, might be better to say “failure of a datapath”?
Informative references to CFM and TWAMP would be useful

Section 4

“by appending the Null-Authentication type “. Suggest “by appending an authentication section with the NULL Authentication type “

Section 5
“BFD uses authentication TLV”, suggest change to “BFD uses an authentication section”.

“BFD packets MUST include NULL-Auth TLV”. Change to “BFD control packets MUST include an authentication section with the NULL Authentication type”

Section 5.1

“The first BFD NULL-Auth type processed by the receiver…”.  Change to  “The first BFD authentication section with the NULL Authentication type, in a valid BFD control packet, processed by the receiver” .

Also, does it have to be NULL Auth, I believe it can be any auth with sequence number? If that’s the case change to  “The first BFD authentication section with a non-zero sequence number, in a valid BFD control packet, processed by the receiver is used for….”.

Regards,

Reshad.

From: Rtg-bfd <[email-masked]> on behalf of Santosh P K <[email-masked]>
Date: Sunday, July 19, 2020 at 4:06 PM
To: "[email-masked]" <[email-masked]>
Subject: Fwd: New Version Notification for draft-ietf-bfd-stability-06.txt

Hello All,
    A new version of draft for BFD-stablity is here for review. Changes include addressing shepherd comments as provided here. https://datatracker.ietf.org/doc/draft-ietf-bfd-stability/shepherdwriteup/. Please also see attached diff.

Thanks
Santosh P K
---------- Forwarded message ---------
From: <[email-masked]<mailto:[email-masked]>>
Date: Mon, Jul 13, 2020 at 4:41 PM
Subject: New Version Notification for draft-ietf-bfd-stability-06.txt
To: Mach Chen <[email-masked]<mailto:[email-masked]>>, Ankur Saxena <[email-masked]<mailto:[email-masked]>>, Peng Fan <[email-masked]<mailto:[email-masked]>>, Mahesh Jethanandani <[email-masked]<mailto:[email-masked]>>, Ashesh Mishra <[email-masked]<mailto:[email-masked]>>, Santosh Pallagatti <[email-masked]<mailto:[email-masked]>>

Name:           draft-ietf-bfd-stability
Revision:       06
Title:          BFD Stability
Document date:  2020-07-13
Group:          bfd
Pages:          6
URL:            https://www.ietf.org/internet-drafts/draft-ietf-bfd-stability-06.txt
Status:         https://datatracker.ietf.org/doc/draft-ietf-bfd-stability/
Htmlized:       https://tools.ietf.org/html/draft-ietf-bfd-stability-06
Htmlized:       https://datatracker.ietf.org/doc/html/draft-ietf-bfd-stability
Diff:           https://www.ietf.org/rfcdiff?url2=draft-ietf-bfd-stability-06

Abstract:

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org>.

The IETF Secretariat

---

From: Santosh P K <[email-masked]>
Date: Fri, 24 Jul 2020 20:01:09 +0530

Reshad,
  Thanks again. I will address these comments.

Thanks
Santosh P K

On Fri, Jul 24, 2020 at 8:13 AM Reshad Rahman (rrahman) <[email-masked]>
wrote:

> General: NULL authentication TLV is still used, should be replaced with
> NULL authentication type or section as appropriate.
>
> “BFD packets MUST include NULL-Auth TLV”. Change to “BFD control packets
> MUST include an authentication section with the NULL Authentication type”
>
>
>
> Section 5.1
>
>
>
> *From: *Rtg-bfd <[email-masked]> on behalf of Santosh P K <
> *Date: *Sunday, July 19, 2020 at 4:06 PM
> *To: *"[email-masked]" <[email-masked]>
> *Subject: *Fwd: New Version Notification for
> draft-ietf-bfd-stability-06.txt
>
>
>
> Hello All,
>