Subject: [Rtg-yang-coord] NETMOD interim meeting canceled

From: Benoit Claise <[email-masked]>
Date: Wed, 22 Oct 2014 06:16:23 -0700

Dear all,

Today NETMOD interim meeting is canceled.

I received some pushbacks from the routing ADs, on the ground that:
1. This interim appears to be meeting to discuss a non-WG draft for 
which there is no milestone in the working group and for which there is 
an obvious home outside the working group.
2. The agenda was not announced a week in advance on the IETF announce 
list as is required

Regards, Benoit

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Wed, 22 Oct 2014 09:29:27 -0400

This is hugely disappointing. This is the kind of procedural non-sense has and IS driving people away from the IETF to other places where this work is going to get done. The simple effect of such silliness will be a reduction in speed and quantity of model development.  If the goal of the IESG is to slow down the velocity of model development and creation, then this approach is perfect.

	For the record, the interim NETMOD meeting cadence has one meeting focused on Yang and the other on modeling; is not NETMOD-specific per say, but to promote model creation because no other bi-weekly forum exists to do so. It is also a place to bring in non-IETF work such as the work done in ODL, other open source, or just the public community that has explicitly wanted to avoid the IETF.  We have found it a convenient and fruitful place to discuss, and actually *build* models - regardless of their ultimate WG home.  The simple reason: its a single place for many of the experts to gather. I think you will find it very difficult to get those people onto a per-WG call every other week.  

	I hope the IESG considers this approach carefully because I do not think it will have the affect the larger IETF community is interested in.

	--Tom

> On Oct 22, 2014:9:16 AM, at 9:16 AM, Benoit Claise <[email-masked]> wrote:
> 
> Dear all,
> 
> 1. This interim appears to be meeting to discuss a non-WG draft for which there is no milestone in the working group and for which there is an obvious home outside the working group.
> 2. The agenda was not announced a week in advance on the IETF announce list as is required
> 
> Regards, Benoit
> 
> _______________________________________________
> Rtg-yang-coord mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtg-yang-coord
>

---

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 22 Oct 2014 14:48:56 +0100

I understand and appreciate your desire to get work done.

The rules for IETF virtual interims are neither hard to discover, nor hard to
comply with. The rules exist to ensure that people are included in the work, and
I am sure that inclusion is what you want.

I find it unfortunate that you scheduled a working group meeting to discuss only
one of a pair of competing documents on the same topic, that you didn't make the
information about the meeting available to the authors of the competing document
or to the people who care about the protocol being modelled, and I find it
upsetting (yes, I am actually upset) that you decided to discuss in Netmod a
document that belongs in the OSPF working group.

If, as it surely sounds, you wish that the Netmod working group had a different
charter to enable it to take on models for protocols that already have a home in
other working groups, then I suggest you need to recharter. But I doubt that
your reasoning that [YANG] experts will not go to all the other working groups
will carry much weight. Frankly, and without wanting to disrespect the YANG
experts, it is easier to understand YANG than it is to understand OSPF. If this
were not the case then the Netmod working group would have failed in its design
of YANG! 

Conclusion: 
You want to work on a YANG model for OSPF. Go to the OSPF working group and
discuss it (there are already some threads). Review and comment on the competing
document. Try to get agreement between all of the authors of both documents, or
try to identify the differences. Work with the chairs of the OSPF working group
to advance the work.

Adrian

> -----Original Message-----
> From: Thomas D. Nadeau [mailto:[email-masked]]
> Sent: 22 October 2014 14:29
> To: Benoit Claise
> Cc: NETMOD Working Group; [email-masked]; [email-masked];
> [email-masked]
> Subject: Re: [Rtg-yang-coord] NETMOD interim meeting canceled
> 
> 
> 	This is hugely disappointing. This is the kind of procedural non-sense
has
> and IS driving people away from the IETF to other places where this work is
going
> to get done. The simple effect of such silliness will be a reduction in speed
and
> quantity of model development.  If the goal of the IESG is to slow down the
> velocity of model development and creation, then this approach is perfect.
> 
> 	For the record, the interim NETMOD meeting cadence has one meeting
> focused on Yang and the other on modeling; is not NETMOD-specific per say, but
> to promote model creation because no other bi-weekly forum exists to do so. It
> is also a place to bring in non-IETF work such as the work done in ODL, other
open
> source, or just the public community that has explicitly wanted to avoid the
IETF.
> We have found it a convenient and fruitful place to discuss, and actually
*build*
> models - regardless of their ultimate WG home.  The simple reason: its a
single
> place for many of the experts to gather. I think you will find it very
difficult to get
> those people onto a per-WG call every other week.
> 
> 	I hope the IESG considers this approach carefully because I do not think
it
> will have the affect the larger IETF community is interested in.
> 
> 	--Tom
> 
> 
> 
> > 1. This interim appears to be meeting to discuss a non-WG draft for which
there
> is no milestone in the working group and for which there is an obvious home
> outside the working group.

---

From: Robert Raszuk <[email-masked]>
Date: Wed, 22 Oct 2014 15:50:58 +0200

Hi Tom,

I agree with you.

Not longer then few days back I have received request from paying customers
to add OSPF, BGP & BFD API to the product.

All I could propose was few slowly moving drafts.

I recommend you setup a meetup.com space for rtg-yang regular online
discussions and turn those drafts which are in progress into OpenStack
Neutron blueprints.

I think the progress will be much faster and much wider in the community ;-)

Cheers,
R.

On Wed, Oct 22, 2014 at 3:29 PM, Thomas D. Nadeau <[email-masked]>
wrote:

>
>         This is hugely disappointing. This is the kind of procedural
> non-sense has and IS driving people away from the IETF to other places
> where this work is going to get done. The simple effect of such silliness
> will be a reduction in speed and quantity of model development.  If the
> goal of the IESG is to slow down the velocity of model development and
> creation, then this approach is perfect.
>
> focused on Yang and the other on modeling; is not NETMOD-specific per say,
> but to promote model creation because no other bi-weekly forum exists to do
> so. It is also a place to bring in non-IETF work such as the work done in
> ODL, other open source, or just the public community that has explicitly
> wanted to avoid the IETF.  We have found it a convenient and fruitful place
> to discuss, and actually *build* models - regardless of their ultimate WG
> home.  The simple reason: its a single place for many of the experts to
> gather. I think you will find it very difficult to get those people onto a
> per-WG call every other week.
>
>         I hope the IESG considers this approach carefully because I do not
> think it will have the affect the larger IETF community is interested in.
>
>         --Tom
>
>
>
> which there is no milestone in the working group and for which there is an
> obvious home outside the working group.

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Wed, 22 Oct 2014 09:51:32 -0400

Hide behind the rules all you like, but this is a simple example of why people are going elsewhere to work on these things.

	--Tom

> On Oct 22, 2014:9:48 AM, at 9:48 AM, Adrian Farrel <[email-masked]> wrote:
>

---

From: Robert Raszuk <[email-masked]>
Date: Wed, 22 Oct 2014 16:01:43 +0200

Hi Adrian,

What other competing OSPF yang model are you referring to?

Can you provide link to discussions about that other model on OSPF WG list
taking place ?

Thx,
R.

On Wed, Oct 22, 2014 at 3:48 PM, Adrian Farrel <[email-masked]> wrote:

> non-sense
> think
> which
> list
> > as is required

---

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 22 Oct 2014 15:13:25 +0100

Hi Robert,
 
http://datatracker.ietf.org/doc/draft-wang-i2rs-ospf-dm/
 
Yes, it is in the wrong WG as well.
 
No, I can't point to it being discussed on the OSPF list. Not sure that fact proves anything.
 
Adrian
 
From: [email-masked] [mailto:[email-masked]] On Behalf Of Robert Raszuk
Sent: 22 October 2014 15:02
To: Adrian Farrel
Cc: Thomas D. Nadeau; Benoit Claise; [email-masked]; [email-masked]
Subject: Re: [Rtg-yang-coord] NETMOD interim meeting canceled
 
Hi Adrian,

Can you provide link to discussions about that other model on OSPF WG list taking place ? 
 
Thx,
R.

Conclusion:

Adrian

has
going
and
open
IETF.
*build*
single
difficult to get
it
there

---

From: Andy Bierman <[email-masked]>
Date: Wed, 22 Oct 2014 07:18:14 -0700

Hi Adrian,

I agree with you. The OSPF WG should be discussing OSPF data models,
not the NETMOD WG. The domain experts need to reach consensus
on a feature set (and maybe info model) and then get 1 or 2 YANG experts to
help translate that to a data model. (Not the other way around -- a room
full of YANG experts and 1 or 2 OSPF experts).

I also prefer that virtual interim meetings be used to discuss open issues
on chartered items, not as an additional forum to promote individual drafts.

Andy

On Wed, Oct 22, 2014 at 6:48 AM, Adrian Farrel <[email-masked]> wrote:

> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod
>

---

From: Robert Raszuk <[email-masked]>
Date: Wed, 22 Oct 2014 16:18:55 +0200

Adrian,

Ah that document I know. But this is almost completely different topic.

At least to me I2RS is not about configuring OSPF protocol. It is about
collecting and possibly augmenting routing system with data.

On the other hand Yang model takes care about instatiation and management
of a given protocol. There can be some little overlap, but does not need to
be at all.

Best,
R.

On Wed, Oct 22, 2014 at 4:13 PM, Adrian Farrel <[email-masked]> wrote:

> *From:* [email-masked] [mailto:[email-masked]] *On Behalf Of *Robert
> Raszuk
> *Sent:* 22 October 2014 15:02
> *To:* Adrian Farrel
> *Cc:* Thomas D. Nadeau; Benoit Claise; [email-masked];
> [email-masked]
>
> *Subject:* Re: [Rtg-yang-coord] NETMOD interim meeting canceled
>
>
>
> Hi Adrian,
>
>
>

---

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 22 Oct 2014 15:24:20 +0100

Excellent.
 
This is exactly the discussion that should be happening.
 
Adrian
 
From: [email-masked] [mailto:[email-masked]] On Behalf Of Robert Raszuk
Sent: 22 October 2014 15:19
To: Adrian Farrel
Cc: Thomas D. Nadeau; Benoit Claise; [email-masked]; [email-masked]
Subject: Re: [Rtg-yang-coord] NETMOD interim meeting canceled
 
Adrian,

At least to me I2RS is not about configuring OSPF protocol. It is about collecting and possibly augmenting routing system with data. 
 
On the other hand Yang model takes care about instatiation and management of a given protocol. There can be some little overlap, but does not need to be at all.
 
Best,
R.

 

 
Adrian

 
Hi Adrian,

 
Thx,
R.

Conclusion:

Adrian

has
going
and
open
IETF.
*build*
single
difficult to get
it
there

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Wed, 22 Oct 2014 10:35:10 -0400

No one said that OSPF experts could not attend to provide input.   The issue is that OSPF was not doing this. If they want to take over doing all OSPF models, then great, but to date no one was.  The agreement in NETMOD (and our charter) is to facilitate the creation of models when WGs don’t want to do them, have the expertise to do them, etc…  Also, getting the right Yang experts in one place is not going to happen for every WG in the IETF; its just not realistic.  I understand that ultimately the WG needs to have consensus, but quick iteration to construct the model surely can happen in a small “design team” fashion, right?

	And in terms of today’s meeting being canceled, really what purpose was that other than to stall/slow-down work?  The group that was there to work on the OSPF model was indeed a bunch of folks from OSPF (Acee Lindem for example was on the call).  So now since we won’t have another interim meeting until after Hawaii, so the next time this group can get together is possibly in Hawaii, but that is probably unlikely as a large number of people are not going to Hawaii.  So the net-net is a slowing of progress in this area.  Probably not the result the IETF community wants.

	—Tom

> On Oct 22, 2014:10:18 AM, at 10:18 AM, Andy Bierman <[email-masked]> wrote:
> 
> Hi Adrian,
> 
> On Wed, Oct 22, 2014 at 6:48 AM, Adrian Farrel <[email-masked] <mailto:[email-masked]>> wrote:
> > From: Thomas D. Nadeau [mailto:[email-masked] <mailto:[email-masked]>]
> > Cc: NETMOD Working Group; [email-masked] <mailto:[email-masked]>; [email-masked] <mailto:[email-masked]>;
> > [email-masked] <mailto:[email-masked]>
> > > On Oct 22, 2014:9:16 AM, at 9:16 AM, Benoit Claise <[email-masked] <mailto:[email-masked]>>
> wrote:
> > >
> > > Dear all,
> > >
> > > [email-masked] <mailto:[email-masked]>
> > > https://www.ietf.org/mailman/listinfo/rtg-yang-coord <https://www.ietf.org/mailman/listinfo/rtg-yang-coord>
> > >
> 
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/netmod <https://www.ietf.org/mailman/listinfo/netmod>
>

---

From: Jeff Haas <[email-masked]>
Date: Wed, 22 Oct 2014 10:43:37 -0400

> On the other hand Yang model takes care about instatiation and management of a given protocol. There can be some little overlap, but does not need to be at all.

Just for clarity, the long term goal of Sue's draft was *not* to be a competing ospf draft, it was to provide enough of an example config base to demonstrate where I2RS hooks would go.

I2RS is not in the business of trying to do the modeling work of other WG's protocols.  

I2RS is definitely in the business of seeing standardized models advance so we can hook into them.

Figuring out the most productive way to have that discussion has obviously been a bit bumpy.  Hence, one of the reasons to have the rtg-yang-coord list.

FWIW, I agree with Adrian that the scope of the netmod interim design sessions has crept a bit out of the expected charter.  This isn't to say that work shouldn't happen, but when it does:
- There needs to be adequate notice (apparently Adrian's biggest complaint)
- Some mindfulness about group scope needs to be accommodated.

The comment about taking your ball and going someplace else to play (meetup.com) was not worthy of a chair, Tom.  While there's certainly precedent in other orgs of working faster, there's also similar precent of fork and fracture.

-- Jeff

---

From: Andy Bierman <[email-masked]>
Date: Wed, 22 Oct 2014 07:45:28 -0700

Hi,

I think the interim did not need to be cancelled. There are ACL, SYSLOG,
and YANG Mount topics. I was going to call in for those, not OSPF.
But I have been saying (for over a year now) that it is time to move
domain-specific data models into the domain-specific WGs.
I think NETMOD WG should focus on the YANG language and
infrastructure modules.

Andy

On Wed, Oct 22, 2014 at 7:35 AM, Thomas D. Nadeau <[email-masked]>
wrote:

>
> No one said that OSPF experts could not attend to provide input.   The
> issue is that OSPF was not doing this. If they want to take over doing all
> OSPF models, then great, but to date no one was.  The agreement in NETMOD
> (and our charter) is to facilitate the creation of models when WGs don't
> want to do them, have the expertise to do them, etc...  Also, getting the
> right Yang experts in one place is not going to happen for every WG in the
> IETF; its just not realistic.  I understand that ultimately the WG needs to
> have consensus, but quick iteration to construct the model surely can
> happen in a small "design team" fashion, right?
>
> And in terms of today's meeting being canceled, really what purpose was
> that other than to stall/slow-down work?  The group that was there to work
> on the OSPF model was indeed a bunch of folks from OSPF (Acee Lindem for
> example was on the call).  So now since we won't have another interim
> meeting until after Hawaii, so the next time this group can get together is
> possibly in Hawaii, but that is probably unlikely as a large number of
> people are not going to Hawaii.  So the net-net is a slowing of progress in
> this area.  Probably not the result the IETF community wants.
>
> --Tom
>
>
>
>> > > On Oct 22, 2014:9:16 AM, at 9:16 AM, Benoit Claise <[email-masked]
>> >
>> wrote:
>> > >
>> > > Dear all,
>> > >
>> > > 2. The agenda was not announced a week in advance on the IETF
>> announce list
>> > as is required
>> > >
>> > > Regards, Benoit
>> > >

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Wed, 22 Oct 2014 10:48:06 -0400

> On Oct 22, 2014:10:43 AM, at 10:43 AM, Jeff Haas <[email-masked]> wrote:
> 
> 
> On Oct 22, 2014, at 10:18 AM, Robert Raszuk <[email-masked] <mailto:[email-masked]>> wrote:
> 
>> Adrian,
>> 
> The comment about taking your ball and going someplace else to play (meetup.com <http://meetup.com/>) was not worthy of a chair, Tom.  While there's certainly precedent in other orgs of working faster, there's also similar precent of fork and fracture.

	For the record, I never suggested we go to meetup.com <http://meetup.com/> anywhere; that was Robert that did.

	—Tom

---

From: Robert Raszuk <[email-masked]>
Date: Wed, 22 Oct 2014 16:51:09 +0200

> The comment about taking your ball and going someplace else to
> play (meetup.com) was not worthy of a chair, Tom.

Jeff,

I am not sure I am with you. My point was that whatever tools we have in
place should be used.

For me - I would highly appreciate if Derek alone would record a sessions
and explain his draft. Then publish it on you tube.

That's it.

Maybe it should not be called interim meeting .. maybe IETF has no name for
it, but just progressing work based on the 3 meetings a year + mailing
lists seems not to be the most efficient choice these days. There are many
ways to improve it.

The only question is if IETF is ready for it or not.

Cheers,
R.

On Wed, Oct 22, 2014 at 4:43 PM, Jeff Haas <[email-masked]> wrote:

> Just for clarity, the long term goal of Sue's draft was *not* to be a
> competing ospf draft, it was to provide enough of an example config base to
> demonstrate where I2RS hooks would go.
>
> Figuring out the most productive way to have that discussion has obviously
> been a bit bumpy.  Hence, one of the reasons to have the rtg-yang-coord
> list.
>
> FWIW, I agree with Adrian that the scope of the netmod interim design
> sessions has crept a bit out of the expected charter.  This isn't to say
> that work shouldn't happen, but when it does:
> The comment about taking your ball and going someplace else to play (
> meetup.com) was not worthy of a chair, Tom.  While there's certainly
> precedent in other orgs of working faster, there's also similar precent of
> fork and fracture.
>
> -- Jeff
>
>

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Wed, 22 Oct 2014 10:52:09 -0400

We are trying. The thing is that you cannot just hoist that onto WGs and say “here you go.” if they don’t want to do it.  Again, the Netmod charter was specifically modified to accommodate that case.   And while some WGs in the routing area are not enthusiastic about building models, others aren’t, nor are other WGs at the IETF. So for those, what do you do? Ignore them? The other point is that others outside of the IETF are working on these models.  It is squarely within the IETF community’s interest to bring these back into the fold.  Many of these folks are skittish about coming to the IETF altogether so we’ve tried to encourage them to participate in this way. If we want to push these folks away with procedural reasons, then we have made our bed...

	—tom

> On Oct 22, 2014:10:45 AM, at 10:45 AM, Andy Bierman <[email-masked]> wrote:
> 
> Hi,
> 
> On Wed, Oct 22, 2014 at 7:35 AM, Thomas D. Nadeau <[email-masked] <mailto:[email-masked]>> wrote:
> 
>> On Oct 22, 2014:10:18 AM, at 10:18 AM, Andy Bierman <[email-masked] <mailto:[email-masked]>> wrote:
>> 
>> Hi Adrian,
>>

---

From: Jeff Haas <[email-masked]>
Date: Wed, 22 Oct 2014 10:57:35 -0400

On Oct 22, 2014, at 10:48 AM, Thomas D. Nadeau <[email-masked]> wrote:

> For the record, I never suggested we go to meetup.com anywhere; that was Robert that did.
> 

My apologies then.  I'm replying to mail between too many other things for proper attention apparently.

-- Jeff

---

From: Andy Bierman <[email-masked]>
Date: Wed, 22 Oct 2014 07:59:26 -0700

On Wed, Oct 22, 2014 at 7:52 AM, Thomas D. Nadeau <[email-masked]>
wrote:

>
> We are trying. The thing is that you cannot just hoist that onto WGs and
> say "here you go." if they don't want to do it.  Again, the Netmod charter
> was specifically modified to accommodate that case.   And while some WGs in
> the routing area are not enthusiastic about building models, others aren't,
> nor are other WGs at the IETF. So for those, what do you do? Ignore them?
> The other point is that others outside of the IETF are working on these
> models.  It is squarely within the IETF community's interest to bring these
> back into the fold.  Many of these folks are skittish about coming to the
> IETF altogether so we've tried to encourage them to participate in this
> way. If we want to push these folks away with procedural reasons, then we
> have made our bed...
>
>
This "network management scope" discussion has been going on since
the early days of SNMP.  It's up to the people approving WG charters
to ask for configuration, not just monitoring. It's up to the WG members
to agree on a common subset of configuration parameters. NETMOD WG
can help with the YANG details.

--tom
Andy

> On Wed, Oct 22, 2014 at 7:35 AM, Thomas D. Nadeau <[email-masked]
> > wrote:
>
>>
>>> > > On Oct 22, 2014:9:16 AM, at 9:16 AM, Benoit Claise <
>>> [email-masked]>
>>> wrote:
>>> > >
>>> > > Dear all,
>>> > >

---

From: "Ken Gray (kegray)" <[email-masked]>
Date: Wed, 22 Oct 2014 15:00:42 +0000

Is this also the competing draft you referred to?

From: Adrian Farrel <[email-masked]<mailto:[email-masked]>>
Reply-To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, October 22, 2014 10:13 AM
To: 'Robert Raszuk' <[email-masked]<mailto:[email-masked]>>
Cc: "Benoit Claise (bclaise)" <[email-masked]<mailto:[email-masked]>>, "'Thomas D. Nadeau'" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Rtg-yang-coord] NETMOD interim meeting canceled

Hi Robert,

Adrian

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Robert Raszuk
Sent: 22 October 2014 15:02
To: Adrian Farrel
Cc: Thomas D. Nadeau; Benoit Claise; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Rtg-yang-coord] NETMOD interim meeting canceled

Hi Adrian,

Thx,
R.

On Wed, Oct 22, 2014 at 3:48 PM, Adrian Farrel <[email-masked]<mailto:[email-masked]>> wrote:
I understand and appreciate your desire to get work done.

Conclusion:

Adrian

> From: Thomas D. Nadeau [mailto:[email-masked]<mailto:[email-masked]>]
> Cc: NETMOD Working Group; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>;
> [email-masked]<mailto:[email-masked]>
has
going
and
open
IETF.
*build*
single
difficult to get
it
> > On Oct 22, 2014:9:16 AM, at 9:16 AM, Benoit Claise <[email-masked]<mailto:[email-masked]>>
there
> > [email-masked]<mailto:[email-masked]>

_______________________________________________
Rtg-yang-coord mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/rtg-yang-coord

---

From: Jeff Haas <[email-masked]>
Date: Wed, 22 Oct 2014 11:02:40 -0400

> 	We are trying. The thing is that you cannot just hoist that onto WGs and say “here you go.” if they don’t want to do it.  Again, the Netmod charter was specifically modified to accommodate that ca…

I've had part of this conversation with Alia recently and with many others at the prior IETF, including Benoit.  That was part of the motivation to form the rtg-yang-coord list.  Simply put, modeling work needs to happen but the subset of people who actively care about it in any particular WG is usually a fraction of the participants.  Additionally, the danger of doing it in netmod is overloading people who are wanting to work on the language but don't necessarily want to contribute to a given bit of modeling effort.

I don't know that the "coord" efforts need a full WG, but the semantics of managing that at an IETF process perspective are something the IESG cares more about than I think I do.  Basically, coord is likely to be a bunch of dynamically spun design teams, hopefully reporting back their lessons to someplace like this list.

-- Jeff

---

From: <[email-masked]>
Date: Wed, 22 Oct 2014 13:44:54 +0000

Hi,

I also agree that this is a bad idea. I thought that IETF willing and especially yours, Benoit, was to speed up availability of standard models. The process of having small teams working with weekly calls works almost good but we still have some issue that are both technical (dedicated to the topic addressed by the model) and also YANG writing, model consistencies ... that requires discussion, and as often mailing list is not as good as meetings (that's why the proposal of small teams was done).

At the present time, I personally support the initiative of having interim meetings in Netmod to discuss proposed Yang models : this will ensure consistency between models and will help to solve global issues in modeling. It's just the starting of Yang modeling, leaving only Yang models within home WG (ISIS for my point of view) would be, IMO, a very bad idea and will for sure slow down the availability of standards ... and I also think that it may discourage people to work on because of the added overhead.

It was just my opinion ...

Best Regards,

Stephane

-----Original Message-----
From: netmod [mailto:[email-masked]] On Behalf Of Thomas D. Nadeau
Sent: Wednesday, October 22, 2014 15:29
To: Benoit Claise
Cc: [email-masked]; [email-masked]; NETMOD Working Group; [email-masked]
Subject: Re: [netmod] [Rtg-yang-coord] NETMOD interim meeting canceled

	--Tom

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 22 Oct 2014 16:05:34 +0100

Yes.
And, as Jeff explains, it is not intended to compete. Perhaps "feed into" would
be a good term.
And as Robert notes, the overlap can be handled in discussion.
 
It's great that we have venues to discuss this work. I hope we can advance it
quickly. Doing so "in secret" will, however, not end well for anyone.
 
Adrian
 
From: Rtg-yang-coord [mailto:[email-masked]] On Behalf Of Ken
Gray (kegray)
Sent: 22 October 2014 16:01
To: [email-masked]; 'Robert Raszuk'
Cc: Benoit Claise (bclaise); 'Thomas D. Nadeau'; [email-masked];
[email-masked]
Subject: Re: [Rtg-yang-coord] NETMOD interim meeting canceled

From: Adrian Farrel <[email-masked]>
Reply-To: "[email-masked]" <[email-masked]>
Date: Wednesday, October 22, 2014 10:13 AM
To: 'Robert Raszuk' <[email-masked]>
Cc: "Benoit Claise (bclaise)" <[email-masked]>, "'Thomas D. Nadeau'"
<[email-masked]>, "[email-masked]"
<[email-masked]>, "[email-masked]"
<[email-masked]>
Subject: Re: [Rtg-yang-coord] NETMOD interim meeting canceled
 
Hi Robert,

 
No, I can't point to it being discussed on the OSPF list. Not sure that fact
proves anything.
 
Adrian
 
Cc: Thomas D. Nadeau; Benoit Claise; [email-masked];
 
Hi Adrian,

 
Thx,
R.

Conclusion:

Adrian

has
going
and
open
IETF.
*build*
single
difficult to get
it
there

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Wed, 22 Oct 2014 15:08:43 +0000

FWIW, The OSPF YANG model is on the agenda for IETF 91. We do plan to more forward and poll for OSPF WG adoption as well.

Thanks,
Acee

From: Andy Bierman <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, October 22, 2014 at 10:18 AM
To: Adrian Farrel <[email-masked]<mailto:[email-masked]>>
Cc: "Thomas D. Nadeau" <[email-masked]<mailto:[email-masked]>>, "Benoit Claise (bclaise)" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, NETMOD Working Group <[email-masked]<mailto:[email-masked]>>, Routing ADs <[email-masked]<mailto:[email-masked]>>
Subject: Re: [netmod] [Rtg-yang-coord] NETMOD interim meeting canceled
Resent-From: <[email-masked]<mailto:[email-masked]>>
Resent-To: Acee Lindem <[email-masked]<mailto:[email-masked]>>, <[email-masked]<mailto:[email-masked]>>
Resent-Date: Wednesday, October 22, 2014 at 10:18 AM

Hi Adrian,

Andy

On Wed, Oct 22, 2014 at 6:48 AM, Adrian Farrel <[email-masked]<mailto:[email-masked]>> wrote:
I understand and appreciate your desire to get work done.

Conclusion:

Adrian

has
going
and
open
IETF.
*build*
single
difficult to get
it
there

_______________________________________________
netmod mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/netmod

---

From: "Eric Voit (evoit)" <[email-masked]>
Date: Wed, 22 Oct 2014 15:20:13 +0000

As Tom and others note, today's Netmod interim was to have topics beyond OSPF.  These included OpenDaylight related work.   The IETF should be encouraging venues for Open Source developer audiences.  Cancelling full meetings via IETF procedural mechanisms signals the opposite.

I *like* the idea of each WG being the owner for their domain models.  This scales well for the reasons  pointed out below.  And I do have sympathy for a WG wanting to close on a definitive answer for a YANG model before implications are discussed elsewhere.   But I am worried that we are enforcing an overly serial process.  Or of constraining communication.  The market will work around this.

In the controller space, YANG technology is not static.  Some degree of parallelism is needed across IETF WGs.  Clueful Open Source/YANG developers cannot extend themselves across all WG where YANG modeling might occur.

Eric

From: Thomas D. Nadeau, October 22, 2014 10:52 AM

          We are trying. The thing is that you cannot just hoist that onto WGs and say "here you go." if they don't want to do it.  Again, the Netmod charter was specifically modified to accommodate that case.   And while some WGs in the routing area are not enthusiastic about building models, others aren't, nor are other WGs at the IETF. So for those, what do you do? Ignore them? The other point is that others outside of the IETF are working on these models.  It is squarely within the IETF community's interest to bring these back into the fold.  Many of these folks are skittish about coming to the IETF altogether so we've tried to encourage them to participate in this way. If we want to push these folks away with procedural reasons, then we have made our bed...

          -tom

On Oct 22, 2014:10:45 AM, at 10:45 AM, Andy Bierman <[email-masked]<mailto:[email-masked]>> wrote:

Hi,

Andy

On Wed, Oct 22, 2014 at 7:35 AM, Thomas D. Nadeau <[email-masked]<mailto:[email-masked]>> wrote:

No one said that OSPF experts could not attend to provide input.   The issue is that OSPF was not doing this. If they want to take over doing all OSPF models, then great, but to date no one was.  The agreement in NETMOD (and our charter) is to facilitate the creation of models when WGs don't want to do them, have the expertise to do them, etc...  Also, getting the right Yang experts in one place is not going to happen for every WG in the IETF; its just not realistic.  I understand that ultimately the WG needs to have consensus, but quick iteration to construct the model surely can happen in a small "design team" fashion, right?

And in terms of today's meeting being canceled, really what purpose was that other than to stall/slow-down work?  The group that was there to work on the OSPF model was indeed a bunch of folks from OSPF (Acee Lindem for example was on the call).  So now since we won't have another interim meeting until after Hawaii, so the next time this group can get together is possibly in Hawaii, but that is probably unlikely as a large number of people are not going to Hawaii.  So the net-net is a slowing of progress in this area.  Probably not the result the IETF community wants.

-Tom

On Oct 22, 2014:10:18 AM, at 10:18 AM, Andy Bierman <[email-masked]<mailto:[email-masked]>> wrote:

Hi Adrian,

Andy

Conclusion:

Adrian

has
going
and
open
IETF.
*build*
single
difficult to get
it
there

---

From: Dean Bogdanovic <[email-masked]>
Date: Wed, 22 Oct 2014 15:14:41 +0000

> I don't know that the "coord" efforts need a full WG, but the semantics of managing that at an IETF process perspective are something the IESG cares more about than I think I do.  Basically, coord…

This is a good proposal. We need to be more dynamic with model creations and need people who are experts in the area. But absolutely have to be better coordinated. I think that rtg-yang-coord is a good start, but we need such a alias for other areas too. Since I was part of a (call it experiment/try) for ACL and OSPF models, I think it was a good way to create vendor neutral models. It might be not the fastest way, but it was very productive. Could have we been faster with the models? Yes, but then our paying day job would suffer, so we are running into same problems as all other volunteering based projects. It is obvious that we need a more flexibility within IETF, but also the efforts have to be better coordinated.

Dean

---

From: "Ken Gray (kegray)" <[email-masked]>
Date: Wed, 22 Oct 2014 15:24:01 +0000

Seems to me that a certain amount of omniscience would be required to know that there's a competing draft in another WG (I know a lot of us list-troll multiple WG, but it might be an assumption we all do).

Which I think is the gist of some of the dialogue in the thread.  Is there a requirement that all yang related drafts notify this group (straight up question, I don't know if the tooling has been done to make that happen … requirement for "yang" in draft name to trigger such an event …anything? …did I miss that)?

Personally, the scatter-gather approach to modeling hasn't yielded outstanding results to date (okay, that's opinion) … and it makes it harder to know system-wide, where the heck we (the IETF community) are in completion of the task many of us are now hearing from customers – that the thing we call "router" or "switch" have a complete model set from which we could drive an API (the day of the CLI causing brand loyalty probably passed us by while we were sleeping).  Would this list be tracking something like that … do we even understand that that is the effort afoot?

To me, "coordinator" or "coordination" would imply that macro level responsibility.  Can a list own that, or should we delegate it to a group?  And, if so, what group would that be?

From: Adrian Farrel <[email-masked]<mailto:[email-masked]>>
Reply-To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, October 22, 2014 11:05 AM
To: Ken Gray <[email-masked]<mailto:[email-masked]>>, 'Robert Raszuk' <[email-masked]<mailto:[email-masked]>>
Cc: "Benoit Claise (bclaise)" <[email-masked]<mailto:[email-masked]>>, "'Thomas D. Nadeau'" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Rtg-yang-coord] NETMOD interim meeting canceled

Yes.
And, as Jeff explains, it is not intended to compete. Perhaps "feed into" would be a good term.
And as Robert notes, the overlap can be handled in discussion.

It's great that we have venues to discuss this work. I hope we can advance it quickly. Doing so "in secret" will, however, not end well for anyone.

Adrian

From: Rtg-yang-coord [mailto:[email-masked]] On Behalf Of Ken Gray (kegray)
Sent: 22 October 2014 16:01
To: [email-masked]<mailto:[email-masked]>; 'Robert Raszuk'
Cc: Benoit Claise (bclaise); 'Thomas D. Nadeau'; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Rtg-yang-coord] NETMOD interim meeting canceled

Hi Robert,

Adrian

From:[email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Robert Raszuk
Sent: 22 October 2014 15:02
To: Adrian Farrel
Cc: Thomas D. Nadeau; Benoit Claise; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Rtg-yang-coord] NETMOD interim meeting canceled

Hi Adrian,

Thx,
R.

Conclusion:

Adrian

has
going
and
open
IETF.
*build*
single
difficult to get
it
there

---

From: "Adrian Farrel" <[email-masked]>
Date: Wed, 22 Oct 2014 16:31:15 +0100

Eric,
 
I cannot speak to why the meeting was cancelled. 
My disquiet was simply that an item on the agenda was out of scope and not
properly announced to achieve the correct participation.
 
The text I sent to Benoit read...
 
> In summary: if this meeting does not have material to discuss under
> the agenda for which the meeting was called, then it must be cancelled.
 
You appear to be saying that there was work to be done that was in scope for the
WG and was part of the agenda that was published. 
 
So I'm a bit puzzled. 
 
Adrian

From: Eric Voit (evoit) [mailto:[email-masked]] 
Sent: 22 October 2014 16:20
To: Thomas D. Nadeau; Andy Bierman
Cc: [email-masked]; NETMOD Working Group; [email-masked];
[email-masked]; [email-masked]; Farrel Adrian
Subject: RE: [netmod] [Rtg-yang-coord] NETMOD interim meeting canceled
 
As Tom and others note, today's Netmod interim was to have topics beyond OSPF.
These included OpenDaylight related work.   The IETF should be encouraging
venues for Open Source developer audiences.  Cancelling full meetings via IETF
procedural mechanisms signals the opposite.  
 
I *like* the idea of each WG being the owner for their domain models.  This
scales well for the reasons  pointed out below.  And I do have sympathy for a WG
wanting to close on a definitive answer for a YANG model before implications are
discussed elsewhere.   But I am worried that we are enforcing an overly serial
process.  Or of constraining communication.  The market will work around this.  
 
In the controller space, YANG technology is not static.  Some degree of
parallelism is needed across IETF WGs.  Clueful Open Source/YANG developers
cannot extend themselves across all WG where YANG modeling might occur. 
 
Eric

From: Thomas D. Nadeau, October 22, 2014 10:52 AM
          We are trying. The thing is that you cannot just hoist that onto WGs
and say "here you go." if they don't want to do it.  Again, the Netmod charter
was specifically modified to accommodate that case.   And while some WGs in the
routing area are not enthusiastic about building models, others aren't, nor are
other WGs at the IETF. So for those, what do you do? Ignore them? The other
point is that others outside of the IETF are working on these models.  It is
squarely within the IETF community's interest to bring these back into the fold.
Many of these folks are skittish about coming to the IETF altogether so we've
tried to encourage them to participate in this way. If we want to push these
folks away with procedural reasons, then we have made our bed...
 
          -tom

 
Hi,

Andy

No one said that OSPF experts could not attend to provide input.   The issue is
that OSPF was not doing this. If they want to take over doing all OSPF models,
then great, but to date no one was.  The agreement in NETMOD (and our charter)
is to facilitate the creation of models when WGs don't want to do them, have the
expertise to do them, etc.  Also, getting the right Yang experts in one place is
not going to happen for every WG in the IETF; its just not realistic.  I
understand that ultimately the WG needs to have consensus, but quick iteration
to construct the model surely can happen in a small "design team" fashion,
right?
 
And in terms of today's meeting being canceled, really what purpose was that
other than to stall/slow-down work?  The group that was there to work on the
OSPF model was indeed a bunch of folks from OSPF (Acee Lindem for example was on
the call).  So now since we won't have another interim meeting until after
Hawaii, so the next time this group can get together is possibly in Hawaii, but
that is probably unlikely as a large number of people are not going to Hawaii.
So the net-net is a slowing of progress in this area.  Probably not the result
the IETF community wants.
 
-Tom

 
Hi Adrian,

Andy

Conclusion:

Adrian

has
going
and
open
IETF.
*build*
single
difficult to get
it
there

---

From: "Acee Lindem (acee)" <[email-masked]>
Date: Wed, 22 Oct 2014 16:19:03 +0000

To summarize, then it Is not a competing draft. As I stated previously, the OSPF YANG model which started last year in netmod WG will be presented at IETF 91 and we will work towards OSPF WG adoption.

Thanks,
Acee

From: Jeff Haas <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, October 22, 2014 at 10:43 AM
To: Robert Raszuk <[email-masked]<mailto:[email-masked]>>, "Thomas D. Nadeau" <[email-masked]<mailto:[email-masked]>>
Cc: "Benoit Claise (bclaise)" <[email-masked]<mailto:[email-masked]>>, Adrian Farrel <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Rtg-yang-coord] NETMOD interim meeting canceled

On Oct 22, 2014, at 10:18 AM, Robert Raszuk <[email-masked]<mailto:[email-masked]>> wrote:

Adrian,

The comment about taking your ball and going someplace else to play (meetup.com<http://meetup.com>) was not worthy of a chair, Tom.  While there's certainly precedent in other orgs of working faster, there's also similar precent of fork and fracture.

-- Jeff

---

From: "Eric Voit (evoit)" <[email-masked]>
Date: Wed, 22 Oct 2014 17:04:52 +0000

It is true I wish the meeting had run today to address other things.  Putting that aside I had a larger point.

OpenDaylight is seeing new YANG technologies which are being implemented for a set of new topics.  I have listed a few below to provide context.  Many of these topics have implications to multiple IETF Working Groups.  Awaiting charter changes before having discussions in or between WG slows these discussions.  Enforcing a process so that YANG modeling discussions must go through distributed WGs serially slows these discussions.   I am not offering a solution here.  I am just observing that the industry is moving faster than the IETF.

Some YANG OpenDaylight Topics which I would love to see the IETF take on:

(1) Multi-device YANG Abstractions
YANG syntax is used for multi-device abstractions in OpenDaylight MD-SAL.  This conflicts with RFC 6244 which defines a single-box boundaries.  Should the IETF consider architectures where YANG models span devices?  What about for multi-box protocols like VRRP?  What about Anycast interfaces into clusters of devices acting as one?  How about cloud abstraction into a Designated Router?

(2) Generic Pub/Sub Mechanisms
RFC 5277 on Netconf notifications doesn't include information on how to handle Pub/Sub so that one device is immediately informed about object changes in another.  I believe there is some demand for Pub/Sub which is tied to YANG and with no required linkage to a transport protocol.  There are also needs for Pub/Sub beyond YANG.  How should we approach this area?

(3) Maintaining Consistency in a Multi-Controller world
There will not be one controller for a network.  There will be many.  How do you determine precedence when conflicting config information is being sent from multiple sources?  How does this change the information encoded in the model?

In summary I would assert that handling solutions to the problems above independently across all WGs is not viable.

Eric

From: Adrian Farrel, October 22, 2014 11:31 AM

Eric,

I cannot speak to why the meeting was cancelled.
My disquiet was simply that an item on the agenda was out of scope and not properly announced to achieve the correct participation.

> the agenda for which the meeting was called, then it must be cancelled.

You appear to be saying that there was work to be done that was in scope for the WG and was part of the agenda that was published.

So I'm a bit puzzled.

Adrian

Cc: [email-masked]<mailto:[email-masked]>; NETMOD Working Group; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Farrel Adrian

Eric

          -tom

Hi,

Andy

-Tom

Hi Adrian,

Andy

Conclusion:

Adrian

has
going
and
open
IETF.
*build*
single
difficult to get
it
there

---

From: "Susan Hares" <[email-masked]>
Date: Wed, 22 Oct 2014 14:07:53 -0400

Adrian, Robert, and Thomas:  

These two drafts interact due to the netmod suggestion to I2RS that the configuration datastore and the I2rs ephemeral datastore can be part of the same data store.  I2rs has not agreed to combined datastore on the list or in a meeting.  The details of the interactions are being worked out.  However, to push this state I am preparing a comparison draft between: 

 <http://datatracker.ietf.org/doc/draft-yeung-netmod-ospf/> http://datatracker.ietf.org/doc/draft-yeung-netmod-ospf/

 <http://datatracker.ietf.org/doc/draft-wang-i2rs-ospf-dm/> http://datatracker.ietf.org/doc/draft-wang-i2rs-ospf-dm/

Acee encouraged me on the I2RS mailing list to keep 1 OSPF yang draft (draft-yeung-netmod-ospf) and suggest changes to support I2RS requirements.  To provide this comparison, I am writing a draft-hares-i2rs-ospf-yeung-adds-00 to suggest these changes based on the requirements listed in  <http://datatracker.ietf.org/doc/draft-hares-i2rs-usecase-reqs-summary/> draft-hares-i2rs-usecase-reqs-summary-00 for IGPs.  These changes should inform the thinking of the draft-yeung-netmod-ospf authors, but should not hold up progress on this draft. Please note that even though the I2RS chairs directed the creation of the draft-hares-i2rs-usecase-reqs-summary list of all potential I2rs requirements – this draft has been adopted as a WG draft.  

Finally, to give a technical moment to an otherwise banal bashing of Adrian’s support for Acee’s earlier declaration to hold this review in OSPF, I offer the “sound byte” level of comparison below (see draft-hares-i2rs-ospf-yeung-adds-00 for full details).  

Sue 

Comparison: 

draft-yeung-netmod-ospf-01 (2/14/2014)  - configuration, but lacked the definitions to support real-time status of ospf-mt, ospf-rib, ospf-neighbor, ospf-lsa-database, ospf-state, and ospf-status. 

draft-wang-i2rs-ospf-dm-00 (9/26/2014)  - not focused on configuration, but added definitions to support real-time status of ospf-mt, ospf-rib, ospf-neighbor, ospf-lsa-data, ospf-state, and ospf-status. 

draft-yeung-netmod-ospf-02 (10/14/2014) – added definitions for ospf-mt, ospf lsa database, ospf-TE, and ospf status and state information which was included in draft-i2rs-wang-ospf-dm-00 draft.  The draft-yeung-netmod-ospf-02 now has the form.  

·         The configuration with the muti-topology view (write/read) 

·         protocol state and ospf-lsa-database (read only) 

·         notification on events (read-only)

draft-hares-i2rs-ospf-yeung-adds—(upcoming) summarizes these differences and suggests changes to be made to the draft-yeung-netmod-ospf-02 in order to fulfill I2RS requirements (mostly in changes to state found in protocol, ospf-lsa-database, and events plus an addition of ospf-rib module), and some additions to configuration. 

From: Rtg-yang-coord [mailto:[email-masked]] On Behalf Of Adrian Farrel
Sent: Wednesday, October 22, 2014 10:13 AM
To: 'Robert Raszuk'
Cc: 'Benoit Claise'; 'Thomas D. Nadeau'; [email-masked]; [email-masked]
Subject: Re: [Rtg-yang-coord] NETMOD interim meeting canceled

Hi Robert,

Adrian

Hi Adrian,

Thx,

R.

Conclusion:

Adrian

has
going
and
open
IETF.
*build*
single
difficult to get
it
there

---

From: "Susan Hares" <[email-masked]>
Date: Wed, 22 Oct 2014 14:13:26 -0400

Robert: 

I2RS requirements have been setting ephemeral state that may change the OSPF protocol actions.  This augmenting function may interact with how configuration causes the protocol to interaction. 

I encourage you to post to Alia Atlas thread: [i2rs] Why do we need a datastore?

http://www.ietf.org/mail-archive/web/i2rs/current/threads.html#02078

or Joel Halpern’s thread [i2rs] Running and I2RS Ephemeral Config Interaction

http://www.ietf.org/mail-archive/web/i2rs/current/msg02034.html

Help I2RS determine exactly what the ephemeral datastore really means. 

Sue Hares 

From: Rtg-yang-coord [mailto:[email-masked]] On Behalf Of Robert Raszuk
Sent: Wednesday, October 22, 2014 10:19 AM
To: Adrian Farrel
Cc: Benoit Claise; Thomas D. Nadeau; [email-masked]; [email-masked]
Subject: Re: [Rtg-yang-coord] NETMOD interim meeting canceled

Adrian,

Best,

R.

Hi Robert,

Adrian

Hi Adrian,

Thx,

R.

Conclusion:

Adrian

has
going
and
open
IETF.
*build*
single
difficult to get
it
there

---

From: "Susan Hares" <[email-masked]>
Date: Wed, 22 Oct 2014 14:31:54 -0400

Tom: 

Acee indicated earlier on the i2rs list (September discussion) that the OSPF
yang model was going to be standardized in OSPF.  I'm glad we've got the
rtg-yang-coord list to sort out these issues. 

IDR will pick up all BGP related yang modules.  A charter addition has been
made.  IDR will gladly accept input from the netmod WG or hold joint interim
session to make this effort go fast.  The configuration drafts for bgp
(draft-zhdankin-netmod-bgp-cfg-00.txt) and the I2rs drafts for bgp
(draft-i2rs-hares-bgp-dm-00) have only a 5% functional overlap.  I will be
releasing a draft that compares these two drafts, and looks at how these
drafts fulfill the I2RS BGP use case requirements. 

IDR will sponsor a design team in IDR to push the rapid development of bgp
configuration or bgp i2rs.  If you could suggest a few netmod people to help
this effort it would help.  

My understanding of IETF best practices indicate that joint interims need 2
weeks announcement of topics. 

Sue 

From: Rtg-yang-coord [mailto:[email-masked]] On Behalf Of
Thomas D. Nadeau
Sent: Wednesday, October 22, 2014 10:35 AM
To: Andy Bierman
Cc: [email-masked]; NETMOD Working Group;
[email-masked]; [email-masked]; [email-masked];
Benoit Claise; Farrel Adrian
Subject: Re: [Rtg-yang-coord] [netmod] NETMOD interim meeting canceled

            No one said that OSPF experts could not attend to provide input.
The issue is that OSPF was not doing this. If they want to take over doing
all OSPF models, then great, but to date no one was.  The agreement in
NETMOD (and our charter) is to facilitate the creation of models when WGs
don't want to do them, have the expertise to do them, etc.  Also, getting
the right Yang experts in one place is not going to happen for every WG in
the IETF; its just not realistic.  I understand that ultimately the WG needs
to have consensus, but quick iteration to construct the model surely can
happen in a small "design team" fashion, right?

            And in terms of today's meeting being canceled, really what
purpose was that other than to stall/slow-down work?  The group that was
there to work on the OSPF model was indeed a bunch of folks from OSPF (Acee
Lindem for example was on the call).  So now since we won't have another
interim meeting until after Hawaii, so the next time this group can get
together is possibly in Hawaii, but that is probably unlikely as a large
number of people are not going to Hawaii.  So the net-net is a slowing of
progress in this area.  Probably not the result the IETF community wants.

            -Tom

On Oct 22, 2014:10:18 AM, at 10:18 AM, Andy Bierman <[email-masked]>
wrote:

Hi Adrian,

 

Andy

The rules for IETF virtual interims are neither hard to discover, nor hard
to
comply with. The rules exist to ensure that people are included in the work,
and
I am sure that inclusion is what you want.

I find it unfortunate that you scheduled a working group meeting to discuss
only
one of a pair of competing documents on the same topic, that you didn't make
the
information about the meeting available to the authors of the competing
document
or to the people who care about the protocol being modelled, and I find it
upsetting (yes, I am actually upset) that you decided to discuss in Netmod a
document that belongs in the OSPF working group.

If, as it surely sounds, you wish that the Netmod working group had a
different
charter to enable it to take on models for protocols that already have a
home in
other working groups, then I suggest you need to recharter. But I doubt that
your reasoning that [YANG] experts will not go to all the other working
groups
will carry much weight. Frankly, and without wanting to disrespect the YANG
experts, it is easier to understand YANG than it is to understand OSPF. If
this
were not the case then the Netmod working group would have failed in its
design
of YANG!

Conclusion:
You want to work on a YANG model for OSPF. Go to the OSPF working group and
discuss it (there are already some threads). Review and comment on the
competing
document. Try to get agreement between all of the authors of both documents,
or
try to identify the differences. Work with the chairs of the OSPF working
group
to advance the work.

Adrian

non-sense
has
going
and
> focused on Yang and the other on modeling; is not NETMOD-specific per say,
but
open
IETF.
*build*
single
difficult to get
think
it
which
there
list

---

From: "Susan Hares" <[email-masked]>
Date: Wed, 22 Oct 2014 14:41:23 -0400

Jeff:

Thanks for mentioning this fact.  All of the I2rs drafts for OSPF, ISIS, and
BGP did not want to be competing drafts - but only places for I2RS hooks to
go into.   The comparison show only 5-10% overlap in these hooks. I will
post the comparison to this list.   

People have suggested the I2rs RIB-info needs to be an ephemeral copy unique
to I2RS.   I'd love input on whether this groups things this is true. 

Sue 

From: Rtg-yang-coord [mailto:[email-masked]] On Behalf Of
Jeff Haas
Sent: Wednesday, October 22, 2014 10:44 AM
To: Robert Raszuk; Thomas D. Nadeau
Cc: Benoit Claise; Adrian Farrel; [email-masked];
[email-masked]
Subject: Re: [Rtg-yang-coord] NETMOD interim meeting canceled

Adrian,

On the other hand Yang model takes care about instatiation and management of
a given protocol. There can be some little overlap, but does not need to be
at all.

I2RS is not in the business of trying to do the modeling work of other WG's
protocols.  

I2RS is definitely in the business of seeing standardized models advance so
we can hook into them.

The comment about taking your ball and going someplace else to play
(meetup.com) was not worthy of a chair, Tom.  While there's certainly
precedent in other orgs of working faster, there's also similar precent of
fork and fracture.

-- Jeff

---

From: "Susan Hares" <[email-masked]>
Date: Wed, 22 Oct 2014 14:45:33 -0400

Robert: 

I think the IETF is ready for the rapid response time in interims. I think joint topics should get a 2 week’s notice if it involves other WGs topics.  That’s simple planning by the co-chairs who can put the topic on the agenda 2 weeks in advance.  

Sue 

From: Rtg-yang-coord [mailto:[email-masked]] On Behalf Of Robert Raszuk
Sent: Wednesday, October 22, 2014 10:51 AM
To: Jeff Haas
Cc: Benoit Claise; Thomas D. Nadeau; [email-masked]; [email-masked]; Adrian Farrel
Subject: Re: [Rtg-yang-coord] NETMOD interim meeting canceled

> play ( <http://meetup.com/> meetup.com) was not worthy of a chair, Tom.

Jeff,

I am not sure I am with you. My point was that whatever tools we have in place should be used. 

For me - I would highly appreciate if Derek alone would record a sessions and explain his draft. Then publish it on you tube. 

That's it. 

Maybe it should not be called interim meeting .. maybe IETF has no name for it, but just progressing work based on the 3 meetings a year + mailing lists seems not to be the most efficient choice these days. There are many ways to improve it. 

Cheers,
R.

 

 

 

Adrian,

-- Jeff

---

From: Alia Atlas <[email-masked]>
Date: Wed, 22 Oct 2014 14:47:20 -0400

Robert,

The IETF is absolutely ready for progressing work beyond 3 meetings a year
+ mailing lists.  For instance, NVO3 has had 3 virtual interims between
last IETF and now and plans to continue doing so after this IETF.

A meeting without the right and interested participants is not so useful.
That's why sending out the agenda a week ahead of time is important.

The sky isn't falling here.

Alia

On Wed, Oct 22, 2014 at 10:51 AM, Robert Raszuk <[email-masked]> wrote:

> Maybe it should not be called interim meeting .. maybe IETF has no name
> for it, but just progressing work based on the 3 meetings a year + mailing
>> Figuring out the most productive way to have that discussion has
>> obviously been a bit bumpy.  Hence, one of the reasons to have the
>> rtg-yang-coord list.
>>

---

From: "Susan Hares" <[email-masked]>
Date: Wed, 22 Oct 2014 14:50:52 -0400

Stephane: 

I think it is important to receive both the wisdom from the netmod WG and
the protocol WG.  I find that there are yang model consistencies and
limitations that require aid in the yang models I've worked on.  This is
especially true for the state and ephemeral state. 

Sue 

-----Original Message-----
From: Rtg-yang-coord [mailto:[email-masked]] On Behalf Of
[email-masked]
Sent: Wednesday, October 22, 2014 9:45 AM
To: Benoit Claise
Cc: [email-masked]; [email-masked]; NETMOD Working Group;
[email-masked]
Subject: Re: [Rtg-yang-coord] [netmod] NETMOD interim meeting canceled

Hi,

I also agree that this is a bad idea. I thought that IETF willing and
especially yours, Benoit, was to speed up availability of standard models.
The process of having small teams working with weekly calls works almost
good but we still have some issue that are both technical (dedicated to the
topic addressed by the model) and also YANG writing, model consistencies ...
that requires discussion, and as often mailing list is not as good as
meetings (that's why the proposal of small teams was done).

At the present time, I personally support the initiative of having interim
meetings in Netmod to discuss proposed Yang models : this will ensure
consistency between models and will help to solve global issues in modeling.
It's just the starting of Yang modeling, leaving only Yang models within
home WG (ISIS for my point of view) would be, IMO, a very bad idea and will
for sure slow down the availability of standards ... and I also think that
it may discourage people to work on because of the added overhead.

Best Regards,

Stephane

-----Original Message-----
From: netmod [mailto:[email-masked]] On Behalf Of Thomas D. Nadeau
Sent: Wednesday, October 22, 2014 15:29
To: Benoit Claise
Cc: [email-masked]; [email-masked]; NETMOD Working Group;
[email-masked]

	This is hugely disappointing. This is the kind of procedural
non-sense has and IS driving people away from the IETF to other places where
this work is going to get done. The simple effect of such silliness will be
a reduction in speed and quantity of model development.  If the goal of the
IESG is to slow down the velocity of model development and creation, then
this approach is perfect.

	--Tom

> 1. This interim appears to be meeting to discuss a non-WG draft for which
there is no milestone in the working group and for which there is an obvious
home outside the working group.

____________________________________________________________________________
_____________________________________________

Ce message et ses pieces jointes peuvent contenir des informations
confidentielles ou privilegiees et ne doivent donc pas etre diffuses,
exploites ou copies sans autorisation. Si vous avez recu ce message par
erreur, veuillez le signaler a l'expediteur et le detruire ainsi que les
pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou
falsifie. Merci.

This message and its attachments may contain confidential or privileged
information that may be protected by law; they should not be distributed,
used or copied without authorisation.
If you have received this email in error, please notify the sender and
delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been
modified, changed or falsified.
Thank you.

---

From: Robert Raszuk <[email-masked]>
Date: Wed, 22 Oct 2014 20:55:54 +0200

Alia & Sue,

Apparently my intentions were not received as intended.

I am not complaining on the way interim meetings are setup. It is good to
have an agenda and even better to have it week or two in advance. For
physical presence interims maybe even month or two.

My point is much broader. Having been involved in different SDOs and in
general open source community work I see that interims + 3 physical
meetings + mailing lists and txt formatted drafts is not enough any more.

A lot of good comments are received on a regular say weekly or bi-weekly
live discussions, watching recording presentations without waiting for next
physical meeting, building feature xyz from github, contributing to it,
testing etc ...

None of the latter happens in IETF. IETF seems like documents shepards in
ITU :) World has moved and I really do not think IETF is catching up with
those new trends in new projects handling.

Moreover with most of IETF vendors not really (with some exceptions)
involved in any serious open source products I see that current way IETF
operates is unlikely to change any time soon.

Cheers,
R.

On Wed, Oct 22, 2014 at 8:47 PM, Alia Atlas <[email-masked]> wrote:

>>> On the other hand Yang model takes care about instatiation and
>>> management of a given protocol. There can be some little overlap, but does
>>> not need to be at all.
>>>
>>>

---

From: "Susan Hares" <[email-masked]>
Date: Wed, 22 Oct 2014 14:56:09 -0400

Eric: 

What were the OpenDaylight topics for the call?  

Sue 

Eric Voit (evoit)
Sent: Wednesday, October 22, 2014 11:20 AM
Farrel Adrian

As Tom and others note, today's Netmod interim was to have topics beyond
OSPF.  These included OpenDaylight related work.   The IETF should be
encouraging venues for Open Source developer audiences.  Cancelling full
meetings via IETF procedural mechanisms signals the opposite.  

I *like* the idea of each WG being the owner for their domain models.  This
scales well for the reasons  pointed out below.  And I do have sympathy for
a WG wanting to close on a definitive answer for a YANG model before
implications are discussed elsewhere.   But I am worried that we are
enforcing an overly serial process.  Or of constraining communication.  The
market will work around this.  

Eric

          We are trying. The thing is that you cannot just hoist that onto
WGs and say "here you go." if they don't want to do it.  Again, the Netmod
charter was specifically modified to accommodate that case.   And while some
WGs in the routing area are not enthusiastic about building models, others
aren't, nor are other WGs at the IETF. So for those, what do you do? Ignore
them? The other point is that others outside of the IETF are working on
these models.  It is squarely within the IETF community's interest to bring
these back into the fold.  Many of these folks are skittish about coming to
the IETF altogether so we've tried to encourage them to participate in this
way. If we want to push these folks away with procedural reasons, then we
have made our bed...

          -tom

On Oct 22, 2014:10:45 AM, at 10:45 AM, Andy Bierman <[email-masked]>
wrote:

Hi,

infrastructure modules.

Andy

No one said that OSPF experts could not attend to provide input.   The issue
is that OSPF was not doing this. If they want to take over doing all OSPF
models, then great, but to date no one was.  The agreement in NETMOD (and
our charter) is to facilitate the creation of models when WGs don't want to
do them, have the expertise to do them, etc.  Also, getting the right Yang
experts in one place is not going to happen for every WG in the IETF; its
just not realistic.  I understand that ultimately the WG needs to have
consensus, but quick iteration to construct the model surely can happen in a
small "design team" fashion, right?

And in terms of today's meeting being canceled, really what purpose was that
other than to stall/slow-down work?  The group that was there to work on the
OSPF model was indeed a bunch of folks from OSPF (Acee Lindem for example
was on the call).  So now since we won't have another interim meeting until
after Hawaii, so the next time this group can get together is possibly in
Hawaii, but that is probably unlikely as a large number of people are not
going to Hawaii.  So the net-net is a slowing of progress in this area.
Probably not the result the IETF community wants.

-Tom

Hi Adrian,

 

Andy

Conclusion:

Adrian

non-sense
has
going
and
but
open
IETF.
*build*
single
difficult to get
think
it
which
there
list

---

From: "Eric Voit (evoit)" <[email-masked]>
Date: Wed, 22 Oct 2014 19:13:10 +0000

Two weeks ago at the Netmod Interim, we discussed:
  http://datatracker.ietf.org/doc/draft-voit-netmod-peer-mount-requirements/
  http://datatracker.ietf.org/doc/draft-clemm-netmod-mount/
We used these slides<http://www.voit.org/Peer-Mount-Netconf-WG-Oct2014.pdf> to introduce the topics.

On the Netmod interim agenda today was to be a recap/summary of the resulting mailing list discussions, as well the teeing up of exactly what could be on the plate for Hawaii Netmod face-to-face.

Thanks,
Eric

From: Susan Hares, October 22, 2014 2:56 PM

Eric:

Sue

From: Rtg-yang-coord [mailto:[email-masked]] On Behalf Of Eric Voit (evoit)

Eric

          -tom

Hi,

Andy

-Tom

Hi Adrian,

Andy

Conclusion:

Adrian

has
going
and
open
IETF.
*build*
single
difficult to get
it
there

---

From: "Susan Hares" <[email-masked]>
Date: Wed, 22 Oct 2014 15:22:48 -0400

Robert: 

I think IETF is in the process of changing.  I think this morning’s problem was just a clear indication of the agenda’s scope, and advance cross-group warning.  The weekly interims are awesome.  IETF’s changing  - so perhaps in an offline memo you can suggest ways you can help I2rs and IDR yang work go quicker. 

I looked into the OpenDaylight work as prototyping place, but OpenDaylight has an Eclipse license.  Does this create an IETF IPR problem?  I rather like the OpenDaylight BGP module. 

Sue 

PS – I hope to get my I2rs yang modules in github before IETF 91.   

From: Rtg-yang-coord [mailto:[email-masked]] On Behalf Of Robert Raszuk
Sent: Wednesday, October 22, 2014 2:56 PM
To: Alia Atlas
Cc: [email-masked]; Thomas D. Nadeau; Jeff Haas; Ospf Chairs; Benoit Claise; Adrian Farrel
Subject: Re: [Rtg-yang-coord] NETMOD interim meeting canceled

Alia & Sue,

I am not complaining on the way interim meetings are setup. It is good to have an agenda and even better to have it week or two in advance. For physical presence interims maybe even month or two. 

My point is much broader. Having been involved in different SDOs and in general open source community work I see that interims + 3 physical meetings + mailing lists and txt formatted drafts is not enough any more. 

A lot of good comments are received on a regular say weekly or bi-weekly live discussions, watching recording presentations without waiting for next physical meeting, building feature xyz from github, contributing to it, testing etc ... 

None of the latter happens in IETF. IETF seems like documents shepards in ITU :) World has moved and I really do not think IETF is catching up with those new trends in new projects handling. 

Moreover with most of IETF vendors not really (with some exceptions) involved in any serious open source products I see that current way IETF operates is unlikely to change any time soon.

Cheers,

R.

 

 

Robert,

The IETF is absolutely ready for progressing work beyond 3 meetings a year + mailing lists.  For instance, NVO3 has had 3 virtual interims between last IETF and now and plans to continue doing so after this IETF.

A meeting without the right and interested participants is not so useful.  That's why sending out the agenda a week ahead of time is important.

Alia

Jeff,

That's it. 

Cheers,
R.

 

 

 

Adrian,

-- Jeff

---

From: "Susan Hares" <[email-masked]>
Date: Wed, 22 Oct 2014 15:24:55 -0400

Very helpful slides.  Will this be reschedule to November 5th? 

Sue 

From: Eric Voit (evoit) [mailto:[email-masked]] 
Sent: Wednesday, October 22, 2014 3:13 PM
To: Susan Hares; 'Thomas D. Nadeau'; 'Andy Bierman'
Cc: [email-masked]; 'NETMOD Working Group';
[email-masked]; [email-masked]; [email-masked];
'Farrel Adrian'
Subject: RE: [Rtg-yang-coord] [netmod] NETMOD interim meeting canceled

We used these slides <http://www.voit.org/Peer-Mount-Netconf-WG-Oct2014.pdf>
to introduce the topics.   

On the Netmod interim agenda today was to be a recap/summary of the
resulting mailing list discussions, as well the teeing up of exactly what
could be on the plate for Hawaii Netmod face-to-face.

Thanks,

Eric

Eric: 

Sue 

Eric

          -tom

Hi,

infrastructure modules.

Andy

-Tom

Hi Adrian,

 

Andy

Conclusion:

Adrian

non-sense
has
going
and
but
open
IETF.
*build*
single
difficult to get
think
it
which
there
list

---

From: Benoit Claise <[email-masked]>
Date: Wed, 22 Oct 2014 14:08:56 -0700

Dear all,
>
> Tom:
>
> Acee indicated earlier on the i2rs list (September discussion) that 
> the OSPF yang model was going to be standardized in OSPF.  I'm glad 
> we've got the rtg-yang-coord list to sort out these issues.
>
> IDR will pick up all BGP related yang modules.  A charter addition has 
> been made.  IDR will gladly accept input from the netmod WG or hold 
> joint interim session to make this effort go fast.
>
Exactly. The YANG modules should be standardized in the respective WGs.
To have good YANG modules, you need:
1. the technology experts, i.e. the respective WG
2. YANG review

I don't understand all this fuss about: "oh, but you can't speak about 
an OSPF module in a NETMOD WG".
We want to do what's right by providing YANG review of the documents, 
nothing else.

I don't understand all this fuss about: "oh, but if you speak about one 
OSPF YANG model, then you must include all the other ones".
People who want feedback on their YANG modules are welcome to join. This 
was the goal.

Regards, Benoit

> The configuration drafts for bgp 
> (draft-i2rs-hares-bgp-dm-00) have only a 5% functional overlap.  I 
> will be releasing a draft that compares these two drafts, and looks at 
> how these drafts fulfill the I2RS BGP use case requirements.
>
> IDR will sponsor a design team in IDR to push the rapid development of 
> bgp configuration or bgp i2rs.  If you could suggest a few netmod 
> people to help this effort it would help.
>
> My understanding of IETF best practices indicate that joint interims 
> need 2 weeks announcement of topics.
>
> Sue
>
> *From:*Rtg-yang-coord [mailto:[email-masked]] *On 
> Behalf Of *Thomas D. Nadeau
> *Sent:* Wednesday, October 22, 2014 10:35 AM
> *To:* Andy Bierman
> *Cc:* [email-masked]; NETMOD Working Group; 
> [email-masked]; [email-masked]; 
> [email-masked]; Benoit Claise; Farrel Adrian
> *Subject:* Re: [Rtg-yang-coord] [netmod] NETMOD interim meeting canceled
>
> issue is that OSPF was not doing this. If they want to take over doing 
> NETMOD (and our charter) is to facilitate the creation of models when 
> WGs don't want to do them, have the expertise to do them, etc... 
>  Also, getting the right Yang experts in one place is not going to 
> happen for every WG in the IETF; its just not realistic.  I understand 
> that ultimately the WG needs to have consensus, but quick iteration to 
> construct the model surely can happen in a small "design team" 
> fashion, right?
>
> And in terms of today's meeting being canceled, really what purpose 
> was that other than to stall/slow-down work?  The group that was there 
> to work on the OSPF model was indeed a bunch of folks from OSPF (Acee 
> Lindem for example was on the call).  So now since we won't have 
> another interim meeting until after Hawaii, so the next time this 
> group can get together is possibly in Hawaii, but that is probably 
> unlikely as a large number of people are not going to Hawaii.  So the 
> net-net is a slowing of progress in this area.  Probably not the 
> result the IETF community wants.
>
> ---Tom
>
>     On Oct 22, 2014:10:18 AM, at 10:18 AM, Andy Bierman
>     <[email-masked] <mailto:[email-masked]>> wrote:
>
>     Hi Adrian,
>
>     On Wed, Oct 22, 2014 at 6:48 AM, Adrian Farrel
>     <[email-masked] <mailto:[email-masked]>> wrote:
>
>     > Cc: NETMOD Working Group; [email-masked]
>     <mailto:[email-masked]>; [email-masked]
>     <mailto:[email-masked]>;
>     > > On Oct 22, 2014:9:16 AM, at 9:16 AM, Benoit Claise
>     <[email-masked] <mailto:[email-masked]>>
>     wrote:
>     > >
>     > > Dear all,
>     > >

---

From: Benoit Claise <[email-masked]>
Date: Wed, 22 Oct 2014 14:12:36 -0700

Adrian,
> My disquiet was simply that an item on the agenda was out of scope and 
> not properly announced to achieve the correct participation.
>
> You appear to be saying that there was work to be done that was in 
> scope for the WG and was part of the agenda that was published.
>
> So I'm a bit puzzled.
>
You raised the "violation of IETF" process flag + the issue that we 
should not be discussing non NETMOD documents in NETMOD, and now, you're 
puzzled... Really?

Regards, Benoit

> Adrian
>
> *From:*Eric Voit (evoit) [mailto:[email-masked]]
> *Sent:* 22 October 2014 16:20
> *To:* Thomas D. Nadeau; Andy Bierman
> [email-masked]; Farrel Adrian
> *Subject:* RE: [netmod] [Rtg-yang-coord] NETMOD interim meeting canceled
>
> As Tom and others note, today's Netmod interim was to have topics 
> beyond OSPF.  These included OpenDaylight related work.   The IETF 
> should be encouraging venues for Open Source developer audiences. 
> Cancelling full meetings via IETF procedural mechanisms signals the 
> opposite.
>
> I *like* the idea of each WG being the owner for their domain models.  
> This scales well for the reasons  pointed out below.  And I do have 
> sympathy for a WG wanting to close on a definitive answer for a YANG 
> model before implications are discussed elsewhere.   But I am worried 
> that we are enforcing an overly serial process. Or of constraining 
> communication.  The market will work around this.
>
> In the controller space, YANG technology is not static.  Some degree 
> of parallelism is needed across IETF WGs.  Clueful Open Source/YANG 
> developers cannot extend themselves across all WG where YANG modeling 
> might occur.
>
> Eric
>
> *From:*Thomas D. Nadeau, October 22, 2014 10:52 AM
>
> and say "here you go." if they don't want to do it.  Again, the Netmod 
> charter was specifically modified to accommodate that case.   And 
> while some WGs in the routing area are not enthusiastic about building 
> models, others aren't, nor are other WGs at the IETF. So for those, 
> what do you do? Ignore them? The other point is that others outside of 
> the IETF are working on these models.  It is squarely within the IETF 
> community's interest to bring these back into the fold.  Many of these 
> folks are skittish about coming to the IETF altogether so we've tried 
> to encourage them to participate in this way. If we want to push these 
> ---tom
>     On Oct 22, 2014:10:45 AM, at 10:45 AM, Andy Bierman
>     On Wed, Oct 22, 2014 at 7:35 AM, Thomas D. Nadeau
>     <[email-masked] <mailto:[email-masked]>> wrote:
>
>     The issue is that OSPF was not doing this. If they want to take
>     over doing all OSPF models, then great, but to date no one was. 
>     The agreement in NETMOD (and our charter) is to facilitate the
>     creation of models when WGs don't want to do them, have the
>     expertise to do them, etc...  Also, getting the right Yang experts
>     in one place is not going to happen for every WG in the IETF; its
>     just not realistic. I understand that ultimately the WG needs to
>     have consensus, but quick iteration to construct the model surely
>     can happen in a small "design team" fashion, right?
>
>     purpose was that other than to stall/slow-down work?  The group
>     that was there to work on the OSPF model was indeed a bunch of
>     folks from OSPF (Acee Lindem for example was on the call).  So now
>     since we won't have another interim meeting until after Hawaii, so
>     the next time this group can get together is possibly in Hawaii,
>     but that is probably unlikely as a large number of people are not
>     going to Hawaii.  So the net-net is a slowing of progress in this
>     area. Probably not the result the IETF community wants.
>
>     ---Tom
>
>         > > 2. The agenda was not announced a week in advance on the
>         IETF announce list
>         > as is required
>         > >
>         > > Regards, Benoit
>         > >

---

From: Thomas Nadeau <[email-masked]>
Date: Wed, 22 Oct 2014 17:32:38 -0400

+1

> On Oct 22, 2014, at 5:08 PM, Benoit Claise <[email-masked]> wrote:
> 
> Dear all,
>> Tom:
>>  
>> Acee indicated earlier on the i2rs list (September discussion) that the OSPF yang model was going to be standardized in OSPF.  I’m glad we’ve got the rtg-yang-coord list to sort out these issues.
>>  
>> IDR will pick up all BGP related yang modules.  A charter addition has been made.  IDR will gladly accept input from the netmod WG or hold joint interim session to make this effort go fast. 
> I don't understand all this fuss about: "oh, but you can't speak about an OSPF module in a NETMOD WG".
> We want to do what's right by providing YANG review of the documents, nothing else.
> 
> I don't understand all this fuss about: "oh, but if you speak about one OSPF YANG model, then you must include all the other ones".
> People who want feedback on their YANG modules are welcome to join. This was the goal.
> 
> Regards, Benoit
> 
>> The configuration drafts for bgp (draft-zhdankin-netmod-bgp-cfg-00.txt) and the I2rs drafts for bgp (draft-i2rs-hares-bgp-dm-00) have only a 5% functional overlap.  I will be releasing a draft that compares these two drafts, and looks at how these drafts fulfill the I2RS BGP use case requirements.
>>  
>> IDR will sponsor a design team in IDR to push the rapid development of bgp configuration or bgp i2rs.  If you could suggest a few netmod people to help this effort it would help.  
>>  
>> My understanding of IETF best practices indicate that joint interims need 2 weeks announcement of topics. 
>>  
>> Sue
>>  
>> From: Rtg-yang-coord [mailto:[email-masked]] On Behalf Of Thomas D. Nadeau
>> Cc: [email-masked]; NETMOD Working Group; [email-masked]; [email-masked]; [email-masked]; Benoit Claise; Farrel Adrian

---

From: "Derek Man-Kit Yeung (myeung)" <[email-masked]>
Date: Wed, 22 Oct 2014 21:41:12 +0000

Hi Sue,

Looking forwards to the comparison doc. That should help to make the OSPF model more comprehensive.

Thanks,
- Derek

From: Susan Hares <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, October 22, 2014 11:07 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, 'Robert Raszuk' <[email-masked]<mailto:[email-masked]>>
Cc: "Benoit Claise (bclaise)" <[email-masked]<mailto:[email-masked]>>, "'Thomas D. Nadeau'" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Rtg-yang-coord] NETMOD interim meeting canceled

http://datatracker.ietf.org/doc/draft-yeung-netmod-ospf/
http://datatracker.ietf.org/doc/draft-wang-i2rs-ospf-dm/

Acee encouraged me on the I2RS mailing list to keep 1 OSPF yang draft (draft-yeung-netmod-ospf) and suggest changes to support I2RS requirements.  To provide this comparison, I am writing a draft-hares-i2rs-ospf-yeung-adds-00 to suggest these changes based on the requirements listed in draft-hares-i2rs-usecase-reqs-summary-00<http://datatracker.ietf.org/doc/draft-hares-i2rs-usecase-reqs-summary/> for IGPs.  These changes should inform the thinking of the draft-yeung-netmod-ospf authors, but should not hold up progress on this draft. Please note that even though the I2RS chairs directed the creation of the draft-hares-i2rs-usecase-reqs-summary list of all potential I2rs requirements – this draft has been adopted as a WG draft.

Sue

Comparison:

From: Rtg-yang-coord [mailto:[email-masked]] On Behalf Of Adrian Farrel
Sent: Wednesday, October 22, 2014 10:13 AM
To: 'Robert Raszuk'
Cc: 'Benoit Claise'; 'Thomas D. Nadeau'; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Subject: Re: [Rtg-yang-coord] NETMOD interim meeting canceled

Hi Robert,

Adrian

Hi Adrian,

Thx,
R.

Conclusion:

Adrian

has
going
and
open
IETF.
*build*
single
difficult to get
it
there

---

From: <[email-masked]>
Date: Thu, 23 Oct 2014 07:44:03 +0000

Susan,

I completely agree that bits and bytes in the model should be discussed in the protocol WG but for modeling, limitations, and all stuffs related to Yang, it's still good to discuss it in Netmod.

Best Regards,

Stephane

-----Original Message-----
From: Susan Hares [mailto:[email-masked]] 
Sent: Wednesday, October 22, 2014 20:51
To: LITKOWSKI Stephane SCE/IBNF; 'Benoit Claise'
Cc: [email-masked]; [email-masked]; 'NETMOD Working Group'; [email-masked]
Subject: RE: [Rtg-yang-coord] [netmod] NETMOD interim meeting canceled

Stephane: 

I think it is important to receive both the wisdom from the netmod WG and the protocol WG.  I find that there are yang model consistencies and limitations that require aid in the yang models I've worked on.  This is especially true for the state and ephemeral state. 

Sue 

-----Original Message-----
From: Rtg-yang-coord [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Wednesday, October 22, 2014 9:45 AM
To: Benoit Claise
Cc: [email-masked]; [email-masked]; NETMOD Working Group; [email-masked]
Subject: Re: [Rtg-yang-coord] [netmod] NETMOD interim meeting canceled

Hi,

I also agree that this is a bad idea. I thought that IETF willing and especially yours, Benoit, was to speed up availability of standard models.
The process of having small teams working with weekly calls works almost good but we still have some issue that are both technical (dedicated to the topic addressed by the model) and also YANG writing, model consistencies ...
that requires discussion, and as often mailing list is not as good as meetings (that's why the proposal of small teams was done).

At the present time, I personally support the initiative of having interim meetings in Netmod to discuss proposed Yang models : this will ensure consistency between models and will help to solve global issues in modeling.
It's just the starting of Yang modeling, leaving only Yang models within home WG (ISIS for my point of view) would be, IMO, a very bad idea and will for sure slow down the availability of standards ... and I also think that it may discourage people to work on because of the added overhead.

Best Regards,

Stephane

-----Original Message-----
From: netmod [mailto:[email-masked]] On Behalf Of Thomas D. Nadeau
Sent: Wednesday, October 22, 2014 15:29
To: Benoit Claise
Cc: [email-masked]; [email-masked]; NETMOD Working Group; [email-masked]
Subject: Re: [netmod] [Rtg-yang-coord] NETMOD interim meeting canceled

	--Tom

> 1. This interim appears to be meeting to discuss a non-WG draft for 
there is no milestone in the working group and for which there is an obvious home outside the working group.

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration, Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law; they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Ladislav Lhotka <[email-masked]>
Date: Thu, 23 Oct 2014 10:32:30 +0200

> I completely agree that bits and bytes in the model should be discussed in the protocol WG but for modeling, limitations, and all stuffs related to Yang, it's still good to discuss it in Netmod.

Actually, there is also the group of “YANG Doctors”, and it might be more appropriate to discuss the YANG parts with them and not in the NETMOD group. At any rate, I think we should clarify (and document) the workflow for the development of YANG modules whose primary home is outside the NETMOD working group. This email thread proves it is needed.

Lada

--
Ladislav Lhotka, CZ.NIC Labs
PGP Key ID: E74E8C0C

---

From: <[email-masked]>
Date: Thu, 23 Oct 2014 09:20:08 +0000

> At any rate, I think we should clarify (and document) the workflow for the development of YANG modules

Right, currently, as modeling is just starting, there is a lack of guidelines that's why more babysitting is needed at this time. But it's hard to define guidelines now, without gathering experiences from Yang writing people.

-----Original Message-----
From: Ladislav Lhotka [mailto:[email-masked]] 
Sent: Thursday, October 23, 2014 10:33
To: LITKOWSKI Stephane SCE/IBNF
Cc: Susan Hares; Benoit Claise; [email-masked]; [email-masked]; NETMOD Working Group; [email-masked]
Subject: Re: [Rtg-yang-coord] [netmod] NETMOD interim meeting canceled

> I completely agree that bits and bytes in the model should be discussed in the protocol WG but for modeling, limitations, and all stuffs related to Yang, it's still good to discuss it in Netmod.

Actually, there is also the group of "YANG Doctors", and it might be more appropriate to discuss the YANG parts with them and not in the NETMOD group. At any rate, I think we should clarify (and document) the workflow for the development of YANG modules whose primary home is outside the NETMOD working group. This email thread proves it is needed.

Lada

>> <[email-masked]>
>> announce list as is required
>> 
>> Regards, Benoit
>> 
> ______________________________________________________________________
> ______ _____________________________________________
> 
> ______________________________________________________________________
> ___________________________________________________
> 
> exploites ou copies sans autorisation. Si vous avez recu ce message 
> par erreur, veuillez le signaler a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration, Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.
> 
> This message and its attachments may contain confidential or 
> privileged information that may be protected by law; they should not be distributed, used or copied without authorisation.

---

From: Andy Bierman <[email-masked]>
Date: Thu, 23 Oct 2014 08:21:47 -0700

On Wed, Oct 22, 2014 at 2:08 PM, Benoit Claise <[email-masked]> wrote:

>  Dear all,
>
>  Tom:
>
>
>
> Acee indicated earlier on the i2rs list (September discussion) that the
> OSPF yang model was going to be standardized in OSPF.  I'm glad we've got
> the rtg-yang-coord list to sort out these issues.
>
>
>
> been made.  IDR will gladly accept input from the netmod WG or hold joint
> interim session to make this effort go fast.
>

There is a difference between discussing a YANG module wrt/ its usage of
YANG
language constructs, and discussing a module wrt/ the proper set of knobs
for
a particular protocol (or feature).

My objections are to the latter discussion.
We saw with the ietf-routing module that wide review
from routing experts happened rather late in the process.
IMO if that module was done in a routing WG instead of netmod,
the process would have been faster.

Andy

>  The configuration drafts for bgp (draft-zhdankin-netmod-bgp-cfg-00.txt)
> and the I2rs drafts for bgp (draft-i2rs-hares-bgp-dm-00) have only a 5%
> functional overlap.  I will be releasing a draft that compares these two
> drafts, and looks at how these drafts fulfill the I2RS BGP use case
> requirements.
>
>
>
> configuration or bgp i2rs.  If you could suggest a few netmod people to
> help this effort it would help.
>
>
>
> *From:* Rtg-yang-coord [mailto:[email-masked]
> <[email-masked]>] *On Behalf Of *Thomas D. Nadeau
>             No one said that OSPF experts could not attend to provide
> input.   The issue is that OSPF was not doing this. If they want to take
> over doing all OSPF models, then great, but to date no one was.  The
> agreement in NETMOD (and our charter) is to facilitate the creation of
> models when WGs don't want to do them, have the expertise to do them, etc...
>  Also, getting the right Yang experts in one place is not going to happen
> for every WG in the IETF; its just not realistic.  I understand that
> ultimately the WG needs to have consensus, but quick iteration to construct
> the model surely can happen in a small "design team" fashion, right?
>
>
>

---

From: Kiran Agrahara Sreenivasa <[email-masked]>
Date: Wed, 22 Oct 2014 15:34:00 -0600

+1 -OSPF + ISIS + TE YANG model authors were waiting for this opportunity to discuss the open issues and present an update.

Many of those even logged in to the meeting before I had to begrudgingly announce cancelation :(

From: netmod [mailto:[email-masked]] On Behalf Of Benoit Claise
Sent: Wednesday, October 22, 2014 4:09 PM
To: Susan Hares; 'Thomas D. Nadeau'; 'Andy Bierman'
Cc: [email-masked]; 'NETMOD Working Group'; [email-masked]; [email-masked]; [email-masked]; 'Farrel Adrian'
Subject: Re: [netmod] [Rtg-yang-coord] NETMOD interim meeting canceled

Dear all,
Tom:

Acee indicated earlier on the i2rs list (September discussion) that the OSPF yang model was going to be standardized in OSPF.  I'm glad we've got the rtg-yang-coord list to sort out these issues.

Regards, Benoit

Sue

From: Rtg-yang-coord [mailto:[email-masked]] On Behalf Of Thomas D. Nadeau
Sent: Wednesday, October 22, 2014 10:35 AM
To: Andy Bierman
Cc: [email-masked]<mailto:[email-masked]>; NETMOD Working Group; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Benoit Claise; Farrel Adrian
Subject: Re: [Rtg-yang-coord] [netmod] NETMOD interim meeting canceled

            -Tom

Hi Adrian,

Andy

Conclusion:

Adrian

has
going
and
open
IETF.
*build*
single
difficult to get
it
there