Subject: [Rtg-yang-coord] Yang model for LDP/mLDP

From: "Kamran Raza (skraza)" <[email-masked]>
Date: Wed, 26 Nov 2014 04:25:08 +0000

Hi,

We would like to bring into your kind notice that a multi-vendor team has started working on the design of the Yang model for LDP/mLDP.  Currently, the team comprise following members:

  Robin Li - [email-masked]<mailto:[email-masked]> (Huawei)
  Jescia Chen - [email-masked]<mailto:[email-masked]> (Huawei)
  Kamran Raza  - [email-masked]<mailto:[email-masked]> (Cisco)
  Reshad Rahman - [email-masked]<mailto:[email-masked]> (Cisco)
  Santosh Esale - [email-masked]<mailto:[email-masked]> (Juniper)
  Vishnu Pavan Beeram - [email-masked]<mailto:[email-masked]> (Juniper)
  Himanshu Shah - [email-masked]<mailto:[email-masked]> (Ciena)

The team had our first formal meeting today and we have scheduled calls to meet weekly to make progress on LDP yang model in upcoming weeks. We will keep MPLS WG and rtg-yang-coord alias posted with regards to our progress, as well as, solicit input as/when required.
[ P.S.:  If you wish to contribute to the design of LDP/mLDP yang model, please let me know accordingly by sending an email and I will add you to the team / meeting invite]

FYI, following is the summary of the main points discussed/agreed in our first meeting:

1- The scope of our work (and document) includes:
- LDP, mLDP, and Multi-topology (LDP/mLDP)
        - Config, Operational State, Notifications, and RPCs

2- We have broken the effort into following phases:
       ph1- Overall config model/hierarchy (keeping LDP/mLDP/MT in mind)
       ph2- LDP: cfg, notifs, rpcs
       ph3- mLDP: cfg, notifs, rpcs
       ph4- LDP: state
       ph5- mLDP: state
       ph6- Multi-topology (everything)

3- The plan is to have the ph1-3 completed before next IETF and the draft posted with the update.

4- In the meantime (and in parallel), we will continue to attend MPLS level Yang meetings (to be arranged by Tarek)
    to define MPLS common base, and leverage LDP yang accordingly.

5- The next meeting/call for LDP Yang will be on Tue Dec 2nd with the following agenda:
     - Complete discussions on ph1.
     - Deep dive into ph2 (define overall LDP cfg tree, followed by expansion of each container)

Rgds,
—
Kamran
(on behalf of LDP Yang team)

---

From: Jeff Tantsura <[email-masked]>
Date: Wed, 26 Nov 2014 06:39:18 +0000

Hi Kamran,

Please add Xufeng Liu [email-masked] and myself from E/// side.
Thanks!

Cheers,
Jeff

From: "Kamran Raza (skraza)" <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, November 25, 2014 at 8:25 PM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "Reshad Rahman (rrahman)" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "Benoit Claise (bclaise)" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [mpls] Yang model for LDP/mLDP

Hi,

Rgds,
—
Kamran