Subject: [Rtg-yang-coord] Generic LSP Yang

From: Dhruv Dhody <[email-masked]>
Date: Thu, 5 Mar 2015 22:18:30 +0530

Hi,

Xian and I have created generic base yang model for LSPs. This model
is expected to be augmented by seperate data model with specific
signalling protocol and technology.

See https://tools.ietf.org/html/draft-zhang-mpls-lspdb-yang-00

Comments / Suggestions ?

We need to work out the relationship with the rest of MPLS yang model
which can be hashed out in Dallas.

Regards,
Dhruv / Xian

Excuse the obvious nit with the LSP abbreviation expansion :P

---

From: Lou Berger <[email-masked]>
Date: Thu, 05 Mar 2015 12:18:24 -0500

Hi Dhruv,
    Good stuff!  There's already some related work going on based on the
TE LSP drafts/work started in MPLS and now in the TEAS WG.  -- This was
mentioned at the TEAS interim too, see
http://www.ietf.org/proceedings/interim/2014/12/18/teas/minutes/minutes-interim-2014-teas-1

It looks like you don't completely overlap as you are also considering
non-TE LSPs. 

So I guess a basic question to answer is what is the relationship of the
models of TE and non-TE LSPs. e.g,
- a generic LSP model with parallel TE and non-TE sub models
- a generic LSP model with protocol specific models
- a generic LSP model with some mix of the above (which I think you are
proposing)
- no generic LSP model, and separate  TE and non-TE sub models
- etc

It's not clear to me how much value a generic model brings, but details
always help to clarify the situation.  

My preference would be to have more details on the non-TE models (to
compare against the TE model) before deciding on the need for / value of
a generic LSP model.

Lou

On 3/5/2015 11:48 AM, Dhruv Dhody wrote:
> _______________________________________________
> mpls mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/mpls
>

---

From: Lou Berger <[email-masked]>
Date: Thu, 05 Mar 2015 12:27:38 -0500

I should have made clear that my previous mail and stated preference was
as an individual. 

As TEAS co-chair: if you need a place to discuss the generic model in
Dallas, we're happy to have you in TEAS, and will complement our planned
TE model related discussion.  Clearly non-te LSP model specifics should
be discussed in their respective WGs. 

Lou

---

From: "Susan Hares" <[email-masked]>
Date: Fri, 6 Mar 2015 07:06:30 -0500

Dhruv, Xian and Lou:

Thank you for working on the genric LSP work.  After the TEAS WG, could the
I2RS WG get a summary of your discussion.  

Sue Hares

-----Original Message-----
From: Teas [mailto:[email-masked]] On Behalf Of Dhruv Dhody
Sent: Friday, March 06, 2015 7:00 AM
To: 'Lou Berger'; Dhruv Dhody; [email-masked]
Cc: [email-masked]; Zhangxian (Xian); TEAS WG
Subject: Re: [Teas] [mpls] Generic LSP Yang

Hi Lou,

> -----Original Message-----
> From: Teas [mailto:[email-masked]] On Behalf Of Lou Berger
> Sent: 05 March 2015 22:48
> To: Dhruv Dhody; [email-masked]
> Cc: [email-masked]; Zhangxian (Xian); TEAS WG
> Subject: Re: [Teas] [mpls] Generic LSP Yang
> 
> Hi Dhruv,
>     Good stuff!  There's already some related work going on based on 
> the TE LSP drafts/work started in MPLS and now in the TEAS WG.  -- 
> This was mentioned at the TEAS interim too, see
> http://www.ietf.org/proceedings/interim/2014/12/18/teas/minutes/minute
> s-
> interim-2014-teas-1
> 

[Dhruv]: Yes, our aim is to go one level up and see if we can have a generic
LSP yang model including TE and non-TE, as well any signaling protocol or
lack thereof (static, SR).  

> 
> So I guess a basic question to answer is what is the relationship of 
> the models of TE and non-TE LSPs. e.g,

[Dhruv]: Our aim is to explore and see if we have attributes common to all
LSP irrespective of TE/non-TE; signaling protocol, Segment Routing and even
PCEP to warrant such a generic LSP model. 

A possible overall relationship with the model is in the draft - 
                 +---------------+
                 | Generic LSPDB |
                 |   ietf-lspdb  |
                 +-------^-------+
                         |
         ---------------------------------------------
        |                |                |           |
        |                |                |           |
   +----+----+   +-------+-------+   +----+----+   +--+--+
   | LDP-LSP |   |    BGP-LSP    |   |  TE-LSP |   | SR  |
   |         |   |               |   |         |   |     |
   +---------+   +---------------+   +----^----+   +--^--+
                                          |           |
                                           -----------
                                          |           |
                                          |           |
                                     +----+----+   +--+--+
                                     | RSVP-TE |   | SR- |
                                     |         |   | TE  |
                                     +----^----+   +--^--+
                                          |           |
                                          |           |
                                           -----------
                                          |
                                     +----+----+
                                     |  PCEP   |
                                     |         |
                                     +---------+

> 
> It's not clear to me how much value a generic model brings, but 
> details always help to clarify the situation.
> 
> compare against the TE model) before deciding on the need for / value 
> of a generic LSP model.

[Dhruv]: Yes, I think that would surely help. 
IMHO the ease of augmentation and having a generic base model is one of the
key advantages of YANG, so we hope its a worthwhile exercise to explore the
need for such a generic model instead of separate TE and non-TE models. 

Regards,
Dhruv

> > We need to work out the relationship with the rest of MPLS yang 
> > model which can be hashed out in Dallas.
> >
> > Regards,
> > Dhruv / Xian
> >
> Teas mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/teas

_______________________________________________
Teas mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/teas

---

From: Lou Berger <[email-masked]>
Date: Fri, 06 Mar 2015 09:05:09 -0500

Dhruv,

On 03/06/2015 07:00 AM, Dhruv Dhody wrote:
>>     Good stuff!  There's already some related work going on based on the TE
>> LSP drafts/work started in MPLS and now in the TEAS WG.  -- This was
>> It looks like you don't completely overlap as you are also considering non-TE
>> LSPs.
> 
> [Dhruv]: Yes, our aim is to go one level up and see if we can have a
> generic LSP yang model including TE and non-TE, as well any signaling
> protocol or lack thereof (static, SR).
> 

Understood.  BTW non-signaled TE is still part of TE architecture and
the yang model work underway in TEAS. (TP, and to some degree PCE really
made this point clear.)

> [Dhruv]: Our aim is to explore and see if we have attributes common
> to all LSP irrespective of TE/non-TE; signaling protocol, Segment
> Routing and even PCEP to warrant such a generic LSP model.
> 

Sure. PCE driven TE LSPs are in scope of the generic TE YANG models
being developed.   PCEP protocol specifics belong to PCE.

>> My preference would be to have more details on the non-TE models (to compare
>> against the TE model) before deciding on the need for / value of a generic
>> LSP model.
> 

Glad to hear we're in agreement.

> IMHO the ease of augmentation and having a generic base model is one
> of the key advantages of YANG, so we hope its a worthwhile exercise
> to explore the need for such a generic model instead of separate TE
> and non-TE models.
> 
The details of each will certainly demonstrate the degree of overlap.

Thanks,
Lou

---

From: Robert Raszuk <[email-masked]>
Date: Sat, 7 Mar 2015 12:47:44 +0100

I would agree with Igor.

Other then name overlap those are completely different technologies and
artificially putting them under "LSP" umbrella just does not bring any
value, but only confuses things even more.

Q: What SPRING-LSP has anything in common with "label" when you use v6
header ?

If you want to search for some commonalities let's remove LDP-LSPs from
this mix (as the is not relevant) and leave TE-LSP & SPRING + maybe also
add BIER as well as change the name to Generic-EP (Engineered Paths).

I see no value of goruping based on the fact that data plane uses mpls
labels, but rather I would see reasonable to provide models based on the
transport path characteristics for the traffic it is to carry.

Best,
r.

On Fri, Mar 6, 2015 at 2:11 PM, Igor Bryskin <[email-masked]>
wrote:

> Druv,
>
> IMHO TE-LSP, LDP-LSP and SPRING-LSP have nothing in common. They should
> have totally independent models each being developed in respective WG.
>
> Igor
>

---

From: Dhruv Dhody <[email-masked]>
Date: Fri, 6 Mar 2015 12:00:29 +0000

Hi Lou,

> It looks like you don't completely overlap as you are also considering non-TE

[Dhruv]: Yes, our aim is to go one level up and see if we can have a generic LSP yang model including TE and non-TE, as well any signaling protocol or lack thereof (static, SR).  

> - no generic LSP model, and separate  TE and non-TE sub models

[Dhruv]: Our aim is to explore and see if we have attributes common to all LSP irrespective of TE/non-TE; signaling protocol, Segment Routing and even PCEP to warrant such a generic LSP model. 

[Dhruv]: Yes, I think that would surely help. 
IMHO the ease of augmentation and having a generic base model is one of the key advantages of YANG, so we hope its a worthwhile exercise to explore the need for such a generic model instead of separate TE and non-TE models. 

Regards,
Dhruv

---

From: Igor Bryskin <[email-masked]>
Date: Fri, 6 Mar 2015 13:11:28 +0000

Druv,

IMHO TE-LSP, LDP-LSP and SPRING-LSP have nothing in common. They should have totally independent models each being developed in respective WG.

Igor

-----Original Message-----
From: mpls [mailto:[email-masked]] On Behalf Of Dhruv Dhody
Sent: Friday, March 06, 2015 7:00 AM
To: 'Lou Berger'; Dhruv Dhody; [email-masked]
Cc: [email-masked]; Zhangxian (Xian); TEAS WG
Subject: Re: [mpls] [Teas] Generic LSP Yang

Hi Lou,

Regards,
Dhruv