Subject: [Rtg-yang-coord] IETF draft -> YANG module extraction -> compilation

From: Benoit Claise <[email-masked]>
Date: Thu, 26 Mar 2015 15:37:03 +0100

Dear all,

Part of the IETF 92 hackathon, Jan Medved and I developed a tool for 
YANG modules extraction and compilation.
The outcome is right now on my private web site at 
http://www.claise.be/IETFYANGPageCompilation.html, but you should really 
bookmark 
http://www.ietf.org/iesg/directorate/yang-model-coordination-group.html 
and follow the WIKI link.

Please make sure your YANG modules compile. Btw, don't forget the pyang 
--ietf option.
Some numbers:

  * Number of YANG models in IETF drafts that passed compilation: 28/113
  * Number of all YANG models in IETF drafts (good, bad, example, badly
    formatted, etc. ): 189

There is room for improvement.
Some of the draft authors have been notified about specific mistakes in 
their module

Next steps:
     - include this tool part of the idnits
     - cron job to create this page
     - post the code (currently polishing it)
     - produce a similar page for opendaylight

Regards, Benoit

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Thu, 26 Mar 2015 10:46:27 -0400

When are you going to make the code available?  There are additions that some have talked about making.

	--Tom

> On Mar 26, 2015:10:37 AM, at 10:37 AM, Benoit Claise <[email-masked]> wrote:
> 
> Dear all,
> 
> Part of the IETF 92 hackathon, Jan Medved and I developed a tool for YANG modules extraction and compilation. 
> The outcome is right now on my private web site at http://www.claise.be/IETFYANGPageCompilation.html <http://www.claise.be/IETFYANGPageCompilation.html>, but you should really bookmark  http://www.ietf.org/iesg/directorate/yang-model-coordination-group.html <http://www.ietf.org/iesg/directorate/yang-model-coordination-group.html> and follow the WIKI link.
> 
> Please make sure your YANG modules compile. Btw, don't forget the pyang --ietf option.
> Some numbers:
> Number of YANG models in IETF drafts that passed compilation: 28/113
> Number of all YANG models in IETF drafts (good, bad, example, badly formatted, etc. ): 189
> Some of the draft authors have been notified about specific mistakes in their module
> 
> Next steps: 
> _______________________________________________
> Rtg-yang-coord mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtg-yang-coord

---

From: Benoit Claise <[email-masked]>
Date: Thu, 26 Mar 2015 15:56:14 +0100

Tom,

>
> When are you going to make the code available?
Somewhere next week.

Regards, Benoit
> There are additions that some have talked about making.
>
> --Tom
>
>> On Mar 26, 2015:10:37 AM, at 10:37 AM, Benoit Claise 
>> <[email-masked] <mailto:[email-masked]>> wrote:
>>
>> Dear all,
>>
>> http://www.claise.be/IETFYANGPageCompilation.html, but you should 
>> really bookmark 
>>   * Number of all YANG models in IETF drafts (good, bad, example,
>>     badly formatted, etc. ): 189
>>
>> [email-masked] <mailto:[email-masked]>

---

From: "Jan Medved (jmedved)" <[email-masked]>
Date: Thu, 26 Mar 2015 15:05:00 +0000

What are the additions that would be required?

/Jan

From: "Benoit Claise (bclaise)" <[email-masked]<mailto:[email-masked]>>
Date: Thursday, March 26, 2015 at 7:56 AM
To: "Thomas D. Nadeau" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Jan Medved <[email-masked]<mailto:[email-masked]>>
Subject: Re: [Rtg-yang-coord] IETF draft -> YANG module extraction -> compilation

Tom,

Regards, Benoit

--Tom

On Mar 26, 2015:10:37 AM, at 10:37 AM, Benoit Claise <[email-masked]<mailto:[email-masked]>> wrote:

Dear all,

Part of the IETF 92 hackathon, Jan Medved and I developed a tool for YANG modules extraction and compilation.
The outcome is right now on my private web site at http://www.claise.be/IETFYANGPageCompilation.html, but you should really bookmark  http://www.ietf.org/iesg/directorate/yang-model-coordination-group.html and follow the WIKI link.

  *   Number of YANG models in IETF drafts that passed compilation: 28/113
  *   Number of all YANG models in IETF drafts (good, bad, example, badly formatted, etc. ): 189

Next steps:

Regards, Benoit
_______________________________________________
Rtg-yang-coord mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/rtg-yang-coord

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Thu, 26 Mar 2015 11:16:24 -0400

There were a number of things some discussed at the yangathon, so I will let those people post here.  

> On Mar 26, 2015:11:05 AM, at 11:05 AM, Jan Medved (jmedved) <[email-masked]> wrote:
> 
> From: "Benoit Claise (bclaise)" <[email-masked] <mailto:[email-masked]>>
> To: "Thomas D. Nadeau" <[email-masked] <mailto:[email-masked]>>
> Cc: "[email-masked] <mailto:[email-masked]>" <[email-masked] <mailto:[email-masked]>>, Jan Medved <[email-masked] <mailto:[email-masked]>>
>>>> On Mar 26, 2015:10:37 AM, at 10:37 AM, Benoit Claise <[email-masked] <mailto:[email-masked]>> wrote:
>>>> 
>>>> Dear all,
>>>> 
>>>> https://www.ietf.org/mailman/listinfo/rtg-yang-coord <https://www.ietf.org/mailman/listinfo/rtg-yang-coord>
>>> 
>>

---

From: "Carl Moberg (camoberg)" <[email-masked]>
Date: Thu, 26 Mar 2015 15:27:30 +0000

Team,

 I would humbly suggest we put it up as is on the github and let people
use that environment to suggest (and even provide) additional features and
fixes.

 And we should ask the tools team (Henrik L) to link from tools.ietf.org
when that's ready.

-- 
Carl Moberg
Technology Director
[email-masked]

On 3/26/15, 8:16 AM, "Thomas D. Nadeau" <[email-masked]> wrote:

>From: "Benoit Claise (bclaise)" <[email-masked]>
>To: "Thomas D. Nadeau" <[email-masked]>
>Cc: "[email-masked]" <[email-masked]>, Jan Medved
><[email-masked]>
>>http://www.claise.be/IETFYANGPageCompilation.html
>><http://www.claise.be/IETFYANGPageCompilation.html>, but you should
>>really bookmark 
>>
>><http://www.ietf.org/iesg/directorate/yang-model-coordination-group.html>

---

From: Benoit Claise <[email-masked]>
Date: Thu, 26 Mar 2015 10:28:43 -0500

Carl,

This is obviously the goal.

Regards, Benoit

---

From: Benoit Claise <[email-masked]>
Date: Thu, 26 Mar 2015 10:59:32 -0500

On 26/03/2015 09:37, Benoit Claise wrote:
> http://www.ietf.org/iesg/directorate/yang-model-coordination-group.html and 
> follow the WIKI link.
>
Improved code + just run with the latest set of drafts

  * Number of YANG models in IETF drafts that passed compilation: 28/118
  * Number of all YANG models in IETF drafts (good, bad, example, badly
    formatted, etc. ): 212

Regards, Benoit

---

From: Anees Shaikh <[email-masked]>
Date: Thu, 26 Mar 2015 11:02:10 -0500

Benoit, Jan, thanks for putting this together -- should be useful to
improve submitted YANG modules.

Regarding room for improvement, before making this part of idnits, etc.
I'd suggest (i) we don't want to fail modules that don't use an IETF
namespace until the corresponding draft becomes a WG draft, gets renamed,
etc., and (ii) need a way to follow dependencies on modules in other
namespaces.

Per Carl's suggestion, I will try to copy these into issues in the github
when the code is posted.

thanks again.
-- Anees

On Thu, Mar 26, 2015 at 10:59 AM, Benoit Claise <[email-masked]> wrote:

>    - Number of YANG models in IETF drafts that passed compilation: 28/113
>    - Number of all YANG models in IETF drafts (good, bad, example, badly
>    formatted, etc. ): 189
>
>    - Number of YANG models in IETF drafts that passed compilation: 28/118
>    - Number of all YANG models in IETF drafts (good, bad, example, badly
>    formatted, etc. ): 212
>
> Regards, Benoit
>
>
>
> Rtg-yang-coord mailing [email-masked]://www.ietf.org/mailman/listinfo/rtg-yang-coord
>
>
>

---

From: Benoit Claise <[email-masked]>
Date: Thu, 26 Mar 2015 15:00:52 -0500

Hi Anees,
> Regarding room for improvement, before making this part of idnits, 
> etc.  I'd suggest (i) we don't want to fail modules that don't use an 
> IETF namespace until the corresponding draft becomes a WG draft, gets 
> renamed, etc., and
wrt to "fail modules", there are two types of failures: pyang and idnits
pyang: should report this as a failure
idnits: I don't believe that a pyang error should prevent someone from 
posting a draft.

Expressed differently, I don't feel like evaluating every single pyang 
error, and arbitrarily selecting which ones should allow/prevent posting.

> (ii) need a way to follow dependencies on modules in other namespaces.
Right. As far as I know, there are not even tools to follow dependencies 
within the same namespace. Would be happy to stand corrected...

>
> Per Carl's suggestion, I will try to copy these into issues in the 
> github when the code is posted.
Great. thanks

Benoit
>
> thanks again.
> -- Anees
>
> On Thu, Mar 26, 2015 at 10:59 AM, Benoit Claise <[email-masked] 
> <mailto:[email-masked]>> wrote:
>
>>     Part of the IETF 92 hackathon, Jan Medved and I developed a tool
>>     for YANG modules extraction and compilation.
>         badly formatted, etc. ): 212
>
>     Regards, Benoit
>

---

From: Benoit Claise <[email-masked]>
Date: Thu, 26 Mar 2015 15:56:59 -0500

Dear all,

The extraction function has been posted at 
https://github.com/YangModels/yang/tree/master/tools/xym
The page generation function will need some clean up and hence some time.

Regards, Benoit

---

From: "Reshad Rahman (rrahman)" <[email-masked]>
Date: Thu, 26 Mar 2015 22:19:41 +0000

Someone misspelled <CODE BEGINS> :-)

If set to 'True' <CDE BEGINS> / <CODE ENDS> are "

From: "Benoit Claise (bclaise)" <[email-masked]<mailto:[email-masked]>>
Date: Thursday, March 26, 2015 at 4:56 PM
To: "Thomas D. Nadeau" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "Jan Medved (jmedved)" <[email-masked]<mailto:[email-masked]>>
Subject: [Rtg-yang-coord] Code posted (was: IETF draft -> YANG module extraction -> compilation )

Dear all,

The extraction function has been posted at https://github.com/YangModels/yang/tree/master/tools/xym
The page generation function will need some clean up and hence some time.

Regards, Benoit
Tom,

Regards, Benoit

--Tom

Dear all,

Next steps:

Regards, Benoit

_______________________________________________
Rtg-yang-coord mailing list
[email-masked]<mailto:[email-masked]>https://www.ietf.org/mailman/listinfo/rtg-yang-coord