Subject: Re: [Rtg-yang-coord] [netmod] Requirements for I2RS protocol and I2RS interim (6/24/2015 at 10:00 - 11:30am ET)

From: "BELOTTI, SERGIO (SERGIO)" <[email-masked]>
Date: Wed, 1 Jul 2015 09:27:35 +0000

Hello Susan,
-          Topology model which is a composite of:
o   Generic topology model: draft-ietf-i2rs-yang-network-topo-01<https://datatracker.ietf.org/doc/draft-ietf-i2rs-yang-network-topo/>
o   L3 topology model: draft-ietf-i2rs-yang-l3-topology-00<https://datatracker.ietf.org/doc/draft-ietf-i2rs-yang-l3-topology/>
o   L2 topology model: draft-ietf-i2rs-yang-l2-network-topology-00<https://datatracker.ietf.org/doc/draft-ietf-i2rs-yang-l2-network-topology/>
o   L1 Topology model: draft-zhang-i2rs-l1-topo-yang-model-01 (-02 released later this week).
o   Service topology model: draft-hares-i2rs-service-topo-yang-model-00 (released on Wednesday)

At this time, none of the Topology models utilize Traffic engineering.  It is anticipated that these models will support traffic engineering.

Reading this , my question is whether there is intention for Traffic Engineering part of topology model to exploit/coordinate with Teas , and particularly with
 draft-liu-teas-yang-te-topo or to proceed with distinct contributions internal to I2RS.

Thanks
Sergio

---

From: Lou Berger <[email-masked]>
Date: Wed, 01 Jul 2015 11:38:36 -0400

> At this time, none of the Topology models utilize Traffic
engineering.  It is anticipated that these models will support traffic
engineering.

Sue, Jeff,
    Given some recent messages on the list, I thought it best to confirm
we're all still on the same page. 

Based on our past discussions, it's my understanding that the work being
done in TEAS (see draft-ietf-teas-yang-te-topo) will serve as the
foundation for TE support in the I2RS models.  I complete agree that
there are details on how the different topology models will
integrate/mesh still needs to be worked out, and I assumed that this is
what you/Sue were referring to above. -- But we will not have two sets
of TE topology models.

I believe that the authors of the respective drafts are already are
working this.  (Pavan, my co-chair as well as coauthor of the TEAS yang
model, can comment on this.)

Please let me know if I missed/miss-understood something.

Thanks,
Lou
(as TEAS WG co-chair)
On 6/23/2015 2:19 PM, Susan Hares wrote:
>
> Netconf Working Group:
>
>  
>
> The I2RS WG would like to pass you a set of requirements for the I2RS
> protocol, and asks that you provide an analysis by IETF 93 on whether
> NETCONF or RESTCONF can meet these requirements.   We expect that
> these requirements may require changes to the either NETCONF or
> RESTCONF. 
>
>  
>
> The I2RS architecture document (draft-ietf-i2rs-architecture-09
> <https://datatracker.ietf.org/doc/draft-ietf-i2rs-architecture/>)
> provides a high-level overview of the I2RS  protocol.  The I2RS has
> compiled the following documents to provide the additional details on
> the requirements for the protocols.
>
>  
>
> 1)      draft-ietf-i2rs-ephemeral-state-00
> <https://datatracker.ietf.org/doc/draft-ietf-i2rs-ephemeral-state/> 
>
> 2)      draft-ietf-i2rs-pub-sub-requirements-02
> <https://datatracker.ietf.org/doc/draft-ietf-i2rs-pub-sub-requirements/> 
>
> 3)      draft-ietf-i2rs-traceability-03
> <https://datatracker.ietf.org/doc/draft-ietf-i2rs-traceability/> 
>
>  
>
> The draft-ietf-i2rs-ephemeral-state-00 contains the results of the
> discussion from the 6/10 interim and the top 10 requirements for
> I2RS.  In addition, the draft-ietf-i2rs-ephemeral-state-00 contains an
> set of detailed requirements on how the I2RS WG sees the I2RS protocol
> operating.  These detailed requirements are to be seen as suggestions
> on what type of solution the I2RS WG would like to see, but I2RS WG is
> asking the NETCONF WG to provide its best designed protocol.  Please
> note as part of these detailed requirement the
> draft-ietf-i2rs-ephemeral-states-00 contains the idea of using
> metadata to record secondary identity.   
>
>  
>
> The I2RS protocol is driven by data-models.  The approved data models
> for protocol independent services are:
>
> -          draft-ietf-i2rs-rib-data-model-00
> <https://datatracker.ietf.org/doc/draft-ietf-i2rs-rib-data-model/>
>
> -          Filter-Based RIBS:  draft-kini-i2rs-fb-rib-data-model.00
> (released later this week)
>
> o   Generic topology model: draft-ietf-i2rs-yang-network-topo-01
> <https://datatracker.ietf.org/doc/draft-ietf-i2rs-yang-network-topo/> 
>
> o   L3 topology model: draft-ietf-i2rs-yang-l3-topology-00
> <https://datatracker.ietf.org/doc/draft-ietf-i2rs-yang-l3-topology/> 
>
> o   L2 topology model: draft-ietf-i2rs-yang-l2-network-topology-00
> <https://datatracker.ietf.org/doc/draft-ietf-i2rs-yang-l2-network-topology/> 
>
> o   Service topology model:
> draft-hares-i2rs-service-topo-yang-model-00 (released on Wednesday)
>
>  
>
> At this time, none of the Topology models utilize Traffic
> engineering.  It is anticipated that these models will support traffic
> engineering.  Estimated rates of transfer and timing requirements for
> these modules are at: http://trac.tools.ietf.org/wg/i2rs/trac/wiki -
> under the protocol requirements table.
>
>  
>
> We hope that NETCONF WG can provide some initial feedback on these
> requirements by IETF 93 at the Tuesday I2RS session.   I2RS will use
> the 6/24 interim at 10:00-11:30am ET  to provide a time for any
> participate in the I2RS, netconf, or netmod group to ask additional
> questions on these requirements.
>
>  
>
> Sue Hares
>
>  
>
> Interim time: 10:00-11:30am ET
>
> Date 6/24/2015
>
> Webex:
>
> https://ietf.webex.com/ietf/j.php?MTID=m4260bee7be61cb17b0008a3c52069d0f
>
>  
>
> agenda:
>
>  
>
> 10:00 – 10:05 – Bash Agenda
>
> 10:05 – 10:20- -  review of requirements from
>
> draft-ietf-i2rs-ephemeral-state-00
>
> draft-ietf-i2rs-pub-sub-requirements-02
>
> draft-ietf-i2rs-traceability-03
>
> Timing requirements
>
>  
>
> 10:20 – 10:30    Review of requirements for mutual authentication,
>
> and transaction in  draft-hares-auth-trans-01 requirements
>
>  
>
> 10:30- 11:30     Open discussion for I2RS Requirements
>
>  
>
> Proceedings and slides can be found at:
>
> http://www.ietf.org/proceedings/interim/2015/06/24/i2rs/proceedings.html
>
>  
>
> Sue Hares
>
>  
>
>  
>
>
>
> _______________________________________________
> Rtg-yang-coord mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtg-yang-coord

---

From: Jeffrey Haas <[email-masked]>
Date: Wed, 1 Jul 2015 15:36:14 -0400

Lou,

> what you/Sue were referring to above. -- But we will not have two sets

I'll admit to not having recently read the teas model.  I'll try to correct
that soon.

That said, we have some interesting headaches to work through for i2rs
purposes:
- We need a base model to work from.  Which group provides the base is
  unimportant.
- Some level of the abstract TE interactions that have i2rs impacts will
  potentially impose some impact on the models.
- The biggest question is interactions with regard to ephemeral state.

As you might have noticed, we're having quite the issue trying to shake out
ephemeral state issues with netmod/netconf.  Until we know what the answer
is going to be in yang and the protocols, there's a large unknown as to
whether we'll need our own "base model" or not.  

But just like with everything else in yang, we want to make sure that when
there are reusable components, lets do it one place.  As I said during
today's i2rs interim, we do have to be careful about doing premature refactoring -
doubly so as we don't know what the impacts of ephemeral stuff will be on
i2rs.

(Benoit will hopefully take the above observation as a note that even
modeling work is starting to get impacted now and not just language/protocol.)

The best I can recommend at this time is lets make sure everyone is paying
attention to both drafts, identifying common components and be aware that we
may need to reconcile the models via refactoring when the time comes.  Plus
it gets more eyeballs on both models.

> model, can comment on this.)

I'm going to largely say, "Don't Panic".  We all want to do the right thing
IETF-wise.

-- Jeff

---

From: Lou Berger <[email-masked]>
Date: Wed, 01 Jul 2015 15:54:39 -0400

Jeff,
    Thank you for the response.  All sounds right.  I have a couple of
additional points included below that I suspect we agree on.

On 7/1/2015 3:36 PM, Jeffrey Haas wrote:
...
> it gets more eyeballs on both models.
Agreed.  Perhaps we can get a time for the authors of the I2RS and TEAS
drafts to sit together in Prague to try to work through some of the
details - or at least ensure they are on the same technical page? I
talked to Pavan and he's willing to setup this up/coordinate.

> I'm going to largely say, "Don't Panic".  We all want to do the right thing

I think we should ensure that we don't produce two models for the same
thing -- this is a "motherhood" statement, so I'd be surprised if
there's any disagreement on this point.

Thanks,
Lou

---

From: "Susan Hares" <[email-masked]>
Date: Wed, 1 Jul 2015 18:49:09 -0400

Lou and Jeffrey:

On 7/22, I talked with the TEAS TE authors team.  They had concerns about
how the I2RS was going to integrate the TEAS work.  I realized there are two
different approaches to the models - and I expressed my  hope that we could
have aligned/merged models.  I chatted with the I2RS topology draft authors,
and I found that the authors had not yet begun to work on the TE models.
The best plan is to try to get the TEAS authors and the I2RS Topology
authors together at IETF 93 and get a plan together for migrating these
teams together.  

I will send a few times out to teams this evening.   It would really help
I2RS if the TEAS group would meet early in the week (or if the folks are at
the hack-athon like I am we may meet Saturday night).  We could then try to
give NETCONF our best insight on the TE additions. 

 In order to prepare for this TE/Non-TE merge, I2RS WG need to finalize the
non-TE models in the topology.  Today's interim was target to firm up the
Service and T1 topology models, but the T1 topology model will not be ready
until IETF 93.  My message in June hoped that we would be to the TE models
by IETF so that NETCONF would have our entire scope, but we will not be
there by the beginning of IETF.   I2RS will be following up in August and
September with Interims that focus on the TE models in I2RS Topology model. 

Do you have any other suggestions? 

Sue 

-----Original Message-----
From: i2rs [mailto:[email-masked]] On Behalf Of Lou Berger
Sent: Wednesday, July 01, 2015 11:39 AM
To: Susan Hares; 'Jeffrey Haas'
Cc: [email-masked]; [email-masked]; 'BRUNGARD, DEBORAH A'; Vishnu
Pavan Beeram; 'Alvaro Retana (aretana)'; 'Alia Atlas'
Subject: Re: [i2rs] [Rtg-yang-coord] Requirements for I2RS protocol and I2RS
interim (6/24/2015 at 10:00 - 11:30am ET)

Sue, Jeff,

Based on our past discussions, it's my understanding that the work being
done in TEAS (see draft-ietf-teas-yang-te-topo) will serve as the foundation
for TE support in the I2RS models.  I complete agree that there are details
on how the different topology models will integrate/mesh still needs to be
worked out, and I assumed that this is what you/Sue were referring to above.
-- But we will not have two sets of TE topology models.

I believe that the authors of the respective drafts are already are working
this.  (Pavan, my co-chair as well as coauthor of the TEAS yang model, can
comment on this.)

Thanks,
Lou
(as TEAS WG co-chair)
On 6/23/2015 2:19 PM, Susan Hares wrote:
> discussion from the 6/10 interim and the top 10 requirements for I2RS.  
> In addition, the draft-ietf-i2rs-ephemeral-state-00 contains an set of 
> detailed requirements on how the I2RS WG sees the I2RS protocol 
> At this time, none of the Topology models utilize Traffic engineering.  
> It is anticipated that these models will support traffic engineering.  
> Estimated rates of transfer and timing requirements for these modules 
> are at: http://trac.tools.ietf.org/wg/i2rs/trac/wiki - under the 
> protocol requirements table.
>
>  
>
> 10:00 - 10:05 - Bash Agenda
>
> 10:05 - 10:20- -  review of requirements from
>
> 10:20 - 10:30    Review of requirements for mutual authentication,
>

_______________________________________________
i2rs mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/i2rs

---

From: Lou Berger <[email-masked]>
Date: Thu, 02 Jul 2015 13:09:42 -0400

Sue,

On 7/1/2015 6:49 PM, Susan Hares wrote:
> ... In order to prepare for this TE/Non-TE merge, ...

It sounds like the authors are working through this. So all that is
needed seems to be happening.  We should probably announce the time and
place where the authors will be meeting in Prague so that others who are
interested can show.  (I'm assuming Pavan will coordinate the space
request with the authors and secretariat.) -- Certianly an brief update
in each WG seems appropriate.  Not sure this more than someone saying
something at the mic.

> I2RS will be following up in August and

This should work, as long as the interims include the active
participants.  We're having so many interims nowadays that it seems
folks are having trouble balancing day jobs (or sleep if you end up on
the wrong end of the time zone mismatch) with meetings...

Thanks,
Lou

---

From: Mahesh Jethanandani <[email-masked]>
Date: Thu, 2 Jul 2015 14:06:00 -0700

> On Jun 30, 2015, at 3:13 PM, Eric Voit (evoit) <[email-masked]> wrote:
> 
> What might be interesting for a NETCONF speaking slot is an analysis of what requirements from “draft-ietf-i2rs-pub-sub-requirements” are met by “draft-clemm-netconf-yang-push”. 

Susan or somebody from i2rs WG can decide whether the suggested presentation would help clarify i2rs requirements to NETCONF. From a personal perspective it would certainly help to have examples of how the requirements could be met.

Cheers.

Mahesh Jethanandani
[email-masked]

---

From: "Susan Hares" <[email-masked]>
Date: Thu, 2 Jul 2015 17:06:41 -0400

Mahesh: 

I think this would really help show how the requirements can be met. Let’s plan on Eric doing an analysis of what requirements are met by “draft-clemm-netconf-yang-push”. 

Sue 

From: i2rs [mailto:[email-masked]] On Behalf Of Mahesh Jethanandani
Sent: Thursday, July 02, 2015 5:06 PM
To: Eric Voit (evoit)
Cc: [email-masked]; [email-masked]; NETMOD Working Group; BRUNGARD, DEBORAH A; Alexander Clemm (alex); Netconf; Susan Hares
Subject: Re: [i2rs] [Rtg-yang-coord] [netmod] Requirements for I2RS protocol and I2RS interim (6/24/2015 at 10:00 - 11:30am ET)

Cheers.

Mahesh Jethanandani

[email-masked]

---

From: "Susan Hares" <[email-masked]>
Date: Fri, 3 Jul 2015 15:39:23 -0400

Sergio: 

Just in case you missed in the rest of the email threads: 

Yes – I2RS plans to coordinate the topology model with the TEAS Topology model.  The work began with the authors last week, and will continue in a discussion of the TEAS And Topology authors next week (7/8)  in a conference call, and at IETF on Sunday (7/19 from 6-7pm). 

The I2RS WG will provide an update on the merging of these two models.  If you are a TEAS author, please let me know.   If you wish to help on an I2RS Topology model, the I2RS working group would appreciate your review of any model. 

I am personally working on the service layer model. 

Sue Hares 

From: BELOTTI, SERGIO (SERGIO) [mailto:[email-masked]] 
Sent: Wednesday, July 01, 2015 5:28 AM
To: Susan Hares; 'Mahesh Jethanandani'
Cc: [email-masked]; [email-masked]; 'NETMOD Working Group'; 'Netconf'; 'BRUNGARD, DEBORAH A'
Subject: RE: [Rtg-yang-coord] [netmod] Requirements for I2RS protocol and I2RS interim (6/24/2015 at 10:00 - 11:30am ET)

Hello Susan,

o   Generic topology model:  <https://datatracker.ietf.org/doc/draft-ietf-i2rs-yang-network-topo/> draft-ietf-i2rs-yang-network-topo-01 

o   L3 topology model:  <https://datatracker.ietf.org/doc/draft-ietf-i2rs-yang-l3-topology/> draft-ietf-i2rs-yang-l3-topology-00 

o   L2 topology model:  <https://datatracker.ietf.org/doc/draft-ietf-i2rs-yang-l2-network-topology/> draft-ietf-i2rs-yang-l2-network-topology-00 

Thanks

Sergio

---

From: Vishnu Pavan Beeram <[email-masked]>
Date: Wed, 1 Jul 2015 20:41:51 -0400

+ Alex
+ <te-topo-model> authors

Sue, Jeff,

The authors of the <te-topo-model> draft had a meeting today with one of
the authors (Alex) of the <network-topo-model> draft and discussed ways to
align the topo models. The consensus so far is that the <te-topo-model>
WILL augment the <network-topo-model>. There are some issues that need to
be worked out (mapping identifiers, termination-points), but those should
get resolved in due course of time.

I'll sync up with you (Sue) and coordinate a meeting between the authors of
the <te-topo-model> and the authors of the I2RS topo model(s) at the IETF
--- hopefully early in the week.

Regards,
-Pavan

On Wed, Jul 1, 2015 at 6:49 PM, Susan Hares <[email-masked]> wrote:

> foundation

---

From: "Alexander Clemm (alex)" <[email-masked]>
Date: Thu, 2 Jul 2015 16:56:27 +0000

Yes, I believe we made a lot of progress.  Most of us will be in Prague and having a meeting there to try and “wrap up” things will be good idea.
--- Alex

From: Vishnu Pavan Beeram [mailto:[email-masked]]
Sent: Wednesday, July 01, 2015 5:42 PM
To: Susan Hares
Cc: Lou Berger; Jeffrey Haas; [email-masked]; [email-masked]; BRUNGARD, DEBORAH A; Alia Atlas; Alvaro Retana (aretana); Vishnu Pavan Beeram; [email-masked]; Alexander Clemm (alex)
Subject: Re: [i2rs] [Rtg-yang-coord] Requirements for I2RS protocol and I2RS interim (6/24/2015 at 10:00 - 11:30am ET)

+ Alex
+ <te-topo-model> authors
Sue, Jeff,
The authors of the <te-topo-model> draft had a meeting today with one of the authors (Alex) of the <network-topo-model> draft and discussed ways to align the topo models. The consensus so far is that the <te-topo-model> WILL augment the <network-topo-model>. There are some issues that need to be worked out (mapping identifiers, termination-points), but those should get resolved in due course of time.

I'll sync up with you (Sue) and coordinate a meeting between the authors of the <te-topo-model> and the authors of the I2RS topo model(s) at the IETF --- hopefully early in the week.
Regards,
-Pavan

On Wed, Jul 1, 2015 at 6:49 PM, Susan Hares <[email-masked]<mailto:[email-masked]>> wrote:
Lou and Jeffrey:

Sue

-----Original Message-----
From: i2rs [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Lou Berger
Sent: Wednesday, July 01, 2015 11:39 AM
To: Susan Hares; 'Jeffrey Haas'
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; 'BRUNGARD, DEBORAH A'; Vishnu

Sue, Jeff,

Thanks,
Lou
(as TEAS WG co-chair)
On 6/23/2015 2:19 PM, Susan Hares wrote:
> [email-masked]<mailto:[email-masked]>

_______________________________________________
i2rs mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/i2rs

_______________________________________________
i2rs mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/i2rs

---

From: "Susan Hares" <[email-masked]>
Date: Thu, 2 Jul 2015 17:35:04 -0400

Mahesh: 

I’m trying to schedule a set of meeting before I2RS presents at NETCONF so it would be helpful to know when the I2RS session would be schedule in NETCONF. 

Is I2RS requirements presentation at the Tuesday meeting with Netconf [15:20 – 17:20] which is just before the I2RS meeting [17:40- 18:40].  This back-to-back session would allow us to encourage people to hear the presentations in NETCONF and then come to I2RS to discuss any open issues for I2RS.  

Do you think we should present the NETMOD requirements before the NETCONF requirements?  I can request a brief presentation in NETMOD.  I am working on a draft to express I2RS requirements for netmod.  The requirements for NETMO will not be an I2RS WG document – only a chair’s observations on the differences between the yang modules. 

Sue Hares 

 

Cheers.

Mahesh Jethanandani

[email-masked]

---

From: "Zhangxian (Xian)" <[email-masked]>
Date: Fri, 3 Jul 2015 03:46:46 +0000

Hi,

   I would echo what Lou said in another email:

“We should probably announce the time and place where the authors will be meeting in Prague so that others who are interested can show.”

I am definitely interested.

Another suggestion is: can we try to draw a relationship diagram to see how the topology related models fits together (irrespective of which WG should work on what)? In the <network-topo-model> draft, there is already a diagram which might be helpful as a starting point.

Regards,
Xian

From: i2rs [mailto:[email-masked]] On Behalf Of Vishnu Pavan Beeram
Sent: 2015年7月2日 8:42
To: Susan Hares
Cc: [email-masked]; [email-masked]; BRUNGARD, DEBORAH A; [email-masked]; Vishnu Pavan Beeram; Alia Atlas; [email-masked]; Jeffrey Haas; Alvaro Retana (aretana); Lou Berger
Subject: Re: [i2rs] [Rtg-yang-coord] Requirements for I2RS protocol and I2RS interim (6/24/2015 at 10:00 - 11:30am ET)

+ Alex

Sue

-----Original Message-----
From: i2rs [mailto:[email-masked]<mailto:[email-masked]>] On Behalf Of Lou Berger
Sent: Wednesday, July 01, 2015 11:39 AM
To: Susan Hares; 'Jeffrey Haas'
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; 'BRUNGARD, DEBORAH A'; Vishnu

Sue, Jeff,

Thanks,
Lou
(as TEAS WG co-chair)

---

From: "Susan Hares" <[email-masked]>
Date: Fri, 3 Jul 2015 14:35:22 -0400

Xian:

The time will be 6:00pm-7:00pm (18:00-19:00) on Sunday 7/19/2015 in Prague.  

I’m also trying to lock down a conference call at 11:00am-12:00 ET (8:00am-12:00pm PT, 23:00-23:59 Beijing) on 7/8 for the TEAS authors and the topology authors.  By this time I will have reviewed the TEAS and I2RS drafts submitted, and I will have questions for the authors. 

Please let me know if you can attend these two meetings.

Sue 

From: i2rs [mailto:[email-masked]] On Behalf Of Zhangxian (Xian)
Sent: Thursday, July 02, 2015 11:47 PM
To: Susan Hares; Vishnu Pavan Beeram; Lou Berger; [email-masked]
Cc: [email-masked]; [email-masked]; BRUNGARD, DEBORAH A; [email-masked]; Alia Atlas; Jeffrey Haas; Alvaro Retana (aretana)
Subject: Re: [i2rs] [Rtg-yang-coord] Requirements for I2RS protocol and I2RS interim (6/24/2015 at 10:00 - 11:30am ET)

Hi, 

Regards,
Xian

+ Alex

Sue, Jeff,

Regards,

-Pavan

Lou and Jeffrey:

Sue

-----Original Message-----
From: i2rs [mailto:[email-masked]] On Behalf Of Lou Berger
Sent: Wednesday, July 01, 2015 11:39 AM
To: Susan Hares; 'Jeffrey Haas'
Cc: [email-masked]; [email-masked]; 'BRUNGARD, DEBORAH A'; Vishnu

Sue, Jeff,

Thanks,
Lou
(as TEAS WG co-chair)

i2rs mailing list
[email-masked]

---

From: Lou Berger <[email-masked]>
Date: Fri, 03 Jul 2015 15:49:01 -0400

Sue,

On 7/3/2015 2:35 PM, Susan Hares wrote:
> By this time I will have reviewed the TEAS and I2RS drafts submitted,
> and I will have questions for the authors.

It might be helpful to have this discussion on list so others who are on
the call can follow/participate.

Thanks,
Lou

---

From: "Susan Hares" <[email-masked]>
Date: Fri, 3 Jul 2015 16:49:00 -0400

Lou:

This webex (7/8) is to help inform the I2RS chair so that prior to kicking
off the mail list discussion. 

Sue 

-----Original Message-----
From: Lou Berger [mailto:[email-masked]] 
Sent: Friday, July 03, 2015 3:49 PM
To: Susan Hares; 'Zhangxian (Xian)'; 'Vishnu Pavan Beeram';
[email-masked]
Cc: [email-masked]; [email-masked]; 'BRUNGARD, DEBORAH A';
[email-masked]; 'Alia Atlas'; 'Jeffrey Haas'; 'Alvaro Retana (aretana)'
Subject: Re: [i2rs] [Rtg-yang-coord] Requirements for I2RS protocol and I2RS
interim (6/24/2015 at 10:00 - 11:30am ET)

Sue,

> and I will have questions for the authors.

It might be helpful to have this discussion on list so others who are on the
call can follow/participate.

Thanks,
Lou

---

From: Tom Taylor <[email-masked]>
Date: Mon, 6 Jul 2015 16:14:22 -0400

In theory, at least, LIME needs a topology model, but it has to cover 
multiple layers. I'll keep an eye on this work.

Tom Taylor

...

---

From: "Susan Hares" <[email-masked]>
Date: Tue, 7 Jul 2015 10:26:21 -0400

Tom:

We should chat.  Lime, TEAS, and I2RS are looking at multiple layer topology
models. 

LIME is looking at the configuration of OAM. 
TEAS is looking at traffic engineering. 
I2RS is looking at  Virtual topology that are created by the I2RS protocol. 
  
 I2RS topology protocol independent topologies are composites from
 other protocol-dependent topologies.   OAM could be consider one
 of those other protocol dependent.

Sue 

-----Original Message-----
From: Rtg-yang-coord [mailto:[email-masked]] On Behalf Of
Tom Taylor
Sent: Monday, July 06, 2015 4:14 PM
To: [email-masked]
Subject: Re: [Rtg-yang-coord] [i2rs] Requirements for I2RS protocol and I2RS
interim (6/24/2015 at 10:00 - 11:30am ET)

Tom Taylor

On 01/07/2015 8:41 PM, Vishnu Pavan Beeram wrote:
> The authors of the <te-topo-model> draft had a meeting today with one 
> of the authors (Alex) of the <network-topo-model> draft and discussed 
> ways to align the topo models. The consensus so far is that the 
> <te-topo-model> WILL augment the <network-topo-model>. There are some 
> issues that need to be worked out (mapping identifiers, 
> termination-points), but those should get resolved in due course of time.
>
> I'll sync up with you (Sue) and coordinate a meeting between the 
> authors of the <te-topo-model> and the authors of the I2RS topo 
> model(s) at the IETF
...

---

From: "Susan Hares" <[email-masked]>
Date: Tue, 7 Jul 2015 14:22:53 -0400

Tom:

We are having a meeting of the TEAS And I2RS authors on Wednesday at 12:00pm
ET.  If you would like to listen in, please let me know. 

Sue 

-----Original Message-----
From: Rtg-yang-coord [mailto:[email-masked]] On Behalf Of
Susan Hares
Sent: Tuesday, July 07, 2015 10:26 AM
To: 'Tom Taylor'; [email-masked]
Subject: Re: [Rtg-yang-coord] [i2rs] Requirements for I2RS protocol and I2RS
interim (6/24/2015 at 10:00 - 11:30am ET)

Tom:

  

Sue 

-----Original Message-----

Tom Taylor

...