Subject: Re: [Rtg-yang-coord] yang models intended for the mpls wg

From: "Carlos Pignataro (cpignata)" <[email-masked]>
Date: Mon, 3 Aug 2015 14:29:02 +0000

Thanks Loa for starting a good discussion. Mahesh was asking the right questions, in terms of what are the right abstractions that ought to be modeled, and how to structure the intersection between technology specific (like MPLS), even more specific (like MPLS-TE, MPLS-TP), these abstractions (like Tunnels and OAM), and adjacent technologies.

What follows is the OAM lens for this discussion.

[Responding with a LIME co-chair hat on]

From an OAM perspective, we had a good discussion in LIME in Prague, and I’d like to somewhat summarize some of the decisions and next steps:
LIME is chartered [1] to provide technology and layer independent OAM Models (and OAM here includes ping, mpls lsp ping, bfd, etc)
Success in this context is having these generic model augmented with technology specific from bfd, mpls, etc. I.e., that this abstraction is actually used!

Based on these two points, we have two key deliverables in LIME — these are not our only deliverables, but these are the most relevant for this discussion:
YANG data model(s) for generic layer-independent and technology-independent configuration, reporting and presentation for OAM mechanisms.
Applicability document: The YANG model(s) specified in this working group must be usable and extensible by the existing OAM technologies. This usability and extensibility must be demonstrated, for example with IP Ping, traceroute, BFD, and LSP Ping. Note the technology-specific data model extensions should ideally be worked on in the respective working groups.
There are a few OAM technology-specific models appearing and being worked on, and one of the next steps that LIME will drive is getting all these together, along with the authors of our base model and the applicability document, to rationalize all these OAM efforts.

Specifically, there are these three technology-specific OAM Drafts:
https://tools.ietf.org/html/draft-zhang-mpls-tp-yang-oam-01.txt <https://tools.ietf.org/html/draft-zhang-mpls-tp-yang-oam-01.txt>
https://tools.ietf.org/html/draft-zheng-mpls-lsp-ping-yang-cfg-01.txt <https://tools.ietf.org/html/draft-zheng-mpls-lsp-ping-yang-cfg-01.txt>
https://tools.ietf.org/html/draft-zheng-bfd-yang <https://tools.ietf.org/html/draft-zheng-bfd-yang>
And these two LIME docs:
Generic model: https://tools.ietf.org/html/draft-tissa-lime-yang-oam-model-05 <https://tools.ietf.org/html/draft-tissa-lime-yang-oam-model-05>
Applicability: https://tools.ietf.org/html/draft-zhuang-lime-yang-oam-model-applicability-00 <https://tools.ietf.org/html/draft-zhuang-lime-yang-oam-model-applicability-00>
We should get the set of authors of these together, perhaps in a structured virtual interim. We can drive these OAM alignment/structuring from LIME. Copying MPLS and BFD co-chairs.

Thanks,

— Carlos.
[1] https://datatracker.ietf.org/wg/lime/charter/ <https://datatracker.ietf.org/wg/lime/charter/>

> On Jul 27, 2015, at 6:34 PM, Tom Taylor <[email-masked]> wrote:
> 
> I do not consider ping to have localization capability. That's why I consider BFD to be the functional equivalent.
> 
> Review is certainly something that LIME will welcome, I'm sure.
> 
> Tom
> 
> On 27/07/2015 11:51 AM, Gregory Mirsky wrote:
>> Hi Tom,
>> I don't think that BFD is or will be used as on-demand OAM tool as it does not have localization capability. Ping or traceroute are more suitable, in my opinion. But if that is how LIME model maps existing OAM tools, then I'd encourage presenting and asking for review of the LIME model by WGs that designed this OAM mechanisms, e.g. MPLS Ping and BFD.
>> 
>> 	Regards,
>> 		Greg
>> 
>> -----Original Message-----
>> From: Tom Taylor [mailto:[email-masked]]
>> Sent: Monday, July 27, 2015 8:34 AM
>> To: Gregory Mirsky; Mahesh Jethanandani; Loa Andersson
>> Cc: [email-masked]; YANG Doctors
>> Subject: Re: [Rtg-yang-coord] yang models intended for the mpls wg
>> 
>> I am not claiming that the capabilities of LSP ping are limited to those of tracert, or that the capabilities of BFD are limited to those of ping. I am saying that if I want to request these two functions (continuity check and hop-by-hop path characterization) at a generic level then the corresponding implementations at the MPLS technology-specific level would be invoked when the LIME RPCs were invoked at the boundaries of an MPLS segment.
>> 
>> The idea would be that once a fault was localized to that segment and to the MPLS layer as opposed to a supporting layer, the manager could invoke the technology-specific models as necessary to get details.
>> 
>> Tom
>> 
>> On 27/07/2015 11:18 AM, Gregory Mirsky wrote:
>>> Hi Tom,
>>> I think I cannot agree with any of your comparisons.
>>> LSP Ping provides both on-demand ping and traceroute functions.
>>> BFD, if you refer to RFC 5880, provides variety of functions, primarily as proactive continuity check (Asynchronous and on-demand modes, as well as ping by Echo mode). RFC 5884 BFD over MPLS LSP consider only Asynchronous mode.
>>> One can argue that ping may be used as proactive continuity check mechanism but that is not what it was originally designed and such application would, most likely, require use of another application, e.g. Measurement Agent per LMAP Reference model.
>>> 
>>> I think it would be really helpful to define relationships between objects of LIME model and models specified in MPLS, BFD and other groups that had developed OAM tools that broadly used in the industry.
>>> 
>>> 	Regards,
>>> 		Greg
>>> 
>>> -----Original Message-----
>>> From: Tom Taylor [mailto:[email-masked]]
>>> Sent: Monday, July 27, 2015 8:06 AM
>>> To: Gregory Mirsky; Mahesh Jethanandani; Loa Andersson
>>> Cc: [email-masked]; YANG Doctors
>>> Subject: Re: [Rtg-yang-coord] yang models intended for the mpls wg
>>> 
>>> LSP ping really corresponds to the generic tracert model, in that it provides hop-by-hop path characterization. I can see the LIME tracert RPC being invoked, and the MPLS nodes returning the parameters defined for that RPC to the extent that they correspond to what LSP ping reports.
>>> 
>>> BFD seems to correspond quite nicely to LIME ping in terms of the function performed.
>>> 
>>> Tom
>>> 
>>> On 27/07/2015 1:36 AM, Gregory Mirsky wrote:
>>>> Hi Tom,
>>>> what is relationship between MPLS LSP Ping and "generic ping" models? Or, between BFD and "generic continuity check"?
>>>> 
>>>> 	Regards,
>>>> 		Greg
>>>> 
>>>> -----Original Message-----
>>>> From: Rtg-yang-coord [mailto:[email-masked]] On
>>>> Behalf Of Tom Taylor
>>>> Sent: Saturday, July 25, 2015 5:19 AM
>>>> To: Mahesh Jethanandani; Loa Andersson
>>>> Cc: [email-masked]; YANG Doctors
>>>> Subject: Re: [Rtg-yang-coord] yang models intended for the mpls wg
>>>> 
>>>> The generic ping module is a LIME work item.
>>>> 
>>>> Tom Taylor
>>>> 
>>>> On 24/07/2015 9:24 AM, Mahesh Jethanandani wrote:
>>>>> [with yang doctor hat on]
>>>>> 
>>>>> Loa,
>>>>> 
>>>>> Has there been any discussion around how these models interact with each other or how the mpls WG would like to see the models structured.
>>>>> 
>>>>> For example, from this list of models (and I admit I have not looked at a complete list of mpls related yang models or each in detail), a couple of questions arise.
>>>>> 
>>>>> - Is there a plan for a generic mpls yang model?
>>>>> - plan for a more specific mpls-tp, mpls-te etc. yang model (they could be an extension of the more generic mpls model)?
>>>>> - plan for a generic ping module (may belong in NETMOD WG)?
>>>>> - plan for a mpls ping module (again an extension of the more generic ping module that interfaces with mpls module)?
>>>>> - plan for a ldp module that interfaces with the mpls module?
>>>>> - plan for a rsvp-te module that interfaces with mpls-te module?
>>>>> 
>>>>> Having some structure to the models would probably help these and other yang authors in their design.
>>>>> 
>>>>> Thanks.
>>>>> 
>>>>> Mahesh Jethanandani
>>>>> [email-masked]
>>>>> 
>>>>>> On Jul 24, 2015, at 11:39 AM, Loa Andersson <[email-masked]> wrote:
>>>>>> 
>>>>>> Folks,
>>>>>> 
>>>>>> There are four yang models intended for the MPLS working group, we
>>>>>> have not yet started the process of adoption as working group documents.
>>>>>> The four documents are:
>>>>>> 
>>>>>> 1. draft-zhang-mpls-tp-yang-oam (announced earlier) 2.
>>>>>> draft-zheng-mpls-lsp-ping-yang-cfg (announced now) 3.
>>>>>> draft-openconfig-mpls-consolidated-model (announced now) 4.
>>>>>> draft-raza-mpls-ldp-mldp-yang (announced now)
>>>>>> 
>>>>>> /Loa
>>>>>> 
>>>>>> 
>>>>>> 
>>>>>> 
>>>>>> --
>>>>>> 
>>>>>> 
>>>>>> Loa Andersson                        email: [email-masked]
>>>>>> Senior MPLS Expert                          [email-masked]
>>>>>> Huawei Technologies (consultant)     phone: +46 739 81 21 64
>>>>>> 
>>>>>> _______________________________________________
>>>>>> Rtg-yang-coord mailing list
>>>>>> [email-masked]
>>>>>> https://www.ietf.org/mailman/listinfo/rtg-yang-coord
>>>>> 
>>>>> _______________________________________________
>>>>> Rtg-yang-coord mailing list
>>>>> [email-masked]
>>>>> https://www.ietf.org/mailman/listinfo/rtg-yang-coord
>>>>> 
>>>> 
>>>> _______________________________________________
>>>> Rtg-yang-coord mailing list
>>>> [email-masked]
>>>> https://www.ietf.org/mailman/listinfo/rtg-yang-coord
>>>> 
>>> 
>> 
> 
> _______________________________________________
> Rtg-yang-coord mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtg-yang-coord

---

From: Mahesh Jethanandani <[email-masked]>
Date: Mon, 3 Aug 2015 15:18:29 -0700

Carlos,

One more OAM model that I would like to add to this list is the MEF model on CFM. Specifically MEF 38 <https://www.mef.net/Assets/Technical_Specifications/PDF/MEF_38.pdf>. The model was written 3 years ago and does not align with most of the models written today.

As editor of the YANG project in MEF, I am asking folks if they would be interested in updating MEF 38 to align it with the current models.

Thanks.

> On Aug 3, 2015, at 7:29 AM, Carlos Pignataro (cpignata) <[email-masked]> wrote:
> 

Mahesh Jethanandani
[email-masked]