Subject: [Rtg-yang-coord] Fwd: We start to see our first YANG version 1.1 modules

From: Benoit Claise <[email-masked]>
Date: Sun, 8 Nov 2015 08:17:14 +0100

Dear all,

I will stop duplicating messages to the different YANG-related mailing 
lists.
I hope that you guys are part of [email-masked], to which I post 
from time to time.

Regards, Benoit

-------- Forwarded Message --------
Subject: 	We start to see our first YANG version 1.1 modules
Date: 	Sun, 8 Nov 2015 08:14:38 +0100
From: 	Benoit Claise <[email-masked]>
To: 	[email-masked] <[email-masked]>

Dear all,

We start to see our first version 1.1 YANG data modules, coming from:
     draft-entitydt-netmod-entity-00.txt
     draft-ietf-netconf-server-model-08.txt:
     draft-ietf-netmod-rfc6020bis-08.txt:
     draft-wilton-netmod-intf-ext-yang-01.txt:

The corresponding YANG modules are:
DEBUG: [email-masked] is version 1.1
DEBUG: [email-masked] is version 1.1
DEBUG: [email-masked] is version 1.1
DEBUG: [email-masked] is version 1.1
DEBUG: [email-masked] is version 1.1
DEBUG: [email-masked] is version 1.1
DEBUG: [email-masked] is version 1.1

Regards, Benoit

---

From: Andy Bierman <[email-masked]>
Date: Mon, 9 Nov 2015 10:16:49 -0800

Hi,

YANG 1.1 has had only 2 comprehensive reviews.
Seems like the IETF should finish YANG 1.1 before using it.
Even though the version says 1.1 and the charter says bugfixes only,
there are many massive changes required to a server in order
to support YANG 1.1, so I strongly suggest people review the draft.

Andy

On Sat, Nov 7, 2015 at 11:17 PM, Benoit Claise <[email-masked]> wrote:

> -------- Forwarded Message -------- Subject: We start to see our first
> YANG version 1.1 modules Date: Sun, 8 Nov 2015 08:14:38 +0100 From: Benoit
> Claise <[email-masked]> <[email-masked]> To: [email-masked]
> <[email-masked]> <[email-masked]>
>
> Dear all,
>
> _______________________________________________
> yang-doctors mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/yang-doctors
>
>

---

From: Kent Watsen <[email-masked]>
Date: Tue, 10 Nov 2015 19:13:23 +0000

[Moving rtg-yang-coord to BCC]

Hi Andy,

5 out of 7 of the YANG modules listed below are from my server-model draft, for which the WG said I SHOULD use 1.1 (specifically the new if-feature and action statements).   The server-model draft has a normative reference onto 6020bis, so it’s okay, right?

Kent

From: yang-doctors <[email-masked]<mailto:[email-masked]>> on behalf of Andy Bierman <[email-masked]<mailto:[email-masked]>>
Date: Monday, November 9, 2015 at 1:16 PM
To: Benoit Claise <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, YANG Doctors <[email-masked]<mailto:[email-masked]>>
Subject: Re: [yang-doctors] Fwd: We start to see our first YANG version 1.1 modules

Hi,

Andy

On Sat, Nov 7, 2015 at 11:17 PM, Benoit Claise <[email-masked]<mailto:[email-masked]>> wrote:
Dear all,

I will stop duplicating messages to the different YANG-related mailing lists.
I hope that you guys are part of [email-masked]<mailto:[email-masked]>, to which I post from time to time.

Regards, Benoit

-------- Forwarded Message --------
Subject:        We start to see our first YANG version 1.1 modules
Date:   Sun, 8 Nov 2015 08:14:38 +0100
From:   Benoit Claise <[email-masked]><mailto:[email-masked]>
To:     [email-masked]<mailto:[email-masked]> <[email-masked]><mailto:[email-masked]>

Dear all,

The corresponding YANG modules are:
DEBUG: [email-masked]<mailto:[email-masked]> is version 1.1
DEBUG: [email-masked]<mailto:[email-masked]> is version 1.1
DEBUG: [email-masked]<mailto:[email-masked]> is version 1.1
DEBUG: [email-masked]<mailto:[email-masked]> is version 1.1
DEBUG: [email-masked]<mailto:[email-masked]> is version 1.1
DEBUG: [email-masked]<mailto:[email-masked]> is version 1.1
DEBUG: [email-masked]<mailto:[email-masked]> is version 1.1

Regards, Benoit

_______________________________________________
yang-doctors mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/yang-doctors

---

From: Benoit Claise <[email-masked]>
Date: Fri, 13 Nov 2015 10:38:40 +0100

Dear all,

Discussing with Alia, it seems that we need to clarify the relationship 
between the different groups dealing with YANG.

- Routing Area YANG Coordination
     Goal: routing related YANG coordination
     Contact: [email-masked]
     Pointer: http://trac.tools.ietf.org/area/rtg/trac/wiki/RtgYangCoord

- YANG Multicast Design Team
     Goal: design team for YANG models for multicast, with focus on 
protocols related to PIM and IGMP/MLD
     Contact: http://trac.tools.ietf.org/wg/pim/trac/wiki/yang
     Pointer: http://trac.tools.ietf.org/wg/pim/trac/wiki/yang

- YANG Model Coordination Group
     Goal: broader YANG coordination.
     Contact: [email-masked]
     Pointer: 
http://www.ietf.org/iesg/directorate/yang-model-coordination-group.html
     Mode of operation: everybody can subscribe to the mailing list, 
webex calls are among ourselves
     See the latest status, presented at the IETF 94: 03 - YANG Model 
Coordination Group 
<https://www.ietf.org/proceedings/94/slides/slides-94-netmod-22.pdf>

    In a nutshell, we're focusing on
    Phase 1: List of the YANG models (inventory)
    Phase 2: Tooling
    Phase 3: Help with compilation
    Phase 4: Training/Education
    Phase 5: Coordination across SDOs/Opensource
    Phase 6: Model Coordination within the IETF
    Phase 7: Standardization Priorities

- the YANG doctors:
     Goal: The YANG doctors/reviewers help the OPS AD to review YANG 
documents on the IESG agenda.
     Contact: [email-masked] <mailto:[email-masked]>
     Pointer: http://www.ietf.org/iesg/directorate/yang-doctors.html

- NETMOD mailing list:
     Goal: YANG language discussion + YANG data models for which no 
specific WG exists
     Contact: [email-masked]
     Pointer: https://datatracker.ietf.org/wg/netmod/charter/

I know that some of you are part of the multiple groups, and I know that 
there are sometimes redundant discussions, however, let's try to use the 
correct communication channel.

I hope that my message below makes more sense now.

Regards, Benoit

> DEBUG:[email-masked]  is version 1.1
> DEBUG:[email-masked]  is version 1.1
> DEBUG:[email-masked]  is version 1.1
> DEBUG:[email-masked]  is version 1.1
> DEBUG:[email-masked]  is version 1.1
> DEBUG:[email-masked]  is version 1.1
> DEBUG:[email-masked]  is version 1.1
>
> Regards, Benoit
>
>
>
>
>
> Rtg-yang-coord mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/rtg-yang-coord