Subject: Re: [Rtg-yang-coord] Notification in Yang

From: Dhruv Dhody <[email-masked]>
Date: Wed, 19 Jul 2017 10:01:09 +0530

Hi,

A reminder....
This question remained un-answered, regarding the notifications in Yang
model. Any guidance would be appreciated, thanks!

Regards,
Dhruv

On Wed, May 17, 2017 at 5:50 PM, Dhruv Dhody <[email-masked]> wrote:

> Hi Yang-Doctors,
>
> What is the guideline for including Notification in the Yang model, now
> that [I-D.ietf-netconf-yang-push] and [I-D.ietf-netconf-subscribed-notifications]
> is the preferred approach?
>
> Should we keep only "mandatory to implement notifications" in the Yang
> model? Or just remove the notifications completely?
>
> A guideline to model writers would be helpful here, IMHO.
>
> Regards,
>
> Dhruv
>
>
>
>

---

From: Lou Berger <[email-masked]>
Date: Wed, 19 Jul 2017 07:37:53 +0200

Dhruv,

    Perhaps send a message on this to netmod.  This topic has come up a
couple of times this week and your suggestion of guidelines make sense
and perhaps should be addressed in 6087bis.

Thanks,

Lou

On July 19, 2017 6:31:46 AM Dhruv Dhody <[email-masked]> wrote:

> Hi, 
>
> A reminder.... 
> This question remained un-answered, regarding the notifications in
> Yang model. Any guidance would be appreciated, thanks! 
>
> Regards,
> Dhruv
>
> On Wed, May 17, 2017 at 5:50 PM, Dhruv Dhody <[email-masked]
> <mailto:[email-masked]>> wrote:
>
>     Hi Yang-Doctors,
>
>     What is the guideline for including Notification in the Yang
>     model, now that [I-D.ietf-netconf-yang-push] and
>     [I-D.ietf-netconf-subscribed-notifications] is the preferred approach?
>
>     Should we keep only "mandatory to implement notifications" in the
>     Yang model? Or just remove the notifications completely?
>
> _______________________________________________
> Rtg-yang-coord mailing list
> [email-masked] <mailto:Rtg-yang-coord%40ietf.org>
> https://www.ietf.org/mailman/listinfo/rtg-yang-coord
>