Subject: [saag] About the "Draft text for a PQ Maintenance WG"

From: Ludovic Perret <[email-masked]>
Date: Wed, 28 Jul 2021 20:03:13 +0000

Dear,

Following the meeting of yesterday and the discussion on post-quantum, I have few comments on the  draft text for a PQ Maintenance WG :
https://datatracker.ietf.org/meeting/111/materials/slides-111-saag-companion-to-how-should-the-ietf-approach-pq-security-draft-pq-maintenance-charter-00

  *    [Post Quantum work collaborators] --> what is exactly the semantic behind that ? Do you expect a commitment from pq people ?
  *   The [Planned WG Acronym] WG will not define new PQ algorithms and methods --> What do you mean by method ?
     *   I would suggest "The [Planned WG Acronym] WG will rely on future NIST or international pq  standards"

Best Regards,

Ludovic Perret,

CPO, co-founder, CryptoNext Security
https://cryptonext-security.com/

---

From: Yaron Sheffer <[email-masked]>
Date: Thu, 29 Jul 2021 23:51:23 +0300

I support Ludovic’s second point. Also:

* "Maintenance" is not a great name, because of course we're not doing any maintenance on PQ algorithms/protocols. Maybe "PQ Ops"?

* "And the WG may propose deprecation of such algorithms" - can be read as "the WG will deprecate algorithms" which IMO should be left to the per-protocol working groups. Even where such WGs do not exist, it is *still* not a good idea for this WG to deprecate algorithms in specific protocols since it doesn't have the operational experience required to do that.

Thanks,

                Yaron

From: saag <[email-masked]> on behalf of Ludovic Perret <[email-masked]>
Reply-To: Ludovic Perret <[email-masked]>
Date: Wednesday, July 28, 2021 at 23:03
To: "[email-masked]" <[email-masked]>
Subject: [saag] About the "Draft text for a PQ Maintenance WG"

Dear,  

·          [Post Quantum work collaborators] --> what is exactly the semantic behind that ? Do you expect a commitment from pq people ?  

·         The [Planned WG Acronym] WG will not define new PQ algorithms and methods --> What do you mean by method ?  

·         I would suggest "The [Planned WG Acronym] WG will rely on future NIST or international pq  standards" 

Best Regards, 

Ludovic Perret, 

_______________________________________________ saag mailing list [email-masked] https://www.ietf.org/mailman/listinfo/saag