Subject: [saag] Fwd: Last Call: <draft-ietf-sfc-proof-of-transit-08.txt> (Proof of Transit) to Experimental RFC

From: Benjamin Kaduk <[email-masked]>
Date: Tue, 14 Sep 2021 20:40:58 -0700

The proof-of-transit techniques in this document might be interesting to
readers here.

-Ben

On Tue, Sep 14, 2021 at 10:19:23AM -0700, The IESG wrote:
> 
> The IESG has received a request from the Service Function Chaining WG (sfc)
> to consider the following document: - 'Proof of Transit'
>   <draft-ietf-sfc-proof-of-transit-08.txt> as Experimental RFC
> 
> The IESG plans to make a decision in the next few weeks, and solicits final
> comments on this action. Please send substantive comments to the
> [email-masked] mailing lists by 2021-09-28. Exceptionally, comments may
> be sent to [email-masked] instead. In either case, please retain the beginning
> of the Subject line to allow automated sorting.
> 
> Abstract
> 
> 
>    Several technologies such as Traffic Engineering (TE), Service
>    Function Chaining (SFC), and policy based routing are used to steer
>    traffic through a specific, user-defined path.  This document defines
>    mechanisms to securely prove that traffic transited a defined path.
>    These mechanisms allow to securely verify whether, within a given
>    path, all packets traversed all the nodes that they are supposed to
>    visit.  This document specifies a data model to enable these
>    mechanisms using YANG.
> 
> 
> 
> 
> The file can be obtained via
> https://datatracker.ietf.org/doc/draft-ietf-sfc-proof-of-transit/
> 
> 
> The following IPR Declarations may be related to this I-D:
> 
>    https://datatracker.ietf.org/ipr/2937/
>    https://datatracker.ietf.org/ipr/3751/
> 
> 
> 
> 
> 
> 
> _______________________________________________
> IETF-Announce mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/ietf-announce

---

From: Christian Huitema <[email-masked]>
Date: Mon, 20 Sep 2021 11:27:56 -0700

> The proof-of-transit techniques in this document might be interesting to

Or not. The proposed algorithm is broken.

-- Christian Huitema

> saag mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/saag