Subject: Re: [saag] About the "Draft text for a PQ Maintenance WG"

From: "Kampanakis, Panos" <[email-masked]>
Date: Wed, 29 Sep 2021 14:42:28 +0000

Hi Roman, Ben,

I think there was interest in the last SAAG meeting and this thread for work to start in this area. And NIST may pick some of its first algorithms in the next 4-5 months based on what they have recently said.

Any updates on a PQ Maintenance WG?

Thx,
Panos

From: saag <[email-masked]> On Behalf Of Kampanakis, Panos
Sent: Thursday, August 5, 2021 10:46 PM
To: Roman Danyliw <[email-masked]>; [email-masked]
Subject: RE: [EXTERNAL] [saag] About the "Draft text for a PQ Maintenance WG"

CAUTION: This email originated from outside of the organization. Do not click links or open attachments unless you can confirm the sender and know the content is safe.

+1 on the current status of the new charter. Looks good.

I would like to suggest SSH to be first in the
“The WG is currently focused on updating …”

SSH is orphan and relatively straightforward (similar to how TLS is getting PQ algorithms).

Other examples could be DNSsec, Kerberos. We could follow CURDLE there as well and be ambiguous on the other protocols. CURDLE didn’t end up working on all of the ones in its charter either. It all depends on having enough interest.

From: saag <[email-masked]<mailto:[email-masked]>> On Behalf Of Roman Danyliw
Sent: Thursday, August 5, 2021 5:05 PM
To: Yaron Sheffer <[email-masked]<mailto:[email-masked]>>; Ludovic Perret <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: RE: [EXTERNAL] [saag] About the "Draft text for a PQ Maintenance WG"

CAUTION: This email originated from outside of the organization. Do not click links or open attachments unless you can confirm the sender and know the content is safe.

Hi Yaron.

Thanks.  I made the edit.

Roman

From: Yaron Sheffer <[email-masked]<mailto:[email-masked]>>
Sent: Thursday, August 5, 2021 4:18 PM
To: Roman Danyliw <[email-masked]<mailto:[email-masked]>>; Ludovic Perret <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: [saag] About the "Draft text for a PQ Maintenance WG"

Hi Roman,

Yes, the “tentative” CURDLE text is IMO more reasoned.

Thanks,
                Yaron

From: Roman Danyliw <[email-masked]<mailto:[email-masked]>>
Date: Thursday, August 5, 2021 at 22:31
To: Yaron Sheffer <[email-masked]<mailto:[email-masked]>>, Ludovic Perret <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: RE: [saag] About the "Draft text for a PQ Maintenance WG"

Hi Yaron!

Thanks for the feedback.  More inline …

From: saag <[email-masked]<mailto:[email-masked]>> On Behalf Of Yaron Sheffer
Sent: Thursday, July 29, 2021 4:51 PM
To: Ludovic Perret <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: [saag] About the "Draft text for a PQ Maintenance WG"

I support Ludovic’s second point. Also:

[Roman] Agreed. Fixed and further discussed in response to him/

* "Maintenance" is not a great name, because of course we're not doing any maintenance on PQ algorithms/protocols. Maybe "PQ Ops"?

[Roman] No question that we need a good WG name.  The maintenance was targeted at the IETF protocols, not PQ algorithms/protocols, as the primary output of the WG was to updated specifications of existing protocols.

The charter only uses “maintenance” is one place:

“The [Planned WG Name] working group ([Planned WG Acronym]) is chartered as a maintenance WG to analyze; and adapt or update IETF protocols, registries, and associated code points with PQ cryptographic mechanism.”

The intent still stands with s/maintenance WG/WG/ so I’ll remove that word and we can ruminate further on the WG name.

* "And the WG may propose deprecation of such algorithms" - can be read as "the WG will deprecate algorithms" which IMO should be left to the per-protocol working groups. Even where such WGs do not exist, it is *still* not a good idea for this WG to deprecate algorithms in specific protocols since it doesn't have the operational experience required to do that.

[Roman] I can see the risk you are highlighting.  That sentiment is borrowed from the CURDLE charter (https://datatracker.ietf.org/doc/charter-ietf-curdle/) which gave itself the same latitude when updating those documents for EC.  Would you feel more comfortable with more tentative text similar to CURDLE?

The CURDLE working group will be handling changes to protocols and registries
some of which include what are now considered outdated algorithm options, and
may propose deprecation of such algorithms. Such deprecation needs to be done
with care, ensuring that interoperability and the needs of existing
implementers and deployments are properly considered. Where deprecation is
practical, the working group is encouraged to deprecate.

Regards,
Roman

Thanks,
                Yaron

From: saag <[email-masked]<mailto:[email-masked]>> on behalf of Ludovic Perret <[email-masked]<mailto:[email-masked]>>
Reply-To: Ludovic Perret <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, July 28, 2021 at 23:03
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [saag] About the "Draft text for a PQ Maintenance WG"

Dear,

Following the meeting of yesterday and the discussion on post-quantum, I have few comments on the  draft text for a PQ Maintenance WG :
https://datatracker.ietf.org/meeting/111/materials/slides-111-saag-companion-to-how-should-the-ietf-approach-pq-security-draft-pq-maintenance-charter-00
·         [Post Quantum work collaborators] --> what is exactly the semantic behind that ? Do you expect a commitment from pq people ?
·        The [Planned WG Acronym] WG will not define new PQ algorithms and methods --> What do you mean by method ?
·        I would suggest "The [Planned WG Acronym] WG will rely on future NIST or international pq  standards"
Best Regards,

Ludovic Perret,

CPO, co-founder, CryptoNext Security
https://cryptonext-security.com/

_______________________________________________ saag mailing list [email-masked]<mailto:[email-masked]> https://www.ietf.org/mailman/listinfo/saag

---

From: Ludovic Perret <[email-masked]>
Date: Wed, 29 Sep 2021 15:50:54 +0000

Hi,

------ Message d'origine ------
De: "Kampanakis, Panos" <kpanos=[email-masked]<mailto:kpanos=[email-masked]>>
À: "Roman Danyliw" <[email-masked]<mailto:[email-masked]>>; "Benjamin Kaduk" <[email-masked]<mailto:[email-masked]>>
Cc : "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Envoyé : 29/09/2021 16:42:28
Objet : Re: [saag] About the "Draft text for a PQ Maintenance WG"

Hi Roman, Ben,

++1.

Best Regards,

Ludovic,

Thx,
Panos

From: saag <[email-masked]<mailto:[email-masked]>> On Behalf Of Kampanakis, Panos
Sent: Thursday, August 5, 2021 10:46 PM
To: Roman Danyliw <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: RE: [EXTERNAL] [saag] About the "Draft text for a PQ Maintenance WG"

Hi Yaron.

Thanks.  I made the edit.

Roman

Hi Roman,

Thanks,
                Yaron

Hi Yaron!

Regards,
Roman

Thanks,
                Yaron

Dear,

Ludovic Perret,

---

From: "Salz, Rich" <[email-masked]>
Date: Wed, 29 Sep 2021 16:41:10 +0000

I find the concept of post-quantum *maintenance* very strange.

---

From: "Kampanakis, Panos" <[email-masked]>
Date: Wed, 29 Sep 2021 16:53:18 +0000

Maybe maintenance is the wrong word, but the point is to have a WG for orphaned (without a WG) protocols like CURDLE was for Curve25519/448.

From: saag <[email-masked]> On Behalf Of Salz, Rich
Sent: Wednesday, September 29, 2021 12:41 PM
To: Ludovic Perret <[email-masked]>; Roman Danyliw <[email-masked]>; Benjamin Kaduk <[email-masked]>; [email-masked]
Cc: Kampanakis, Panos <kpanos=[email-masked]>
Subject: RE: [EXTERNAL] [saag] About the "Draft text for a PQ Maintenance WG"

---

From: Roman Danyliw <[email-masked]>
Date: Wed, 29 Sep 2021 18:23:05 +0000

Hi!

We’ve heard this confusion on using the “maintenance” short hand to characterize this potential body of work.  The intent was what Panos described – a short hand where the “maintenance” was on existing IETF protocol to allow it to benefit from PQC mechanisms.

The proposed, templated charter language more precisely captures the intent -- “The [Planned WG Name] working group ([Planned WG Acronym]) is chartered as a WG to analyze, adapt or update IETF protocols, registries, and associated code points with PQ cryptographic mechanisms.” (https://github.com/rdanyliw/ietf-pq-maintenance/blob/main/pqm-charter.md).  I’ve removed “PQ maintenance” from the header of the templated charter.  It now reads “PQC Agility WG”.  The term didn’t appear in the charter text itself.  However, to eliminate all possible confusion I also the one instance of maintenance by s/protocol maintenance/protocol changes/.

Roman

From: Kampanakis, Panos <[email-masked]>
Sent: Wednesday, September 29, 2021 12:53 PM
To: Salz, Rich <rsalz=[email-masked]>; Roman Danyliw <[email-masked]>; Benjamin Kaduk <[email-masked]>; [email-masked]
Subject: RE: [saag] About the "Draft text for a PQ Maintenance WG"

From: saag <[email-masked]<mailto:[email-masked]>> On Behalf Of Salz, Rich
Sent: Wednesday, September 29, 2021 12:41 PM
To: Ludovic Perret <[email-masked]<mailto:[email-masked]>>; Roman Danyliw <[email-masked]<mailto:[email-masked]>>; Benjamin Kaduk <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Cc: Kampanakis, Panos <kpanos=[email-masked]<mailto:kpanos=[email-masked]>>
Subject: RE: [EXTERNAL] [saag] About the "Draft text for a PQ Maintenance WG"

---

From: "Salz, Rich" <[email-masked]>
Date: Wed, 29 Sep 2021 18:25:38 +0000

Your changes sound right to me, thanks.