Subject: [saag] Overview of Quantum-Resistant Cryptography

From: John Mattsson <[email-masked]>
Date: Wed, 8 Dec 2021 09:15:45 +0000

Hi,

We felt that there was no comprehensive and up to date overview of quantum-resistant cryptography and decided to write one. How quantum technology will affect security is an area full of snakeoil. We hope this is of interest. Comments welcome.

The full 40-page report can be found on arXiv:
"Quantum-Resistant Cryptography"
https://arxiv.org/abs/2112.00399

A shorter summary of the report can be found in Ericsson Technology Review:
"Quantum technology and its impact on security in mobile networks"
https://www.ericsson.com/en/reports-and-papers/ericsson-technology-review/articles/ensuring-security-in-mobile-networks-post-quantum
Cheers,
John

---

From: Eric Rescorla <[email-masked]>
Date: Wed, 8 Dec 2021 10:17:38 -0800

This is really useful. Thanks for posting it!

-Ekr

On Wed, Dec 8, 2021 at 1:16 AM John Mattsson <john.mattsson=
[email-masked]> wrote:

> Hi,
>
>
>
> We felt that there was no comprehensive and up to date overview of
> quantum-resistant cryptography and decided to write one. How quantum
> technology will affect security is an area full of snakeoil. We hope this
> is of interest. Comments welcome.
>
>
>
> _______________________________________________
> CFRG mailing list
> [email-masked]
> https://www.irtf.org/mailman/listinfo/cfrg
>

---

From: Jean-Michel Combes <[email-masked]>
Date: Fri, 10 Dec 2021 14:01:19 +0100

+1

Thanks!

Best regards,

JMC.

Le mer. 8 déc. 2021 à 19:19, Eric Rescorla <[email-masked]> a écrit :

> saag mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/saag
>

---

From: Florence D <[email-masked]>
Date: Mon, 13 Dec 2021 13:41:27 +0000

Hi John,

Thanks for sharing these; I found the paper a really clear and comprehensive overview of a complex topic.  I particularly like the way that it roots the academic topics in the real world, looking at the developments in post-quantum cryptography and quantum computing alongside the realities of the timelines and the systems we are trying to secure.  The tables comparing the performance of the KEMs and signatures in round 3 of the NIST post-quantum process will be useful references for matching up NIST algorithms with applications and protocols.

People in this group might also be interested in two technical reports which were recently published by ETSI QSC (Quantum Safe Cryptography):

  *   TR 103 616 "Quantum-Safe Signatures" https://www.etsi.org/deliver/etsi_tr/103600_103699/103616/01.01.01_60/tr_103616v010101p.pdf
  *   TR 103 823 "Quantum-Safe Public Key Encryption and Key Encapsulation" https://www.etsi.org/deliver/etsi_tr/103800_103899/103823/01.01.01_60/tr_103823v010101p.pdf
These reports make a good next step after the Ericsson paper.  They aim to give concise descriptions of the schemes remaining in the NIST process, using a consistent notation to help readers understand the similarities and differences between them.

Flo
UK National Cyber Security Centre

From: saag <[email-masked]> On Behalf Of John Mattsson
Sent: 08 December 2021 09:16
To: saag <[email-masked]>; IRTF CFRG <[email-masked]>; [email-masked]
Subject: [saag] Overview of Quantum-Resistant Cryptography

You don't often get email from john.mattsson=[email-masked]. Learn why this is important<http://aka.ms/LearnAboutSenderIdentification>
Hi,

Cheers,
John
This information is exempt under the Freedom of Information Act 2000 (FOIA) and may be exempt under other UK information legislation. Refer any FOIA queries to [email-masked]. All material is UK Crown Copyright (c)

---

From: Hannes Tschofenig <[email-masked]>
Date: Mon, 13 Dec 2021 13:55:23 +0000

Thanks for sharing, John & Flo.

FWIW we have also published a whitepaper on this topic and you can find it here:
https://community.arm.com/arm-research/m/resources/1002

Ciao
Hannes

From: saag <[email-masked]> On Behalf Of Florence D
Sent: Monday, December 13, 2021 2:41 PM
To: John Mattsson <john.mattsson=[email-masked]>; saag <[email-masked]>; IRTF CFRG <[email-masked]>; [email-masked]
Subject: Re: [saag] Overview of Quantum-Resistant Cryptography

Hi John,

Flo

From: saag <[email-masked]<mailto:[email-masked]>> On Behalf Of John Mattsson
Sent: 08 December 2021 09:16
To: saag <[email-masked]<mailto:[email-masked]>>; IRTF CFRG <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: [saag] Overview of Quantum-Resistant Cryptography

You don't often get email from john.mattsson=[email-masked]<mailto:john.mattsson=[email-masked]>. Learn why this is important<http://aka.ms/LearnAboutSenderIdentification>
Hi,

Cheers,
John
This information is exempt under the Freedom of Information Act 2000 (FOIA) and may be exempt under other UK information legislation. Refer any FOIA queries to [email-masked]<mailto:[email-masked]>. All material is UK Crown Copyright (c)
IMPORTANT NOTICE: The contents of this email and any attachments are confidential and may also be privileged. If you are not the intended recipient, please notify the sender immediately and do not disclose the contents to any other person, use it for any purpose, or store or copy the information in any medium. Thank you.