Subject: Re: [saag] About the "Draft text for a PQ Maintenance WG"

From: Roman Danyliw <[email-masked]>
Date: Wed, 23 Mar 2022 12:02:25 +0000

Hi Panos!

No updates.  While there is concrete charter text describing the mechanics of how such a hypothetical WG would operate, it doesn't describe what protocols would be in scope for the initial body of work.  Progress is blocked pending identification of such initial milestones (i.e., what protocols need a PQC re-design but don't have an existing WG to address it).

Feedback continues to be welcome on this list (saag@ietf).  I've been trying to keep a running summary of the PQC work in the IETF at https://trac.ietf.org/trac/sec/wiki/PQCAgility.

Regards,
Roman

> -----Original Message-----
> From: Kampanakis, Panos <[email-masked]>
> Sent: Tuesday, January 25, 2022 11:08 PM
> To: [email-masked]
> Cc: Roman Danyliw <[email-masked]>; Benjamin Kaduk <[email-masked]>
> Subject: RE: [saag] Re: About the "Draft text for a PQ Maintenance WG"
> 
> Hi Roman, Ben,
> 
> Just resurrecting this thread from a few months back.
> 
> Do you know if there will be any updates or progress on this new WG by IETF-
> 113?
> 
> Thanks,
> Panos
> 
> 
> -----Original Message-----
> From: saag <[email-masked]> On Behalf Of Sheehe, Charles J. (GRC-
> LCN0)
> Sent: Thursday, October 14, 2021 8:19 AM
> To: [email-masked]
> Subject: RE: [EXTERNAL] [saag] [EXTERNAL] Re: About the "Draft text for a PQ
> Maintenance WG"
> 
> CAUTION: This email originated from outside of the organization. Do not click
> links or open attachments unless you can confirm the sender and know the
> content is safe.
> 
> 
> 
> Hi
> 
> I think the charter looks fine.
> 
> Thanks
> Chuck
> 
> Charles J. Sheehe III
> Computer Engineer
> Secure Networks, System
> Integration and Test Branch (LCN)
> Glenn Research Center
> 21000 Brookpark Rd
> Cleveland, OH 44135
> [email-masked] Email
> [email-masked] SIPRmail
> Office: 216-433-5179
>      It is not the critic who counts; not the man who points out how the strong
> man stumbles, or where the doer of deeds could have done them better.
> 
>     The credit belongs to the man who is actually in the arena, whose face is
> marred by dust and sweat and blood; who strives valiantly; who errs, who
> comes short again and again, because there is no effort without error and
> shortcoming; but who does actually strive to do the deeds; who knows great
> enthusiasms, the great devotions; who spends himself in a worthy cause; who
> at the best knows in the end the triumph of high achievement, and who at the
> worst, if he fails, at least fails while daring greatly, so that his place shall never
> be with those cold and timid souls who neither know victory nor defeat.
> Theodore Roosevelt
> 
> -----Original Message-----
> From: saag <[email-masked]> On Behalf Of Roman Danyliw
> Sent: Wednesday, September 29, 2021 2:23 PM
> To: Kampanakis, Panos <[email-masked]>; Salz, Rich
> <rsalz=[email-masked]>; Benjamin Kaduk <[email-masked]>;
> [email-masked]
> Subject: [EXTERNAL] Re: [saag] About the "Draft text for a PQ Maintenance
> WG"
> 
> Hi!
> 
> 
> 
> We've heard this confusion on using the "maintenance" short hand to
> characterize this potential body of work.  The intent was what Panos described
> - a short hand where the "maintenance" was on existing IETF protocol to allow
> it to benefit from PQC mechanisms.
> 
> 
> 
> The proposed, templated charter language more precisely captures the intent --
> "The [Planned WG Name] working group ([Planned WG Acronym]) is chartered
> as a WG to analyze, adapt or update IETF protocols, registries, and associated
> code points with PQ cryptographic mechanisms."
> (https://github.com/rdanyliw/ietf-pq-maintenance/blob/main/pqm-charter.md
> <https://gcc02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fgithub.
> com%2Frdanyliw%2Fietf-pq-maintenance%2Fblob%2Fmain%2Fpqm-
> charter.md&data=04%7C01%7CCharles.J.Sheehe%40nasa.gov%7Cd092f22f99e
> c48fe1a1a08d983764e40%7C7005d45845be48ae8140d43da96dd17b%7C0%7
> C0%7C637685366837666194%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4w
> LjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C2000&sdat
> a=mJG8R%2FPW8OcWxEdkDGyJ1P0DxvUhWd2XODuf55oYDSM%3D&reserved
> =0> ).  I've removed "PQ maintenance" from the header of the templated
> charter.  It now reads "PQC Agility WG".  The term didn't appear in the charter
> text itself.  However, to eliminate all possible c  onfusion I also the one instance
> of maintenance by s/protocol maintenance/protocol changes/.
> 
> 
> 
> Roman
> 
> 
> 
> From: Kampanakis, Panos <[email-masked]>
> Sent: Wednesday, September 29, 2021 12:53 PM
> To: Salz, Rich <rsalz=[email-masked]>; Roman Danyliw
> <[email-masked]>; Benjamin Kaduk <[email-masked]>; [email-masked]
> Subject: RE: [saag] About the "Draft text for a PQ Maintenance WG"
> 
> 
> 
> Maybe maintenance is the wrong word, but the point is to have a WG for
> orphaned (without a WG) protocols like CURDLE was for Curve25519/448.
> 
> 
> 
> From: saag <[email-masked] <mailto:[email-masked]> > On
> Behalf Of Salz, Rich
> Sent: Wednesday, September 29, 2021 12:41 PM
> To: Ludovic Perret <[email-masked]
> <mailto:[email-masked]> >; Roman Danyliw
> <[email-masked] <mailto:[email-masked]> >; Benjamin Kaduk <[email-masked]
> <mailto:[email-masked]> >; [email-masked] <mailto:[email-masked]>
> Cc: Kampanakis, Panos <kpanos=[email-masked]
> <mailto:kpanos=[email-masked]> >
> Subject: RE: [EXTERNAL] [saag] About the "Draft text for a PQ Maintenance
> WG"
> 
> 
> 
> CAUTION: This email originated from outside of the organization. Do not click
> links or open attachments unless you can confirm the sender and know the
> content is safe.
> 
> 
> 
> I find the concept of post-quantum *maintenance* very strange.
> 
> 
> 
> 
> 
> _______________________________________________
> saag mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/saag

---

From: Rebecca Guthrie <[email-masked]>
Date: Fri, 25 Mar 2022 11:18:29 +0000

Hi Roman,
		
Thank you for keeping track of the PQ work in IETF (and thanks to Panos for reviving this topic)! Is the PQ activity list something that others are able to update? There is a draft, JSON Encoding for PQ Signatures (draft-prorock-cose-post-quantum-signatures-00), and another newly-uploaded draft, draft-guthrie-ipsecme-ikev2-hybrid-auth, that can be added to the list.

Also- though it is still being worked out which protocols are in the scope of the proposed PQ Agility WG charter, could it be helpful to establish a separate mail-list, as a place to begin these conversations?

Rebecca

-----Original Message-----
From: saag <[email-masked]> On Behalf Of Roman Danyliw
Sent: Wednesday, March 23, 2022 8:02 AM
To: Kampanakis, Panos <[email-masked]>; [email-masked]
Subject: Re: [saag] About the "Draft text for a PQ Maintenance WG"

Hi Panos!

Feedback continues to be welcome on this list (saag@ietf).  I've been trying to keep a running summary of the PQC work in the IETF at https://gcc02.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftrac.ietf.org%2Ftrac%2Fsec%2Fwiki%2FPQCAgility&amp;data=04%7C01%7Crmguthr%40uwe.nsa.gov%7C654932872ddc4f843f7808da0cc51cae%7Cd61e9a6ffc164f848a3e6eeff33e136b%7C0%7C0%7C637836337995913584%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=AoUcD0vWmShCxinFoJRzqq8Mr5z9aIAycqchpMKiIj4%3D&amp;reserved=0.

Regards,
Roman

> Do you know if there will be any updates or progress on this new WG by 
> IETF- 113?
> 
> Thanks,
> Panos
> 
> 
> Subject: RE: [EXTERNAL] [saag] [EXTERNAL] Re: About the "Draft text 
> for a PQ Maintenance WG"
> 
> CAUTION: This email originated from outside of the organization. Do 
> not click links or open attachments unless you can confirm the sender 
> and know the content is safe.
> 
> 
> 
> Hi
> 
>      It is not the critic who counts; not the man who points out how 
> the strong man stumbles, or where the doer of deeds could have done them better.
> 
>     The credit belongs to the man who is actually in the arena, whose 
> face is marred by dust and sweat and blood; who strives valiantly; who 
> errs, who comes short again and again, because there is no effort 
> without error and shortcoming; but who does actually strive to do the 
> deeds; who knows great enthusiasms, the great devotions; who spends 
> himself in a worthy cause; who at the best knows in the end the 
> triumph of high achievement, and who at the worst, if he fails, at 
> least fails while daring greatly, so that his place shall never be with those cold and timid souls who neither know victory nor defeat.
> Theodore Roosevelt
> 
> Subject: [EXTERNAL] Re: [saag] About the "Draft text for a PQ 
> Maintenance WG"
> 
> Hi!
> 
> 
> 
> - a short hand where the "maintenance" was on existing IETF protocol 
> to allow it to benefit from PQC mechanisms.
> 
> 
> 
> The proposed, templated charter language more precisely captures the 
> intent -- "The [Planned WG Name] working group ([Planned WG Acronym]) 
> is chartered as a WG to analyze, adapt or update IETF protocols, 
> registries, and associated code points with PQ cryptographic mechanisms."
> (https://gcc02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fgit
> hub.com%2Frdanyliw%2Fietf-pq-maintenance%2Fblob%2Fmain%2Fpqm-charter.m
> d&amp;data=04%7C01%7Crmguthr%40uwe.nsa.gov%7C654932872ddc4f843f7808da0
> cc51cae%7Cd61e9a6ffc164f848a3e6eeff33e136b%7C0%7C0%7C63783633799591358
> 4%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6
> Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=qmZgx%2BJWwcrKtqD7fwcL2lK43UQa
> 5K0dPkZYl0n2ZGo%3D&amp;reserved=0 
> charter.  It now reads "PQC Agility WG".  The term didn't appear in 
> the charter text itself.  However, to eliminate all possible c  
> onfusion I also the one instance of maintenance by s/protocol maintenance/protocol changes/.
> 
> 
> 
> Roman
> 
> 
> 
> Subject: RE: [EXTERNAL] [saag] About the "Draft text for a PQ 
> Maintenance WG"
> 
> 
> 
> CAUTION: This email originated from outside of the organization. Do 
> not click links or open attachments unless you can confirm the sender 
> and know the content is safe.
> 
> 
> 
> https://gcc02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.
> ietf.org%2Fmailman%2Flistinfo%2Fsaag&amp;data=04%7C01%7Crmguthr%40uwe.
> nsa.gov%7C654932872ddc4f843f7808da0cc51cae%7Cd61e9a6ffc164f848a3e6eeff
> 33e136b%7C0%7C0%7C637836337995913584%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiM
> C4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;s
> data=TjuCPc2ZfiBT39IBiWwjaalTum%2BdDTf8cdHV%2FQo4pN0%3D&amp;reserved=0

_______________________________________________
saag mailing list
[email-masked]
https://gcc02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fsaag&amp;data=04%7C01%7Crmguthr%40uwe.nsa.gov%7C654932872ddc4f843f7808da0cc51cae%7Cd61e9a6ffc164f848a3e6eeff33e136b%7C0%7C0%7C637836337995913584%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=TjuCPc2ZfiBT39IBiWwjaalTum%2BdDTf8cdHV%2FQo4pN0%3D&amp;reserved=0

---

From: Mike Prorock <[email-masked]>
Date: Fri, 25 Mar 2022 09:07:01 -0400

Two items moving forward on this area that I am aware of are:
https://www.ietf.org/id/draft-uni-qsckeys-00.html
and
https://www.ietf.org/id/draft-prorock-cose-post-quantum-signatures-00.html

As I am working directly on the latter - I can note that we have been
receiving good engagement on the topic in the COSE WG, but due to the
current stage of NIST review we could see some slowdowns as a result.

Mike Prorock
CTO, Founder
https://mesur.io/

On Wed, Mar 23, 2022 at 8:03 AM Roman Danyliw <[email-masked]> wrote:

> Hi Panos!
>
> No updates.  While there is concrete charter text describing the mechanics
> of how such a hypothetical WG would operate, it doesn't describe what
> protocols would be in scope for the initial body of work.  Progress is
> blocked pending identification of such initial milestones (i.e., what
> protocols need a PQC re-design but don't have an existing WG to address it).
>
> Feedback continues to be welcome on this list (saag@ietf).  I've been
> trying to keep a running summary of the PQC work in the IETF at
> https://trac.ietf.org/trac/sec/wiki/PQCAgility.
>
> Regards,
> Roman
>
> IETF-
> face is
> intent --
> > (
> https://github.com/rdanyliw/ietf-pq-maintenance/blob/main/pqm-charter.md
> > <
> https://gcc02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fgithub.

---

From: Mike Prorock <[email-masked]>
Date: Fri, 25 Mar 2022 09:08:17 -0400

Email crossed - yes, thank you Rebecca - we are actively working on the PQC
Signature side of things with some great support from a variety of
parties.  Getting a defined list as this is an evolving space would be
great.

Mike Prorock
CTO, Founder
https://mesur.io/

On Fri, Mar 25, 2022 at 7:19 AM Rebecca Guthrie <rmguthr=
[email-masked]> wrote:

> Hi Roman,
>
> Thank you for keeping track of the PQ work in IETF (and thanks to Panos
> for reviving this topic)! Is the PQ activity list something that others are
> able to update? There is a draft, JSON Encoding for PQ Signatures
> (draft-prorock-cose-post-quantum-signatures-00), and another newly-uploaded
> draft, draft-guthrie-ipsecme-ikev2-hybrid-auth, that can be added to the
> list.
>
> Also- though it is still being worked out which protocols are in the scope
> of the proposed PQ Agility WG charter, could it be helpful to establish a
> separate mail-list, as a place to begin these conversations?
>
> Rebecca
>
> https://gcc02.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftrac.ietf.org%2Ftrac%2Fsec%2Fwiki%2FPQCAgility&amp;data=04%7C01%7Crmguthr%40uwe.nsa.gov%7C654932872ddc4f843f7808da0cc51cae%7Cd61e9a6ffc164f848a3e6eeff33e136b%7C0%7C0%7C637836337995913584%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=AoUcD0vWmShCxinFoJRzqq8Mr5z9aIAycqchpMKiIj4%3D&amp;reserved=0
> .
>
> Regards,
> Roman
>
> > least fails while daring greatly, so that his place shall never be with
> those cold and timid souls who neither know victory nor defeat.
> > Theodore Roosevelt
> >

---

From: "Kampanakis, Panos" <[email-masked]>
Date: Sat, 26 Mar 2022 03:36:59 +0000

Thanks for the update Roman.

FWIW, I will repeat that imo the new WG's charter should include SSH initially. CURDLE ended up focusing on SSH as well. If participants want to focus on more orphaned protocols for PQ migration then we could add DNSSEC, JSON Signatures, Kerberos or more. CURDLE initially wanted to focus one some of those as well, but it ended up working only on SSH. So, the new WG could start small and update the charter as necessary. SSH is a good chunk of work in itself. 

Please note that NIST Round 3 will pick its first KEM in the next couple of weeks and it would benefit the community to bring PQ-hybrid and auth to SSH like other WGs are doing for IKEv2 and (D)TLS already.

Rgs,
Panos

-----Original Message-----
From: Roman Danyliw <[email-masked]> 
Sent: Wednesday, March 23, 2022 8:02 AM
To: Kampanakis, Panos <[email-masked]>; [email-masked]
Cc: Benjamin Kaduk <[email-masked]>
Subject: RE: [EXTERNAL] [saag] Re: About the "Draft text for a PQ Maintenance WG"

CAUTION: This email originated from outside of the organization. Do not click links or open attachments unless you can confirm the sender and know the content is safe.

Hi Panos!

Regards,
Roman

---

From: "Kampanakis, Panos" <[email-masked]>
Date: Sat, 26 Mar 2022 03:46:41 +0000

Hi Mike, Rebecca,

As much I would like for this new WG to be formed, I am of the opinion that if these two work items have a good existing WG, they should be worked there.

To me, it seems that draft-guthrie-ipsecme-ikev2-hybrid-auth belongs to IPSECME, draft-becker-guthrie-cert-binding-for-multi-auth belongs to LAMPS, draft-becker-guthrie-noncomposite-hybrid-auth<https://datatracker.ietf.org/doc/draft-becker-guthrie-noncomposite-hybrid-auth>  belongs to TLS or LAMPS, draft-uni-qsckeys-00<https://www.ietf.org/id/draft-uni-qsckeys-00.html> belongs to LAMPS and draft-prorock-cose-post-quantum-signatures belongs to COSE. It is always better to bring drafts to their corresponding areas of expertise if it exists as that would guarantee the quality of a draft.

Personally, I think the new PQ WG should focus on areas whose WGs have concluded and are currently orphan from an IETF WG.

Rgs,
Panos

From: saag <[email-masked]> On Behalf Of Mike Prorock
Sent: Friday, March 25, 2022 9:08 AM
To: Rebecca Guthrie <rmguthr=[email-masked]>
Cc: [email-masked]
Subject: RE: [EXTERNAL] [saag] About the "Draft text for a PQ Maintenance WG"

Email crossed - yes, thank you Rebecca - we are actively working on the PQC Signature side of things with some great support from a variety of parties.  Getting a defined list as this is an evolving space would be great.

Mike Prorock
CTO, Founder
https://mesur.io/

On Fri, Mar 25, 2022 at 7:19 AM Rebecca Guthrie <rmguthr=[email-masked]<mailto:[email-masked]>> wrote:
Hi Roman,

Rebecca

-----Original Message-----
From: saag <[email-masked]<mailto:[email-masked]>> On Behalf Of Roman Danyliw
Sent: Wednesday, March 23, 2022 8:02 AM
To: Kampanakis, Panos <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: [saag] About the "Draft text for a PQ Maintenance WG"

Hi Panos!

Regards,
Roman

> From: Kampanakis, Panos <[email-masked]<mailto:[email-masked]>>
> To: [email-masked]<mailto:[email-masked]>
> Cc: Roman Danyliw <[email-masked]<mailto:[email-masked]>>; Benjamin Kaduk <[email-masked]<mailto:[email-masked]>>
> From: saag <[email-masked]<mailto:[email-masked]>> On Behalf Of Sheehe, Charles J.
> (GRC-
> LCN0)
> To: [email-masked]<mailto:[email-masked]>
> [email-masked]<mailto:[email-masked]> Email
> [email-masked]<mailto:[email-masked]> SIPRmail
> Office: 216-433-5179
> From: saag <[email-masked]<mailto:[email-masked]>> On Behalf Of Roman Danyliw
> To: Kampanakis, Panos <[email-masked]<mailto:[email-masked]>>; Salz, Rich
> <rsalz=[email-masked]<mailto:[email-masked]>>; Benjamin Kaduk <[email-masked]<mailto:[email-masked]>>;
> [email-masked]<mailto:[email-masked]>
> hub.com<http://hub.com>%2Frdanyliw%2Fietf-pq-maintenance%2Fblob%2Fmain%2Fpqm-charter.m
> d&amp;data=04%7C01%7Crmguthr%40uwe.nsa.gov<http://40uwe.nsa.gov>%7C654932872ddc4f843f7808da0
> charter.md&data=04%7C01%7CCharles.J.Sheehe%40nasa.gov<http://40nasa.gov>%7Cd092f22f99e
> From: Kampanakis, Panos <[email-masked]<mailto:[email-masked]>>
> To: Salz, Rich <rsalz=[email-masked]<mailto:[email-masked]>>; Roman Danyliw
> <[email-masked]<mailto:[email-masked]>>; Benjamin Kaduk <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
> From: saag <[email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>> > On
> Behalf Of Salz, Rich
> To: Ludovic Perret <[email-masked]<mailto:[email-masked]>
> <mailto:[email-masked]<mailto:[email-masked]>> >; Roman Danyliw
> <[email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>> >; Benjamin Kaduk <[email-masked]<mailto:[email-masked]>
> <mailto:[email-masked]<mailto:[email-masked]>> >; [email-masked]<mailto:[email-masked]> <mailto:[email-masked]<mailto:[email-masked]>>
> Cc: Kampanakis, Panos <kpanos=[email-masked]<mailto:[email-masked]>
> <mailto:kpanos<mailto:kpanos>=[email-masked]<mailto:[email-masked]>> >
> [email-masked]<mailto:[email-masked]>
> ietf.org<http://ietf.org>%2Fmailman%2Flistinfo%2Fsaag&amp;data=04%7C01%7Crmguthr%40uwe.
> nsa.gov<http://nsa.gov>%7C654932872ddc4f843f7808da0cc51cae%7Cd61e9a6ffc164f848a3e6eeff

_______________________________________________
saag mailing list
[email-masked]<mailto:[email-masked]>
https://gcc02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fsaag&amp;data=04%7C01%7Crmguthr%40uwe.nsa.gov%7C654932872ddc4f843f7808da0cc51cae%7Cd61e9a6ffc164f848a3e6eeff33e136b%7C0%7C0%7C637836337995913584%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=TjuCPc2ZfiBT39IBiWwjaalTum%2BdDTf8cdHV%2FQo4pN0%3D&amp;reserved=0

_______________________________________________
saag mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/saag

---

From: Rebecca Guthrie <[email-masked]>
Date: Sun, 27 Mar 2022 22:04:46 +0000

Hi Panos,

Yes, I agree that the drafts do all belong to those respective working groups. To clarify, I only meant to suggest that these drafts be added to the list of PQ work in IETF at https://trac.ietf.org/trac/sec/wiki/PQCAgility, not that these become work items for the PQ WG.

Rebecca

From: saag <[email-masked]> On Behalf Of Kampanakis, Panos
Sent: Friday, March 25, 2022 11:47 PM
To: Mike Prorock <[email-masked]>; Rebecca Guthrie <rmguthr=[email-masked]>
Cc: [email-masked]
Subject: Re: [saag] About the "Draft text for a PQ Maintenance WG"

Hi Mike, Rebecca,

To me, it seems that draft-guthrie-ipsecme-ikev2-hybrid-auth belongs to IPSECME, draft-becker-guthrie-cert-binding-for-multi-auth belongs to LAMPS, draft-becker-guthrie-noncomposite-hybrid-auth<https://gcc02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-becker-guthrie-noncomposite-hybrid-auth&data=04%7C01%7Crmguthr%40uwe.nsa.gov%7C4abca524b0c5431de41e08da0edb5e5e%7Cd61e9a6ffc164f848a3e6eeff33e136b%7C0%7C0%7C637838632639524961%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=pf5tYMyCs2tvlrq1%2FTgle1HwETftYMBNl1EYUVhKxWU%3D&reserved=0>  belongs to TLS or LAMPS, draft-uni-qsckeys-00<https://gcc02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fid%2Fdraft-uni-qsckeys-00.html&data=04%7C01%7Crmguthr%40uwe.nsa.gov%7C4abca524b0c5431de41e08da0edb5e5e%7Cd61e9a6ffc164f848a3e6eeff33e136b%7C0%7C0%7C637838632639524961%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=2OKMHoYrceU%2BBbIOMcn6jJeSVPFKdE5IS%2F5%2F1IYrsV0%3D&reserved=0> belongs to LAMPS and draft-prorock-cose-post-quantum-signatures belongs to COSE. It is always better to bring drafts to their corresponding areas of expertise if it exists as that would guarantee the quality of a draft.

Rgs,
Panos

From: saag <[email-masked]<mailto:[email-masked]>> On Behalf Of Mike Prorock
Sent: Friday, March 25, 2022 9:08 AM
To: Rebecca Guthrie <rmguthr=[email-masked]<mailto:rmguthr=[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>
Subject: RE: [EXTERNAL] [saag] About the "Draft text for a PQ Maintenance WG"

Mike Prorock
CTO, Founder
https://mesur.io/<https://gcc02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fmesur.io%2F&data=04%7C01%7Crmguthr%40uwe.nsa.gov%7C4abca524b0c5431de41e08da0edb5e5e%7Cd61e9a6ffc164f848a3e6eeff33e136b%7C0%7C0%7C637838632639680751%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=r1CFZbUj7O%2BNo6JVlgbYcE77PdxFFTUq4G4FVkt9thg%3D&reserved=0>

Rebecca

-----Original Message-----
From: saag <[email-masked]<mailto:[email-masked]>> On Behalf Of Roman Danyliw
Sent: Wednesday, March 23, 2022 8:02 AM
To: Kampanakis, Panos <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: [saag] About the "Draft text for a PQ Maintenance WG"

Hi Panos!

Feedback continues to be welcome on this list (saag@ietf).  I've been trying to keep a running summary of the PQC work in the IETF at https://gcc02.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftrac.ietf.org%2Ftrac%2Fsec%2Fwiki%2FPQCAgility&amp;data=04%7C01%7Crmguthr%40uwe.nsa.gov%7C654932872ddc4f843f7808da0cc51cae%7Cd61e9a6ffc164f848a3e6eeff33e136b%7C0%7C0%7C637836337995913584%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=AoUcD0vWmShCxinFoJRzqq8Mr5z9aIAycqchpMKiIj4%3D&amp;reserved=0<https://gcc02.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftrac.ietf.org%2Ftrac%2Fsec%2Fwiki%2FPQCAgility&data=04%7C01%7Crmguthr%40uwe.nsa.gov%7C4abca524b0c5431de41e08da0edb5e5e%7Cd61e9a6ffc164f848a3e6eeff33e136b%7C0%7C0%7C637838632639680751%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=Jp7ToDJOJsfpZrIDybklkD1iayyQM4g%2FogDC4VgEoE8%3D&reserved=0>.

Regards,
Roman

> hub.com<https://gcc02.safelinks.protection.outlook.com/?url=http%3A%2F%2Fhub.com%2F&data=04%7C01%7Crmguthr%40uwe.nsa.gov%7C4abca524b0c5431de41e08da0edb5e5e%7Cd61e9a6ffc164f848a3e6eeff33e136b%7C0%7C0%7C637838632639680751%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=U7FU4%2Bg0bapKdyEdbnWElj1k8pOASikrqSq1zh%2Ft6yU%3D&reserved=0>%2Frdanyliw%2Fietf-pq-maintenance%2Fblob%2Fmain%2Fpqm-charter.m
> d&amp;data=04%7C01%7Crmguthr%40uwe.nsa.gov<https://gcc02.safelinks.protection.outlook.com/?url=http%3A%2F%2F40uwe.nsa.gov%2F&data=04%7C01%7Crmguthr%40uwe.nsa.gov%7C4abca524b0c5431de41e08da0edb5e5e%7Cd61e9a6ffc164f848a3e6eeff33e136b%7C0%7C0%7C637838632639680751%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=fbB5kjBISa7D9stg%2F%2BjJ8BgKBlp4%2BW%2BHuRZZgDqa4BI%3D&reserved=0>%7C654932872ddc4f843f7808da0
> charter.md&data=04%7C01%7CCharles.J.Sheehe%40nasa.gov<https://gcc02.safelinks.protection.outlook.com/?url=http%3A%2F%2F40nasa.gov%2F&data=04%7C01%7Crmguthr%40uwe.nsa.gov%7C4abca524b0c5431de41e08da0edb5e5e%7Cd61e9a6ffc164f848a3e6eeff33e136b%7C0%7C0%7C637838632639680751%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=omqhdtvGKjzrujW9dH0F2C2oJPXj5gzvbmixu%2BVvTwk%3D&reserved=0>%7Cd092f22f99e
> ietf.org<https://gcc02.safelinks.protection.outlook.com/?url=http%3A%2F%2Fietf.org%2F&data=04%7C01%7Crmguthr%40uwe.nsa.gov%7C4abca524b0c5431de41e08da0edb5e5e%7Cd61e9a6ffc164f848a3e6eeff33e136b%7C0%7C0%7C637838632639680751%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=Di9mRiVDvRWeW2QkqP7BGbITf1dks%2Bf6I33tahu3oa0%3D&reserved=0>%2Fmailman%2Flistinfo%2Fsaag&amp;data=04%7C01%7Crmguthr%40uwe.
> nsa.gov<https://gcc02.safelinks.protection.outlook.com/?url=http%3A%2F%2Fnsa.gov%2F&data=04%7C01%7Crmguthr%40uwe.nsa.gov%7C4abca524b0c5431de41e08da0edb5e5e%7Cd61e9a6ffc164f848a3e6eeff33e136b%7C0%7C0%7C637838632639680751%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=BvPCxySWH196MT6KsNrb0foGlARNHppunQ6SkBERDjc%3D&reserved=0>%7C654932872ddc4f843f7808da0cc51cae%7Cd61e9a6ffc164f848a3e6eeff

_______________________________________________
saag mailing list
[email-masked]<mailto:[email-masked]>
https://gcc02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fsaag&amp;data=04%7C01%7Crmguthr%40uwe.nsa.gov%7C654932872ddc4f843f7808da0cc51cae%7Cd61e9a6ffc164f848a3e6eeff33e136b%7C0%7C0%7C637836337995913584%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&amp;sdata=TjuCPc2ZfiBT39IBiWwjaalTum%2BdDTf8cdHV%2FQo4pN0%3D&amp;reserved=0<https://gcc02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fsaag&data=04%7C01%7Crmguthr%40uwe.nsa.gov%7C4abca524b0c5431de41e08da0edb5e5e%7Cd61e9a6ffc164f848a3e6eeff33e136b%7C0%7C0%7C637838632639680751%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=RS59DTNrKrARsJQ%2Fjoy3eaX50L%2BJBhSMuA5X8VXkrSg%3D&reserved=0>

_______________________________________________
saag mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/saag<https://gcc02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fsaag&data=04%7C01%7Crmguthr%40uwe.nsa.gov%7C4abca524b0c5431de41e08da0edb5e5e%7Cd61e9a6ffc164f848a3e6eeff33e136b%7C0%7C0%7C637838632639680751%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=RS59DTNrKrARsJQ%2Fjoy3eaX50L%2BJBhSMuA5X8VXkrSg%3D&reserved=0>

---

From: Mike Prorock <[email-masked]>
Date: Mon, 28 Mar 2022 08:18:58 -0400

+1 Rebecca - add to list on the wiki
Mailing list on PQC could be helpful as there are topics that cross WGs.

Panos,
I do think there are items that will arise (or that are arising) that might
ot cleanly fit into one of the existing WGs which I believe you
were referring to and finding a home and an approach will likely be needed.

Mike Prorock
CTO, Founder
https://mesur.io/

On Sun, Mar 27, 2022 at 6:05 PM Rebecca Guthrie <rmguthr=
[email-masked]> wrote:

> Hi Panos,
>
>
>
> Yes, I agree that the drafts do all belong to those respective working
> groups. To clarify, I only meant to suggest that these drafts be added to
> the list of PQ work in IETF at
> https://trac.ietf.org/trac/sec/wiki/PQCAgility, not that these become
> work items for the PQ WG.
>
>
>
> Rebecca
>
>
>
> *From:* saag <[email-masked]> *On Behalf Of * Kampanakis, Panos
> *Sent:* Friday, March 25, 2022 11:47 PM
> *To:* Mike Prorock <[email-masked]>; Rebecca Guthrie <rmguthr=
> [email-masked]>
> *Cc:* [email-masked]
> *Subject:* Re: [saag] About the "Draft text for a PQ Maintenance WG"
>
>
>
> Hi Mike, Rebecca,
>
>
>
> As much I would like for this new WG to be formed, I am of the opinion
> that if these two work items have a good existing WG, they should be worked
> there.
>
>
>
> To me, it seems that draft-guthrie-ipsecme-ikev2-hybrid-auth belongs to
> IPSECME, draft-becker-guthrie-cert-binding-for-multi-auth belongs to
> LAMPS, draft-becker-guthrie-noncomposite-hybrid-auth
> <https://gcc02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-becker-guthrie-noncomposite-hybrid-auth&data=04%7C01%7Crmguthr%40uwe.nsa.gov%7C4abca524b0c5431de41e08da0edb5e5e%7Cd61e9a6ffc164f848a3e6eeff33e136b%7C0%7C0%7C637838632639524961%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=pf5tYMyCs2tvlrq1%2FTgle1HwETftYMBNl1EYUVhKxWU%3D&reserved=0>
>  belongs to TLS or LAMPS, draft-uni-qsckeys-00
> <https://gcc02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fid%2Fdraft-uni-qsckeys-00.html&data=04%7C01%7Crmguthr%40uwe.nsa.gov%7C4abca524b0c5431de41e08da0edb5e5e%7Cd61e9a6ffc164f848a3e6eeff33e136b%7C0%7C0%7C637838632639524961%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=2OKMHoYrceU%2BBbIOMcn6jJeSVPFKdE5IS%2F5%2F1IYrsV0%3D&reserved=0>
> belongs to LAMPS and draft-prorock-cose-post-quantum-signatures belongs to
> COSE. It is always better to bring drafts to their corresponding areas of
> expertise if it exists as that would guarantee the quality of a draft.
>
>
>
> Personally, I think the new PQ WG should focus on areas whose WGs have
> concluded and are currently orphan from an IETF WG.
>
>
>
> Rgs,
>
> Panos
>
>
>
>
>
> *From:* saag <[email-masked]> *On Behalf Of *Mike Prorock
> *Sent:* Friday, March 25, 2022 9:08 AM
> *To:* Rebecca Guthrie <rmguthr=[email-masked]>
> *Cc:* [email-masked]
> *Subject:* RE: [EXTERNAL] [saag] About the "Draft text for a PQ
> Maintenance WG"
>
>
>
> *CAUTION*: This email originated from outside of the organization. Do not
> click links or open attachments unless you can confirm the sender and know
> the content is safe.
>
>
>
> Email crossed - yes, thank you Rebecca - we are actively working on the
> PQC Signature side of things with some great support from a variety of
> <https://gcc02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fmesur.io%2F&data=04%7C01%7Crmguthr%40uwe.nsa.gov%7C4abca524b0c5431de41e08da0edb5e5e%7Cd61e9a6ffc164f848a3e6eeff33e136b%7C0%7C0%7C637838632639680751%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=r1CFZbUj7O%2BNo6JVlgbYcE77PdxFFTUq4G4FVkt9thg%3D&reserved=0>
>
>
>
>
>
>
>
> <https://gcc02.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftrac.ietf.org%2Ftrac%2Fsec%2Fwiki%2FPQCAgility&data=04%7C01%7Crmguthr%40uwe.nsa.gov%7C4abca524b0c5431de41e08da0edb5e5e%7Cd61e9a6ffc164f848a3e6eeff33e136b%7C0%7C0%7C637838632639680751%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=Jp7ToDJOJsfpZrIDybklkD1iayyQM4g%2FogDC4VgEoE8%3D&reserved=0>
> .
>
> Regards,
> Roman
>
> > hub.com
> <https://gcc02.safelinks.protection.outlook.com/?url=http%3A%2F%2Fhub.com%2F&data=04%7C01%7Crmguthr%40uwe.nsa.gov%7C4abca524b0c5431de41e08da0edb5e5e%7Cd61e9a6ffc164f848a3e6eeff33e136b%7C0%7C0%7C637838632639680751%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=U7FU4%2Bg0bapKdyEdbnWElj1k8pOASikrqSq1zh%2Ft6yU%3D&reserved=0>
> %2Frdanyliw%2Fietf-pq-maintenance%2Fblob%2Fmain%2Fpqm-charter.m
> > d&amp;data=04%7C01%7Crmguthr%40uwe.nsa.gov
> <https://gcc02.safelinks.protection.outlook.com/?url=http%3A%2F%2F40uwe.nsa.gov%2F&data=04%7C01%7Crmguthr%40uwe.nsa.gov%7C4abca524b0c5431de41e08da0edb5e5e%7Cd61e9a6ffc164f848a3e6eeff33e136b%7C0%7C0%7C637838632639680751%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=fbB5kjBISa7D9stg%2F%2BjJ8BgKBlp4%2BW%2BHuRZZgDqa4BI%3D&reserved=0>
> %7C654932872ddc4f843f7808da0
> > charter.md&data=04%7C01%7CCharles.J.Sheehe%40nasa.gov
> <https://gcc02.safelinks.protection.outlook.com/?url=http%3A%2F%2F40nasa.gov%2F&data=04%7C01%7Crmguthr%40uwe.nsa.gov%7C4abca524b0c5431de41e08da0edb5e5e%7Cd61e9a6ffc164f848a3e6eeff33e136b%7C0%7C0%7C637838632639680751%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=omqhdtvGKjzrujW9dH0F2C2oJPXj5gzvbmixu%2BVvTwk%3D&reserved=0>
> %7Cd092f22f99e
> > ietf.org
> <https://gcc02.safelinks.protection.outlook.com/?url=http%3A%2F%2Fietf.org%2F&data=04%7C01%7Crmguthr%40uwe.nsa.gov%7C4abca524b0c5431de41e08da0edb5e5e%7Cd61e9a6ffc164f848a3e6eeff33e136b%7C0%7C0%7C637838632639680751%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=Di9mRiVDvRWeW2QkqP7BGbITf1dks%2Bf6I33tahu3oa0%3D&reserved=0>
> %2Fmailman%2Flistinfo%2Fsaag&amp;data=04%7C01%7Crmguthr%40uwe.
> > nsa.gov
> <https://gcc02.safelinks.protection.outlook.com/?url=http%3A%2F%2Fnsa.gov%2F&data=04%7C01%7Crmguthr%40uwe.nsa.gov%7C4abca524b0c5431de41e08da0edb5e5e%7Cd61e9a6ffc164f848a3e6eeff33e136b%7C0%7C0%7C637838632639680751%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=BvPCxySWH196MT6KsNrb0foGlARNHppunQ6SkBERDjc%3D&reserved=0>
> %7C654932872ddc4f843f7808da0cc51cae%7Cd61e9a6ffc164f848a3e6eeff
> <https://gcc02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fsaag&data=04%7C01%7Crmguthr%40uwe.nsa.gov%7C4abca524b0c5431de41e08da0edb5e5e%7Cd61e9a6ffc164f848a3e6eeff33e136b%7C0%7C0%7C637838632639680751%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=RS59DTNrKrARsJQ%2Fjoy3eaX50L%2BJBhSMuA5X8VXkrSg%3D&reserved=0>
>
> <https://gcc02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fsaag&data=04%7C01%7Crmguthr%40uwe.nsa.gov%7C4abca524b0c5431de41e08da0edb5e5e%7Cd61e9a6ffc164f848a3e6eeff33e136b%7C0%7C0%7C637838632639680751%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=RS59DTNrKrARsJQ%2Fjoy3eaX50L%2BJBhSMuA5X8VXkrSg%3D&reserved=0>
>

---

From: Christine Cloostermans <[email-masked]>
Date: Mon, 28 Mar 2022 16:49:02 +0200

Hi all,

I am unsure whether the WG makes sense unless there are specific uncovered
work items, but I do think it makes sense to have a platform where such
work items can be identified.
Since PQC is a topic that will touch so many areas, I think it makes sense
if there is a place to zoom out and look at the big picture for missing
items.

In this regard, the wiki is a very good and useful initiative, and I think
a mailing list where discussion can be held, like whether work is being
done in a certain area, which WG would be a natural home, whether the wiki
needs to be updated, and whether there are work items uncovered by another
workgroup, might be a good solution as well.
Then if the latter in this list is the case, then a WG can still be
discussed at that time?

Just my two cents, cheers,

Christine Cloostermans

Op ma 28 mrt. 2022 om 14:19 schreef Mike Prorock <[email-masked]>:

> I do think there are items that will arise (or that are arising) that
> might ot cleanly fit into one of the existing WGs which I believe you
>> *CAUTION*: This email originated from outside of the organization. Do
>> not click links or open attachments unless you can confirm the sender and
>> know the content is safe.
>>
>>
>>
>> Also- though it is still being worked out which protocols are in the
>> scope of the proposed PQ Agility WG charter, could it be helpful to
>> establish a separate mail-list, as a place to begin these conversations?
>>
>> Rebecca
>>
>> No updates.  While there is concrete charter text describing the
>> mechanics of how such a hypothetical WG would operate, it doesn't describe
>> what protocols would be in scope for the initial body of work.  Progress is

---

From: "Kampanakis, Panos" <[email-masked]>
Date: Tue, 29 Mar 2022 03:11:21 +0000

> Then if the latter in this list is the case, then a WG can still be discussed at that time?

So let me ask the question again then. TLS, LAMPS and IPSECME WG’s are working on PQ Key Exchange TLS, PQ X.509/CMS and and PQ IKEv2 respectively. COSE maybe be picking up PQ Sig for JWS.
Which WG will pick up PQ-hybrid key exchange and PQ auth for SSH?

From: saag <[email-masked]> On Behalf Of Christine Cloostermans
Sent: Monday, March 28, 2022 10:49 AM
To: Mike Prorock <[email-masked]>
Cc: [email-masked]; Rebecca Guthrie <rmguthr=[email-masked]>; Kampanakis, Panos <kpanos=[email-masked]>
Subject: RE: [EXTERNAL] [saag] About the "Draft text for a PQ Maintenance WG"

Hi all,

I am unsure whether the WG makes sense unless there are specific uncovered work items, but I do think it makes sense to have a platform where such work items can be identified.
Since PQC is a topic that will touch so many areas, I think it makes sense if there is a place to zoom out and look at the big picture for missing items.

In this regard, the wiki is a very good and useful initiative, and I think a mailing list where discussion can be held, like whether work is being done in a certain area, which WG would be a natural home, whether the wiki needs to be updated, and whether there are work items uncovered by another workgroup, might be a good solution as well.
Then if the latter in this list is the case, then a WG can still be discussed at that time?

Christine Cloostermans

Op ma 28 mrt. 2022 om 14:19 schreef Mike Prorock <[email-masked]<mailto:[email-masked]>>:
+1 Rebecca - add to list on the wiki
Mailing list on PQC could be helpful as there are topics that cross WGs.

Panos,
I do think there are items that will arise (or that are arising) that might ot cleanly fit into one of the existing WGs which I believe you were referring to and finding a home and an approach will likely be needed.

Mike Prorock
CTO, Founder
https://mesur.io/

On Sun, Mar 27, 2022 at 6:05 PM Rebecca Guthrie <rmguthr=[email-masked]<mailto:[email-masked]>> wrote:
Hi Panos,

Rebecca

From: saag <[email-masked]<mailto:[email-masked]>> On Behalf Of Kampanakis, Panos
Sent: Friday, March 25, 2022 11:47 PM
To: Mike Prorock <[email-masked]<mailto:[email-masked]>>; Rebecca Guthrie <rmguthr=[email-masked]<mailto:[email-masked]>>
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [saag] About the "Draft text for a PQ Maintenance WG"

Hi Mike, Rebecca,

To me, it seems that draft-guthrie-ipsecme-ikev2-hybrid-auth belongs to IPSECME, draft-becker-guthrie-cert-binding-for-multi-auth<http://draft-becker-guthrie-cert-binding-for-multi-auth> belongs to LAMPS, draft-becker-guthrie-noncomposite-hybrid-auth<https://gcc02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-becker-guthrie-noncomposite-hybrid-auth&data=04%7C01%7Crmguthr%40uwe.nsa.gov%7C4abca524b0c5431de41e08da0edb5e5e%7Cd61e9a6ffc164f848a3e6eeff33e136b%7C0%7C0%7C637838632639524961%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=pf5tYMyCs2tvlrq1%2FTgle1HwETftYMBNl1EYUVhKxWU%3D&reserved=0>  belongs to TLS or LAMPS, draft-uni-qsckeys-00<https://gcc02.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fid%2Fdraft-uni-qsckeys-00.html&data=04%7C01%7Crmguthr%40uwe.nsa.gov%7C4abca524b0c5431de41e08da0edb5e5e%7Cd61e9a6ffc164f848a3e6eeff33e136b%7C0%7C0%7C637838632639524961%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C3000&sdata=2OKMHoYrceU%2BBbIOMcn6jJeSVPFKdE5IS%2F5%2F1IYrsV0%3D&reserved=0> belongs to LAMPS and draft-prorock-cose-post-quantum-signatures belongs to COSE. It is always better to bring drafts to their corresponding areas of expertise if it exists as that would guarantee the quality of a draft.

Rgs,
Panos

Mike Prorock
CTO, Founder

Rebecca

-----Original Message-----
From: saag <[email-masked]<mailto:[email-masked]>> On Behalf Of Roman Danyliw
Sent: Wednesday, March 23, 2022 8:02 AM
To: Kampanakis, Panos <[email-masked]<mailto:[email-masked]>>; [email-masked]<mailto:[email-masked]>
Subject: Re: [saag] About the "Draft text for a PQ Maintenance WG"

Hi Panos!

Regards,
Roman