Subject: Re: [SAM] Minutes & Slides

From: "KELLIL Mounir" <[email-masked]>
Date: Wed, 18 Aug 2010 16:17:23 +0200

Dear Thomas and all,

Thanks for the minutes of the last SAMRG session,

I would like to clarify some points related to MTOCP protocol, raised during the last meeting. Please find my comments below.

- Question from Joerg Ott: The previous work of UDP Multicast Tunneling Protocol (UMTP) seems to describe all techniques you have mentioned, it seems like you're tunneling?

[MK] UMTP tunnels multicast UDP datagrams inside unicast UDP datagrams. So, as said Alexandru, our protocol does not use such a tunneling. Instead, in our ptotocol if a link is unicast only, then the IP header of the packet to be formwarded through that link will have a unciast destination address (and, there will be no other IP header for that packet). Of course, UDP header is used for data transport.  So, there is no tunneling at all in MTOCP; i.e., no multicast-in-unicast tunneling, no IP-in-IP tunneling, no double UDP headers...
In MTOCP, the overlay node (ON) "translates"  any multicast packet to be forwarded into a unicast packet if the output link is unicast only.

- Question from Thomas Schmidt: Is dynamic configuration of the tree planed?

[MK] MTO-Ctrl can be used to configure dynamically the overlay tree using the three commands we defined (commands sent from MTO-Ctrl to ON). Yet, MTO-Ctrl does not integrate/define any triggers for such commands. The triggers are part of an external module, which in our testbed is SIP-based.

- Lichun Li: How does a host join the group?

[MK] Via IGMP/MLD in multicast. Via SIP-based exchange with session manager (external module) in unicast. MTO-Ctrl is not aware of hosts. It does not interact with hosts either.

Your comments are welcome

Best regards

Mounir

> -----Message d'origine-----
> De : [email-masked] [mailto:[email-masked]] De la part de
> Thomas C. Schmidt
> Envoyé : vendredi 30 juillet 2010 13:34
> À : sam
> Objet : [SAM] Minutes & Slides
> 
> Hi all,
> 
> the minutes & all presentations are online now, please see
> http://datatracker.ietf.org/meeting/78/materials.html#wg-SAMRG
> 
> Cheers,
> 
> Thomas
> --
> 
> Prof. Dr. Thomas C. Schmidt
> ° Hamburg University of Applied Sciences                   Berliner Tor 7
> °
> ° Dept. Informatik, Internet Technologies Group    20099 Hamburg, Germany
> °
> ° http://www.haw-hamburg.de/inet                   Fon: +49-40-42875-8452
> °
> ° http://www.informatik.haw-hamburg.de/~schmidt    Fax: +49-40-42875-8409
> °
> _______________________________________________
> SAM mailing list
> [email-masked]
> http://www.irtf.org/mailman/listinfo/sam

---

From: "KELLIL Mounir" <[email-masked]>
Date: Thu, 19 Aug 2010 12:37:59 +0200

Hi Lichun,

Please find below my comments

________________________________

MTO controller must know all hosts in the multicast group, right? 

[MK] No. Actually, the MTO-Ctrl knows the topology of the MTO tree in terms of ONs and maintains the connection information of this MTO tree (connections between ONs, connection from the source to ON, and connections from ONs to the hosts). If the host is a multicast receiver, MTO-Ctrl will know his multicast address only. MTO-Ctrl, as a functional component, needs to rely on an external module (a SIP-based session manager, in our implementation) that interfaces with the hosts to have a full scenario.      

I also have questions about ON. 
Is ON routing device or server? 

[MK]  As a functional component, the ON needs IP routing to deliver data. ON is routing agnostic, though. So as such, ON can run on a multicast router or, for instance, on a Linux machine with a multicast routing deamon.

Can a host work as an ON? 

[MK] Yes. 

Can a ON serves multiple multicast groups？ 

[MK] Yes. 

Your work is very interesting. Can you give some references about the whole multicast solution? 

[MK] our work is part of a solution described in a technical document (http://www.ict-ccast.eu/files/C-Cast_D13_revised.pdf) of the project C-CAST (http://www.ict-ccast.eu/), which is a 2-year European project that ended a few weeks ago.  

Best regards

Mounir

"KELLIL Mounir" <[email-masked]> 
发件人:  [email-masked] 

2010-08-18 22:17 

收件人

"sam" <[email-masked]> 

抄送

主题

Re: [SAM] Minutes & Slides

Dear Thomas and all,

Best regards

Mounir

 
--------------------------------------------------------
ZTE Information Security Notice: The information contained in this mail is solely property of the sender's organization. This mail communication is confidential. Recipients named above are obligated to maintain secrecy and are not permitted to disclose the contents of this communication to others.
This email and any files transmitted with it are confidential and intended solely for the use of the individual or entity to whom they are addressed. If you have received this email in error please notify the originator of the message. Any views expressed in this message are those of the individual sender.
This message has been scanned for viruses and Spam by ZTE Anti-Spam system.