Subject: [sami] FW: New Version Notification for draft-gu-statemigration-framework-00.txt

From: "Guyingjie (Yingjie)" <[email-masked]>
Date: Wed, 4 Jul 2012 04:06:51 +0000

Hi all,
We just submitted a framework draft for state migration. 

We are looking forward to your comments. Thanks in advance.

Best Regards
Gu Yingjie

-----邮件原件-----
发件人: [email-masked] [mailto:[email-masked]] 
发送时间: 2012年7月4日 乐乐3:05
收件人: [email-masked]
抄送: Guyingjie (Yingjie); [email-masked]
主题: New Version Notification for draft-gu-statemigration-framework-00.txt

A new version of I-D, draft-gu-statemigration-framework-00.txt
has been successfully submitted by Melinda Shore and posted to the
IETF repository.

Filename:	 draft-gu-statemigration-framework
Revision:	 00
Title:		 A Framework and Problem Statement for Flow-associated Middlebox State Migration
Creation date:	 2012-07-03
WG ID:		 Individual Submission
Number of pages: 17
URL:             http://www.ietf.org/internet-drafts/draft-gu-statemigration-framework-00.txt
Status:          http://datatracker.ietf.org/doc/draft-gu-statemigration-framework
Htmlized:        http://tools.ietf.org/html/draft-gu-statemigration-framework-00

Abstract:
   This document presents an initial framework and discussion of the
   problem of transferring middlebox (for example, firewall or NAT)
   flow-coupled state from one middlebox to another while the flow is
   still active.  This has most recently come up in the context of
   virtual machine (VM) migration between hypervisors, but it is a
   problem that has appeared in other situations, as well.  We present
   some of the parameters of the problem, define some language for
   discussing the problem, and begin to identify a path forward for
   addressing it.

The IETF Secretariat

---

From: <[email-masked]>
Date: Fri, 6 Jul 2012 18:25:50 -0400

I generally like this draft - I've sent a bunch of comments directly to the
authors, many of which are editorial.

OTOH, the 4.2 State vs. Policy section appears worthy of a wider discussion.

This section appears to introduce a concept of a related set of middleboxes
- the rough operational definition is "the set of middleboxes across which
policy has to be uniformly provisioned in order to obtain consistent policy
enforcement in the presence of middlebox state migration".  This seems rather
important to understanding the likely scope of deployment and the administrative
characteristics of state migration so I'd suggest more text on this concept
in that section or somewhere nearby.  This also relates to discussion of
middleboxes knowing about each other in the second paragraph of Section 6.
In addition, with respect to the concerns in at least section 7.2, this
leans towards a heavy reliance on configuration for (or to support) discovery.

The fact that this topic touches upon multiple sections is indicative of its
importance, and it feels like a good "place to dig" to come up with an
initial state migration problem scenario/subset) that might be solvable in
a reasonable period of time. The sort of thing I have in mind is that if
the middleboxes are under common administration, and are in the same
administrative domain as the attachment points across which the endpoint
movement occurs, a number of the hard problems in Section 7 (e.g., discovery)
are amenable to solution via configuration and the security discussion is
qualitatively rather different from what's in Section 8.

Thanks,
--David
----------------------------------------------------
David L. Black, Distinguished Engineer
EMC Corporation, 176 South St., Hopkinton, MA  01748
+1 (508) 293-7953             FAX: +1 (508) 293-7786
[email-masked]        Mobile: +1 (978) 394-7754
----------------------------------------------------

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf Of
> Guyingjie (Yingjie)
> Sent: Wednesday, July 04, 2012 12:07 AM
> To: [email-masked]
> Cc: Melinda Shore; Senthil Sivakumar (ssenthil)
> Subject: [sami] FW: New Version Notification for draft-gu-statemigration-
> framework-00.txt
> 
> Hi all,
> _______________________________________________
> sami mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sami