Subject: [scim] Missing "operations": attribute in SCIM PATCH

From: Phil Hunt <[email-masked]>
Date: Tue, 9 Sep 2014 10:31:42 -0700

WG Members:

Just to let the group know, there is a JSON bug in the current API (draft 10) regarding PATCH.

When we moved the “schemas” attribute to the top of the message we forgot to prefix the array of operations with an attribute.  The result is that Draft 10’s PATCH messages will not validate in JSON.

To fix the problem, I propose we add the attribute “Operations” (which is consistent with Bulk). See example below:

PATCH /Users/2819c223-7f76-453a-919d-413861904646
Host: example.com
Accept: application/scim+json
Content-Type: application/scim+json
Authorization: Bearer h480djs93hd8
If-Match: W/"a330bc54f0671c9"

{ 
  "schemas": ["urn:ietf:params:scim:api:messages:2.0:PatchOp"],
  "Operations": [{
    "op":"replace",
    "path":"emails[type eq \"work\"].value",
    "value":"[email-masked]"
  }]
}

Phil

@independentid
www.independentid.com
[email-masked]

---

From: Kelly Grizzle <[email-masked]>
Date: Tue, 9 Sep 2014 17:36:28 +0000

+1

From: scim [mailto:[email-masked]] On Behalf Of Phil Hunt
Sent: Tuesday, September 09, 2014 12:32 PM
To: SCIM WG
Subject: [scim] Missing "operations": attribute in SCIM PATCH

WG Members:

When we moved the "schemas" attribute to the top of the message we forgot to prefix the array of operations with an attribute.  The result is that Draft 10's PATCH messages will not validate in JSON.

To fix the problem, I propose we add the attribute "Operations" (which is consistent with Bulk). See example below:

Host: example.com<http://example.com>

{
  "schemas": ["urn:ietf:params:scim:api:messages:2.0:PatchOp"],
  "Operations": [{
    "op":"replace",
    "path":"emails[type eq \"work\"].value",
    "value":"[email-masked]<mailto:[email-masked]>"
  }]
}

Phil

@independentid
www.independentid.com<http://www.independentid.com>
[email-masked]<mailto:[email-masked]>