Subject: [scim] Comments on Bulk

From: Ian Glazer <[email-masked]>
Date: Fri, 5 Sep 2014 11:30:20 -0400

Here's a few comments and questions on the new Bulk section... which I
generally like a lot.

1 - bulkId "REQUIRED when method is POST." Curiously, why wouldn't bulkId
be required on things like PUT or PATCH?

2 - Is GET permitted? I don't think it makes sense but I just wanted to
check.

3 - 3.5.2 - Can I send different bulkId's per operation in a bulk
transaction? I believe the answer is yes and I think that is demonstrated
in the Circular Reference section. 3.5.2 doesn't make that point clear.

4 - 3.5.2 It isn't obvious in the example that Alice is user
"92b725cd-9465-4e7d-8c16-01f8e146b87a" I think we need a sentence before
the "A subsequent GET request for the 'Tour Guides' Group..." that explains
Alice has been created with the id...

5 - 3.5.4 - How would the client learn of the provider's maximum number of
operations and payload size? Are these new configuration attributes?

-- 
Ian Glazer
Senior Director, Identity
+1 202 255 3166
@iglazer <https://twitter.com/iglazer>

---

From: Phil Hunt <[email-masked]>
Date: Fri, 5 Sep 2014 10:44:48 -0700

Ian,

Thanks for the comments. Good to know!

See my responses in line…

Phil

@independentid
www.independentid.com
[email-masked]

On Sep 5, 2014, at 8:30 AM, Ian Glazer <[email-masked]> wrote:

> Here's a few comments and questions on the new Bulk section... which I generally like a lot.
> 
> 1 - bulkId "REQUIRED when method is POST." Curiously, why wouldn't bulkId be required on things like PUT or PATCH?

In POST, there is no known identifier before the request. With PUT and PATCH you have to be modifying a pre-existing object.
> 
> 2 - Is GET permitted? I don't think it makes sense but I just wanted to check.

According to the spec, the only methods permitted are:  POST, PUT, PATCH, or DELETED (see method on page 41)
> 
> 3 - 3.5.2 - Can I send different bulkId's per operation in a bulk transaction? I believe the answer is yes and I think that is demonstrated in the Circular Reference section. 3.5.2 doesn't make that point clear.

Agreed. Will add some text.
> 
> 4 - 3.5.2 It isn't obvious in the example that Alice is user "92b725cd-9465-4e7d-8c16-01f8e146b87a" I think we need a sentence before the "A subsequent GET request for the 'Tour Guides' Group..." that explains Alice has been created with the id…

Ok. Will clarify.
> 
> 5 - 3.5.4 - How would the client learn of the provider's maximum number of operations and payload size? Are these new configuration attributes?

I will put a reference back to core-schema.  But the attributes are: bulk.supported, bulk.maxOperations and bulk.maxPayloadSize

> @iglazer
> _______________________________________________
> scim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/scim