Subject: [scim] I-D Action: draft-ietf-scim-core-schema-10.txt

From: [email-masked]
Date: Mon, 15 Sep 2014 13:05:07 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
 This draft is a work item of the System for Cross-domain Identity Management Working Group of the IETF.

        Title           : System for Cross-Domain Identity Management: Core Schema
        Authors         : Phil Hunt
                          Kelly Grizzle
                          Erik Wahlstroem
                          Chuck Mortimore
	Filename        : draft-ietf-scim-core-schema-10.txt
	Pages           : 66
	Date            : 2014-09-15

Abstract:
   The System for Cross-Domain Identity Management (SCIM) specifications
   are designed to make identity management in cloud based applications
   and services easier.  The specification suite builds upon experience
   with existing schemas and deployments, placing specific emphasis on
   simplicity of development and integration, while applying existing
   authentication, authorization, and privacy models.  Its intent is to
   reduce the cost and complexity of user management operations by
   providing a common user schema and extension model, as well as
   binding documents to provide patterns for exchanging this schema
   using HTTP protocol.

   This document provides a platform neutral schema and extension model
   for representing users and groups and other resource types in JSON
   format.  This schema is intended for exchange and use with cloud
   service providers.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-scim-core-schema/

There's also a htmlized version available at:
http://tools.ietf.org/html/draft-ietf-scim-core-schema-10

A diff from the previous version is available at:
http://www.ietf.org/rfcdiff?url2=draft-ietf-scim-core-schema-10

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Phil Hunt <[email-masked]>
Date: Mon, 15 Sep 2014 13:13:24 -0700

This draft includes some editorial changes to improve readability specifically:

* Simplified namespace definition for urn:ietf:params:scim
* Clarified "schemas" attribute as representing the JSON body schema in an HTTP Req/Resp
* Reduced use of confusing term "core" in "Core User" and “Core Group” vs core schema vs core attributes
* Added clarifications and security considerations for externalId

Finally, sections 3 and 4 were re-worked to make it clear how Resource Types are defined and extended and the relationship and role of the schemas attribute in JSON objects and messages.

There were no normative changes other than clarifications.

Comments appreciated.

I will post the next API draft revision tomorrow.

NOTE:  as the discussion on externalId is still ongoing, I have not changed the definition in this draft to multi-valued. I think we should open a ticket for this one as I think there are a number of different current uses (some of which may require multi-values). We may even want to use “type” from the multi-valued attribute type definition.  OR, we may want to talk about a more complex security context bound values model (I am not sure how this would work).

Phil

@independentid
www.independentid.com
[email-masked]

On Sep 15, 2014, at 1:05 PM, [email-masked] wrote:

> _______________________________________________
> scim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/scim