Subject: [scim] [Invalid Example] Country Attribute

From: Shelley <[email-masked]>
Date: Thu, 12 May 2016 14:58:38 -0500

The SCIM 1.1 and 2.0 specifications mandate the use of the ISO 3166-1
"alpha-2" code format [1]:

> country  The country name component.  When specified, the value
>          MUST be in ISO 3166-1 "alpha-2" code format [ISO3166 <https://tools.ietf.org/html/rfc7643#ref-ISO3166>]; e.g.,
>          the United States and Sweden are "US" and "SE", respectively.
>
>
However, the User examples do not adhere to this requirement:

>   "addresses": [
>     {
>       "type": "work",
>       "streetAddress": "100 Universal City Plaza",
>       "locality": "Hollywood",
>       "region": "CA",
>       "postalCode": "91608",      "country": "USA",
>       "formatted": "100 Universal City Plaza\nHollywood, CA 91608 USA",
>       "primary": true
>     },
>     {
>       "type": "home",
>       "streetAddress": "456 Hollywood Blvd",
>       "locality": "Hollywood",
>       "region": "CA",
>       "postalCode": "91608",      "country": "USA",
>       "formatted": "456 Hollywood Blvd\nHollywood, CA 91608 USA"
>     }
>   ]
>
>
[1] https://tools.ietf.org/html/rfc7643#section-4.1.2
[2] https://tools.ietf.org/html/rfc7643#section-8.2

---

From: Phil Hunt <[email-masked]>
Date: Thu, 12 May 2016 13:07:43 -0700

Thanks Shelley.  Good spotting.

Phil

@independentid
www.independentid.com <http://www.independentid.com/>[email-masked] <mailto:[email-masked]>

> On May 12, 2016, at 12:58 PM, Shelley <[email-masked]> wrote:
> 
> The SCIM 1.1 and 2.0 specifications mandate the use of the ISO 3166-1 "alpha-2" code format [1]:
> [1] https://tools.ietf.org/html/rfc7643#section-4.1.2 <https://tools.ietf.org/html/rfc7643#section-4.1.2>
> [2] https://tools.ietf.org/html/rfc7643#section-8.2 <https://tools.ietf.org/html/rfc7643#section-8.2>
> _______________________________________________
> scim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/scim

---

From: Alexey Melnikov <[email-masked]>
Date: Thu, 12 May 2016 20:03:40 -0400

Hi,

> On 12 May 2016, at 16:07, Phil Hunt <[email-masked]> wrote:
> 

Can this be submitted as an erratum?
> www.independentid.com
> [email-masked]
>>>          MUST be in ISO 3166-1 "alpha-2" code format [ISO3166]; e.g.,