Subject: [scim] /ServiceProviderConfig vs. /ServiceProviderConfigs

From: Shelley <[email-masked]>
Date: Wed, 26 Feb 2020 11:30:46 -0600

I just wanted to get some confirmation regarding the service provider
configuration endpoint in SCIM 2.0.

My understanding from the RFCs [1] and some past discussions (e.g. [3]) is
that the endpoint is intended to be* /ServiceProviderConfig *(singular) in
SCIM 2.0, despite that it was */ServiceProviderConfigs* (plural) in SCIM
1.1.

However, there are some *errata *that state the SCIM 2.0 RFC documents are
incorrect and actually should use the plural form [3,4]. I'm assuming these
are just erroneous errata?

[1] https://tools.ietf.org/html/rfc7644#section-4
[2] https://mailarchive.ietf.org/arch/msg/scim/8DlmxC-2Ju-VqYCHZwXK2Z6O_90/
[3] https://www.rfc-editor.org/errata/eid4979
[4] https://www.rfc-editor.org/errata/eid4978

---

From: Phillip Hunt <[email-masked]>
Date: Wed, 26 Feb 2020 15:05:05 -0700

I would have to check. But it is singular because it is not a container but a resource. 

Phil

> On Feb 26, 2020, at 10:31 AM, Shelley <[email-masked]> wrote:
> 
> 
> I just wanted to get some confirmation regarding the service provider configuration endpoint in SCIM 2.0.
> 
> My understanding from the RFCs [1] and some past discussions (e.g. [3]) is that the endpoint is intended to be /ServiceProviderConfig (singular) in SCIM 2.0, despite that it was /ServiceProviderConfigs (plural) in SCIM 1.1.
> 
> However, there are some errata that state the SCIM 2.0 RFC documents are incorrect and actually should use the plural form [3,4]. I'm assuming these are just erroneous errata?
> 
> _______________________________________________
> scim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/scim