Subject: [scim] New charter - strawman draft

From: Darran Rolls <[email-masked]>
Date: Mon, 15 Jun 2020 12:11:53 +0000

In readiness for our interest group call on Thursday at 11am central US time, I wanted to throw out a strawman charter statement.  Please review and comment here first:

The System for Cross-domain Identity Management (SCIM) working group is being re-chartered to extend the current SCIM 2.0 specification, further refine its operational capabilities, and enhance the standardization of methods for creating, reading, searching, modifying, and deleting user identities and identity-related objects across
administrative domains.  The goal of this renewed effort is to further the operational simplification of an expanded set of common tasks related to user identity management in services and applications in a growing ecosystem.

The word "Standardize" does not mean that the working group will develop new technologies.  Specifically this working group with look to build upon the existing SCIM 2.0 specification rather than defining any new protocol elements.  The groups new work will be focused on delivering operational protocol enhancements and extending the schema definitions to cover more managed objects and endpoints.  To better support the growing number of commercial and open source implementations of SCIM 2.0, this effort will also focus on delivering new capabilities targeted at  promoting interoperability and enabling the verification and testing of different implementations.
The SCIM working group will initially be directed towards operational protocol enhancements and new schema definitions in the following areas:

  *   Multi-value paging & cursor pagination
  *   Relying party user provisioning
  *   Soft Delete
  *   Extended HR /user data and related action events
  *   Ratification of extensions to address Privilege Account Management user cases

It will follow this work by considering extensions to the protocol and operational model that address the verification the establishment and interoperability between implementations.  When and where necessary, the group will modify and enhance the existing SCIM 2.0 schema and REST-based protocol, but will do so with a focus on backwards compatibility and the goal of adding to rather than breaking an existing SCIM 2.0 implementation.  However, where enhanced interoperability and streamlined operations are necessary, changes may be specified that require updates to an implementation to remain interoperable with this new work.

Finally, the working group will continue to ensure that the SCIM protocol embodies good security practices. Given both the sensitivity of the information being conveyed in SCIM messages and the regulatory requirements regarding the privacy of personally identifiable information, the working group will continue to pay particular attention to issues around authorization, authenticity, and privacy and consider new features targeted at enhanced security for the protocol.
--
Darran Rolls
https://www.darranrolls.com
LinkedIn<https://www.linkedin.com/in/darran-rolls-068b84> @djrolls<https://twitter.com/djrolls>

---

From: Quint Daenen <[email-masked]>
Date: Tue, 16 Jun 2020 21:08:37 +0200

Hi Darran

Thank you for writing out this draft proposal and starting up a discussion.
See you on Thursday 25th.

Regards
Quint Daenen
LinkedIn <https://www.linkedin.com/in/quint-daenen/> | GitHub 
<https://github.com/di-wu>

On 15.06.20 14:11, Darran Rolls wrote:
>
> In readiness for our interest group call on Thursday at 11am central 
> US time, I wanted to throw out a strawman charter statement.  Please 
> review and comment here first:
>
> The System for Cross-domain Identity Management (SCIM) working group 
> is being re-chartered to extend the current SCIM 2.0 specification, 
> further refine its operational capabilities, and enhance the 
> standardization of methods for creating, reading, searching, 
> modifying, and deleting user identities and identity-related objects 
> across
> administrative domains.  The goal of this renewed effort is to further 
> the operational simplification of an expanded set of common tasks 
> related to user identity management in services and applications in a 
> growing ecosystem.
>
> The word "Standardize" does not mean that the working group will 
> develop new technologies.  Specifically this working group with look 
> to build upon the existing SCIM 2.0 specification rather than defining 
> any new protocol elements. The groups new work will be focused on 
> delivering operational protocol enhancements and extending the schema 
> definitions to cover more managed objects and endpoints.  To better 
> support the growing number of commercial and open source 
> implementations of SCIM 2.0, this effort will also focus on delivering 
> new capabilities targeted at  promoting interoperability and enabling 
> the verification and testing of different implementations.
>
> The SCIM working group will initially be directed towards operational 
> protocol enhancements and new schema definitions in the following areas:
>
> It will follow this work by considering extensions to the protocol and 
> operational model that address the verification the establishment and 
> interoperability between implementations.  When and where necessary, 
> the group will modify and enhance the existing SCIM 2.0 schema and 
> REST-based protocol, but will do so with a focus on backwards 
> compatibility and the goal of adding to rather than breaking an 
> existing SCIM 2.0 implementation.  However, where enhanced 
> interoperability and streamlined operations are necessary, changes may 
> be specified that require updates to an implementation to remain 
> interoperable with this new work.
>
> Finally, the working group will continue to ensure that the SCIM 
> protocol embodies good security practices. Given both the sensitivity 
> of the information being conveyed in SCIM messages and the regulatory 
> requirements regarding the privacy of personally identifiable 
> information, the working group will continue to pay particular 
> attention to issues around authorization, authenticity, and privacy 
> and consider new features targeted at enhanced security for the protocol.
>
> -- 
>
> Darran Rolls
>
> LinkedIn <https://www.linkedin.com/in/darran-rolls-068b84> @djrolls 
> <https://twitter.com/djrolls>
>
>
> _______________________________________________
> scim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/scim