Subject: [scim] Work Items and Topics - Catalog and Tally

From: Darran Rolls <[email-masked]>
Date: Wed, 22 Jul 2020 19:57:01 +0000

In order to asses interest and commitment to specific topics and work items for a refreshed charter, I’ve captured the items discussed so far in the following table.  Please do two things 1) Review the list of items and let me know if there is other work we should be considering  2) By return message indicate the items you are personally interested in and are (more importantly) prepared to work on.  You can either send that message to me directly or back to this thread on the list.  I’ll then summarize the results back to the group.

I’ll start the process by saying:

Darran Rolls:  Willing to work on items 1-6,7,8

NOTE:  Time is of the essence.  Assuming we can get a BOF on the calendar for IEFT 108 next week, we’ll need this data to make our case for re chartering the WG.

#1
Multi-value Paging
Individual Draft
Phil Hunt
https://datatracker.ietf.org/doc/draft-hunt-scim-mv-paging/
#2
Cursor Pagination
Individual Draft
Matt Peterson
https://tools.ietf.org/html/draft-peterson-scim-cursor-pagination-00
#3
Relying Party User Provisioning
Individual Draft
Mark Wahl
https://tools.ietf.org/html/draft-wahl-scim-profile-00
#4
Soft Delete
Individual Draft
Morteza Ansari
https://datatracker.ietf.org/doc/draft-ansari-scim-soft-delete/
#5
New HR Schema
Concept
Matt Domsch

#6
PAM Schema
Individual Draft
Kelly Grizzle
https://datatracker.ietf.org/doc/draft-grizzle-scim-pam-ext/
#7
Interoperation Considerations
Concept
Darran Rolls

#8
Developing a Test Suit
Concept
Darran Rolls

Thanks

--
Darran Rolls
https://www.darranrolls.com
LinkedIn<https://www.linkedin.com/in/darran-rolls-068b84> @djrolls<https://twitter.com/djrolls>

---

From: Quint Daenen <[email-masked]>
Date: Fri, 24 Jul 2020 12:33:43 +0200

Hi all

I am interested in the following items, ordered by personal relevance:
- *4*. Soft Delete
- *8*. Test Suite
- *1* & *2*. Multi-Value Paging and Cursor Pagination
-* 3*. Relying Party User Provisioning

TL;DR
Quint Daenen: Willing to work on items *1-4* and *8*.

---

Most SCIM Servers I have interacted with already use *Soft Delete* 'behind
the scenes'. I guess that it is never a bad idea to avoid potential data
loss? The draft of Morteza Ansari is a good solution to *extend* the
current spec to support this. It would be great to see this integrated with
SCIM.

Today there are various SCIM implementations having their own 'additional'
requirements. Such as a required email address, which is not the case in
the default user schema. It is possible to define your own schema to
enforce this. From my experience it is not that simple to check whether
these implementations are compliant with the SCIM specification. I have
already written some limited test suites. It would be great if a general *Test
Suite* existed that can validate whether a server implementation is
compliant with SCIM. This is all possible since all the needed information
is retrievable from the Service Provider Configuration endpoints.

*Multi-Value Paging* would enhance the current filter possibilities. I
think this is the most complex item in the list. It would make SCIM more
complex, but at the same time more versatile. This would also avoid
overwhelming the client and sp and make the responses cleaner.

The two most used pagination patterns in HTTP-based protocols are: Index
Pagination, and Cursor Pagination. It would be of interest to be able to
support both. If *Cursor Pagination* is already used in another
application, it can be difficult to create a SCIM implementation for it.

*Relying Party User Provisioning* would make the scope of SCIM much bigger.
I do not think SCIM is currently too big or difficult. Yet this would be a
substantial addition to SCIM.

---

Regards
Quint Daenen
LinkedIn <https://www.linkedin.com/in/quint-daenen/> | GitHub
<https://github.com/di-wu>

On Wed, Jul 22, 2020 at 9:57 PM Darran Rolls <[email-masked]> wrote:

> In order to asses interest and commitment to specific topics and work
> items for a refreshed charter, I’ve captured the items discussed so far in
> the following table.  Please do two things 1) Review the list of items and
> let me know if there is other work we should be considering  2) By return
> message indicate the items you are personally interested in and are (more
> importantly) prepared to work on.  You can either send that message to me
> directly or back to this thread on the list.  I’ll then summarize the
> results back to the group.
>
>
>
> NOTE:  Time is of the essence.  Assuming we can get a BOF on the calendar
> for IEFT 108 next week, we’ll need this data to make our case for re
> chartering the WG.
>
>
>
> #1
>
> Multi-value Paging
>
> Individual Draft
>
> Phil Hunt
>
> *https://datatracker.ietf.org/doc/draft-hunt-scim-mv-paging/
> <https://datatracker.ietf.org/doc/draft-hunt-scim-mv-paging/>*
>
> #2
>
> Cursor Pagination
>
> Individual Draft
>
> Matt Peterson
>
> *https://tools.ietf.org/html/draft-peterson-scim-cursor-pagination-00
> <https://tools.ietf.org/html/draft-peterson-scim-cursor-pagination-00>*
>
> #3
>
> *https://tools.ietf.org/html/draft-wahl-scim-profile-00
> <https://tools.ietf.org/html/draft-wahl-scim-profile-00>*
>
> #4
>
> Soft Delete
>
> Individual Draft
>
> *Morteza Ansari*
>
> *https://datatracker.ietf.org/doc/draft-ansari-scim-soft-delete/
> <https://datatracker.ietf.org/doc/draft-ansari-scim-soft-delete/>*
>
> #5
>
> New HR Schema
>
> Concept
>
> Matt Domsch
>
>
>
> #6
>
> PAM Schema
>
> Individual Draft
>
> Kelly Grizzle
>
> *https://datatracker.ietf.org/doc/draft-grizzle-scim-pam-ext/
> <https://datatracker.ietf.org/doc/draft-grizzle-scim-pam-ext/>*
>
> #7
>
> LinkedIn <https://www.linkedin.com/in/darran-rolls-068b84> @djrolls
> <https://twitter.com/djrolls>
>
>
> _______________________________________________
> scim mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/scim
>

---

From: "Matt Peterson (mpeterso)" <[email-masked]>
Date: Fri, 24 Jul 2020 15:35:00 +0000

Darren,

Matt Peterson:  interested in and willing to work on 1, 2, and 6.

From: scim <[email-masked]> On Behalf Of Quint Daenen
Sent: Friday, July 24, 2020 4:34 AM
To: Darran Rolls <[email-masked]>
Cc: [email-masked]
Subject: Re: [scim] Work Items and Topics - Catalog and Tally

CAUTION: This email originated from outside of the organization. Do not follow guidance, click links, or open attachments unless you recognize the sender and know the content is safe.

Hi all

I am interested in the following items, ordered by personal relevance:
- 4. Soft Delete
- 8. Test Suite
- 1 & 2. Multi-Value Paging and Cursor Pagination
- 3. Relying Party User Provisioning

TL;DR
Quint Daenen: Willing to work on items 1-4 and 8.

---

Most SCIM Servers I have interacted with already use Soft Delete 'behind the scenes'. I guess that it is never a bad idea to avoid potential data loss? The draft of Morteza Ansari is a good solution to extend the current spec to support this. It would be great to see this integrated with SCIM.

Today there are various SCIM implementations having their own 'additional' requirements. Such as a required email address, which is not the case in the default user schema. It is possible to define your own schema to enforce this. From my experience it is not that simple to check whether these implementations are compliant with the SCIM specification. I have already written some limited test suites. It would be great if a general Test Suite existed that can validate whether a server implementation is compliant with SCIM. This is all possible since all the needed information is retrievable from the Service Provider Configuration endpoints.

Multi-Value Paging would enhance the current filter possibilities. I think this is the most complex item in the list. It would make SCIM more complex, but at the same time more versatile. This would also avoid overwhelming the client and sp and make the responses cleaner.

The two most used pagination patterns in HTTP-based protocols are: Index Pagination, and Cursor Pagination. It would be of interest to be able to support both. If Cursor Pagination is already used in another application, it can be difficult to create a SCIM implementation for it.

Relying Party User Provisioning would make the scope of SCIM much bigger. I do not think SCIM is currently too big or difficult. Yet this would be a substantial addition to SCIM.

---

Regards
Quint Daenen
LinkedIn<https://nam05.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.linkedin.com%2Fin%2Fquint-daenen%2F&data=02%7C01%7Cmatt.peterson%40oneidentity.com%7C115b5f81864e48d965b408d82fbd17ff%7C91c369b51c9e439c989c1867ec606603%7C0%7C1%7C637311836504311948&sdata=WaW7oRAO%2B6H4hCrukNIu6UGjIZp2XHivOfKovyNluDM%3D&reserved=0> | GitHub<https://nam05.safelinks.protection.outlook.com/?url=https%3A%2F%2Fgithub.com%2Fdi-wu&data=02%7C01%7Cmatt.peterson%40oneidentity.com%7C115b5f81864e48d965b408d82fbd17ff%7C91c369b51c9e439c989c1867ec606603%7C0%7C1%7C637311836504321898&sdata=jIPgpD1eODksPwO2BAFGhADZHgKVs%2BmyQ3epTJpTWlM%3D&reserved=0>

On Wed, Jul 22, 2020 at 9:57 PM Darran Rolls <[email-masked]<mailto:[email-masked]>> wrote:
In order to asses interest and commitment to specific topics and work items for a refreshed charter, I’ve captured the items discussed so far in the following table.  Please do two things 1) Review the list of items and let me know if there is other work we should be considering  2) By return message indicate the items you are personally interested in and are (more importantly) prepared to work on.  You can either send that message to me directly or back to this thread on the list.  I’ll then summarize the results back to the group.

#1
Multi-value Paging
Individual Draft
Phil Hunt
https://datatracker.ietf.org/doc/draft-hunt-scim-mv-paging/<https://nam05.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-hunt-scim-mv-paging%2F&data=02%7C01%7Cmatt.peterson%40oneidentity.com%7C115b5f81864e48d965b408d82fbd17ff%7C91c369b51c9e439c989c1867ec606603%7C0%7C1%7C637311836504321898&sdata=pqtGcCs4tF2Jz872sHhyNjp6pFHC6d65M5hC4cfzodQ%3D&reserved=0>
#2
Cursor Pagination
Individual Draft
Matt Peterson
https://tools.ietf.org/html/draft-peterson-scim-cursor-pagination-00<https://nam05.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-peterson-scim-cursor-pagination-00&data=02%7C01%7Cmatt.peterson%40oneidentity.com%7C115b5f81864e48d965b408d82fbd17ff%7C91c369b51c9e439c989c1867ec606603%7C0%7C1%7C637311836504331865&sdata=%2F3QKbNpNLaAmnKj2mNbjHsl%2FL%2F16adzs5muYCYyNkSM%3D&reserved=0>
#3
Relying Party User Provisioning
Individual Draft
Mark Wahl
https://tools.ietf.org/html/draft-wahl-scim-profile-00<https://nam05.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftools.ietf.org%2Fhtml%2Fdraft-wahl-scim-profile-00&data=02%7C01%7Cmatt.peterson%40oneidentity.com%7C115b5f81864e48d965b408d82fbd17ff%7C91c369b51c9e439c989c1867ec606603%7C0%7C1%7C637311836504331865&sdata=10%2FDq68fRjEetLn1j0iH%2Ft7kNf89LpOJKLvxYbbmHgQ%3D&reserved=0>
#4
Soft Delete
Individual Draft
Morteza Ansari
https://datatracker.ietf.org/doc/draft-ansari-scim-soft-delete/<https://nam05.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-ansari-scim-soft-delete%2F&data=02%7C01%7Cmatt.peterson%40oneidentity.com%7C115b5f81864e48d965b408d82fbd17ff%7C91c369b51c9e439c989c1867ec606603%7C0%7C1%7C637311836504341815&sdata=wtdvOevuX5PN0w4AN9LXBfKeBMEJVkjGdU12UsN1GUk%3D&reserved=0>
#5
New HR Schema
Concept
Matt Domsch

#6
PAM Schema
Individual Draft
Kelly Grizzle
https://datatracker.ietf.org/doc/draft-grizzle-scim-pam-ext/<https://nam05.safelinks.protection.outlook.com/?url=https%3A%2F%2Fdatatracker.ietf.org%2Fdoc%2Fdraft-grizzle-scim-pam-ext%2F&data=02%7C01%7Cmatt.peterson%40oneidentity.com%7C115b5f81864e48d965b408d82fbd17ff%7C91c369b51c9e439c989c1867ec606603%7C0%7C1%7C637311836504341815&sdata=0IUg7YFUI%2BD9iFpMdnMl3OMFVpUFJs3pl23uS%2BjNQL8%3D&reserved=0>
#7
Interoperation Considerations
Concept
Darran Rolls

#8
Developing a Test Suit
Concept
Darran Rolls

Thanks

--
Darran Rolls
https://www.darranrolls.com<https://nam05.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.darranrolls.com%2F&data=02%7C01%7Cmatt.peterson%40oneidentity.com%7C115b5f81864e48d965b408d82fbd17ff%7C91c369b51c9e439c989c1867ec606603%7C0%7C1%7C637311836504341815&sdata=XHGhSm0j9LVqGZS0RYDiIucIRuYJcYX2PnU8uLYUrVA%3D&reserved=0>
LinkedIn<https://nam05.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.linkedin.com%2Fin%2Fdarran-rolls-068b84&data=02%7C01%7Cmatt.peterson%40oneidentity.com%7C115b5f81864e48d965b408d82fbd17ff%7C91c369b51c9e439c989c1867ec606603%7C0%7C1%7C637311836504351768&sdata=xR%2BHsHBQR96PB0LyFOOkbnZGCHOU2lZOGB1g5re%2FDCo%3D&reserved=0> @djrolls<https://nam05.safelinks.protection.outlook.com/?url=https%3A%2F%2Ftwitter.com%2Fdjrolls&data=02%7C01%7Cmatt.peterson%40oneidentity.com%7C115b5f81864e48d965b408d82fbd17ff%7C91c369b51c9e439c989c1867ec606603%7C0%7C1%7C637311836504351768&sdata=Aywg9WYUuDZY2vy6PDSPRgQTBKRwyILt88G6oCE1q%2FE%3D&reserved=0>

_______________________________________________
scim mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/scim<https://nam05.safelinks.protection.outlook.com/?url=https%3A%2F%2Fwww.ietf.org%2Fmailman%2Flistinfo%2Fscim&data=02%7C01%7Cmatt.peterson%40oneidentity.com%7C115b5f81864e48d965b408d82fbd17ff%7C91c369b51c9e439c989c1867ec606603%7C0%7C0%7C637311836504361724&sdata=%2Bp3K9QmtCiykoazSCZtCeczzInqFnAe1cp8QwAxp1lM%3D&reserved=0>

---

From: Jeremy Palenchar <[email-masked]>
Date: Fri, 24 Jul 2020 08:54:09 -0700

I am very much interested in working on 2 and 4.

It seems that adding these features will require some particular responses
by the ServiceProviderConfig endpoint to share these new capabilities with
clients. I will assume this work is part of those individual efforts unless
the group thinks the ServiceProviderConfig endpoint needs additional work
or clarity. If so - I suggest we might add an item to revisit this endpoint
to ensure that all of our new features and capabilities are properly
discoverable by clients.

-jeremy