Subject: scp issue between OpenSSH and SSH2

From: "Nikolin, Vanja, ALABS" <[email-masked]>
Date: Mon, 6 Oct 2003 10:39:05 -0500

Does OpenSSH 3.7.1 solve this problem?
I'm trying to scp using an OpenSSH client to an SSH2 server. ssh works fine, but scp returns this: 
Executing ssh1 in compatibility mode failed

This problem is often quite perplexing, since a ssh -v trace may show that you're using SSH-2 - so what is a message about "ssh1 compatibility mode" doing in there? 
What's happening is this: 
	On the OpenSSH client, you run say, scp foo server:bar. 
	scp runs ssh in a subprocess to connect to the server, and run the remote command scp -t bar. This is intended to start an instance of the scp program on the server, and the two scp's will cooperate by speaking over the SSH connection, to retrieve the file. 
	ssh connects to the server (using either protocol 1 or 2, it doesn't matter), and runs the remote scp command. However, the "scp" that gets run on the server is the SSH2 scp program (scp2), not the OpenSSH one. The crux of the problem is: besides the name, these two scp's have exactly nothing in common. scp2 cannot speak the file-transfer protocol that OpenSSH scp does. However, scp2 recognizes from the "-t" flag what's expected, and tries exec scp1 to service the connection (this is the extent of SSH2's SSH-1 compatibility; where OpenSSH has code for both protocols in a single set of programs, SSH2 expects to execute programs from a parallel SSH1 installation). It fails (presumably because you don't have SSH1 installed), and reports the problem. 
The solution is to install either the OpenSSH or SSH1 version of scp on the server under the name "scp1," somewhere in the sshd2's PATH. 

Thanks!

---

From: Markus Friedl <[email-masked]>
Date: Mon, 6 Oct 2003 17:49:01 +0200

> Does OpenSSH 3.7.1 solve this problem?

no, and it's not related to ietf-ssh@.

openssh's scp implements RCP
openssh's sftp implements SFTP

ssh.com 2.x's scp implements SFTP.

no idea how to fix this.

---

From: Jeffrey Hutzelman <[email-masked]>
Date: Mon, 06 Oct 2003 12:24:55 -0400

> ssh.com 2.x's scp implements SFTP.

Short term: Install ssh.com 2.x's "scp" as "sftp", and use openssh's sftp 
client.
Long term: ssh.com should fix their broken software; SFTP is not scp