Subject: Re: Some questions about "SSH Transport Layer Encryption Modes"

From: [email-masked] (Peter Gutmann)
Date: Sat, 18 Oct 2003 18:56:35 +1300

Markus Friedl <[email-masked]> writes:

>i think this has been discussed before.

Hmm, I think "debated without clear resolution" might be a better description,
if you're referring to the debate from about two years ago.  Specifically, the
exact message/data flow was never totally resolved.

Peter.

---

From: Markus Friedl <[email-masked]>
Date: Sat, 18 Oct 2003 14:33:49 +0200

> exact message/data flow was never totally resolved.

Hm, AFAIK we agreed, that after sending KEXINIT you MUST NOT send
messages of type > 49 (i.e. only transport layer messages are
allowed) until you send NEWKEYS.

As a consequence OpenSSH's implementation of rekeying was changed.

Changing this now again will very likely break interoperabitily.

-m