Subject: sftp message lost in the spam filter..

From: Bill Sommerfeld <[email-masked]>
Date: Mon, 24 Nov 2003 11:25:28 -0500

This got shuffled aside because of a malformed "To:" line..
sorry for the delay in forwarding this to the right place..

					- Bill

------- Forwarded Message

Message-ID: <[email-masked]>
From: Richard Whalen <[email-masked]>
To: 
Cc: [email-masked]
Subject: RE: Case sensitivity on sftp servers
Date: Mon, 8 Sep 2003 08:36:42 -0400 
MIME-Version: 1.0
X-Mailer: Internet Mail Service (5.5.2653.19)
Content-Type: text/plain;
	charset="iso-8859-1"

> -----Original Message-----
> From: Dan O'Reilly [mailto:[email-masked]]
> Sent: Sunday, September 07, 2003 10:43 PM
> To: Martin Pool
> Cc: [email-masked]
> Subject: Re: Case sensitivity on sftp servers
> 
> 
> At 08:20 PM 9/7/2003, Martin Pool wrote:
> >So with case sensitivity on
> >
> >   OPEN("README", WRITE|CREAT|EXCL|CASE_INSENSITIVE)
> >
> >in a directory containing "readme" ought to fail with
> >FILE_ALREADY_EXISTS even on a case-sensitive filesystem, and
> >
> >   OPEN("README", READ|CASE_SENSITIVE)
> >
> >in a directory containing "readme" ought to fail with NO_SUCH_FILE
> >even on a case-insensitive filesystem?
> 
> No, it wouldn't necessarily do so on VMS, which supports 
> multiple versions
> of files.

What Dan should have said was that it would not fail on VMS because on VMS
ODS-2 volumes UPPERCASE is used to store filenames and they are
case-insensitive, so "README", "readme", "ReadMe" (and lots of other
variants) will all open the same file.

VMS ODS-5 volumes are CASE_PRESERVITIVE, but not CASE_SENSITIVE.  On VMS,
it's the user's (process) decision as to whether or not files are treated in
a case sensitive manner.

- ----------------------
Richard Whalen
Process Software

------- End of Forwarded Message

---

From: Martin Pool <[email-masked]>
Date: Tue, 25 Nov 2003 10:51:00 +1100

> it's the user's (process) decision as to whether or not files are treated in

This is moot because we seemed to decide
<ftp://ftp.ietf.org/ietf-mail-archive/secsh/2003-09.mail> that
CASE_SENSITIVE and CASE_INSENSITIVE OPEN flags are not a good
solution.  (Of course it's good to have the message for completeness.)

There seemed to be agreement on Joseph's proposal[0] of allowing the
case-sensitivity of a particular directory to be discovered by reading
its 'flags' attribute and looking at the
SSH_FILEXFER_ATTR_FLAGS_CASE_INSENSITIVE bit.  It makes good sense to
treat case sensitivity as a read-only directory attribute because few
servers will be able to choose what sensitivity they want.  Case
sensitivity is usually determined either by the filesystem or the OS,
not for each individual filesystem operation.  It also make sense for
it to be a per-directory attribute because a single server may have
both case-sensitive and case-insensitive volumes.

Will that SSH_FILEXFER_ATTR_FLAGS proposal go into the standard?

-- 
Martin 
                               linux.conf.au -- Adelaide, January 2004
[0] message [email-masked]