Subject: Re: SSHv2 MIB?

From: [email-masked]
Date: Tue, 9 Dec 2003 12:24:07 -0500

Hi Niels,
What would you use it for?
  The Network Management software (ex: OpenView or other enterprise network
management software) configure SSH configuration via SNMP/MIB.   I'm
surprise that there is no MIB, since most protocols have their MIBs.
  Are you part of the IETF working group?

Thanks

Tam

                    nisse@lysator.                                                                            
                    liu.se (Niels        To:     [email-masked]                                           
                    Möller)              cc:     [email-masked]                                          
                    Sent by:             Subject:     Re: SSHv2 MIB?                                          
                    nisse@lysator.                                                                            
                    liu.se                                                                                    

                    12/09/2003                                                                                
                    11:43 AM                                                                                  

[email-masked] writes:

>   I'm looking for the MIB(s) for Secure Shell (SSHv2).  Would you point
me
> to where I can get it.

There's no such thing, as far as I know. What would you use it for?

/Niels

---

From: [email-masked] (Niels Möller)
Date: 09 Dec 2003 18:24:49 +0100

[email-masked] writes:

> management software) configure SSH configuration via SNMP/MIB.

Which ssh implementations support that? Or is the management software
talking to some separate daemon that speaks SNMP and then writes to
the sshd configuration file and reads the sshd log files?

> I'm surprise that there is no MIB, since most protocols have their
> MIBs. Are you part of the IETF working group?

I'm a member of the working group, and author of one ssh
implementation. (I have to admit that I'm not particularly fond of
SNMP, and other ASN.1 use within the ietf, but if there some IETF work
on an ssh MIB, I'm surprised I've been able to miss it completely).

Regards,
/Niels