Subject: Straw Poll on group name

From: Joseph Galbraith <[email-masked]>
Date: Thu, 26 Aug 2004 17:24:59 -0600

> straw poll:
> 	[A] we should use small integers to refer to common groups
> 		[sample] diffie-hellman-group2-sha1
> 
> 	[B] we should refer to groups by size:
> 		[sample] diffie-hellman-group2048-sha1
> 
> 	[C] we should refer to groups by the ike number
> 		[sample] diffie-hellman-group14-sha1

I prefer [A].

People definitely already have a deployed instance
of [A] (diffie-hellman-group1-sha1.)  It sounds
like some people already have a deployed instance
that could fit into [C] (diffie-hellman-group14-sha1.)

I propose that we actually interpret 'diffie-hellman-group14-sha1
as a member of the ssh specific registry, and put a note
in that groups 2-13 are not defined.

Alternatively, we can quick, grab 12 more groups out of
IKE, randomize their numbers, and assign them to 2-13
so we can have the monotonically increasing property :-)
(I'm kidding!)

I agree that if we've got shipping code already using group14-sha1
it would not be good to change it at this point.  (This is one
of the results of the SSH working group having taken ______wayyyy_____
to long to get something out the door; we've got code shipping on
drafts making it hard to change things.

So my vote is for [A], with a note that for historical reasons, groups
2-13 are unused.

- Joseph

---

From: Martin Forssen <[email-masked]>
Date: Fri, 27 Aug 2004 08:53:39 +0200 (CEST)

> in that groups 2-13 are not defined.

I also think this is the best solution.

	/MaF
-- 
Martin Forssen <[email-masked]>              Development Manager
Phone: +46 31 7744361                         AppGate Network Security AB