Subject: DH key exchange message numbers

From: denis bider <[email-masked]>
Date: Wed, 18 Jan 2006 18:39:26 +0100

Hi all,

am I the only one who can't find KEXDH message numbers defined anywhere in the now published SSH RFCs?

Given that KEXDH is a required key exchange method, I'd expect those message numbers to be defined in the Transport RFC. Yet, when I looked I couldn't find the actual message numbers defined. Is this just my oversight or is it everyone else's? :-)

Best regards,

denis

---

From: Jeffrey Hutzelman <[email-masked]>
Date: Wed, 18 Jan 2006 17:40:34 -0500

On Wednesday, January 18, 2006 06:39:26 PM +0100 denis bider 
<[email-masked]> wrote:

> Given that KEXDH is a required key exchange method, I'd expect those
> message numbers to be defined in the Transport RFC. Yet, when I looked I
> couldn't find the actual message numbers defined. Is this just my
> oversight or is it everyone else's? :-)

Oops.  Indeed, those numbers were removed during editing, as a result of 
what appears to have been some confusion.  Someone commented during AUTH48 
that they should be removed from assignednumbers (now RFC4250), because 
they were in the method-specific space and thus didn't need to be (and 
shouldn't be) in the message number registry.

Unfortunately, they also got dropped from -transport, where the method is 
actually defined.  As a result, these definitions are missing from the 
protocol suite entirely, which I expect makes it tricky to implement. :-)

The correct numbers are these:
>           SSH_MSG_KEXDH_INIT             30
>           SSH_MSG_KEXDH_REPLY            31

I think we need an RFC Errata on this one... :-(

BTW, for those who've been looking for it and can't find it, the SSH
paramaters registry is at http://www.iana.org/assignments/ssh-parameters.
It seems the IANA hasn't yet published a link to that.

-- Jeff

---

From: Chris Lonvick <[email-masked]>
Date: Fri, 20 Jan 2006 09:19:42 -0800 (PST)

Hi,

Oops as well.  :-(

I'll propose the following errata:

---vvv---

RFC 4253 "The Secure Shell (SSH) Transport Layer Protocol"

The table in Section 12.

Current:
          SSH_MSG_DISCONNECT             1
          SSH_MSG_IGNORE                 2
          SSH_MSG_UNIMPLEMENTED          3
          SSH_MSG_DEBUG                  4
          SSH_MSG_SERVICE_REQUEST        5
          SSH_MSG_SERVICE_ACCEPT         6
          SSH_MSG_KEXINIT                20
          SSH_MSG_NEWKEYS                21

Should be:
          SSH_MSG_DISCONNECT             1
          SSH_MSG_IGNORE                 2
          SSH_MSG_UNIMPLEMENTED          3
          SSH_MSG_DEBUG                  4
          SSH_MSG_SERVICE_REQUEST        5
          SSH_MSG_SERVICE_ACCEPT         6
          SSH_MSG_KEXINIT                20
          SSH_MSG_NEWKEYS                21
          SSH_MSG_KEXDH_INIT             30
          SSH_MSG_KEXDH_REPLY            31

---^^^---

Does this cover it?

Thanks,
Chris

On Wed, 18 Jan 2006, Jeffrey Hutzelman wrote:

> Oops.  Indeed, those numbers were removed during editing, as a result of what 
> appears to have been some confusion.  Someone commented during AUTH48 that 
> they should be removed from assignednumbers (now RFC4250), because they were 
> in the method-specific space and thus didn't need to be (and shouldn't be) in 
> the message number registry.
>