Subject: RE: Please publish the attached draft-galb-filexfer-extensions-00.txt

From: "Richard Whalen" <[email-masked]>
Date: Tue, 17 Jan 2006 11:37:42 -0500

Are there any restrictions on "copy-data"?  How are the offsets treated when the file is opened for text transfers?

In section 7 (Temporary files & directories)
You use "prefered" and "preferreed" that I believe should be "preferred"

---

From: Joseph Galbraith <[email-masked]>
Date: Tue, 17 Jan 2006 09:57:16 -0700

> Are there any restrictions on "copy-data"?  How are the offsets treated when the file is opened for text transfers?

Excellent questions... I feel a new draft coming on.

I believe the answer is that "copy-data" has no restrictions,
other than that the the user not exceed quota (of course.)

Of course if it is a huge operation, the server is permitted
to complete it out of order or out right refuse to do it.

Clarified in local sources.

I believe, since this is a local-to-local copy operation,
we should forbid the files to be opened for text transfer--
of course, with VMS having multiple different file local
file formats, perhaps you'd prefer something different?
What do you think it should do?

> You use "prefered" and "preferreed" that I believe should be "preferred"

Ahh.. I see that my creative speller was at full throttle.
Fixed in local source.

Thanks,

Joseph

---

From: denis bider <[email-masked]>
Date: Wed, 18 Jan 2006 01:19:39 +0100

Copying to end-of-file with a single request should be permitted, though. No need to force many packets for the copying process.

On Wed, 18 Jan 2006 01:16:32 +0100, denis bider wrote:
>>> Are there any restrictions on "copy-data"?  How are the offsets
>>>
>>> treated when the file is opened for text transfers?
>>>
> No... it's simpler than that.
>
> The copy-data request is a shortcut for read followed by write,
> just without the data transmission. The server should internally do
> the same thing that would happen if one did a "read" from the
> source, followed by a "write" of the same data that "read" would
> transmit on the wire. No need to prohibit or dictate anything with
> regard to how the two file handles were opened.

---

From: denis bider <[email-masked]>
Date: Wed, 18 Jan 2006 01:16:32 +0100

The copy-data request is a shortcut for read followed by write, just without the data transmission. The server should internally do the same thing that would happen if one did a "read" from the source, followed by a "write" of the same data that "read" would transmit on the wire. No need to prohibit or dictate anything with regard to how the two file handles were opened.