Subject: [sfc] FW: New Version Notification for draft-dolson-sfc-vlan-00.txt

From: Dave Dolson <[email-masked]>
Date: Fri, 14 Feb 2014 19:39:17 +0000

As requested by some of you, this draft details Sandvine's experience with service chaining using VLANs.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Friday, February 14, 2014 2:31 PM
To: Dave Dolson; Dave Dolson
Subject: New Version Notification for draft-dolson-sfc-vlan-00.txt

A new version of I-D, draft-dolson-sfc-vlan-00.txt
has been successfully submitted by David Dolson and posted to the
IETF repository.

Name:		draft-dolson-sfc-vlan
Revision:	00
Title:		VLAN Service Function Chaining
Document date:	2014-02-14
Group:		Individual Submission
Pages:		9
URL:            http://www.ietf.org/internet-drafts/draft-dolson-sfc-vlan-00.txt
Status:         https://datatracker.ietf.org/doc/draft-dolson-sfc-vlan/
Htmlized:       http://tools.ietf.org/html/draft-dolson-sfc-vlan-00

Abstract:
   This document describes an implementation of Service Function Chains
   (SFC) utilizing standard VLAN switching, appropriate for bump-in-the-
   wire Service Function nodes.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Jerome Moisand <[email-masked]>
Date: Fri, 14 Feb 2014 20:18:28 +0000

Dave,

Thanks for sharing.

So in essence, this is using preconfigured VLANs to assemble a service overlay. And a service classifier of sorts is used to steer traffic to the proper VLAN. 

Generalizing a bit, one can that with various forms of preconfigured tunnels (IP, MPLS, VLAN, etc) as long as the SFs can use them as input and output 'logical' interfaces. 

Yup, agreed, this has been deployed in various shapes or forms in the past decade. Nothing wrong with it as long as the use case stays simple. And we should not underestimate the fact that such simple use cases are rather commonplace, while more complex use cases are less common.

I wonder if we should not extend the scope of this draft to 'existing practices'?

Tx
Jerome

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Friday, February 14, 2014 2:31 PM
To: Dave Dolson; Dave Dolson
Subject: New Version Notification for draft-dolson-sfc-vlan-00.txt

Abstract:

The IETF Secretariat

_______________________________________________
sfc mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/sfc