Subject: [sfc] SFC WG Agenda: London

From: "Jim Guichard (jguichar)" <[email-masked]>
Date: Sat, 1 Feb 2014 17:23:38 +0000

Greetings,

It's time to start putting together an agenda for the SFC meeting in London. We've requested one 2.5 hour slot . Because face-to-face time is precious, we intend to focus on:

- WG chartered items for which we have WG-adopted IDs, or IDs that appear headed for WG adoption.

- Specific topics where feedback is needed, and mailing list discussions have not converged.

We also do not intend to give agenda time to everyone who has a draft - the WG sessions do not have time for that, nor is it necessarily an effective use of time. We also do not intend to give agenda time for drafts for which little or no mailing list interest has been generated.

For the upcoming session, we expect to focus on:

1) Problem satement (hopefully not much time needed -- are there any actual open issues?).

2) Use cases.

3) Architecture.

If you have a draft (or plan to submit one) and would like to present (or more specifically, would like the working group to do something with your draft), please:

1) Let us know now (even if the draft is not published yet), so we can start planning;

2) Indicate which WG deliverable the draft relates to; and

3) Indicate what you want the WG to do with your draft. E.g., do you want this to become "THE" WG document for a particular deliverable? Or, is there content in the document you believe should be added to another document? etc. Please do not just respond "I want it to become a WG document". It would be better to explain in what context, and how your draft relates to other drafts that have been submitted.

Thanks!

Thomas & Jim

---

From: "Paul Quinn (paulq)" <[email-masked]>
Date: Fri, 7 Feb 2014 15:21:46 +0000

Jim, Thomas,

I'd like a slot on the agenda for the architecture draft (http://www.ietf.org/internet-drafts/draft-quinn-sfc-arch-04.txt)

thanks,
Paul

On Feb 1, 2014, at 12:23 PM, Jim Guichard (jguichar) <[email-masked]<mailto:[email-masked]>> wrote:

Greetings,

2) Use cases.

3) Architecture.

Thanks!

Thomas & Jim
_______________________________________________
sfc mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/sfc

---

From: Linda Dunbar <[email-masked]>
Date: Sat, 8 Feb 2014 15:53:30 +0000

Jim and Thomas,

We would like a 5-10 minutes slot to show the architecture of chaining existing L4-L7 service functions. By L4-L7, it means that those service functions don't have L2/L3 switching/routing capability.

The goal of the draft is:

- To make SFC WG adopt the fact that there are many service functions deployed that don't terminate the newly proposed SFC Header; Many of them don't have L2/L3 switching/routing capability

- To make SFC WG adopt that Service Function Forwarder (that is defined by draft-quinn-nsc-arch-04) can be a separate entity from service functions.

- To make SFC WG adopt that it is not necessary for every packet to carry the complete service chain forwarding information in its SFC header.  It should be acceptable to have variable length SFC Header. For example, for packets to be encoded with a Chain ID plus optional attributes and have separate messages (either in-band or out-of-band) to inform the detailed forwarding policies for the Chain ID and the Chain attributes in the packets  to the Service Function Forwarding nodes.

- Recognize that from user's perspective, the order of service functions, e.g. Chain#1 {s1, s4, s6}, Chain#2{s4, s7}, is important, but very often which instance of the Service Function "s1" is selected for the Chain #1 is not.
              Among multiple instances of one service function, some could be in close proximity while others are far apart being connected by different network nodes.
              It should be acceptable for Service Chain classifier only identify the chaining at function level and have another entity managing the detailed service instance path.

Thanks, Linda

From: sfc [mailto:[email-masked]] On Behalf Of Jim Guichard (jguichar)
Sent: Saturday, February 01, 2014 11:24 AM
To: [email-masked]
Subject: [sfc] SFC WG Agenda: London

Greetings,

2) Use cases.

3) Architecture.

Thanks!

Thomas & Jim

---

From: [email-masked]
Date: Fri, 14 Feb 2014 11:15:39 +0800

Hello Jim & Thomas,

Yesterday, We posted a draft about use cases of broadband network.  I'd 
like a 10 minutes to show the 
use cases of broadband network in the context of CGN/FW/AAA etc.

Requested details:

1) 
https://datatracker.ietf.org/doc/draft-meng-sfc-broadband-usecases/?include_text=1

2) Provide use cases under several scenarios , 
DS-Lite/NAT44/NAT64&DNS64/lw4o6/MAP/AAA...

3) Propose some considerations about 
     a) "NAT Pool configuration"  & "routing advertising" considerations 
for outbound & inbound routing path
     b) Deploying mode consideration in broadband network.    Standalone 
or directly connecting
     c) NAT traversal
     d)  Example of "service function chains"
     etc.

4) We also refer to studies and concepts of sfc architecture/service 
function path from other drafts such as 
draft-quinn-sfc-arch/draft-parker-sfc-chain-to-path.

Thanks,
Wei & Cui & Bhumip

"sfc" <[email-masked]>  2014-02-02 01:23:38:

> Greetings,
> 
> It's time to start putting together an agenda for the SFC meeting in
> London. We've requested one 2.5 hour slot . Because face-to-face 
> time is precious, we intend to focus on:
> 
> We also do not intend to give agenda time to everyone who has a 
> draft - the WG sessions do not have time for that, nor is it 
> necessarily an effective use of time. We also do not intend to give 
> agenda time for drafts for which little or no mailing list interest 
> has been generated.
> 
> If you have a draft (or plan to submit one) and would like to 
> present (or more specifically, would like the working group to do 
> something with your draft), please:
> 
> 3) Indicate what you want the WG to do with your draft. E.g., do you
> want this to become "THE" WG document for a particular deliverable? 
> Or, is there content in the document you believe should be added to 
> another document? etc. Please do not just respond "I want it to 
> become a WG document". It would be better to explain in what 
> context, and how your draft relates to other drafts that have been 
submitted.
> 
> Thanks!
> 
> Thomas & Jim_______________________________________________
> sfc mailing list
> [email-masked]

---

From: Ross Callon <[email-masked]>
Date: Fri, 14 Feb 2014 16:00:04 +0000

We would like to request a slot to present draft-rijsman-sfc-metadata-considerations. Since Bruno will not be in London, the intent is that Bruno and I will create slides and then I will present them.

Regarding your specific questions:

1) Let us know now:

                Done (this email)

                The intent of the draft is to clearly articulate the use-cases, implementation options, and challenges related to metadata (what is it, what is it used for, what options are there for conveying metadata,...). As such, the issue raised in this draft are important inputs to the various chartered work items for the working group.

                Whether this draft would end up being published on its own, or would be folded into other drafts, is TBD by the WG.

In terms of the amount of time to present the draft: I think that 10 minutes would be sufficient, more time would be great if available and would allow more discussion of details.

Thanks, Ross

From: sfc [mailto:[email-masked]] On Behalf Of Jim Guichard (jguichar)
Sent: Saturday, February 01, 2014 12:24 PM
To: [email-masked]
Subject: [sfc] SFC WG Agenda: London

Greetings,

2) Use cases.

3) Architecture.

Thanks!

Thomas & Jim