Subject: [sfc] Framework & routing

From: [email-masked]
Date: Thu, 20 Feb 2014 11:07:10 +0800

Hi, med

  I was looking at your framework proposal. 

  The proposal elaborates on framework &  PDP architecture and 
  some deployment considerations such as deployment models.
 
  In section 10.2 para 3, it describes a router-based mechanisam
  which offers a default router for the packets delivery between 
  SF nodes. 

  However,I would like to know how inbound traffic steer packets 
  to the Ingress Node for inbound direction ?
  Such as, there is a NAT44 SF node with public ipv4 address pool
  12.3.4.0/24, then how to advertise this route to the legacy network
  for the inbound traffic ?
  This maybe a deployment consideration need to point out.

BRs,
Linda
--------------------------------------------------------
ZTE Information Security Notice: The information contained in this mail (and any attachment transmitted herewith) is privileged and confidential and is intended for the exclusive use of the addressee(s).  If you are not an intended recipient, any disclosure, reproduction, distribution or other dissemination or use of the information contained is strictly prohibited.  If you have received this mail in error, please delete it and notify us immediately.
--------------------------------------------------------
ZTE Information Security Notice: The information contained in this mail (and any attachment transmitted herewith) is privileged and confidential and is intended for the exclusive use of the addressee(s).  If you are not an intended recipient, any disclosure, reproduction, distribution or other dissemination or use of the information contained is strictly prohibited.  If you have received this mail in error, please delete it and notify us immediately.

---

From: <[email-masked]>
Date: Tue, 25 Feb 2014 17:00:28 +0100

Hi Linda,

Please see inline.

Cheers,
Med

De : [email-masked] [mailto:[email-masked]]
Envoyé : jeudi 20 février 2014 04:07
À : BOUCADAIR Mohamed IMT/OLN
Cc : Bhumip Khasnabish; Wei Meng; [email-masked]; [email-masked]
Objet : [sfc] Framework & routing

Hi, med

  However,I would like to know how inbound traffic steer packets
  to the Ingress Node for inbound direction ?
[Med] This deployment model assumes the SF router is responsible for managing the order and the forwarding to the SFs to be invoked. SF applies its functionality to a received packet and then returns the outcome to the SF Router.

  Such as, there is a NAT44 SF node with public ipv4 address pool
  12.3.4.0/24, then how to advertise this route to the legacy network
  for the inbound traffic ?
[Med] If your question is about the router-based model, the routing advertisement can be made by the SF Router to attract incoming traffic.
  This maybe a deployment consideration need to point out.
[Med] This point is specific to the SF(NAT) case. FYI, draft-liu-sfc-use-cases tries to generalize this issue as follows:

   o  Some stateful SFs (e.g., NAT or firewall) may need to treat both

      outgoing and incoming packets.  The design of SF Maps must take

      into account such constraints, otherwise, the service may be

      disturbed.  The set of SFs that need to be invoked for both

      direction is up to the responsibility of each administrative

      entity operating an SFC-enabled domain.

---

From: [email-masked]
Date: Wed, 26 Feb 2014 18:24:40 +0800

Hi Med，

  Please see inline.

> [Med] This deployment model assumes the SF router is responsible for
> managing the order and the forwarding to the SFs to be invoked. SF 
> applies its functionality to a received packet and then returns the 
> outcome to the SF Router.
[Wei]: IMHO, because all packets must be returned back, this deployment 
model is costly in terms of performance. If I understand what you
mean correctly.
  Another deployment is that SFs forward packet directly. How about the
solution under this scenario?

> [Med] If your question is about the router-based model, the routing 
> advertisement can be made by the SF Router to attract incoming traffic. 
[Wei]: Do you mean pool MUST configured in SF routers? 
I think this assumption is based on the deployment that SFs return the 
outcome to the SF routers for forwarding rather than forwarding packet
directly by SFs. If the later, how to steer packets to the Ingress Node 
for inbound direction ?

In a way, it might not be suited for everywhere for returning the outcome 
to SF routers .

Thanks,
Wei

"sfc" <[email-masked]>  2014-02-26 00:00:28:

> [Med] This deployment model assumes the SF router is responsible for
> managing the order and the forwarding to the SFs to be invoked. SF 
> applies its functionality to a received packet and then returns the 
> outcome to the SF Router.
> 
> [Med] If your question is about the router-based model, the routing 
> advertisement can be made by the SF Router to attract incoming traffic. 
> [Med] This point is specific to the SF(NAT) case. FYI, draft-liu-
> sfc-use-cases tries to generalize this issue as follows:
>  _______________________________________________
> sfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sfc