Subject: Re: [sfc] Comments on draft-meng-sfc-broadband-usecases-00

From: [email-masked]
Date: Fri, 21 Feb 2014 10:43:46 +0800

Hi Yuchi,

  Thanks for your comments.

  IMO, classifier is a logical entity that can be located in some physical 
apparatuses,
and that includes CPEs/BNASes.

  For IPv6 transition use cases, there might be some different types of 
technology, such
as DS-Lite/LW 4o6/MAP...  That brings a problem that several demonds might 
be made on
CPEs. CPEs MUST support NAT/FIREWALL/SOFTWIRE. 
  In this context, CPE might not be suited to implement all functions.

  In an actual deployment scenario, we can consider a cluster of CPEs with 
a same associated
service node to implement the service functions. Thus, it will simplified 
the functionality
of CPEs and let CPEs unified.
 
  I hope these can address your questions and doubts.

Thanks,
Wei

From: "Yuchi Chen" <chenycmx at gmail.com> 
To: meng.wei2 <meng.wei2 at zte.com.cn> 
Cc: sfc <sfc at ietf.org> 
Date: Thu, 20 Feb 2014 13:27:06 +0800 
List-id: Network Service Chaining <sfc.ietf.org> 

Hi Wei,
 
I've read the draft. IMHO this draft provides a new point of view that SFC 
can be applied in the deployment of IPv6 transition mechanisms. 
 
Here is a question I have:  what is the relationship between CPE/BNAS and 
the classifier? For now the classifier seems to be an individual device. 
If I understand this correctly, I think it might be trival to implement 
such various devices, as their specfications should quite depend on their 
actual locations in the network. Is it possible to let CPE/BNAS perform 
the service functions?
 
Best regards!

--------------------------------------------------------------------------------

Yuchi Chen

---

From: "Yuchi Chen" <[email-masked]>
Date: Fri, 21 Feb 2014 15:32:16 +0800

Hi Wei,
     Yes, thanks for the clarification. I think you mean that such a classifier is not responsible for forwarding packets, but only for packet processing, and once the procedure is done, the packet will be returned to the CPE/BNAS for forwarding. If this is the case, my suggestion is to clarify this point somewhere in the text if possible.

Best regards!

Yuchi Chen

From: meng.wei2
Date: 2014-02-21 10:43
To: chenycmx
CC: sfc
Subject: Re:[sfc] Comments on draft-meng-sfc-broadband-usecases-00

Hi Yuchi, 

  IMO, classifier is a logical entity that can be located in some physical apparatuses, 
and that includes CPEs/BNASes. 

  For IPv6 transition use cases, there might be some different types of technology, such 
as DS-Lite/LW 4o6/MAP...  That brings a problem that several demonds might be made on 
CPEs. CPEs MUST support NAT/FIREWALL/SOFTWIRE. 
  In this context, CPE might not be suited to implement all functions. 

  In an actual deployment scenario, we can consider a cluster of CPEs with a same associated 
service node to implement the service functions. Thus, it will simplified the functionality 
of CPEs and let CPEs unified. 

Thanks, 
Wei 

Hi Wei, 
  
I've read the draft. IMHO this draft provides a new point of view that SFC can be applied in the deployment of IPv6 transition mechanisms. 
  
Here is a question I have:  what is the relationship between CPE/BNAS and the classifier? For now the classifier seems to be an individual device. If I understand this correctly, I think it might be trival to implement such various devices, as their specfications should quite depend on their actual locations in the network. Is it possible to let CPE/BNAS perform the service functions? 
  
Best regards! 

Yuchi Chen

---

From: Jerome Moisand <[email-masked]>
Date: Fri, 21 Feb 2014 18:31:10 +0000

Folks,
The Broadband Forum (BBF) just issued a liaison to IETF, providing a snapshot of its activities on Service Chaining, and notably... (fixed) broadband use cases! This is a work in progress, it takes time to identify scenarios with proper level of support (notably from service providers), but we're making progress.
Broadband Forum Work on Flexible Service Chaining (SD-326)
   https://datatracker.ietf.org/documents/LIAISON/liaison-2014-02-13-broadband-forum-sfc-broadband-forum-work-on-flexible-service-chaining-sd-326-attachment-1.pdf
Somehow we need to consolidate those efforts. I am not entirely sure it makes sense to have two parallel initiatives between IETF and BBF in this respect, two documents to maintain, etc. Hopefully, the point will be discussed in London.
As a side note, the next BBF meeting is scheduled the week after IETF (starting March 3rd, in Malta). Contributions to SD-326 would be very welcome.
Cheers, Jerome   (BBF SD-326 co-editor)
PS. I believe there is a similar point to be made about 3GPP and its new "Service Steering" activity in SA1.
From: sfc [mailto:[email-masked]] On Behalf Of Yuchi Chen
Sent: Friday, February 21, 2014 2:32 AM
To: meng.wei2
Cc: sfc
Subject: Re: [sfc] Comments on draft-meng-sfc-broadband-usecases-00

Hi Wei,

Best regards!
________________________________
Yuchi Chen

From: meng.wei2<mailto:[email-masked]>
Date: 2014-02-21 10:43
To: chenycmx<mailto:[email-masked]>
CC: sfc<mailto:[email-masked]>
Subject: Re:[sfc] Comments on draft-meng-sfc-broadband-usecases-00

Hi Yuchi,

Thanks,
Wei

Hi Wei,

Best regards!

Yuchi Chen