Subject: [sfc] Comments on draft-meng-sfc-broadband-usecases-00

From: "Yuchi Chen" <[email-masked]>
Date: Thu, 20 Feb 2014 13:27:06 +0800

Hi Wei,

I've read the draft. IMHO this draft provides a new point of view that SFC can be applied in the deployment of IPv6 transition mechanisms. 

Here is a question I have:  what is the relationship between CPE/BNAS and the classifier? For now the classifier seems to be an individual device. If I understand this correctly, I think it might be trival to implement such various devices, as their specfications should quite depend on their actual locations in the network. Is it possible to let CPE/BNAS perform the service functions?

Best regards!

Yuchi Chen

---

From: [email-masked]
Date: Sat, 22 Feb 2014 15:37:19 +0800

Hi Yunchi，

   Right. Returning packets to the original CPE/BNAS for forwarding is
one of the modes of deployment consideration. It might be more recommended
for factors of reducing cost.

  PLS have a look at section 4.1 context and figure.

                 +-----------+
                 |    Host   |
                 +-----+-----+
                       |
                       |
             +---------|---------+    +-------------------+
             |                   |    |    -------------  |
             |        CPE        ----->   |    SFP      | |
             |                   <-----   --------------  |
             +---------|---------+    +-------------------+

  There is another mode to the deployment consideration. Service node 
needs to
forward packets to next hop in some way. In section 4.1,

             +-------------------+     +-------------+
             |                   |-out->classifier A |
             |                   |     +------|------+
             |        CPE        |            |
             |                   |            |
             |                   |           out
             +-------------------+            |
                                              |
                                       +------v------+
                                       |             |
                                       |     SFP  A  |
                                       |             |
                                       +------|------+
                                              |
                                              |
                                              v

  These considerations seem to be quite implemented under traditional 
broadband
network. How will it perform in centralized management of broadband 
network? I
think it is an interesting topic many people concern about. 

Thanks,
Wei

From: "Yuchi Chen" <chenycmx at gmail.com> 
To: meng.wei2 <meng.wei2 at zte.com.cn> 
Cc: sfc <sfc at ietf.org> 
Date: Fri, 21 Feb 2014 15:32:16 +0800 
References: 
<[email-masked]> 
List-id: Network Service Chaining <sfc.ietf.org> 

--------------------------------------------------------------------------------
Hi Wei,
     Yes, thanks for the clarification. I think you mean that such a 
classifier is not responsible for forwarding packets, but only for packet 
processing, and once the procedure is done, the packet will be returned to 
the CPE/BNAS for forwarding. If this is the case, my suggestion is to 
clarify this point somewhere in the text if possible.
 
Best regards!

--------------------------------------------------------------------------------

Yuchi Chen
 
From: meng.wei2
Date: 2014-02-21 10:43
To: chenycmx
CC: sfc
Subject: Re:[sfc] Comments on draft-meng-sfc-broadband-usecases-00

Hi Yuchi, 

  Thanks for your comments. 

  IMO, classifier is a logical entity that can be located in some physical 
apparatuses, 
and that includes CPEs/BNASes. 

  For IPv6 transition use cases, there might be some different types of 
technology, such 
as DS-Lite/LW 4o6/MAP...  That brings a problem that several demonds might 
be made on 
CPEs. CPEs MUST support NAT/FIREWALL/SOFTWIRE. 
  In this context, CPE might not be suited to implement all functions. 

  In an actual deployment scenario, we can consider a cluster of CPEs with 
a same associated 
service node to implement the service functions. Thus, it will simplified 
the functionality 
of CPEs and let CPEs unified. 
 
  I hope these can address your questions and doubts. 

Thanks, 
Wei 

From: "Yuchi Chen" <chenycmx at gmail.com> 
To: meng.wei2 <meng.wei2 at zte.com.cn> 
Cc: sfc <sfc at ietf.org> 
Date: Thu, 20 Feb 2014 13:27:06 +0800 
List-id: Network Service Chaining <sfc.ietf.org> 

Hi Wei, 
 
I've read the draft. IMHO this draft provides a new point of view that SFC 
can be applied in the deployment of IPv6 transition mechanisms. 
 
Here is a question I have:  what is the relationship between CPE/BNAS and 
the classifier? For now the classifier seems to be an individual device. 
If I understand this correctly, I think it might be trival to implement 
such various devices, as their specfications should quite depend on their 
actual locations in the network. Is it possible to let CPE/BNAS perform 
the service functions? 
 
Best regards! 

-------------------------------------------------------------------------------- 

Yuchi Chen