Subject: [sfc] Loop detection in service chains - question on draft-boucadair-sfc-requirements

From: Ben Wright <[email-masked]>
Date: Wed, 26 Mar 2014 12:21:40 +0000

Hi,

I'd like to get your input and that of the WG on Loop Detection within a service chain.

draft-boucadair-sfc-requirements explicitly forbids the same SF from appearing in a given SFC (Req #25), to prevent loops forming.   Other drafts allow this - e.g. draft-quinn-sfc-arch: "A given SF can appear one time or multiple times in a given SFC".

I can see that there might be use cases for which it is advantageous to have the same SF appear more than once in SFC.   Would it be acceptable to allow this but use, for example, a TTL-based mechanism to prevent any loops from being long-lived?

Apologies if this has been raised before on the list and I've missed it.

Thanks,

Ben

---

From: <[email-masked]>
Date: Wed, 26 Mar 2014 13:44:51 +0100

Dear Ben,

The main point is to prevent forwarding loops. Because SF loops can lead in some contexts to such forwarding loops, the requirement draft advocates to include SF loop detection as part of the solution capabilities.

Should the solution be configurable to relax these checks is another point that should be discussed.

Note that if loop detection checks are relaxed, and an SF identifier is allowed to be invoked several times, then means to ensure that such Service Function Spiral does not lead to forwarding loops.

Cheers,
Med

De : sfc [mailto:[email-masked]] De la part de Ben Wright
Envoyé : mercredi 26 mars 2014 13:22
À : [email-masked]
Cc : [email-masked]
Objet : [sfc] Loop detection in service chains - question on draft-boucadair-sfc-requirements

Hi,

Thanks,

Ben

---

From: "Jim Guichard (jguichar)" <[email-masked]>
Date: Wed, 26 Mar 2014 13:57:15 +0000

Hi Ben,

Yes, this is most certainly a requirement. I would suggest looking at draft-quinn-sfc-nsh for a description of how the service path ID + service index are used to determine where in the service chain the packet is currently and how the index is decremented at each service hop to facilitate both service hop awareness and loop detection within the service graph.

From: Ben Wright <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, March 26, 2014 at 8:21 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [sfc] Loop detection in service chains - question on draft-boucadair-sfc-requirements

Hi,

I’d like to get your input and that of the WG on Loop Detection within a service chain.

draft-boucadair-sfc-requirements explicitly forbids the same SF from appearing in a given SFC (Req #25), to prevent loops forming.   Other drafts allow this - e.g. draft-quinn-sfc-arch: “A given SF can appear one time or multiple times in a given SFC”.

Apologies if this has been raised before on the list and I’ve missed it.

Thanks,

Ben

---

From: Ron Parker <[email-masked]>
Date: Wed, 26 Mar 2014 14:16:41 +0000

Thanks, Jim.

I'll point out that there is a second take on the SFC service header which is also consistent in its treatment of the SF path and SF index (full disclosure - I am a co-author).

http://datatracker.ietf.org/doc/draft-zhang-sfc-sch/

     Ron

From: sfc [mailto:[email-masked]] On Behalf Of Jim Guichard (jguichar)
Sent: Wednesday, March 26, 2014 9:57 AM
To: Ben Wright; [email-masked]
Cc: [email-masked]
Subject: Re: [sfc] Loop detection in service chains - question on draft-boucadair-sfc-requirements

Hi Ben,

Hi,

Thanks,

Ben

---

From: Ben Wright <[email-masked]>
Date: Wed, 26 Mar 2014 14:22:15 +0000

Hi Jim, Med, Ron,

Thanks for your prompt responses.   I think we're in agreement - spiral paths may be required, but we need to have a mechanism to prevent loops forming.   My reading of REQ#25 was that it disallowed spiral paths.  Given this, how do you feel about us tweaking the text for that requirement to something like:

REQ#25:  Service Functions MAY appear be invoked multiple times in the same Service Function Chain (in a spiral), but the solution MUST prevent Service Function loops.

As Jim and Ron say, we have mechanisms which meet this requirement.

Cheers,

Ben

From: Ron Parker [mailto:[email-masked]]
Sent: 26 March 2014 14:17
To: Jim Guichard (jguichar); Ben Wright; [email-masked]
Cc: [email-masked]
Subject: RE: [sfc] Loop detection in service chains - question on draft-boucadair-sfc-requirements

Thanks, Jim.

     Ron

From: sfc [mailto:[email-masked]] On Behalf Of Jim Guichard (jguichar)
Sent: Wednesday, March 26, 2014 9:57 AM
To: Ben Wright; [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: [sfc] Loop detection in service chains - question on draft-boucadair-sfc-requirements

Hi Ben,

Hi,

Thanks,

Ben

---

From: Lucy yong <[email-masked]>
Date: Wed, 26 Mar 2014 15:34:31 +0000

Yes, this is needed. It is necessary to have a field in SFC header to serve this purpose.

Lucy

From: sfc [mailto:[email-masked]] On Behalf Of Ben Wright
Sent: Wednesday, March 26, 2014 7:22 AM
To: [email-masked]
Cc: [email-masked]
Subject: [sfc] Loop detection in service chains - question on draft-boucadair-sfc-requirements

Hi,

Thanks,

Ben

---

From: "Louis.Fourie" <[email-masked]>
Date: Wed, 26 Mar 2014 16:26:41 +0000

Lucy,
   Drafts on an SFC header:

http://datatracker.ietf.org/doc/draft-quinn-sfc-nsh/

include an index field that can be used to detect loops in the service chain.

-          Louis

From: sfc [mailto:[email-masked]] On Behalf Of Lucy yong
Sent: Wednesday, March 26, 2014 8:35 AM
To: Ben Wright; [email-masked]
Cc: [email-masked]
Subject: Re: [sfc] Loop detection in service chains - question on draft-boucadair-sfc-requirements

Lucy

Hi,

Thanks,

Ben

---

From: <[email-masked]>
Date: Thu, 27 Mar 2014 08:16:42 +0100

Dear Louis,

Yes, there are a variety of means to achieve the functionality. In addition to the pointers you provided, there is also this one: http://tools.ietf.org/html/draft-boucadair-sfc-framework-02#section-10.6 (10.6. Service Function Loops).

I suggest that we focus at this stage on the requirement rather than discussing how to fulfil it.

Cheers,
Med

De : sfc [mailto:[email-masked]] De la part de Louis.Fourie
Envoyé : mercredi 26 mars 2014 17:27
À : Lucy yong; Ben Wright; [email-masked]
Cc : [email-masked]
Objet : Re: [sfc] Loop detection in service chains - question on draft-boucadair-sfc-requirements

Lucy,
   Drafts on an SFC header:

-          Louis

Lucy

To: [email-masked]<mailto:[email-masked]>

Hi,

Thanks,

Ben

---

From: <[email-masked]>
Date: Thu, 27 Mar 2014 08:34:30 +0100

Dear Ben,

What about this proposal?

   REQ#25:  The solution MUST prevent Service Function Loops.

            A.  Relaxing this capability SHOULD be configurable.
            B.  Service Functions MAY be invoked multiple times in the
                same Service Function Chain (denoted as SF Spiral), but
                the solution MUST prevent forwarding loops.

The motivation for this wording is to call out the core functionality (that is loop detection) and allow for some exceptions where the functionality is disabled for some specific deployments.

Cheers,
Med

De : sfc [mailto:[email-masked]] De la part de Ben Wright
Envoyé : mercredi 26 mars 2014 15:22
À : Ron Parker; Jim Guichard (jguichar); [email-masked]
Cc : [email-masked]
Objet : Re: [sfc] Loop detection in service chains - question on draft-boucadair-sfc-requirements

Hi Jim, Med, Ron,

Cheers,

Ben

To: Jim Guichard (jguichar); Ben Wright; [email-masked]<mailto:[email-masked]>

Thanks, Jim.

     Ron

Hi Ben,

Hi,

Thanks,

Ben

---

From: Ben Wright <[email-masked]>
Date: Thu, 27 Mar 2014 10:09:59 +0000

Hi Med,

Thanks for drafting that.  To be clear, I'd be happy to drop option A to allow loop prevention to be configurable.   For me, the key point is to clarify that SF spirals are allowed, even though loops (with data forwarded indefinitely) most definitely are not.

As other folks have pointed out, each of the various solutions provides a mechanism to support this requirement.

Cheers,

Ben

From: [email-masked] [mailto:[email-masked]]
Sent: 27 March 2014 07:35
To: Ben Wright; Ron Parker; Jim Guichard (jguichar); [email-masked]
Cc: [email-masked]
Subject: RE: [sfc] Loop detection in service chains - question on draft-boucadair-sfc-requirements

Dear Ben,

Cheers,
Med

De : sfc [mailto:[email-masked]] De la part de Ben Wright
Envoyé : mercredi 26 mars 2014 15:22
À : Ron Parker; Jim Guichard (jguichar); [email-masked]<mailto:[email-masked]>
Cc : [email-masked]<mailto:[email-masked]>
Objet : Re: [sfc] Loop detection in service chains - question on draft-boucadair-sfc-requirements

Hi Jim, Med, Ron,

Cheers,

Ben

Thanks, Jim.

     Ron

Hi Ben,

Hi,

Thanks,

Ben

---

From: Xuxiaohu <[email-masked]>
Date: Thu, 27 Mar 2014 10:03:02 +0000

Hi Med,

It seems helpful to further mention that in the SF Spiral case, the path selection on the service nodes which may be invoked multiple times in the same service path, now should depend on the combination of the service path ID and the service index, rather than the service path ID alone.

Best regards,
Xiaohu

发件人: sfc [mailto:[email-masked]] 代表 [email-masked]
发送时间: 2014年3月27日 15:35
收件人: Ben Wright; Ron Parker; Jim Guichard (jguichar); [email-masked]
抄送: [email-masked]
主题: Re: [sfc] Loop detection in service chains - question on draft-boucadair-sfc-requirements

Dear Ben,

Cheers,
Med

Hi Jim, Med, Ron,

Thanks for your prompt responses.   I think we’re in agreement – spiral paths may be required, but we need to have a mechanism to prevent loops forming.   My reading of REQ#25 was that it disallowed spiral paths.  Given this, how do you feel about us tweaking the text for that requirement to something like:

Cheers,

Ben

Thanks, Jim.

I’ll point out that there is a second take on the SFC service header which is also consistent in its treatment of the SF path and SF index (full disclosure – I am a co-author).

     Ron

Hi Ben,

Hi,

Thanks,

Ben

---

From: "Jim Guichard (jguichar)" <[email-masked]>
Date: Thu, 27 Mar 2014 12:12:33 +0000

I agree. Why would you want to relax the requirement of preventing loops within a service path? If there is no clear reason then point A. should be removed from the text.

From: Ben Wright <[email-masked]<mailto:[email-masked]>>
Date: Thursday, March 27, 2014 at 6:09 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Ron Parker <[email-masked]<mailto:[email-masked]>>, Jim Guichard <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: RE: [sfc] Loop detection in service chains - question on draft-boucadair-sfc-requirements

Hi Med,

Thanks for drafting that.  To be clear, I’d be happy to drop option A to allow loop prevention to be configurable.   For me, the key point is to clarify that SF spirals are allowed, even though loops (with data forwarded indefinitely) most definitely are not.

Cheers,

Ben

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]]
Sent: 27 March 2014 07:35
To: Ben Wright; Ron Parker; Jim Guichard (jguichar); [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: RE: [sfc] Loop detection in service chains - question on draft-boucadair-sfc-requirements

Dear Ben,

Cheers,
Med

Hi Jim, Med, Ron,

Cheers,

Ben

Thanks, Jim.

     Ron

Hi Ben,

Hi,

Thanks,

Ben

---

From: Ben Wright <[email-masked]>
Date: Thu, 27 Mar 2014 12:59:53 +0000

Hi Xiaohu,

To my mind, I think we should not mention service path ID and service index in the requirements draft.   These are part of the solution, not the requirement itself.

Thanks,

Ben

From: Xuxiaohu [mailto:[email-masked]]
Sent: 27 March 2014 10:03
To: [email-masked]; Ben Wright; Ron Parker; Jim Guichard (jguichar); [email-masked]
Cc: [email-masked]
Subject: re: [sfc] Loop detection in service chains - question on draft-boucadair-sfc-requirements

Hi Med,

Best regards,
Xiaohu

发件人: sfc [mailto:[email-masked]] 代表 [email-masked]<mailto:[email-masked]>
发送时间: 2014年3月27日 15:35
收件人: Ben Wright; Ron Parker; Jim Guichard (jguichar); [email-masked]<mailto:[email-masked]>
抄送: [email-masked]<mailto:[email-masked]>
主题: Re: [sfc] Loop detection in service chains - question on draft-boucadair-sfc-requirements

Dear Ben,

Cheers,
Med

Hi Jim, Med, Ron,

Cheers,

Ben

Thanks, Jim.

     Ron

Hi Ben,

Hi,

Thanks,

Ben

---

From: "Louis.Fourie" <[email-masked]>
Date: Thu, 27 Mar 2014 17:40:30 +0000

Med,
   I agree that requirements should be finalized. Just pointing out that the transport of path identifier
and SF index has been taken into consideration.

-          Louis

From: [email-masked] [mailto:[email-masked]]
Sent: Thursday, March 27, 2014 12:17 AM
To: Louis.Fourie; Lucy yong; Ben Wright; [email-masked]
Cc: [email-masked]
Subject: RE: [sfc] Loop detection in service chains - question on draft-boucadair-sfc-requirements

Dear Louis,

Cheers,
Med

Lucy,
   Drafts on an SFC header:

-          Louis

Lucy

Hi,

Thanks,

Ben

---

From: Lucy yong <[email-masked]>
Date: Thu, 27 Mar 2014 19:58:06 +0000

Hi Louis,

I read both drafts and understood the usage of index in both drafts is the same. But using index in this way can't prevent the loop. Please see my explanation in another thread.
http://www.ietf.org/mail-archive/web/sfc/current/msg01680.html

Regards,
Lucy

From: Louis.Fourie
Sent: Wednesday, March 26, 2014 11:27 AM
To: Lucy yong; Ben Wright; [email-masked]
Cc: [email-masked]
Subject: RE: [sfc] Loop detection in service chains - question on draft-boucadair-sfc-requirements

Lucy,
   Drafts on an SFC header:

-          Louis

Lucy

Hi,

Thanks,

Ben

---

From: "Reinaldo Penno (repenno)" <[email-masked]>
Date: Thu, 27 Mar 2014 20:27:02 +0000

I’m not sure I follow your the issue.

A loop (as in routing loop) is prevented in the control plane.  What we have in the IP header (TTL) is a field that prevents a packet from looping forever. It does not prevent actual looping, it provides a safety catch.

SFC routing loops should also be prevented in the control plane, not on forwarding. So, your orchestration system need to make sure your path does not have loops.  Decrementing the service index at each SFI will provide a safety catch similar to TTL.

Thanks,

Reinaldo

From: Lucy yong <[email-masked]<mailto:[email-masked]>>
Date: Thursday, March 27, 2014 at 12:58 PM
To: "Louis.Fourie" <[email-masked]<mailto:[email-masked]>>, Ben Wright <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [sfc] Loop detection in service chains - question on draft-boucadair-sfc-requirements

Hi Louis,

I read both drafts and understood the usage of index in both drafts is the same. But using index in this way can’t prevent the loop. Please see my explanation in another thread.
http://www.ietf.org/mail-archive/web/sfc/current/msg01680.html

Regards,
Lucy

From: Louis.Fourie
Sent: Wednesday, March 26, 2014 11:27 AM
To: Lucy yong; Ben Wright; [email-masked]<mailto:[email-masked]>
Cc: [email-masked]<mailto:[email-masked]>
Subject: RE: [sfc] Loop detection in service chains - question on draft-boucadair-sfc-requirements

Lucy,
   Drafts on an SFC header:

-          Louis

Lucy

Hi,

Thanks,

Ben

---

From: "Changcheng Huang" <[email-masked]>
Date: Fri, 28 Mar 2014 05:52:04 +0900

I agree. Loop prevention should be done in control plane. TTL was designed
in early days. It does not work today. It is quite common today that a
packet travels a large number of hops.

Chang

From: sfc [mailto:[email-masked]] On Behalf Of Reinaldo Penno
(repenno)
Sent: Friday, March 28, 2014 5:27 AM
To: Lucy yong; Louis.Fourie; Ben Wright;
[email-masked]
Cc: [email-masked]
Subject: Re: [sfc] Loop detection in service chains - question on
draft-boucadair-sfc-requirements

I'm not sure I follow your the issue.

A loop (as in routing loop) is prevented in the control plane.  What we have
in the IP header (TTL) is a field that prevents a packet from looping
forever. It does not prevent actual looping, it provides a safety catch.

SFC routing loops should also be prevented in the control plane, not on
forwarding. So, your orchestration system need to make sure your path does
not have loops.  Decrementing the service index at each SFI will provide a
safety catch similar to TTL.

Thanks,

Reinaldo

From: Lucy yong <[email-masked]>
Date: Thursday, March 27, 2014 at 12:58 PM
To: "Louis.Fourie" <[email-masked]>, Ben Wright
<[email-masked]>,
"[email-masked]"
<[email-masked]>
Cc: "[email-masked]" <[email-masked]>
Subject: Re: [sfc] Loop detection in service chains - question on
draft-boucadair-sfc-requirements

Hi Louis,

I read both drafts and understood the usage of index in both drafts is the
same. But using index in this way can't prevent the loop. Please see my
explanation in another thread.

Regards,

Lucy

From: Louis.Fourie 
Sent: Wednesday, March 26, 2014 11:27 AM
To: Lucy yong; Ben Wright; [email-masked]
Cc: [email-masked]
Subject: RE: [sfc] Loop detection in service chains - question on
draft-boucadair-sfc-requirements

Lucy,

   Drafts on an SFC header:

include an index field that can be used to detect loops in the service
chain.

-          Louis

From: sfc [mailto:[email-masked]] On Behalf Of Lucy yong
Sent: Wednesday, March 26, 2014 8:35 AM
To: Ben Wright; [email-masked]
Cc: [email-masked]
Subject: Re: [sfc] Loop detection in service chains - question on
draft-boucadair-sfc-requirements

Yes, this is needed. It is necessary to have a field in SFC header to serve
this purpose.

Lucy

From: sfc [mailto:[email-masked]] On Behalf Of Ben Wright
Sent: Wednesday, March 26, 2014 7:22 AM
To: [email-masked]
Cc: [email-masked]
Subject: [sfc] Loop detection in service chains - question on
draft-boucadair-sfc-requirements

Hi, 

I'd like to get your input and that of the WG on Loop Detection within a
service chain.  

draft-boucadair-sfc-requirements explicitly forbids the same SF from
appearing in a given SFC (Req #25), to prevent loops forming.   Other drafts
allow this - e.g. draft-quinn-sfc-arch: "A given SF can appear one time or
multiple times in a given SFC".    

I can see that there might be use cases for which it is advantageous to have
the same SF appear more than once in SFC.   Would it be acceptable to allow
this but use, for example, a TTL-based mechanism to prevent any loops from
being long-lived? 

Thanks, 

Ben

---

From: <[email-masked]>
Date: Fri, 28 Mar 2014 11:39:13 +0100

Hi Xioahu,

I’m afraid that including those identifiers in the requirement text is close to the solution discussion rather than identifying the functional need.

Cheers,
Med

De : Xuxiaohu [mailto:[email-masked]]
Envoyé : jeudi 27 mars 2014 11:03
À : BOUCADAIR Mohamed IMT/OLN; Ben Wright; Ron Parker; Jim Guichard (jguichar); [email-masked]
Cc : [email-masked]
Objet : re: [sfc] Loop detection in service chains - question on draft-boucadair-sfc-requirements

Hi Med,

Best regards,
Xiaohu

Dear Ben,

Cheers,
Med

Hi Jim, Med, Ron,

Cheers,

Ben

Thanks, Jim.

     Ron

Hi Ben,

Hi,

Thanks,

Ben

---

From: <[email-masked]>
Date: Fri, 28 Mar 2014 11:47:05 +0100

Dear Ben,

Ok to remove "A". I suggest to change  "Service Function Loops" to "infinite Service Function Loops"

Cheers,
Med

De : Ben Wright [mailto:[email-masked]]
Envoyé : jeudi 27 mars 2014 11:10
À : BOUCADAIR Mohamed IMT/OLN; Ron Parker; Jim Guichard (jguichar); [email-masked]
Cc : [email-masked]
Objet : RE: [sfc] Loop detection in service chains - question on draft-boucadair-sfc-requirements

Hi Med,

Cheers,

Ben

Dear Ben,

Cheers,
Med

Hi Jim, Med, Ron,

Cheers,

Ben

Thanks, Jim.

     Ron

Hi Ben,

Hi,

Thanks,

Ben

---

From: Ben Wright <[email-masked]>
Date: Fri, 28 Mar 2014 10:48:46 +0000

Thanks Med.   I'm happy with that.

From: [email-masked] [mailto:[email-masked]]
Sent: 28 March 2014 10:47
To: Ben Wright; Ron Parker; Jim Guichard (jguichar); [email-masked]
Cc: [email-masked]
Subject: RE: [sfc] Loop detection in service chains - question on draft-boucadair-sfc-requirements

Dear Ben,

Cheers,
Med

À : BOUCADAIR Mohamed IMT/OLN; Ron Parker; Jim Guichard (jguichar); [email-masked]<mailto:[email-masked]>

Hi Med,

Cheers,

Ben

Dear Ben,

Cheers,
Med

Hi Jim, Med, Ron,

Cheers,

Ben

Thanks, Jim.

     Ron

Hi Ben,

Hi,

Thanks,

Ben

---

From: <[email-masked]>
Date: Fri, 28 Mar 2014 13:05:54 +0100

Re-,

The point is that a "strict" loop detection mechanism would not allow for spirals unless it is instructed to do so: hence the configuration option in "A".

As indicated in my response to Ben, I removed "A" but I updated the wording to refer explicitly to "infinite SF loop".

Cheers,
Med

De : Jim Guichard (jguichar) [mailto:[email-masked]]
Envoyé : jeudi 27 mars 2014 13:13
À : Ben Wright; BOUCADAIR Mohamed IMT/OLN; Ron Parker; [email-masked]
Cc : [email-masked]
Objet : Re: [sfc] Loop detection in service chains - question on draft-boucadair-sfc-requirements

Hi Med,

Cheers,

Ben

Dear Ben,

Cheers,
Med

Hi Jim, Med, Ron,

Cheers,

Ben

Thanks, Jim.

     Ron

Hi Ben,

Hi,

Thanks,

Ben

---

From: <[email-masked]>
Date: Fri, 28 Mar 2014 13:16:55 +0100

Re-,

Ok, thanks.

I implemented the change in my local copy. For records, the new wording is as follows:

   REQ#25:  The solution MUST prevent infinite Service Function Loops.

            A.  Service Functions MAY be invoked multiple times in the
                same Service Function Chain (denoted as SF Spiral), but
                the solution MUST prevent forwarding loops.

I didn't included the comment asking to call out some identifiers because IMHO it is solution-specific.

Cheers,
Med

De : Ben Wright [mailto:[email-masked]]
Envoyé : vendredi 28 mars 2014 11:49
À : BOUCADAIR Mohamed IMT/OLN; Ron Parker; Jim Guichard (jguichar); [email-masked]
Cc : [email-masked]
Objet : RE: [sfc] Loop detection in service chains - question on draft-boucadair-sfc-requirements

Dear Ben,

Cheers,
Med

Hi Med,

Cheers,

Ben

Dear Ben,

Cheers,
Med

Hi Jim, Med, Ron,

Cheers,

Ben

Thanks, Jim.

     Ron

Hi Ben,

Hi,

Thanks,

Ben

---

From: "Joel M. Halpern" <[email-masked]>
Date: Fri, 28 Mar 2014 11:52:46 -0400

That looks to me like the right text for this document.  Thank you Med.
Yours,
Joel

On 3/28/14, 8:16 AM, [email-masked] wrote:
> I didn’t included the comment asking to call out some identifiers
> because IMHO it is solution-specific.
>
> Cheers,
>
> Med
>

---

From: Xuxiaohu <[email-masked]>
Date: Sat, 29 Mar 2014 02:30:40 +0000

Hi Med,

I agree that it is not suitable in the requirement draft.  Maybe it could be mentioned in the framework or architecture draft.

Best regards
Xiaohu

发件人: [email-masked] [mailto:[email-masked]]
发送时间: 2014年3月28日 18:39
收件人: Xuxiaohu; Ben Wright; Ron Parker; Jim Guichard (jguichar); [email-masked]
抄送: [email-masked]
主题: RE: [sfc] Loop detection in service chains - question on draft-boucadair-sfc-requirements

Hi Xioahu,

Cheers,
Med

À : BOUCADAIR Mohamed IMT/OLN; Ben Wright; Ron Parker; Jim Guichard (jguichar); [email-masked]<mailto:[email-masked]>

Hi Med,

Best regards,
Xiaohu

Dear Ben,

Cheers,
Med

Hi Jim, Med, Ron,

Cheers,

Ben

Thanks, Jim.

     Ron

Hi Ben,

Hi,

Thanks,

Ben