Subject: Re: [sfc] Mail regarding draft-quinn-sfc-problem-statement

From: "Jim Guichard (jguichar)" <[email-masked]>
Date: Wed, 5 Mar 2014 16:43:37 +0000

Hi Wim,

Could you be more specific in what you would like to see called out in the problem statement and any potential text that you feel is missing? Right now I see that in section 3 (bullet point 4) of the problem statement we have the follow text:

"In addition to sharing of information, the use of metadata addresses several of the issues raised in section 2, most notably the de-coupling of policy from the topology, and the need for per-service classification (and re-classification)".

Does this not capture what you are asking for?

From: <Henderickx>, "Wim (Wim)" <[email-masked]<mailto:[email-masked]>>
Date: Monday, March 3, 2014 at 4:28 AM
To: sfc <[email-masked]<mailto:[email-masked]>>
Subject: [sfc] Mail regarding draft-quinn-sfc-problem-statement

With respect to the problem statement I see a lot of discussions to use the meta-data header to convey information with respect to policies, etc to service fucntions.
If it is a problem we want to tackle in SFC we should also capture this in draft-quinn-sfc-problem-statement.

---

From: "Henderickx, Wim (Wim)" <[email-masked]>
Date: Thu, 6 Mar 2014 16:44:50 +0000

Jim my comment is to be more explicit in the problem statement and define more concretly why meta-data is required. Here are some reasons why meta-data might be used to convey policy information. This list is not complete.

  1.  Outband signalling might be to slow
  2.  Outband signalling might not scale to convey this information
  3.  Allows to correlate IPv4/IPv6 flows of a subscriber in-band
  4.  Allows to convey profile/policy information

From: "Jim Guichard (jguichar)" <[email-masked]<mailto:[email-masked]>>
Date: Wednesday 5 March 2014 16:43
To: Wim Henderickx <[email-masked]<mailto:[email-masked]>>, sfc <[email-masked]<mailto:[email-masked]>>
Subject: Re: [sfc] Mail regarding draft-quinn-sfc-problem-statement

Hi Wim,

---

From: "Jim Guichard (jguichar)" <[email-masked]>
Date: Thu, 6 Mar 2014 16:52:49 +0000

Got it .. Could you please liaise with the problem statement editors and discuss how best to satisfy your needs?

From: <Henderickx>, "Wim (Wim)" <[email-masked]<mailto:[email-masked]>>
Date: Thursday, March 6, 2014 at 11:44 AM
To: Jim Guichard <[email-masked]<mailto:[email-masked]>>, sfc <[email-masked]<mailto:[email-masked]>>
Subject: Re: [sfc] Mail regarding draft-quinn-sfc-problem-statement

Hi Wim,

---

From: "Henderickx, Wim (Wim)" <[email-masked]>
Date: Thu, 6 Mar 2014 16:55:16 +0000

Will do

From: "Jim Guichard (jguichar)" <[email-masked]<mailto:[email-masked]>>
Date: Thursday 6 March 2014 16:52
To: Wim Henderickx <[email-masked]<mailto:[email-masked]>>, sfc <[email-masked]<mailto:[email-masked]>>
Subject: Re: [sfc] Mail regarding draft-quinn-sfc-problem-statement

Hi Wim,