Subject: [sfc] [SFC] Comments of draft-krishnan-sfc-oam-req-framework

From: [email-masked]
Date: Tue, 8 Jul 2014 11:02:04 +0800

Hi co-authors， guys，

Here are two comments and questions on this draft.

1)
+---+ +-+ +-+ +---+
|NVE|-|B|-|B|-|NVE|
+---+ +-+ +-+ +---+
       x---x          L2

I don't know why B&B are between NVEs rather than "L3 network".
If refer to draft-ietf-nvo3-arch-01, here should be "R" and IP-OAM.

2) 
+-+ +--+ +-+ +-+ +--+
|B|-|SF|-|R|-|R|-|SF|
+-+ +--+ +-+ +-+ +--+
Classifer is the beginning of SFC, there might be a overlay network 
between a classifer and an SF. I'm not sure classifer should be disscussed
here and there might exist an OAM mechanism between classifers and SFs.

2) Any other scenarios? Only DC is not sufficient. I propose to 
add some broadband & mobility scenarios.

Thanks,
Wei

---

From: ramki Krishnan <[email-masked]>
Date: Wed, 9 Jul 2014 09:18:46 -0700

Hi Meng,

Thanks for the comments. Please find inline.

Thanks,
Ramki

From: sfc [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Monday, July 07, 2014 8:02 PM
To: [email-masked]
Subject: [sfc] [SFC] Comments of draft-krishnan-sfc-oam-req-framework

Hi co-authors， guys，

1)
+---+ +-+ +-+ +---+
|NVE|-|B|-|B|-|NVE|
+---+ +-+ +-+ +---+
       x---x          L2

Ramki: This is an exemplary depiction and not exhaustive - it is hard to cover all the possibilities in a single line in a figure; we will try to make this figure better as we evolve the draft. Please see text from draft below clarifying this aspect.

The SFC layer resides above the transport layer (where the transport
   layer can simply be implemented using VLANs or may be done using
   overlays such as VXLAN or NVGRE), and below the application layer
   (APP).  Depending on the underlying network
   technology, other OAM layers may be present (NVO3 OAM [NVO3 OAM],
   L3/MPLS OAM [RFC 7276], IEEE 802.1ag CFM [IEEE 802.1ag], etc.).  The
   use of the terms maintenance end point (MEP) and maintenance (MIP)
   are consistent with IEEE 802.1Q are simply used to denote points
   where monitoring services are configured.

2)
+-+ +--+ +-+ +-+ +--+
|B|-|SF|-|R|-|R|-|SF|
+-+ +--+ +-+ +-+ +--+

Ramki: We don’t have any text on classifier. Can you please clarify your question ?

Ramki: We are not restricting this draft to DCs. Please see my first comment. Also, what do you see additionally needed for broadband and mobility scenarios ?

Thanks,
Wei