Subject: [sfc] Does SFF or SFC Proxy maintain flow state?

From: Dave Dolson <[email-masked]>
Date: Mon, 14 Jul 2014 18:58:29 +0000

In draft-merged-sfc-architecture-00, section 4.3,

<quote>
   The SFF component has the following primary responsibilities:
...
   3.  Maintaining flow state: In some cases, the SFF may be stateful.
       It creates flows and stores flow-centric information.  When
       traffic arrives after being steered through an SFC-unaware SF,
       the SFF must perform re-classification of traffic to determine
       the SFP.  A state-full SFF simplifies such classification to a
       flow lookup.
<end quote>

Is this correct? Shouldn't it be the SFC Proxy that maintains flow state in order to re-classify traffic returning from an SFC-unaware SF?

-Dave

---

From: "Joel M. Halpern" <[email-masked]>
Date: Mon, 14 Jul 2014 15:55:43 -0400

The later part of that quote does look like it needs work.  As you say, 
the Proxy is concerned with re-attaching information for SFC-unaware 
service functions.

Yours,
Joel

On 7/14/14, 2:58 PM, Dave Dolson wrote:
> …
> Is this correct? Shouldn’t it be the SFC Proxy that maintains flow state
> in order to re-classify traffic returning from an SFC-unaware SF?
>
> -Dave
>

---

From: "Carlos Pignataro (cpignata)" <[email-masked]>
Date: Tue, 22 Jul 2014 21:39:18 +0000

I agree ‹ thanks Dave. Fixing.

Thanks,

Carlos.

-----Original Message-----
From: Joel Halpern <[email-masked]>
Date: Monday, July 14, 2014 at 3:55 PM
To: Dave Dolson <[email-masked]>, "[email-masked]" <[email-masked]>,
Carlos Pignataro <[email-masked]>
Subject: Re: Does SFF or SFC Proxy maintain flow state?

>> Š
>> Is this correct? Shouldn¹t it be the SFC Proxy that maintains flow state