Subject: [sfc] A new draft-wei-sfc-mobile-consideration-00.

From: Weixinpeng <[email-masked]>
Date: Tue, 1 Jul 2014 09:44:07 +0000

Hi all,

A new draft on Interaction between SFC network and 3GPP network has been submitted. Comments are welcomed!

Best Regards,

Xinpeng

Name:               draft-wei-sfc-mobile-consideration-00

Revision:  00

Title:                  Interaction between SFC network and 3GPP network

Document date:       2014-06-30

Group:               Individual Submission

Pages:               7

URL:            http://www.ietf.org/internet-drafts/draft-wei-sfc-mobile-consideration-00.txt

Status:         https://datatracker.ietf.org/doc/draft-wei-sfc-mobile-consideration/

Htmlized:       http://tools.ietf.org/html/draft-wei-sfc-mobile-consideration-00

Abstract:

   This document provides a discussion of how SFC (Service Function

   Chain) domain could interact with carrier network to provide network

   service for traffic. Here LTE (Long Term Evolution) network is used

   as an example of carrier network for discussion.

---

From: Alla Goldner <[email-masked]>
Date: Tue, 1 Jul 2014 10:55:51 +0000

Dear Xinpeng,

Thanks for providing this Draft!

I have the following comments:

1.       For the Figure 2 Basic LTE network architecture it is very important, in my view, to show TDF (Traffic detection Function) as a Network Element residing on SGi as this element may function as a Traffic Classifier (please also see https://datatracker.ietf.org/doc/draft-ietf-sfc-use-case-mobility/ )

2.       It should be clarified whether LSFC or PSFC includes the order of Service Functions to become parts of service chain. I would think that LSFC should not only include a list, but also the order of SFs to be applied. Then PSFC may handle physical routing.

3.       "Besides LSFC, additional information such as subscriber ID, that might be used but could not be accessed directly by SFC domain, will also be conveyed in service chain request procedure". I don't think this is correct and believe that subscriber ID etc. should be leveraged and used as an input for making LSFC decision by 3GPP network but not be conveyed further to SFC domain (which is in line, by the way, with your following statement on  sorts of information that could be used in creating of LSFC".

4.       With regard to sorts of information that could be used in creating of LSFC, I suggest to reference 3GPP TR 22.808 "Study on Flexible Mobile Service Steering (FMSS)".

Please let me know if you have any questions or comments for my comments. I would be happy to work with you on resolving those.

Best regards,

Alla Goldner
Director of Mobile Technologies and Standards
Allot Communications
Tel +972 9 7619251
Cell +972 54 2493985
Fax +972 9 7443626
[email-masked]<mailto:[email-masked]>
www.allot.com<http://www.allot.com/>

[291X55_signature (2)]

From: sfc [mailto:[email-masked]] On Behalf Of Weixinpeng
Sent: Tuesday, July 01, 2014 12:44 PM
To: [email-masked]
Subject: [sfc] A new draft-wei-sfc-mobile-consideration-00.

Hi all,

Best Regards,

Xinpeng

Revision:  00

Pages:               7

Abstract:

##############################################################################################
This message is intended only for the designated recipient(s).It may contain confidential or proprietary information.
If you are not the designated recipient, you may not review, copy or distribute this message.
If you have mistakenly received this message, please notify the sender by a reply e-mail and delete this message. 
Thank you.
##############################################################################################

---

From: Weixinpeng <[email-masked]>
Date: Wed, 2 Jul 2014 03:13:15 +0000

Hi Alla,
Thanks for your comments!  And I am glad to work together with you on this topic.
And please see my comments inline.

Best Regards,
Xinpeng
From: Alla Goldner [mailto:[email-masked]]
Sent: Tuesday, July 01, 2014 6:56 PM
To: Weixinpeng; [email-masked]
Subject: RE: A new draft-wei-sfc-mobile-consideration-00.

Dear Xinpeng,

1.       For the Figure 2 Basic LTE network architecture it is very important, in my view, to show TDF (Traffic detection Function) as a Network Element residing on SGi as this element may function as a Traffic Classifier (please also see https://datatracker.ietf.org/doc/draft-ietf-sfc-use-case-mobility/ )
[Wei] In the current version, this draft only provide a high level discussion on the interaction between 3GPP network and SFC domain, and more detailed discussion will be included in the following version. Figure2 is a brief introduction about LTE network to show the relationship between LTE network and IP networks , so things like PCC architecture including TDF is not involved  here.

2.       It should be clarified whether LSFC or PSFC includes the order of Service Functions to become parts of service chain. I would think that LSFC should not only include a list, but also the order of SFs to be applied. Then PSFC may handle physical routing.
[Wei] Right, the order of SFs should be specified for both LSFC and PSFC, not just a list of them.

3.       "Besides LSFC, additional information such as subscriber ID, that might be used but could not be accessed directly by SFC domain, will also be conveyed in service chain request procedure". I don't think this is correct and believe that subscriber ID etc. should be leveraged and used as an input for making LSFC decision by 3GPP network but not be conveyed further to SFC domain (which is in line, by the way, with your following statement on  sorts of information that could be used in creating of LSFC".
[Wei] Subscriber ID is provided as example of additional information, besides match rule and LSFC, that might be conveyed to SFC domain, some other information could also be conveyed depending on specific SF(s) included in LSFC. For example, Subscriber ID will be used by SF that implements HTTP header enrichment. I think we can go more deep on discussion for this issue.

4.       With regard to sorts of information that could be used in creating of LSFC, I suggest to reference 3GPP TR 22.808 "Study on Flexible Mobile Service Steering (FMSS)".
[Wei] Ok, thanks for providing this information.

Best regards,

Alla Goldner

[291X55_signature (2)]

From: sfc [mailto:[email-masked]] On Behalf Of Weixinpeng
Sent: Tuesday, July 01, 2014 12:44 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [sfc] A new draft-wei-sfc-mobile-consideration-00.

Hi all,

Best Regards,

Xinpeng

Revision:  00

Pages:               7

Abstract:

________________________________
This message is intended only for the designated recipient(s). It may contain confidential or proprietary information. If you are not the designated recipient, you may not review, copy or distribute this message. If you have mistakenly received this message, please notify the sender by a reply e-mail and delete this message. Thank you.
________________________________

---

From: "Hong Zhang" <[email-masked]>
Date: Wed, 2 Jul 2014 11:14:30 +0800

Hi,
   I have read your draft "draft-wei-sfc-mobile-consideration-00", and I think it is very useful. However, I have a question that, in the draft, it is said that the LTE network and SFC  domain are two seperate domains. What I wondered is that whether the LTE network and SFC domain  are deployed in different network domains or they  are separated in logic and deployed physically in the same network domain. 

Hong Zhang

From: Weixinpeng
Date: 2014-07-01 17:44
To: [email-masked]
 
Best Regards,
Xinpeng

Abstract:

---

From: Weixinpeng <[email-masked]>
Date: Wed, 2 Jul 2014 03:39:26 +0000

Hi Hong,
It's very likely that LTE network and SFC network are deployed by the same network operator, but functionally they are treated as two separate network. Just like LTE network and IMS.

BR,
Xinpeng

From: sfc [mailto:[email-masked]] On Behalf Of Hong Zhang
Sent: Wednesday, July 02, 2014 11:15 AM
To: Weixinpeng
Cc: [email-masked]
Subject: Re: [sfc] A new draft-wei-sfc-mobile-consideration-00.

Hi,

From: Weixinpeng<mailto:[email-masked]>
Date: 2014-07-01 17:44
To: [email-masked]<mailto:[email-masked]>
Subject: [sfc] A new draft-wei-sfc-mobile-consideration-00.

Hi all,

Best Regards,

Xinpeng

Revision:  00

Pages:               7

Abstract:

---

From: Alla Goldner <[email-masked]>
Date: Wed, 2 Jul 2014 06:10:30 +0000

Dear Xinpeng,

Thanks a lot for your response. And please see some further responses below.

Best Regards,

Alla Goldner

[291X55_signature (2)]

From: Weixinpeng [mailto:[email-masked]]
Sent: Wednesday, July 02, 2014 6:13 AM
To: Alla Goldner; [email-masked]
Subject: RE: A new draft-wei-sfc-mobile-consideration-00.

Hi Alla,

Best Regards,
Xinpeng
From: Alla Goldner [mailto:[email-masked]]
Sent: Tuesday, July 01, 2014 6:56 PM
To: Weixinpeng; [email-masked]<mailto:[email-masked]>
Subject: RE: A new draft-wei-sfc-mobile-consideration-00.

Dear Xinpeng,

1.       For the Figure 2 Basic LTE network architecture it is very important, in my view, to show TDF (Traffic detection Function) as a Network Element residing on SGi as this element may function as a Traffic Classifier (please also see https://datatracker.ietf.org/doc/draft-ietf-sfc-use-case-mobility/ )
[Wei] In the current version, this draft only provide a high level discussion on the interaction between 3GPP network and SFC domain, and more detailed discussion will be included in the following version. Figure2 is a brief introduction about LTE network to show the relationship between LTE network and IP networks , so things like PCC architecture including TDF is not involved  here. AG> TDF, in this regard, is not only a part of PCC architecture, but a key entity for service classification with regard to service chaining functionality. This is why it is very important, in my view, to include TDF.

3.       "Besides LSFC, additional information such as subscriber ID, that might be used but could not be accessed directly by SFC domain, will also be conveyed in service chain request procedure". I don't think this is correct and believe that subscriber ID etc. should be leveraged and used as an input for making LSFC decision by 3GPP network but not be conveyed further to SFC domain (which is in line, by the way, with your following statement on  sorts of information that could be used in creating of LSFC".
[Wei] Subscriber ID is provided as example of additional information, besides match rule and LSFC, that might be conveyed to SFC domain, some other information could also be conveyed depending on specific SF(s) included in LSFC. For example, Subscriber ID will be used by SF that implements HTTP header enrichment. I think we can go more deep on discussion for this issue. AG> I see your point. In this case a more detailed requirements may be provided, as these parameters are already available to PGW and TDF (i.e. service classifiers).

Best regards,

Alla Goldner

[291X55_signature (2)]

Hi all,

Best Regards,

Xinpeng

Revision:  00

Pages:               7

Abstract:

---

From: Weixinpeng <[email-masked]>
Date: Thu, 3 Jul 2014 03:44:39 +0000

Hi Alla,
I agree with you that TDF would play a very important role in providing SFC to LTE network, but exactly how the two domain should interact with each other still needs to be considered．
I think I can provide the discussion of TDF related issue in the next version of draft, and I hope we can have more discussion on this.

Best Regards,
-Xinpeng

Dear Xinpeng,

Best regards,

Alla Goldner

[291X55_signature (2)]

Hi all,

Best Regards,

Xinpeng

Revision:  00

Pages:               7

Abstract:

---

From: Ron Parker <[email-masked]>
Date: Thu, 3 Jul 2014 13:20:50 +0000

Hi, Alla.

Since DPI conclusions invariably occur on the Nth packet of a fully qualified flow, where N > 1, how does a TDF make practical steering decisions?   Don’t most service functions need to be involved from the first packet of a new fully qualified flow?   If so, does the TDF need to perform a proxy function to make this practical?

Thanks.

   Ron

From: sfc [mailto:[email-masked]] On Behalf Of Weixinpeng
Sent: Wednesday, July 02, 2014 11:45 PM
To: Alla Goldner; [email-masked]
Subject: Re: [sfc] A new draft-wei-sfc-mobile-consideration-00.

Hi Alla,

Best Regards,
-Xinpeng

Dear Xinpeng,

Best regards,

Alla Goldner

[291X55_signature (2)]

Hi all,

Best Regards,

Xinpeng

Revision:  00

Pages:               7

Abstract:

---

From: Alla Goldner <[email-masked]>
Date: Thu, 3 Jul 2014 13:28:09 +0000

Hi Ron,

Thanks for your question!
DPI algorithms are out of scope of 3GPP and of IETF.
I would not make here a mandatorily assumption on N>1 for all applications as well as I would not say those first few packets' (if exists) steering is critical for implementation.

Best Regards,

Alla Goldner

[291X55_signature (2)]

From: Ron Parker [mailto:[email-masked]]
Sent: Thursday, July 03, 2014 4:21 PM
To: Weixinpeng; Alla Goldner; [email-masked]
Subject: RE: A new draft-wei-sfc-mobile-consideration-00.

Hi, Alla.

Thanks.

   Ron

From: sfc [mailto:[email-masked]] On Behalf Of Weixinpeng
Sent: Wednesday, July 02, 2014 11:45 PM
To: Alla Goldner; [email-masked]<mailto:[email-masked]>
Subject: Re: [sfc] A new draft-wei-sfc-mobile-consideration-00.

Hi Alla,

Best Regards,
-Xinpeng

Dear Xinpeng,

Best regards,

Alla Goldner

[291X55_signature (2)]

Hi all,

Best Regards,

Xinpeng

Revision:  00

Pages:               7

Abstract:

---

From: Ron Parker <[email-masked]>
Date: Thu, 3 Jul 2014 13:35:12 +0000

Alla,

Perhaps I am reading too much into the original line of questions.   When I see “TDF”, I think “DPI”.   Is that inaccurate?   Regarding “first few packets”, wouldn’t some types of service functions have difficulty if they were “switched into” the flow beyond its first packet?

Thanks.

   Ron

From: Alla Goldner [mailto:[email-masked]]
Sent: Thursday, July 03, 2014 9:28 AM
To: Ron Parker; Weixinpeng; [email-masked]
Subject: RE: A new draft-wei-sfc-mobile-consideration-00.

Hi Ron,

Best Regards,

Alla Goldner

[291X55_signature (2)]

From: Ron Parker [mailto:[email-masked]]
Sent: Thursday, July 03, 2014 4:21 PM
To: Weixinpeng; Alla Goldner; [email-masked]<mailto:[email-masked]>
Subject: RE: A new draft-wei-sfc-mobile-consideration-00.

Hi, Alla.

Thanks.

   Ron

Hi Alla,

Best Regards,
-Xinpeng

Dear Xinpeng,

Best regards,

Alla Goldner

[291X55_signature (2)]

Hi all,

Best Regards,

Xinpeng

Revision:  00

Pages:               7

Abstract:

---

From: Alla Goldner <[email-masked]>
Date: Thu, 3 Jul 2014 13:46:49 +0000

Hi, Ron,

TDF includes DPI capabilities and goes beyond that in performing usage monitoring, enforcement and charging for the detected applications.
In case an application can't be detected from its very first packet, it may put some limitations/restrictions/assumptions on implementation, however, as I said, I don't think this is in scope of our discussions here. As DPI algorithms are not under discussion - the consequences of those algorithms' accuracy can't be under discussion as well, I believe.

Best Regards,

Alla Goldner

[291X55_signature (2)]

From: Ron Parker [mailto:[email-masked]]
Sent: Thursday, July 03, 2014 4:35 PM
To: Alla Goldner; Weixinpeng; [email-masked]
Subject: RE: A new draft-wei-sfc-mobile-consideration-00.

Alla,

Thanks.

   Ron

From: Alla Goldner [mailto:[email-masked]]
Sent: Thursday, July 03, 2014 9:28 AM
To: Ron Parker; Weixinpeng; [email-masked]<mailto:[email-masked]>
Subject: RE: A new draft-wei-sfc-mobile-consideration-00.

Hi Ron,

Best Regards,

Alla Goldner

[291X55_signature (2)]

Hi, Alla.

Thanks.

   Ron

Hi Alla,

Best Regards,
-Xinpeng

Dear Xinpeng,

Best regards,

Alla Goldner

[291X55_signature (2)]

Hi all,

Best Regards,

Xinpeng

Revision:  00

Pages:               7

Abstract:

---

From: Ron Parker <[email-masked]>
Date: Thu, 3 Jul 2014 13:52:18 +0000

Thanks, Alla.

I agree with your original comment that TDF is certainly eligible to be a classifier/re-classifier.  However, I wanted to bring out a discussion of the practicality and limitations of such an arrangement.   Thanks for answering my questions.

   Ron

From: Alla Goldner [mailto:[email-masked]]
Sent: Thursday, July 03, 2014 9:47 AM
To: Ron Parker; Weixinpeng; [email-masked]
Subject: RE: A new draft-wei-sfc-mobile-consideration-00.

Hi, Ron,

Best Regards,

Alla Goldner

[291X55_signature (2)]

From: Ron Parker [mailto:[email-masked]]
Sent: Thursday, July 03, 2014 4:35 PM
To: Alla Goldner; Weixinpeng; [email-masked]<mailto:[email-masked]>
Subject: RE: A new draft-wei-sfc-mobile-consideration-00.

Alla,

Thanks.

   Ron

Hi Ron,

Best Regards,

Alla Goldner

[291X55_signature (2)]

Hi, Alla.

Thanks.

   Ron

Hi Alla,

Best Regards,
-Xinpeng

Dear Xinpeng,

Best regards,

Alla Goldner

[291X55_signature (2)]

Hi all,

Best Regards,

Xinpeng

Revision:  00

Pages:               7

Abstract: