Subject: [sfc] Change to Mandatory Context Header in NSH draft - optional presence

From: "Dolganow, Andrew (Andrew)" <[email-masked]>
Date: Wed, 23 Jul 2014 14:30:06 +0000

Following discussion during the meeting today, here is a specific comment on how to Change NSH to allow constant-size, easy-to-process in H/W Context Header while also allowing for deployments that do not need to include the header:

  1.  Keep existing format as per draft section 6 but rename from Mandatory Context Header to Context Header
  2.  Make the presence of header optional and encode presence/absence using  a bit in Base header – proposed change text (in red):

      0 1 2 3  4  5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
     +-+-+-+-+---+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
     |Ver|O|C|CHP|R|R|R|R|R|   Length  |    MD Type    | Next Protocol |
     +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+

CHP –Context Header Present. If specified, Context Header as specified in section 5 below  follows directly Service Path Header

Andrew

---

From: "Henderickx, Wim (Wim)" <[email-masked]>
Date: Wed, 23 Jul 2014 14:34:00 +0000

I agree we should keep the header as small as possible and as such I also believe we don’t need the mandatory Ctxt field to be present.
An alternative to the CHP bit could be to use length or MD-Type to indicate its presence.

From: <Dolganow>, "Andrew (Andrew)" <[email-masked]<mailto:[email-masked]>>
Date: Wednesday 23 July 2014 10:30
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [sfc] Change to Mandatory Context Header in NSH draft - optional presence

Andrew

---

From: Xuxiaohu <[email-masked]>
Date: Wed, 23 Jul 2014 14:45:12 +0000

Hi,

Fully agree that the metadata related information including the context should be optional, rather than mandatory. In addition, I believe the service path header should also be optional, in other words, the NSH is only used for carring the metadata related information.

Best regards,

Xiaohu

________________________________
发件人: sfc [[email-masked]] 代表 Dolganow, Andrew (Andrew) [[email-masked]]
发送时间: 2014年7月23日 22:30
收件人: [email-masked]
主题: [sfc] Change to Mandatory Context Header in NSH draft - optional presence

Andrew

---

From: "Joel M. Halpern" <[email-masked]>
Date: Wed, 23 Jul 2014 10:48:53 -0400

I had read the MD-type as doing exactly this.  So we should simply 
allocate an MD Type that means "no mandatory header."

Yours,
Joel

On 7/23/14, 10:30 AM, Dolganow, Andrew (Andrew) wrote:
> Following discussion during the meeting today, here is a specific
> comment on how to Change NSH to allow constant-size, easy-to-process in
> H/W Context Header while also allowing for deployments that do not need
> to include the header:
>
>  1. Keep existing format as per draft section 6 but rename from
>     Mandatory Context Header to Context Header
>  2. Make the presence of header optional and encode presence/absence
>     using  a bit in Base header – proposed change text (in red):
>
> CHP –Context Header Present. If specified, Context Header as specified
> in section 5 below  follows directly Service Path Header
>
> Andrew
>
>
>
> _______________________________________________
> sfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sfc
>

---

From: Xuxiaohu <[email-masked]>
Date: Wed, 23 Jul 2014 14:49:56 +0000

________________________________
发件人: sfc [[email-masked]] 代表 Henderickx, Wim (Wim) [[email-masked]]
发送时间: 2014年7月23日 22:34
收件人: Dolganow, Andrew (Andrew); [email-masked]
主题: Re: [sfc] Change to Mandatory Context Header in NSH draft - optional presence

[Xiaohu] Great. Using the MD Type field to indicate the presence of service path header, metadata, or  both has been mentioned in this email (http://www.ietf.org/mail-archive/web/sfc/current/msg02172.html).

Best regards,
Xiaohu

Andrew

---

From: "Joel M. Halpern" <[email-masked]>
Date: Wed, 23 Jul 2014 10:50:36 -0400

Clarification, not "none", but "only SFP ID + SFP Index present."

Yours,
Joel

---

From: Lucy yong <[email-masked]>
Date: Wed, 23 Jul 2014 14:53:55 +0000

We also need the option in header where only metadata present, i.e. no SFP ID + Index present.
Lucy

-----Original Message-----
From: sfc [mailto:[email-masked]] On Behalf Of Joel M. Halpern
Sent: Wednesday, July 23, 2014 9:51 AM
To: Dolganow, Andrew (Andrew); [email-masked]
Subject: Re: [sfc] Change to Mandatory Context Header in NSH draft - optional presence

Yours,
Joel

On 7/23/14, 10:48 AM, Joel M. Halpern wrote:
>> comment on how to Change NSH to allow constant-size, easy-to-process 
>> in H/W Context Header while also allowing for deployments that do not 
>> need to include the header:
>>
>>     Mandatory Context Header to Context Header  2. Make the presence 
>> of header optional and encode presence/absence
>>     using  a bit in Base header - proposed change text (in red):
>>
>> CHP -Context Header Present. If specified, Context Header as 
>> specified in section 5 below  follows directly Service Path Header
>>
>> Andrew
>>
>>
>>

---

From: "NAPIERALA, MARIA H" <[email-masked]>
Date: Wed, 23 Jul 2014 14:56:52 +0000

Yes, it should be an option to carry only metadata but not the SFP information.

From: sfc [mailto:[email-masked]] On Behalf Of Xuxiaohu
Sent: Wednesday, July 23, 2014 10:45 AM
To: Dolganow, Andrew (Andrew); [email-masked]
Subject: [sfc] 答复: Change to Mandatory Context Header in NSH draft - optional presence

Hi,

Best regards,

Xiaohu

收件人: [email-masked]<mailto:[email-masked]>

Andrew

---

From: Sumandra Majee <[email-masked]>
Date: Wed, 23 Jul 2014 14:58:32 +0000

Generally agree. But at this point this could be very well be TLV., mandotory TLV.

However I would stress that an appropriate document ( use case/architecture  ) actually captures the relevant required metadata for common use cases.
  A) Subscriber ID in Gi LAN
  B) Classification results
  C) ??

Sumandra

From: <Dolganow>, "Andrew (Andrew)" <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, July 23, 2014 at 10:30 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [sfc] Change to Mandatory Context Header in NSH draft - optional presence

Andrew

---

From: Eric Gray <[email-masked]>
Date: Wed, 23 Jul 2014 14:59:59 +0000

Maria/Lucy/etc.

Can you clarify what meta-data there would be beyond SFP information?

Sent from my iPad

On Jul 23, 2014, at 10:58 AM, "NAPIERALA, MARIA H" <[email-masked]<mailto:[email-masked]>> wrote:

From: sfc [mailto:[email-masked]] On Behalf Of Xuxiaohu
Sent: Wednesday, July 23, 2014 10:45 AM
To: Dolganow, Andrew (Andrew); [email-masked]<mailto:[email-masked]>
Subject: [sfc] 答复: Change to Mandatory Context Header in NSH draft - optional presence

Hi,

Best regards,

Xiaohu

发件人: sfc [[email-masked]<mailto:[email-masked]>] 代表 Dolganow, Andrew (Andrew) [[email-masked]<mailto:[email-masked]>]

Andrew

_______________________________________________
sfc mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/sfc

---

From: "Joel M. Halpern" <[email-masked]>
Date: Wed, 23 Jul 2014 11:00:12 -0400

We could allow the null case.  But is there a significant advantage in 
omitting the SFP-ID + Path Inex, when it is not needed?

WHen we get to the details of the solution behavior, I would like it to 
be clear that the index does not need to be updated if it is not being 
used.  (i.e. what it indexes are the places that use the Path ID + 
index, which is well-defined.)

But I don't mind having the 4 bytes there.  It seems to significantly 
improve interoperability.

Yours,
Joel

---

From: Sumandra Majee <[email-masked]>
Date: Wed, 23 Jul 2014 15:04:46 +0000

e could allow the null case.  But is there a significant advantage in
omitting the SFP-ID + Path Inex, when it is not needed?
[SM] Flow aware devices may not need it on every packet. Since the draft
doesn¹t explicitly talk about pkt based vs. flow aware services, I would
like to see the NULL case supported also.

---

From: "Dolganow, Andrew (Andrew)" <[email-masked]>
Date: Wed, 23 Jul 2014 15:09:22 +0000

The reason I am proposing to use reserved bit is that having 7 reserved
bits seems an overkill (especially since we have version as well to evolve
in the future).  Alternatively we could shrink the number of reserved bits
and allocate the freed-up bits to MD Type for example to allow more broad
use of MD Type. 

Andrew

On 2014-07-23, 10:48 AM, "Joel M. Halpern" wrote:

>>     using  a bit in Base header  proposed change text (in red):
>>
>> CHP Context Header Present. If specified, Context Header as specified

---

From: Xuxiaohu <[email-masked]>
Date: Wed, 23 Jul 2014 15:10:10 +0000

IMHO, the service index should be meaningful even in the case where only metadata is carried. For instance, that index could be used to determine the end of the chain or path which is responsible for stripping the metadata. In other word, the service index should be decoupled from the path id and the metadata. Maybe the Base header is the right place to hold that index. Alternatively, the service path header can still be remained but only the service index part would be used in the case where the path or chain information has been carried somewhere else other than the service path header.

Best regards,
Xiaohu
________________________________________
发件人: sfc [[email-masked]] 代表 Joel M. Halpern [[email-masked]]
发送时间: 2014年7月23日 23:00
收件人: Lucy yong; Dolganow, Andrew (Andrew); [email-masked]
主题: Re: [sfc] Change to Mandatory Context Header in NSH draft - optional presence

Yours,
Joel

---

From: Cathy Zhang <[email-masked]>
Date: Wed, 23 Jul 2014 15:10:38 +0000

I agree with Joel. For better interoperability, we can just keep the 4 bytes and set them to 0 to indicate "only metadata present". Actually "only metadata present" is addressed in SCH header draft presented in today's meeting. 

Cathy

-----Original Message-----
From: sfc [mailto:[email-masked]] On Behalf Of Joel M. Halpern
Sent: Wednesday, July 23, 2014 8:00 AM
To: Lucy yong; Dolganow, Andrew (Andrew); [email-masked]
Subject: Re: [sfc] Change to Mandatory Context Header in NSH draft - optional presence

Yours,
Joel

---

From: Cathy Zhang <[email-masked]>
Date: Wed, 23 Jul 2014 15:16:12 +0000

Metadata Length field serves the purpose well.

Cathy

From: sfc [mailto:[email-masked]] On Behalf Of Henderickx, Wim (Wim)
Sent: Wednesday, July 23, 2014 7:34 AM
To: Dolganow, Andrew (Andrew); [email-masked]
Subject: Re: [sfc] Change to Mandatory Context Header in NSH draft - optional presence

I agree we should keep the header as small as possible and as such I also believe we don't need the mandatory Ctxt field to be present.
An alternative to the CHP bit could be to use length or MD-Type to indicate its presence.

  1.  Keep existing format as per draft section 6 but rename from Mandatory Context Header to Context Header
  2.  Make the presence of header optional and encode presence/absence using  a bit in Base header - proposed change text (in red):

CHP -Context Header Present. If specified, Context Header as specified in section 5 below  follows directly Service Path Header

Andrew

---

From: "Dolganow, Andrew (Andrew)" <[email-masked]>
Date: Wed, 23 Jul 2014 15:17:37 +0000

Agree. More so, we should define ³Null² encoding of each SFP header
fields: either SFP ID or Service Index or both could be set to 0. That way
we will provide max flexibility and at the same time allow easy interop.

Andrew

On 2014-07-23, 11:10 AM, "Cathy Zhang" wrote:

>I agree with Joel. For better interoperability, we can just keep the 4
>bytes and set them to 0 to indicate "only metadata present". Actually
>"only metadata present" is addressed in SCH header draft presented in
>today's meeting. 
>
>Cathy
>

---

From: Lucy yong <[email-masked]>
Date: Wed, 23 Jul 2014 15:18:25 +0000

Just set SP ID 0. Use index for TTL purpose.
Lucy

-----Original Message-----
From: Cathy Zhang 
Sent: Wednesday, July 23, 2014 10:11 AM
To: Joel M. Halpern; Lucy yong; Dolganow, Andrew (Andrew); [email-masked]
Subject: RE: [sfc] Change to Mandatory Context Header in NSH draft - optional presence

Cathy

-----Original Message-----
From: sfc [mailto:[email-masked]] On Behalf Of Joel M. Halpern
Sent: Wednesday, July 23, 2014 8:00 AM
To: Lucy yong; Dolganow, Andrew (Andrew); [email-masked]
Subject: Re: [sfc] Change to Mandatory Context Header in NSH draft - optional presence

We could allow the null case.  But is there a significant advantage in omitting the SFP-ID + Path Inex, when it is not needed?

WHen we get to the details of the solution behavior, I would like it to be clear that the index does not need to be updated if it is not being used.  (i.e. what it indexes are the places that use the Path ID + index, which is well-defined.)

But I don't mind having the 4 bytes there.  It seems to significantly improve interoperability.

Yours,
Joel

On 7/23/14, 10:53 AM, Lucy yong wrote:
>>> in H/W Context Header while also allowing for deployments that do 
>>> not need to include the header:
>>>
>>>      Mandatory Context Header to Context Header  2. Make the 
>>> presence of header optional and encode presence/absence

---

From: "NAPIERALA, MARIA H" <[email-masked]>
Date: Wed, 23 Jul 2014 15:52:38 +0000

e.g., application ID, subscriber ID.

From: Eric Gray [mailto:[email-masked]]
Sent: Wednesday, July 23, 2014 11:00 AM
To: NAPIERALA, MARIA H
Cc: Xuxiaohu; Dolganow, Andrew (Andrew); [email-masked]
Subject: Re: [sfc] 答复: Change to Mandatory Context Header in NSH draft - optional presence

Maria/Lucy/etc.

Sent from my iPad

Hi,

Best regards,

Xiaohu

Andrew

---

From: Dave Dolson <[email-masked]>
Date: Wed, 23 Jul 2014 16:06:49 +0000

What is the next hop when receiving such a packet?
I think the forwarding table for ID 0 would need to be configured.
But then any ID could be used, and 0 is just a convention vs. a special case that the protocol needs to define.

So, I'm saying:
- there is no need for any specification of service chaining without a chain ID. ID is always required, but you can have only one chain if you wish.
- Keep it simple; avoid special cases.

-----Original Message-----
From: Cathy Zhang
Sent: Wednesday, July 23, 2014 10:11 AM
To: Joel M. Halpern; Lucy yong; Dolganow, Andrew (Andrew); [email-masked]
Subject: RE: [sfc] Change to Mandatory Context Header in NSH draft - optional presence

Cathy

-----Original Message-----
From: sfc [mailto:[email-masked]] On Behalf Of Joel M. Halpern
Sent: Wednesday, July 23, 2014 8:00 AM
To: Lucy yong; Dolganow, Andrew (Andrew); [email-masked]
Subject: Re: [sfc] Change to Mandatory Context Header in NSH draft - optional presence

Yours,
Joel

---

From: Henry Fourie <[email-masked]>
Date: Wed, 23 Jul 2014 16:08:27 +0000

Eric,
  L7 parameters extracted from a packet by a DPI engine and transported to downstream SFs.
 Results from SF processing passed to a downstream SF

-          Louis

From: sfc [mailto:[email-masked]] On Behalf Of Eric Gray
Sent: Wednesday, July 23, 2014 8:00 AM
To: NAPIERALA, MARIA H
Cc: Xuxiaohu; Dolganow, Andrew (Andrew); [email-masked]
Subject: Re: [sfc] 答复: Change to Mandatory Context Header in NSH draft - optional presence

Maria/Lucy/etc.

Sent from my iPad

Hi,

Best regards,

Xiaohu

Andrew

---

From: Lucy yong <[email-masked]>
Date: Wed, 23 Jul 2014 17:24:49 +0000

In this case, other info such as outer label is used as the lookup key.
Suggest defining SP ID 0 as of NULL. 

Lucy

-----Original Message-----
From: Dave Dolson [mailto:[email-masked]] 
Sent: Wednesday, July 23, 2014 11:07 AM
To: Lucy yong; Cathy Zhang; Joel M. Halpern; Dolganow, Andrew (Andrew); [email-masked]
Subject: RE: [sfc] Change to Mandatory Context Header in NSH draft - optional presence

So, I'm saying:

-----Original Message-----
From: Cathy Zhang
Sent: Wednesday, July 23, 2014 10:11 AM
To: Joel M. Halpern; Lucy yong; Dolganow, Andrew (Andrew); [email-masked]
Subject: RE: [sfc] Change to Mandatory Context Header in NSH draft - optional presence

Cathy

-----Original Message-----
From: sfc [mailto:[email-masked]] On Behalf Of Joel M. Halpern
Sent: Wednesday, July 23, 2014 8:00 AM
To: Lucy yong; Dolganow, Andrew (Andrew); [email-masked]
Subject: Re: [sfc] Change to Mandatory Context Header in NSH draft - optional presence

Yours,
Joel

---

From: Xuxiaohu <[email-masked]>
Date: Wed, 23 Jul 2014 18:44:13 +0000

Did you mean the Length field in the Variable Context Headers by Metadata Length field? If so, do you want to use a field in the optional variable length context headers to indicate the presence of the four 4-byte
context header outside of the optional variable length context headers?

Best regards,

Xiaohu

________________________________
发件人: sfc [[email-masked]] 代表 Cathy Zhang [[email-masked]]
发送时间: 2014年7月23日 23:16
收件人: Henderickx, Wim (Wim); Dolganow, Andrew (Andrew); [email-masked]
主题: Re: [sfc] Change to Mandatory Context Header in NSH draft - optional presence

Cathy

Andrew

---

From: Cathy Zhang <[email-masked]>
Date: Thu, 24 Jul 2014 16:44:50 +0000

I was referring to the “metadata length” field defined in SCH draft (as shown in Figure 1 and described in section 4.2 of http://datatracker.ietf.org/doc/draft-zhang-sfc-sch/?include_text=1).

Cathy

From: Xuxiaohu
Sent: Wednesday, July 23, 2014 11:44 AM
To: Cathy Zhang; Henderickx, Wim (Wim); Dolganow, Andrew (Andrew); [email-masked]
Subject: 答复: [sfc] Change to Mandatory Context Header in NSH draft - optional presence

Best regards,

Xiaohu

Cathy

Andrew