Subject: [sfc] Load-balancing requirements

From: <[email-masked]>
Date: Fri, 11 Jul 2014 08:23:19 +0000

Hi all,

The requirements in (http://tools.ietf.org/html/draft-boucadair-sfc-requirements-04) includes the following items:

   REQ#25:  The solution MUST allow for load-balancing.

            A.  Load-balancing may be provided by legacy technologies or

                protocols (e.g., make use of load-balancers)

            B.  Load-balancing may be part of the Service Function

                itself.

            C.  Load-balancer may be considered as a Service Function

                element.

            D.  Because of the possible complications, load balancing

                SHOULD NOT be driven by the SFC Classifier.

Given the ongoing discussion in the list, it will really useful to adjust this text accordingly.

Comments to tweak this text, update it, etc, are more than welcome.

Cheers,
Med

---

From: [email-masked]
Date: Fri, 11 Jul 2014 17:23:03 +0800

Hi Med,

    Please see inline.

Thanks,
Wei

"sfc" <[email-masked]>  2014/07/11 16:23:19:

> Hi all,
> 
> The requirements in (http://tools.ietf.org/html/draft-boucadair-sfc-
> requirements-04) includes the following items:
> 

[Wei] : Joel mentioned as follow that there are 3 differet ways that load 
balancing can and 
will interact with service chaining.
"1) Load balancing as a service provided to the end user.……
2) There is internal load balancing.…… 
3) There can also be load balancing done by selecting packet paths for the 
service chaining that
direct traffic to different places. We would not want to require that a 
given service function appear 
at only one place in the network. "

So I don't think these requirements is sufficient for all kind of LBs. Or 
we should redefine 
what Load balancing is. Because IMO, item 1 is an external LB service 
function for choosing 
end users; Item 2 is an internal mechanism to balance packets among SFs 
which achieve the
same function; item 3 looks like achieving similar functionality like TE. 
I cannot see these requirements contain item 1&3 if I capture your 
meaning.
 
BTW, for item 2, we can call it packet distribution instead of load 
balancing.
Why this kind of load balancing CANNOT be driven by the SFC Classifier?

> Med_______________________________________________
> sfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sfc