Subject: [sfc] FW: New Version Notification for draft-huang-sfc-use-case-recursive-service-00.txt

From: "He, Peng" <[email-masked]>
Date: Wed, 2 Jul 2014 19:28:49 -0400

Hi

We have submitted a new draft to discuss and analysis the recursive (e.g., nested) service function chaining scenario/use case, to see if the current existing tools proposed in the WG can cover/support this scenario, or some potential improvement needed. Kindly review the ID and provide your comments please. Thanks a lot.

Regards,
Peng

-------- Original Message --------
Subject:

New Version Notification for draft-huang-sfc-use-case-recursive-service-00.txt

Date:

Wed, 02 Jul 2014 14:11:56 -0700

From:

[email-masked]<mailto:[email-masked]>

To:

Jiafeng Zhu <[email-masked]><mailto:[email-masked]>, Peng He <[email-masked]><mailto:[email-masked]>, Jiafeng Zhu <[email-masked]><mailto:[email-masked]>, Changcheng Huang <[email-masked]><mailto:[email-masked]>, Peng He <[email-masked]><mailto:[email-masked]>, Changcheng Huang <[email-masked]><mailto:[email-masked]>

A new version of I-D, draft-huang-sfc-use-case-recursive-service-00.txt

has been successfully submitted by Changcheng Huang and posted to the

IETF repository.

Name:          draft-huang-sfc-use-case-recursive-service

Revision:      00

Title:         SFC Use Cases on Recursive Service Function Chaining

Document date: 2014-07-01

Group:         Individual Submission

Pages:         7

URL:            http://www.ietf.org/internet-drafts/draft-huang-sfc-use-case-recursive-service-00.txt

Status:         https://datatracker.ietf.org/doc/draft-huang-sfc-use-case-recursive-service/

Htmlized:       http://tools.ietf.org/html/draft-huang-sfc-use-case-recursive-service-00

Abstract:

   Service function chaining (SFC) provides various services that can

   be tailored to different requirements from diversified user groups,

   where each user group forms a collective client that requires

   similar service. SFC is typically deployed as a service overlay with

   its own service topology on top of existing network topology. This

   kind of virtualized structure naturally enables recursive service

   relationship where a client may become a service provider and resell

   SFC services to its own user groups. This document describes some

   exemplary use cases that show the usage of recursive (e.g. nested)

   service function chaining relationship.

Please note that it may take a couple of minutes from the time of submission

until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Weixinpeng <[email-masked]>
Date: Mon, 7 Jul 2014 09:52:15 +0000

Hi Peng,
Thanks for the document, and here are some of my questions:
(1) In Fig. 2, it is said “…dot lines show mapping  relationship…”, so what’s the meaning of “mapping” here?  Does it mean the upper layer SFs (e.g. SFs in B’s SFC)  will use the corresponding SFs  in the lower layer (e.g. A’s level)?
(2) What’s the SFCs’ relation of A, B and C? Embedded or concatenated?

BR,
Xinpeng
From: sfc [mailto:[email-masked]] On Behalf Of He, Peng
Sent: Thursday, July 03, 2014 7:29 AM
To: [email-masked]
Cc: Jiafeng Zhu; [email-masked]
Subject: [sfc] FW: New Version Notification for draft-huang-sfc-use-case-recursive-service-00.txt

Hi

Regards,
Peng

-------- Original Message --------
Subject:

Date:

From:

To:

IETF repository.

Revision:      00

Pages:         7

Abstract:

The IETF Secretariat

---

From: Changcheng Huang <[email-masked]>
Date: Mon, 07 Jul 2014 14:33:23 -0700

Hi Xinpeng,

Thank you for your interest. Yes, mapping means upper level SFs will use 
the corresponding lower level SFs. When a packet arrives at a lower 
level SF node, the node applies certain functions as defined by the 
lower level node first. After that, how the upper level functions are 
applied to the packet depends on how the upper level functions are 
implemented. In the draft, we defined two modes: transparent vs. opaque.

In the transparent mode, the upper level decides what upper level 
functions are needed and asked the lower level node to implement and 
apply those functions after the lower level functions are finished.

In the opaque mode, in addition to deciding what upper level functions 
are required, the upper level also implements the upper level service 
functions using its own software. After the lower level node finishes 
its own service functions, the packet will be passed to upper level 
service function module and processed there. The packet will then be 
forwarded to the next SF node at lower level.

You can find more details about the two modes in the draft.

I am not quite sure what you mean by "embedded" and "concatenated". My 
interpretation is that "embedded" seems to correspond to our transparent 
mode while "concatenated" seems to mean opaque mode.

Best regards,

Chang

On 07/07/2014 02:52 AM, Weixinpeng wrote:
> (1) In Fig. 2, it is said "...dot lines show mapping 
>  relationship...", so what's the meaning of "mapping" here?  Does it 
> mean the upper layer SFs (e.g. SFs in B's SFC)  will use the 
> corresponding SFs  in the lower layer (e.g. A's level)?
>
> (2) What's the SFCs' relation of A, B and C? Embedded or concatenated?
>
> BR,
>
> Xinpeng
>
> *From:*sfc [mailto:[email-masked]] *On Behalf Of *He, Peng
> *Sent:* Thursday, July 03, 2014 7:29 AM
> *To:* [email-masked]
> *Cc:* Jiafeng Zhu; [email-masked]
> *Subject:* [sfc] FW: New Version Notification for 
> draft-huang-sfc-use-case-recursive-service-00.txt
>
> Hi
>
> We have submitted a new draft to discuss and analysis the recursive 
> (e.g., nested) service function chaining scenario/use case, to see if 
> the current existing tools proposed in the WG can cover/support this 
> scenario, or some potential improvement needed. Kindly review the ID 
> and provide your comments please. Thanks a lot.
>
> Regards,
>
> Peng
>
>
>
> *Subject: *
> New Version Notification for 
> draft-huang-sfc-use-case-recursive-service-00.txt
>
> *Date: *
>
> 	
>
> *From: *
> [email-masked] <mailto:[email-masked]>
>
> *To: *
>
> 	
>
> Jiafeng Zhu <[email-masked]> <mailto:[email-masked]>, 
> Peng He <[email-masked]> <mailto:[email-masked]>, Jiafeng Zhu 
> <[email-masked]> <mailto:[email-masked]>, Changcheng 
> Huang <[email-masked]> <mailto:[email-masked]>, Peng He 
> <[email-masked]> <mailto:[email-masked]>, Changcheng Huang 
> <[email-masked]> <mailto:[email-masked]>
>
> URL:http://www.ietf.org/internet-drafts/draft-huang-sfc-use-case-recursive-service-00.txt
> Status:https://datatracker.ietf.org/doc/draft-huang-sfc-use-case-recursive-service/
> Htmlized:http://tools.ietf.org/html/draft-huang-sfc-use-case-recursive-service-00
>   
>   
> Abstract:
> _______________________________________________
> sfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sfc