Subject: [sfc] Fwd: New Version Notification for draft-aldrin-sfc-oam-framework-00.txt

From: Sam Aldrin <[email-masked]>
Date: Wed, 2 Jul 2014 12:20:43 -0700

Hi,

We have submitted a new draft for SFC OAM framework.
Kindly review the ID and provide your comments.

cheers
-sam

---------- Forwarded message ----------
From: <[email-masked]>
Date: Wed, Jul 2, 2014 at 12:17 PM
Subject: New Version Notification for draft-aldrin-sfc-oam-framework-00.txt
To: Nobo Akiya <[email-masked]>, "Sam K. Aldrin" <[email-masked]>,
Carlos Pignataro <[email-masked]>

A new version of I-D, draft-aldrin-sfc-oam-framework-00.txt
has been successfully submitted by Sam K. Aldrin and posted to the
IETF repository.

Name:           draft-aldrin-sfc-oam-framework
Revision:       00
Title:          Service Function Chaining Operations, Administration and
Maintenance Framework
Document date:  2014-07-02
Group:          Individual Submission
Pages:          11
URL:
http://www.ietf.org/internet-drafts/draft-aldrin-sfc-oam-framework-00.txt
Status:
https://datatracker.ietf.org/doc/draft-aldrin-sfc-oam-framework/
Htmlized:       http://tools.ietf.org/html/draft-aldrin-sfc-oam-framework-00

Abstract:
   This document provides reference framework for Operations,
   Administration and Maintenance (OAM) of Service Function Chaining
   (SFC).

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Jiangyuanlong <[email-masked]>
Date: Fri, 4 Jul 2014 08:17:09 +0000

Hi Sam and all,

I’m glad to see your draft on SFC OAM framework, it is a very basic and important piece of work in my view.

We have also uploaded an I-D discussing fault management in SFC, does anyone of you have an interest in this kind of work?

The link to this I-D is:

http://tools.ietf.org/html/draft-jxc-sfc-fm-00

Your opinions are greatly appreciated.

Thanks,
Yuanlong

From: sfc [mailto:[email-masked]] On Behalf Of Sam Aldrin
Sent: Thursday, July 03, 2014 3:21 AM
To: [email-masked]
Cc: Carlos Pignataro (cpignata); Nobo Akiya (nobo)
Subject: [sfc] Fwd: New Version Notification for draft-aldrin-sfc-oam-framework-00.txt

Hi,

cheers
-sam
---------- Forwarded message ----------
From: <[email-masked]<mailto:[email-masked]>>
Date: Wed, Jul 2, 2014 at 12:17 PM
Subject: New Version Notification for draft-aldrin-sfc-oam-framework-00.txt
To: Nobo Akiya <[email-masked]<mailto:[email-masked]>>, "Sam K. Aldrin" <[email-masked]<mailto:[email-masked]>>, Carlos Pignataro <[email-masked]<mailto:[email-masked]>>

Name:           draft-aldrin-sfc-oam-framework
Revision:       00
Title:          Service Function Chaining Operations, Administration and Maintenance Framework
Document date:  2014-07-02
Group:          Individual Submission
Pages:          11
URL:            http://www.ietf.org/internet-drafts/draft-aldrin-sfc-oam-framework-00.txt
Status:         https://datatracker.ietf.org/doc/draft-aldrin-sfc-oam-framework/
Htmlized:       http://tools.ietf.org/html/draft-aldrin-sfc-oam-framework-00

Abstract:

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org>.

The IETF Secretariat

---

From: ramki Krishnan <[email-masked]>
Date: Fri, 4 Jul 2014 06:48:05 -0700

Hi Sam, Yuanlong, All,

We uploaded a document on the SFC OAM topic yesterday  – this includes requirements besides framework. Given the importance of this topic, guess many of us were working on this in parallel. We should probably get together in Toronto to take the appropriate next steps.

https://datatracker.ietf.org/doc/draft-krishnan-sfc-oam-req-framework/

Thanks,
Ramki

From: sfc [mailto:[email-masked]] On Behalf Of Jiangyuanlong
Sent: Friday, July 04, 2014 1:17 AM
To: Sam Aldrin; [email-masked]
Cc: Carlos Pignataro (cpignata); Nobo Akiya (nobo)
Subject: [sfc] Fault management in SFC

Hi Sam and all,

The link to this I-D is:

Thanks,
Yuanlong

To: [email-masked]<mailto:[email-masked]>

Hi,

cheers
-sam
---------- Forwarded message ----------
From: <[email-masked]<mailto:[email-masked]>>
Date: Wed, Jul 2, 2014 at 12:17 PM
Subject: New Version Notification for draft-aldrin-sfc-oam-framework-00.txt
To: Nobo Akiya <[email-masked]<mailto:[email-masked]>>, "Sam K. Aldrin" <[email-masked]<mailto:[email-masked]>>, Carlos Pignataro <[email-masked]<mailto:[email-masked]>>

Abstract:

The IETF Secretariat

---

From: "Carlos Pignataro (cpignata)" <[email-masked]>
Date: Fri, 4 Jul 2014 19:41:07 +0000

Hi, Ramki, Yuanlong,

Thanks for bringing up these two documents! Here's my initial observations:

draft-krishnan-sfc-oam-req-framework:

  *   This document seems to be really thin in actual content.
  *   Removing the introduction, acronyms, and boiler, there's a bit over a page of very generic very high-level requirements.
  *   Although the title says "SFC OAM Requirements and Framework", I do not see text supporting a framework.

draft-jxc-sfc-fm-00:

  *   I am concerned with the creation of a new OAM Protocol in Section 3. SFC architectural documents have a goal of reusing OAM protocols, not re-inventing.
  *   It's not clear of the value of defining a TLV structure when there's no Types. In other words, why draw TLV ASCII diagrams when the requirements and gap analysis are not clear?
  *   The document says things like "BFD can also be used as a tool of proactive CC & CV in SFC.", but then goes on into drawing packets...

I agree this can be a topic for discussions in Toronto.

Thanks,

Carlos.

On Jul 4, 2014, at 9:48 AM, ramki Krishnan <[email-masked]<mailto:[email-masked]>> wrote:

Hi Sam, Yuanlong, All,

Thanks,
Ramki

To: Sam Aldrin; [email-masked]<mailto:[email-masked]>

Hi Sam and all,

Thanks,
Yuanlong

Hi,

cheers
-sam
---------- Forwarded message ----------
From: <[email-masked]<mailto:[email-masked]>>
Date: Wed, Jul 2, 2014 at 12:17 PM
Subject: New Version Notification for draft-aldrin-sfc-oam-framework-00.txt
To: Nobo Akiya <[email-masked]<mailto:[email-masked]>>, "Sam K. Aldrin" <[email-masked]<mailto:[email-masked]>>, Carlos Pignataro <[email-masked]<mailto:[email-masked]>>

Abstract:

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org<http://tools.ietf.org/>.

The IETF Secretariat

---

From: Qin Wu <[email-masked]>
Date: Sat, 5 Jul 2014 01:17:19 +0000

We see a lot of energy to do this kind of survey, would it be good to discuss this in TIME mailing list as well?
https://www.ietf.org/mailman/listinfo/time

Regards!
-Qin
发件人: sfc [mailto:[email-masked]] 代表 ramki Krishnan
发送时间: 2014年7月4日 21:48
收件人: Jiangyuanlong; Sam Aldrin; [email-masked]
抄送: Carlos Pignataro (cpignata); Nobo Akiya (nobo); [email-masked]
主题: Re: [sfc] Fault management in SFC

Hi Sam, Yuanlong, All,

Thanks,
Ramki

Hi Sam and all,

The link to this I-D is:

Thanks,
Yuanlong

Hi,

cheers
-sam
---------- Forwarded message ----------
From: <[email-masked]<mailto:[email-masked]>>
Date: Wed, Jul 2, 2014 at 12:17 PM
Subject: New Version Notification for draft-aldrin-sfc-oam-framework-00.txt
To: Nobo Akiya <[email-masked]<mailto:[email-masked]>>, "Sam K. Aldrin" <[email-masked]<mailto:[email-masked]>>, Carlos Pignataro <[email-masked]<mailto:[email-masked]>>

Abstract:

The IETF Secretariat

---

From: Jiangyuanlong <[email-masked]>
Date: Mon, 7 Jul 2014 11:03:34 +0000

Hi Carlos,

Thanks for your comments. Reusing OAM protocols is also what we are after, but that does not necessarily preclude an SFC encapsulation of OAM message.
We discussed several types of OAM, for example, CC & CV, trace route, PM; it appears these are very basic requirements.

Look forward to discussing more with you on this topic in Toronto.

Thanks,
Yuanlong

From: Carlos Pignataro (cpignata) [mailto:[email-masked]]
Sent: Saturday, July 05, 2014 3:41 AM
To: ramki Krishnan
Cc: Jiangyuanlong; Sam Aldrin; [email-masked]; Nobo Akiya (nobo); [email-masked]
Subject: Re: Fault management in SFC

Hi, Ramki, Yuanlong,

draft-jxc-sfc-fm-00:

Thanks,

Carlos.

Hi Sam, Yuanlong, All,

We uploaded a document on the SFC OAM topic yesterday  - this includes requirements besides framework. Given the importance of this topic, guess many of us were working on this in parallel. We should probably get together in Toronto to take the appropriate next steps.

Thanks,
Ramki

Hi Sam and all,

I'm glad to see your draft on SFC OAM framework, it is a very basic and important piece of work in my view.

Thanks,
Yuanlong

Hi,

cheers
-sam
---------- Forwarded message ----------
From: <[email-masked]<mailto:[email-masked]>>
Date: Wed, Jul 2, 2014 at 12:17 PM
Subject: New Version Notification for draft-aldrin-sfc-oam-framework-00.txt
To: Nobo Akiya <[email-masked]<mailto:[email-masked]>>, "Sam K. Aldrin" <[email-masked]<mailto:[email-masked]>>, Carlos Pignataro <[email-masked]<mailto:[email-masked]>>

Abstract:

The IETF Secretariat

---

From: Qin Wu <[email-masked]>
Date: Mon, 7 Jul 2014 12:57:05 +0000

The generic requirements aspect of [email-masked]<mailto:[email-masked]> maybe more fit into
http://tools.ietf.org/html/draft-king-opsawg-time-multi-layer-oam-use-case-01.
draft-king-opsawg-time-multi-layer-oam-use-case-01 did sort out some high level requirements in the section 4.
But high level requirements in draft-king-opsawg-time-multi-layer-oam-use-case-01 are not specific to SFC OAM.
They also can be applicable to Overlay OAM described in section 3.3 of draft-king-opsawg-time-multi-layer-oam-use-case.

Regarding draft-jxc-sfc-fm-00, is it too rush to go to solution scope to discuss what kind of SFC specific OAM functionalities need to be support and
What SFC specific packet format looks like?

Regards!
-Qin
发件人: sfc [mailto:[email-masked]] 代表 Carlos Pignataro (cpignata)
发送时间: 2014年7月5日 3:41
收件人: ramki Krishnan
抄送: Sam Aldrin; Jiangyuanlong; Nobo Akiya (nobo); [email-masked]; [email-masked]
主题: Re: [sfc] Fault management in SFC

Hi, Ramki, Yuanlong,

draft-jxc-sfc-fm-00:

Thanks,

Carlos.

Hi Sam, Yuanlong, All,

Thanks,
Ramki

Hi Sam and all,

Thanks,
Yuanlong

Hi,

cheers
-sam
---------- Forwarded message ----------
From: <[email-masked]<mailto:[email-masked]>>
Date: Wed, Jul 2, 2014 at 12:17 PM
Subject: New Version Notification for draft-aldrin-sfc-oam-framework-00.txt
To: Nobo Akiya <[email-masked]<mailto:[email-masked]>>, "Sam K. Aldrin" <[email-masked]<mailto:[email-masked]>>, Carlos Pignataro <[email-masked]<mailto:[email-masked]>>

Abstract:

The IETF Secretariat