Subject: [sfc] Comments on draft-quinn-sfc-nsh-03

From: Xuxiaohu <[email-masked]>
Date: Mon, 7 Jul 2014 10:12:58 +0000

Hi co-authors of this draft,

I'm glad to see that the Service Path Header is decoupled from the Base Header of the NSH while the MD Type field is introduced. With such MD Type field, it becomes possible that the Base Header could be followed by 1) a Service Path Header, 2) a context header or 3) both. Option 1 would be used between SFFs in the case where metadata is not required to be shared. Option 2 would be used between SFFs and SFs in the case where SFs don't care about the service path information at all. Option 3 would be used between SFFs in the case where metadata is required to be shared. If you agree with the above possible usages, it may be helpful to allocate two additional MT Type codes besides 0x1 so as to indicate the above three options.

Best regards,
Xiaohu

---

From: Lucy yong <[email-masked]>
Date: Mon, 7 Jul 2014 15:15:42 +0000

IMO: this is good suggestion. We should allow the solution that the SFP is configured by the control plane ahead so no SFP info is in SFC encapsulation. We should also allow the solution that no metadata is conveyed along SFC path.

Lucy

-----Original Message-----
From: sfc [mailto:[email-masked]] On Behalf Of Xuxiaohu
Sent: Monday, July 07, 2014 5:13 AM
To: [email-masked]
Subject: [sfc] Comments on draft-quinn-sfc-nsh-03

I'm glad to see that the Service Path Header is decoupled from the Base Header of the NSH while the MD Type field is introduced. With such MD Type field, it becomes possible that the Base Header could be followed by 1) a Service Path Header, 2) a context header or 3) both. Option 1 would be used between SFFs in the case where metadata is not required to be shared. Option 2 would be used between SFFs and SFs in the case where SFs don't care about the service path information at all. Option 3 would be used between SFFs in the case where metadata is required to be shared. If you agree with the above possible usages, it may be helpful to allocate two additional MD Type codes besides 0x1 so as to indicate the above three options.

Best regards,
Xiaohu

_______________________________________________
sfc mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/sfc