Subject: Re: [sfc] Proposed IRTF Network Functions Virtualization Research Group (NFVRG) - first face-to-face meeting at Toronto

From: "Ken Gray (kegray)" <[email-masked]>
Date: Tue, 8 Jul 2014 13:31:22 +0000

Hey, Ramki.

Couple minor nits on my part:

First, how is this different than the two years of work that was done in ETSI NFV (papers, PoCs, gap-analysis, the works)?  Assuming the fundamental difference is the word "research", how will the research be "qualified" (unique/not-presented-in-another-forum, non-derivative, vendor-agnostic/no-marketing-please, etc.)?

Second, the wording " input to other related standards efforts in ETSI" … brings me back to question one but with a clarification … that was a "study group", right … so, in that specific example wouldn't this be duplication (where "study" and "research" have a good deal of overlap semantically)?

Finally, as Robert has pointed out, there are areas for overlap that need a bit of delineation …and not just in SFC.  My example would be the SDNRG …how will content distribution be decided between the two (of course SDN is not NFV, but there is a relationship in some cases/architectures there so why not just add this to their charter)?

From: ramki Krishnan <[email-masked]<mailto:[email-masked]>>
Date: Monday, July 7, 2014 4:08 PM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Cc: "DIEGO LOPEZ GARCIA ([email-masked]<mailto:[email-masked]>)" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [sfc] Proposed IRTF Network Functions Virtualization Research Group (NFVRG) - first face-to-face meeting at Toronto

Overview of proposed IRTF Network Functions Virtualization Research Group (NFVRG)

Network Function Virtualization (NFV) is a key emerging area for network operators, hardware and software vendors, cloud service providers, and in general network practitioners and researchers. This area requires exploring new directions and working collaboratively on how to create network services that utilize a virtualized infrastructure. Network functions that are traditionally implemented in dedicated hardware appliances will need to be decomposed and executed in virtual machines running in data centers. One key goal of this new area is to reduce capital and operating expenditures for future deployments for networks and associated services. Another important goal is for the network operators to be able to offer value added cloud services to their customers. Finally, new business models will open for the provision of network services.
The technologies enabling the virtualization of network functions are currently in an early stage of, and they need researchers to develop new architectures, systems, and software, and to explore tradeoffs and possibilities for leveraging virtualized infrastructure to provide support for network functions. The Network Functions Virtualization Research Group (NFVRG) will bring together researchers and grow the community around the world in both academia and industry to explore this new research area through workshops, research group meetings etc. at premier conferences such as IEEE ICC, IEEE Globecom and inviting special issues in well-known journals. Some of the key topics of research include virtualization of fixed and mobile network infrastructures, new network architectures based on virtualized network functions, virtualization of the home and enterprise network environments, co-existence with non-virtualized infrastructure and services, and application to growing areas of concern such as Internet of Things (IoT) and next generation content distribution.
The NFVRG will focus on research problems associated with these topics and on bringing a research community together that can jointly address such problems, concentrating on problems that relate not just to networking but also to computing and storage constraints in such environments. It is also hoped that the outcome of the research will benefit standardization efforts that can get spawned via IRTF & IETF BoF meetings and/or provide useful input to other related standards efforts in ETSI or other standards bodies.
More details can be found at - http://trac.tools.ietf.org/group/irtf/trac/wiki/nfvrg
First face-to-face Meeting in Toronto

The first face-to-face meeting of the proposed NFVRG will be held along with the IETF meeting in Toronto on July 30th Wednesday from 11:30am to 1:00pm in the Canadian (C) Room (immediately after the SFC meeting). Please let us know if you have research topics to present during the meeting. Would really appreciate active discussions in the mailing list [email-masked]<mailto:[email-masked]>.
Thanks,
Ramki on behalf of the NFVRG co-chairs

---

From: DIEGO LOPEZ GARCIA <[email-masked]>
Date: Tue, 8 Jul 2014 15:40:23 +0000

Hi Ken,

What the ETSI ISG has done was conceived as pre-standardization tasks, no active research. I'd say the research will be qualified in the same way it is done in the other IRTF groups: by the chairs of the group, with the collaboration of the IRTF chair and the whole community.

An ISG in ETSI is an "Industrial Specification Group", not "study", and its purpose is to produce essentially pre-standardization results (as well as some normative material in terms of requirements, for example, if agreed by the group) and not to report research results.

Finally, the idea of making it an extension of SDNRG is something we discussed, but the SDNRG is already extended enough to accommodate a new item that by itself constitutes a separate approach to networking and hopefully will attract significative attention. For sure there will be boundary cases (where aren't they?) and we'll have to coordinate this with the SDNRG chairs.

Be goode,

On 8 Jul 2014, at 15:31 , Ken Gray (kegray) <[email-masked]<mailto:[email-masked]>> wrote:

Hey, Ramki.

--
PLEASE NOTE MY NEW EMAIL ADDRESS
"Esta vez no fallaremos, Doctor Infierno"

Dr Diego R. Lopez
Telefonica I+D
http://people.tid.es/diego.lopez/

e-mail: [email-masked]
Tel:    +34 913 129 041
Mobile: +34 682 051 091
----------------------------------

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição

---

From: "Ken Gray (kegray)" <[email-masked]>
Date: Tue, 8 Jul 2014 17:49:08 +0000

Hey, Diego, thanks for replying.

To be frank, I'm skeptical about the statement that the outputs of the group might be used as inputs to other SDOs, though I admire the optimism.

I wonder, if the work isn't unique to the IRTF, then why wouldn't the researcher just plug it directly into other SDOs where it might be applicable without the IRTF middleman?

The proposal accurately states that topics in the NFV space have already been broached in other venues (like the IEEE).  What I would hope, should this proceed, is that there be some clear research areas defined/sponsored by the IRTF that are not already being covered elsewhere … rather than attracting the same work to be presented or repeated in the IRTF.

I think the fundamental test of creation should be in the answer to "what will you produce?" and the answer, again … IMO, should be "new ideas/findings".

From: DIEGO LOPEZ GARCIA <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, July 8, 2014 11:40 AM
To: Ken Gray <[email-masked]<mailto:[email-masked]>>
Cc: ramki Krishnan <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: [sfc] Proposed IRTF Network Functions Virtualization Research Group (NFVRG) - first face-to-face meeting at Toronto

Hi Ken,

Be goode,

Hey, Ramki.

Dr Diego R. Lopez
Telefonica I+D

e-mail: [email-masked]<mailto:[email-masked]>
Tel:    +34 913 129 041
Mobile: +34 682 051 091
----------------------------------

---

From: DIEGO LOPEZ GARCIA <[email-masked]>
Date: Tue, 8 Jul 2014 20:30:49 +0000

Hi Ken,

I can assure you that at least for the NFV ISG the results will be used: the dynamic of that group would welcome the results of the group. And I do hope some of IETF WGs will do as well.

The rest of your concerns is applicable to any other hot topic. You name it, but probably SDN would be the archetypal example. The only we can commit is to our best to encourage the production of new ideas and findings.

Be goode,

On 8 Jul 2014, at 19:49 , Ken Gray (kegray) <[email-masked]<mailto:[email-masked]>> wrote:

Hi Ken,

Be goode,

Hey, Ramki.

Dr Diego R. Lopez
Telefonica I+D

Dr Diego R. Lopez
Telefonica I+D