Subject: Re: [sfc] A new draft-wei-sfc-mobile-consideration-00.

From: "Ken Gray (kegray)" <[email-masked]>
Date: Sun, 6 Jul 2014 20:55:54 +0000

Hey, Wei.

Thanks for the document.  I would suggest that you normalize your terminology in 2.1 (LSFC and PSFC) with whatever Joel and Carlos are cooking (draft-merged-sfc-architecture) – otherwise it looks like you're adding to architecture through a use case.  That is, try and use their terms and not new ones.

You take a shot at the interactions between LTE and SFC, and as someone else has already identified, maybe you need more detail?

When you dig into the mobile architecture, is there a specific requirement you see of the chain itself, like the relaying of metadata, the need for forking in some of the flow paths (e.g. Charging)?

Instead of mapping/wiring SFC into mobile (the GiLAN is an obvious use and I encourage you to walk through a complete example), any thought to how the LTE service chain might be re-envisioned in the presence of SFC (change in roles, less reliance on DNS tricks, lower Diameter requirements)?

Thanks for the document.

From: Weixinpeng <[email-masked]<mailto:[email-masked]>>
Date: Tuesday, July 1, 2014 5:44 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [sfc] A new draft-wei-sfc-mobile-consideration-00.

Hi all,

A new draft on Interaction between SFC network and 3GPP network has been submitted. Comments are welcomed!

Best Regards,

Xinpeng

Name:               draft-wei-sfc-mobile-consideration-00

Revision:  00

Title:                  Interaction between SFC network and 3GPP network

Document date:       2014-06-30

Group:               Individual Submission

Pages:               7

URL:            http://www.ietf.org/internet-drafts/draft-wei-sfc-mobile-consideration-00.txt

Status:         https://datatracker.ietf.org/doc/draft-wei-sfc-mobile-consideration/

Htmlized:       http://tools.ietf.org/html/draft-wei-sfc-mobile-consideration-00

Abstract:

   This document provides a discussion of how SFC (Service Function

   Chain) domain could interact with carrier network to provide network

   service for traffic. Here LTE (Long Term Evolution) network is used

   as an example of carrier network for discussion.

---

From: Weixinpeng <[email-masked]>
Date: Mon, 7 Jul 2014 09:22:45 +0000

Hi Ken,
Please see my answers inline. Thanks!

BR,
Xinpeng

From: Ken Gray (kegray) [mailto:[email-masked]]
Sent: Monday, July 07, 2014 4:56 AM
To: Weixinpeng; [email-masked]
Subject: Re: [sfc] A new draft-wei-sfc-mobile-consideration-00.

Hey, Wei.

Thanks for the document.  I would suggest that you normalize your terminology in 2.1 (LSFC and PSFC) with whatever Joel and Carlos are cooking (draft-merged-sfc-architecture) - otherwise it looks like you're adding to architecture through a use case.  That is, try and use their terms and not new ones.
[Wei] Ok, comparing the two documents, I think LSFC is equivalent to SFC and PSFC is equivalent to SFP.

You take a shot at the interactions between LTE and SFC, and as someone else has already identified, maybe you need more detail?
[Wei] Yes, I will provide more detailed discussion on this.

When you dig into the mobile architecture, is there a specific requirement you see of the chain itself, like the relaying of metadata, the need for forking in some of the flow paths (e.g. Charging)?
[Wei] Before the discussion of requirement for the chain,  I think we should first have a clear view of how LTE network and SFC network could interact with each other.

Instead of mapping/wiring SFC into mobile (the GiLAN is an obvious use and I encourage you to walk through a complete example), any thought to how the LTE service chain might be re-envisioned in the presence of SFC (change in roles, less reliance on DNS tricks, lower Diameter requirements)?
[Wei] I think you mentioned a good point, but currently I have not seen any impact, which you mentioned, on LTE service chain.

Thanks for the document.

Hi all,

Best Regards,

Xinpeng

Revision:  00

Pages:               7

Abstract: