Subject: [sfc] Simpler description of Service Function Path

From: Linda Dunbar <[email-masked]>
Date: Wed, 23 Jul 2014 14:05:01 +0000

I think the SFP definition displayed at today SFC session is too complicated, more like lawyer's wording than a term easily understood by engineers (considering there are a lot of IETFers/engineers whose first language is not English).

Here is my suggested simpler wording:

Service Function Path (SFP):
SFP is a pathway traversing a sequence of service functions from ingress to egress of the SFC-enabled domain, including sequence of SFFs and sequence of SFs. This sequence can be specified precisely with exact sequence of SFFs and the sequence of SFs reached by each SFF,  loosely specified with sets of SFFs/SFs, or somewhere in between.

Linda

---

From: "Sprecher, Nurit (NSN - IL/Hod HaSharon)" <[email-masked]>
Date: Wed, 23 Jul 2014 14:40:10 +0000

I would propose to do it even simpler
Service Function Path (SFP):
SFP is a path traversing a sequence of service functions in a SFC-enabled domain. The path includes a sequence of SFFs and/or SFs that can be explicitly or loosely specified. In case of a loosely specification, at least the ingress and the egress SFFs and/or  SFs need to be specified.

From: sfc [mailto:[email-masked]] On Behalf Of ext Linda Dunbar
Sent: Wednesday, July 23, 2014 5:05 PM
To: [email-masked]
Subject: [sfc] Simpler description of Service Function Path

Linda

---

From: Lucy yong <[email-masked]>
Date: Wed, 23 Jul 2014 15:00:22 +0000

How about:

SFP is a path traversing a sequence of service functions in a SFC-enabled domain. The path includes a sequence of SFFs and/or SFs that can be explicitly or loosely specified.

Lucy

From: sfc [mailto:[email-masked]] On Behalf Of Sprecher, Nurit (NSN - IL/Hod HaSharon)
Sent: Wednesday, July 23, 2014 9:40 AM
To: Linda Dunbar; [email-masked]
Subject: Re: [sfc] Simpler description of Service Function Path

From: sfc [mailto:[email-masked]] On Behalf Of ext Linda Dunbar
Sent: Wednesday, July 23, 2014 5:05 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [sfc] Simpler description of Service Function Path

Linda

---

From: "Carlos Pignataro (cpignata)" <[email-masked]>
Date: Wed, 23 Jul 2014 16:15:32 +0000

Lucy, Linda, Nurit,

I do not think that a self-referencing definition will help -- i.e., I am sure "A service function path is a path traversing service functions" is correct but it's not particularly clarifying...

Stepping back a bit, this (proposed by Joel) is where we are and what was discussed on the list and presented today.

   Service Function Path (SFP):  The SFP provides a level of indirection
        between the fully abstract notion of service chain as a sequence
        of functions to be delivered, and the fully specified notion of
        exactly what instances of SFFs the packet will visit when it
        actually traverses the network.  By allowing the control
        components to specify the use of this level of indirection, the
        deployment may choose the degree of SFF/SF instance selection
        authority that is delegated to the network.

I agree it's perhaps not the easiest English to parse, but nonetheless is inclusive of all discussion and captures all key points, while excludes noise.

What specific concerns do you have with this definition? (i.e., what meaning is missing?)

Thanks,

Carlos.

On Jul 23, 2014, at 11:00 AM, Lucy yong <[email-masked]<mailto:[email-masked]>> wrote:

How about:

Lucy

From: sfc [mailto:[email-masked]] On Behalf Of Sprecher, Nurit (NSN - IL/Hod HaSharon)
Sent: Wednesday, July 23, 2014 9:40 AM
To: Linda Dunbar; [email-masked]<mailto:[email-masked]>
Subject: Re: [sfc] Simpler description of Service Function Path

I think the SFP definition displayed at today SFC session is too complicated, more like lawyer’s wording than a term easily understood by engineers (considering there are a lot of IETFers/engineers whose first language is not English).

Linda
_______________________________________________
sfc mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/sfc

---

From: "[email-masked]" <[email-masked]>
Date: Wed, 23 Jul 2014 12:40:09 -0400

Agreed.   I think this is well written, clear, and neither restrictive nor suggestive of any particular implementation.  

From: [email-masked]<[email-masked]>
To: Lucy yong<[email-masked]>
cc: Sprecher, Nurit (NSN - IL/Hod HaSharon)<[email-masked]>,[email-masked]<[email-masked]>,Linda Dunbar<[email-masked]>
Sent: Wednesday, July 23, 2014
Subject: Re: [sfc] Simpler description of Service Function Path

Lucy, Linda, Nurit,

Thanks,

Carlos.

On Jul 23, 2014, at 11:00 AM, Lucy yong <[email-masked]> wrote:

How about:

Lucy

From: sfc [mailto:[email-masked]] On
 Behalf Of Sprecher, Nurit (NSN - IL/Hod HaSharon)

To: Linda Dunbar; 
[email-masked]

 

SFP is a path traversing a sequence of service functions in a SFC-enabled domain. The path includes a sequence of SFFs and/or SFs that can be explicitly or loosely specified. In case of a loosely specification, at least
 the ingress and the egress SFFs and/or  SFs need to be specified.

From: sfc [mailto:[email-masked]] On
 Behalf Of ext Linda Dunbar

To: [email-masked]

 

SFP is a pathway traversing a sequence of service functions from ingress to egress of the SFC-enabled domain, including sequence of SFFs and sequence of SFs. This sequence can be specified precisely with exact sequence of SFFs and the sequence
 of SFs reached by each SFF,  loosely specified with sets of SFFs/SFs, or somewhere in between.

Linda

sfc mailing list

[email-masked]

---

From: "Dolganow, Andrew (Andrew)" <[email-masked]>
Date: Wed, 23 Jul 2014 17:15:55 +0000

I agree with definition to be clear and flexible. If people really want to change it , then here is an attempt to shorten theexisting definitions rather than replacing it:

Service Function Path (SFP): The SFP provides a level of indirection between service chain (an abstract sequence of functions to be delivered) and SFFs the packet will visit when it
actually traverses the network. The use of this level of indirection, allows flexibility in a degree of SFF/SF instance selection  that can be delegated to the network.

Andrew

On 2014-07-23, 12:40 PM, "[email-masked]<mailto:[email-masked]>" wrote:

________________________________
From: [email-masked]<mailto:[email-masked]><[email-masked]<mailto:[email-masked]>>
To: Lucy yong<[email-masked]<mailto:[email-masked]>>
cc: Sprecher, Nurit (NSN - IL/Hod HaSharon)<[email-masked]<mailto:[email-masked]>>,[email-masked]<mailto:[email-masked]><[email-masked]<mailto:[email-masked]>>,Linda Dunbar<[email-masked]<mailto:[email-masked]>>
Sent: Wednesday, July 23, 2014
Subject: Re: [sfc] Simpler description of Service Function Path

Lucy, Linda, Nurit,

Thanks,

Carlos.

How about:
From:sfc [mailto:[email-masked]]On Behalf Of Sprecher, Nurit (NSN - IL/Hod HaSharon)
From:sfc [mailto:[email-masked]]On Behalf Of ext Linda Dunbar

---

From: Lucy yong <[email-masked]>
Date: Wed, 23 Jul 2014 18:21:52 +0000

Joel's proposed text is clear and does not miss anything. Easier reading was suggested.
Lucy

From: Carlos Pignataro (cpignata) [mailto:[email-masked]]
Sent: Wednesday, July 23, 2014 11:16 AM
To: Lucy yong
Cc: Sprecher, Nurit (NSN - IL/Hod HaSharon); Linda Dunbar; [email-masked]
Subject: Re: [sfc] Simpler description of Service Function Path

Lucy, Linda, Nurit,

Thanks,

Carlos.

How about:

Lucy

Linda

---

From: Jiangyuanlong <[email-masked]>
Date: Wed, 23 Jul 2014 18:53:58 +0000

Hi Carlos,

Maybe I miss something, I see "instances of SFF" and 'SFF/SF instance" in the definition of SFP, but could not find any use of "SFF instance" in the texts.
Are you proposing that both SFF and SF are abstracted concepts? Why we introduce "SFF instance" but never use it in the context?

Regards,
Yuanlong

From: sfc [mailto:[email-masked]] On Behalf Of Carlos Pignataro (cpignata)
Sent: Thursday, July 24, 2014 12:16 AM
To: Lucy yong
Cc: Sprecher, Nurit (NSN - IL/Hod HaSharon); [email-masked]; Linda Dunbar
Subject: Re: [sfc] Simpler description of Service Function Path

Lucy, Linda, Nurit,

Thanks,

Carlos.

How about:

Lucy

Linda

---

From: "Carlos Pignataro (cpignata)" <[email-masked]>
Date: Thu, 24 Jul 2014 14:48:14 +0000

Hi, Yuanlong,

This is a good callout -- thanks. We will scrub through the use of "instance" as part of incorporating the SFP definition and feedback.

Thanks!

Carlos.

On Jul 23, 2014, at 2:53 PM, Jiangyuanlong <[email-masked]<mailto:[email-masked]>> wrote:

Hi Carlos,

Maybe I miss something, I see “instances of SFF” and ‘SFF/SF instance” in the definition of SFP, but could not find any use of “SFF instance” in the texts.
Are you proposing that both SFF and SF are abstracted concepts? Why we introduce “SFF instance” but never use it in the context?

Regards,
Yuanlong

From: sfc [mailto:[email-masked]] On Behalf Of Carlos Pignataro (cpignata)
Sent: Thursday, July 24, 2014 12:16 AM
To: Lucy yong
Cc: Sprecher, Nurit (NSN - IL/Hod HaSharon); [email-masked]<mailto:[email-masked]>; Linda Dunbar
Subject: Re: [sfc] Simpler description of Service Function Path

Lucy, Linda, Nurit,

Thanks,

Carlos.

How about:

Lucy

Linda

---

From: "Russ White" <[email-masked]>
Date: Thu, 24 Jul 2014 13:44:28 -0400

> Service Function Path (SFP): The SFP provides a level of indirection
between
> service chain (an abstract sequence of functions to be
> delivered) and SFFs the packet will visit when it actually traverses the
> network. The use of this level of indirection, allows flexibility in a
degree of
> SFF/SF instance selection  that can be delegated to the network.

Or perhaps:

Service Function Path (SFP): A sequence of functions through which traffic
must be delivered in traversing the network. The SFP is an indirect or
abstract topology representation, allowing flexibility in the actual
instances of service functions delegated to perform the actual functions.

Or something more along these lines... IMHO, the language is getting a bit
"technical" for someone who's approaching these documents for the first time
to grock, so we need to put things in less self-referential terms entirely
(if possible).

:-)

Russ

---

From: Jiangyuanlong <[email-masked]>
Date: Thu, 24 Jul 2014 18:18:26 +0000

Thank you for the hard work, and I hope  the result can also be reflected in the PS draft.

Cheers,
Yuanlong

From: Carlos Pignataro (cpignata) [mailto:[email-masked]]
Sent: Thursday, July 24, 2014 10:48 PM
To: Jiangyuanlong
Cc: Lucy yong; Sprecher, Nurit (NSN - IL/Hod HaSharon); [email-masked]; Linda Dunbar
Subject: Re: [sfc] Simpler description of Service Function Path

Hi, Yuanlong,

Thanks!

Carlos.

Hi Carlos,

Regards,
Yuanlong

Lucy, Linda, Nurit,

Thanks,

Carlos.

How about:

Lucy

Linda

---

From: "Darrel Lewis (darlewis)" <[email-masked]>
Date: Fri, 25 Jul 2014 19:32:41 +0000

Yes, and I hope even more fervently, that we can move beyond the definition of terms to the definition of content.

-D
On Jul 24, 2014, at 11:18 AM, Jiangyuanlong <[email-masked]> wrote:

> On Jul 23, 2014, at 2:53 PM, Jiangyuanlong <[email-masked]> wrote:
> 
> 
> Hi Carlos,
>