Subject: [sfc] Proposed IRTF Network Functions Virtualization Research Group (NFVRG) - first face-to-face meeting at Toronto

From: ramki Krishnan <[email-masked]>
Date: Mon, 7 Jul 2014 13:08:50 -0700

Overview of proposed IRTF Network Functions Virtualization Research Group (NFVRG)

Network Function Virtualization (NFV) is a key emerging area for network operators, hardware and software vendors, cloud service providers, and in general network practitioners and researchers. This area requires exploring new directions and working collaboratively on how to create network services that utilize a virtualized infrastructure. Network functions that are traditionally implemented in dedicated hardware appliances will need to be decomposed and executed in virtual machines running in data centers. One key goal of this new area is to reduce capital and operating expenditures for future deployments for networks and associated services. Another important goal is for the network operators to be able to offer value added cloud services to their customers. Finally, new business models will open for the provision of network services.
The technologies enabling the virtualization of network functions are currently in an early stage of, and they need researchers to develop new architectures, systems, and software, and to explore tradeoffs and possibilities for leveraging virtualized infrastructure to provide support for network functions. The Network Functions Virtualization Research Group (NFVRG) will bring together researchers and grow the community around the world in both academia and industry to explore this new research area through workshops, research group meetings etc. at premier conferences such as IEEE ICC, IEEE Globecom and inviting special issues in well-known journals. Some of the key topics of research include virtualization of fixed and mobile network infrastructures, new network architectures based on virtualized network functions, virtualization of the home and enterprise network environments, co-existence with non-virtualized infrastructure and services, and application to growing areas of concern such as Internet of Things (IoT) and next generation content distribution.
The NFVRG will focus on research problems associated with these topics and on bringing a research community together that can jointly address such problems, concentrating on problems that relate not just to networking but also to computing and storage constraints in such environments. It is also hoped that the outcome of the research will benefit standardization efforts that can get spawned via IRTF & IETF BoF meetings and/or provide useful input to other related standards efforts in ETSI or other standards bodies.
More details can be found at - http://trac.tools.ietf.org/group/irtf/trac/wiki/nfvrg
First face-to-face Meeting in Toronto

The first face-to-face meeting of the proposed NFVRG will be held along with the IETF meeting in Toronto on July 30th Wednesday from 11:30am to 1:00pm in the Canadian (C) Room (immediately after the SFC meeting). Please let us know if you have research topics to present during the meeting. Would really appreciate active discussions in the mailing list [email-masked].
Thanks,
Ramki on behalf of the NFVRG co-chairs

---

From: Robert Raszuk <[email-masked]>
Date: Mon, 7 Jul 2014 22:28:46 +0200

Hi Ramki,

> Another important goal is for the network operators to be able to
> offer value added cloud services to their customers.

The above goal of NFVRG seems like identical goal of IETF SFC WG.

Per your write-up I think there may be significant overlap between the
two groups.

That is not to say that NFVRG could not be build and chartered to be
unique with zero overlap, but that is not what your overview says.

I think it may be useful to clarify this before the face to face meeting.

Thx,
R.

On Mon, Jul 7, 2014 at 10:08 PM, ramki Krishnan <[email-masked]> wrote:
> Network Function Virtualization (NFV) is a key emerging area for network
> operators, hardware and software vendors, cloud service providers, and in
> general network practitioners and researchers. This area requires exploring
> new directions and working collaboratively on how to create network services
> that utilize a virtualized infrastructure. Network functions that are
> traditionally implemented in dedicated hardware appliances will need to be
> decomposed and executed in virtual machines running in data centers. One key
> goal of this new area is to reduce capital and operating expenditures for
> future deployments for networks and associated services. Another important
> goal is for the network operators to be able to offer value added cloud
> services to their customers. Finally, new business models will open for the
> provision of network services.
>
> The technologies enabling the virtualization of network functions are
> currently in an early stage of, and they need researchers to develop new
> architectures, systems, and software, and to explore tradeoffs and
> possibilities for leveraging virtualized infrastructure to provide support
> for network functions. The Network Functions Virtualization Research Group
> (NFVRG) will bring together researchers and grow the community around the
> world in both academia and industry to explore this new research area
> through workshops, research group meetings etc. at premier conferences such
> as IEEE ICC, IEEE Globecom and inviting special issues in well-known
> journals. Some of the key topics of research include virtualization of fixed
> and mobile network infrastructures, new network architectures based on
> virtualized network functions, virtualization of the home and enterprise
> network environments, co-existence with non-virtualized infrastructure and
> services, and application to growing areas of concern such as Internet of
> Things (IoT) and next generation content distribution.
>
> The NFVRG will focus on research problems associated with these topics and
> on bringing a research community together that can jointly address such
> problems, concentrating on problems that relate not just to networking but
> also to computing and storage constraints in such environments. It is also
> hoped that the outcome of the research will benefit standardization efforts
> that can get spawned via IRTF & IETF BoF meetings and/or provide useful
> input to other related standards efforts in ETSI or other standards bodies.
>
> More details can be found at -
> http://trac.tools.ietf.org/group/irtf/trac/wiki/nfvrg
>
> The first face-to-face meeting of the proposed NFVRG will be held along with
> the IETF meeting in Toronto on July 30th Wednesday from 11:30am to 1:00pm in
> the Canadian (C) Room (immediately after the SFC meeting). Please let us
> know if you have research topics to present during the meeting. Would really
> appreciate active discussions in the mailing list [email-masked].
>
> Thanks,
>
> _______________________________________________
> sfc mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/sfc
>

---

From: DIEGO LOPEZ GARCIA <[email-masked]>
Date: Mon, 7 Jul 2014 22:35:10 +0000

Hi Robert,

I am under the impression that the term "cloud services" has a too wide meaning. While in SFC I understand we are talking on services located in datacenters, in the NFV context we are talking about network functions that have been virtualized into a cloud-like infrastructure. I agree with you that this term has to be clarified, though I think it is clear in the proposed charter available in the Wiki.

Anyway, SFC has the provision of NFV service forwarding graphs as one of its use cases, so a certain intersection is not only unavoidable but necessary.

Be goode,

On 7 Jul 2014, at 22:28 , Robert Raszuk <[email-masked]<mailto:[email-masked]>> wrote:

Hi Ramki,

Thx,
R.

On Mon, Jul 7, 2014 at 10:08 PM, ramki Krishnan <[email-masked]<mailto:[email-masked]>> wrote:
Overview of proposed IRTF Network Functions Virtualization Research Group
(NFVRG)

Thanks,

--
PLEASE NOTE MY NEW EMAIL ADDRESS
"Esta vez no fallaremos, Doctor Infierno"

Dr Diego R. Lopez
Telefonica I+D
http://people.tid.es/diego.lopez/

e-mail: [email-masked]
Tel:    +34 913 129 041
Mobile: +34 682 051 091
----------------------------------

________________________________

Este mensaje y sus adjuntos se dirigen exclusivamente a su destinatario, puede contener información privilegiada o confidencial y es para uso exclusivo de la persona o entidad de destino. Si no es usted. el destinatario indicado, queda notificado de que la lectura, utilización, divulgación y/o copia sin autorización puede estar prohibida en virtud de la legislación vigente. Si ha recibido este mensaje por error, le rogamos que nos lo comunique inmediatamente por esta misma vía y proceda a su destrucción.

The information contained in this transmission is privileged and confidential information intended only for the use of the individual or entity named above. If the reader of this message is not the intended recipient, you are hereby notified that any dissemination, distribution or copying of this communication is strictly prohibited. If you have received this transmission in error, do not read it. Please immediately reply to the sender that you have received this communication in error and then delete it.

Esta mensagem e seus anexos se dirigem exclusivamente ao seu destinatário, pode conter informação privilegiada ou confidencial e é para uso exclusivo da pessoa ou entidade de destino. Se não é vossa senhoria o destinatário indicado, fica notificado de que a leitura, utilização, divulgação e/ou cópia sem autorização pode estar proibida em virtude da legislação vigente. Se recebeu esta mensagem por erro, rogamos-lhe que nos o comunique imediatamente por esta mesma via e proceda a sua destruição