Subject: [sfc] Fw: New Version Notification for draft-mackie-sfc-using-virtual-networking-02.txt

From: Stuart Mackie <[email-masked]>
Date: Fri, 17 Oct 2014 21:09:14 +0000

Hi Everybody

The purpose of this draft is to act as an existence proof that shows that SFCs can be implemented using existing protocols and existing router functionality when a controller is used to manage SFC topologies. The document uses MPLS over GRE as an example encapsulation protocol, and shows how SFCs can be implemented using both physical and virtualized forwarding functions. There is also discussion of load balancing and how to deal with forward and reverse flow symmetry and service scaling.

(It's version -02 since I took care of editing a few errors).

Comments welcome?.

Stuart

................................

Stuart Mackie
SDN/NFV Architect

+1 914 886 2534
________________________________
From: [email-masked] <[email-masked]>
Sent: Friday, October 17, 2014 4:52 PM
To: Maria Napierala; Maria Napierala; Bruno Rijsman; Diego Daino; EXT - [email-masked]; Stuart Mackie; Diego R.Lopez; Stuart Mackie; Diego R. Lopez; EXT - [email-masked]; Diego Daino; Walter Haeffner; Bruno Rijsman; Walter Haeffner
Subject: New Version Notification for draft-mackie-sfc-using-virtual-networking-02.txt

A new version of I-D, draft-mackie-sfc-using-virtual-networking-02.txt
has been successfully submitted by Stuart Mackie and posted to the
IETF repository.

Name:           draft-mackie-sfc-using-virtual-networking
Revision:       02
Title:          Service Function Chains Using Virtual Networking
Document date:  2014-10-17
Group:          Individual Submission
Pages:          44
URL:            http://www.ietf.org/internet-drafts/draft-mackie-sfc-using-virtual-networking-02.txt
Status:         https://datatracker.ietf.org/doc/draft-mackie-sfc-using-virtual-networking/
Htmlized:       http://tools.ietf.org/html/draft-mackie-sfc-using-virtual-networking-02
Diff:           http://www.ietf.org/rfcdiff?url2=draft-mackie-sfc-using-virtual-networking-02

Abstract:
   This document describes how service function chains (SFC) can be
   applied to traffic flows using routing in a virtual (overlay)
   network to steer traffic between service nodes. Chains can include
   services running in routers, on physical appliances or in virtual
   machines. Service chains have applicability at the subscriber edge,
   business edge and in multi-tenant datacenters. The routing function
   into SFCs and between service functions within an SFC can be
   performed by physical devices (routers), be virtualized inside
   hypervisors, or run as part of a host OS.

   The architecture uses a controller to calculate and install routes
   to implement an SFC, based on a topological model of the chain and
   knowledge of the network addresses that should pass through the
   chain. An advantage of the approach is that SFCs can be implemented
   without alteration to today's BGP standard, and without change to
   the current operation of routers.

   Service chains need to support load balancing between network
   functions, and symmetric forward and reverse paths are required when
   stateful services are involved. This document shows how these
   requirements can be met by using VRFs at the ingress and egress of
   each service instance and by performing load balancing after the
   egress of each service as part of the routing function.

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

The IETF Secretariat

---

From: Stuart Mackie <[email-masked]>
Date: Thu, 30 Oct 2014 19:37:27 +0000

Chairs

I would like to request a 10min slot to present this draft.

Thanks
…………………………..

Stuart Mackie
SDN/NFV Architect

+1 914 886 2534

From: Stuart Mackie <[email-masked]<mailto:[email-masked]>>
Date: Friday, October 17, 2014 at 5:09 PM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: [sfc] Fw: New Version Notification for draft-mackie-sfc-using-virtual-networking-02.txt

Hi Everybody

Comments welcome​.

Stuart

…………………………..

Stuart Mackie
SDN/NFV Architect

+1 914 886 2534
________________________________
From: [email-masked]<mailto:[email-masked]> <[email-masked]<mailto:[email-masked]>>
Sent: Friday, October 17, 2014 4:52 PM
To: Maria Napierala; Maria Napierala; Bruno Rijsman; Diego Daino; EXT - [email-masked]<mailto:[email-masked]>; Stuart Mackie; Diego R.Lopez; Stuart Mackie; Diego R. Lopez; EXT - [email-masked]<mailto:[email-masked]>; Diego Daino; Walter Haeffner; Bruno Rijsman; Walter Haeffner
Subject: New Version Notification for draft-mackie-sfc-using-virtual-networking-02.txt

Abstract:

The IETF Secretariat