Subject: [sfc] Questions to draft-xu-sfc-using-mpls-spring-01

From: Linda Dunbar <[email-masked]>
Date: Wed, 5 Nov 2014 20:10:10 +0000

Xiao Hu, et al,

With the MPLS Stacked Label approach described in your draft, there is really no need for packets to be encapsulated with SFC header anymore, is it?
Or the MPLS label is effectively the SFC ID, correct?

Your draft describes the SFF nodes advertise SIDs (Segment) for their locally attached SFs. Does it mean that each SF  has a unique SID? How about different instances of same Service Function?  Does the SFF also has it own SID?
Each SFF may have many SFs attached to different ports. Does SFF expose those port information to head end classifier node?

Thank you very much,

Linda

---

From: Xuxiaohu <[email-masked]>
Date: Thu, 6 Nov 2014 01:57:55 +0000

Hi Linda,

Your observation is correct.  In the MPLS-SPRING-based SFC approach as described in the draft, since the SFC or SFP information has been encoded in an MPLS label stack, there is no need for carrying the SFC header anymore for the SFC or SFP indication purpose.

As for the SF SID allocation, each SFF which has at least one instance of a given SF attached to it would allocate a label for that SF, rather than allocating a label for each instance. In other words, multiple instances of a given SF would share the same label. How to make a load-balance among those instances of a given SF is local matter of the SFF.

Yes, each SFF would have its own SID which is actually the node SID for that SFF.

Best regards,
Xiaohu

From: Linda Dunbar
Sent: Thursday, November 06, 2014 4:10 AM
To: Xuxiaohu; Lizhenbin; [email-masked]; [email-masked]; [email-masked]
Subject: Questions to draft-xu-sfc-using-mpls-spring-01

Xiao Hu, et al,

Thank you very much,

Linda