Subject: [sfc] draft-quinn-sfc-nsh-03 - " MUST" for Mandatory Context Headers remains the only option for NSH

From: "Dolganow, Andrew (Andrew)" <[email-masked]>
Date: Tue, 4 Nov 2014 16:11:53 +0000

During the last IETF there were several attendees (including myself) who voice strong opinion against mandatory the inclusion of the information beyond based header and service path header. Not all applications require the extra overhead. A discussion on the list followed (see attached email that initiated that discussion) on alternative encodings including mechanisms like use of one of the reserved bit or using another MD Type value to represent header without Mandatory Context Headers.

Can the authors comment on whether they are strongly opposed to include in their draft a proposal that has an option to encode the NSH without the Mandatory Context Headers? I am OK with an encoding that either:

  *   makes  Mandatory Context Headers optional or
  *   Has two types of NSG MD Type 0x1 - the mandatory context headers are present, 0x2 the mandatory context header are not included  (optional variable length metadata could still be used in that type  of header)

Andrew

---

From: Cathy Zhang <[email-masked]>
Date: Mon, 10 Nov 2014 21:49:00 +0000

Hi Andrew,

Thanks for bringing this up. As authors of another service chain header draft (https://datatracker.ietf.org/doc/draft-zhang-sfc-sch/), we support your proposal.
Your proposal is in sync with our service chain header draft, i.e., besides the base header and path header, all other information can be expressed as optional metadata in TLV format.

Last IETF meeting's conclusion is to merge the two header drafts----NSH draft and SCH draft.  We have reached out to the NSH authors about doing the merging as well as addressing the comments/opinions voiced in the Toronto IETF meeting and email alias.

Thanks,
SCH authors

From: sfc [mailto:[email-masked]] On Behalf Of Dolganow, Andrew (Andrew)
Sent: Tuesday, November 04, 2014 8:12 AM
To: [email-masked]
Subject: [sfc] draft-quinn-sfc-nsh-03 - " MUST" for Mandatory Context Headers remains the only option for NSH

Andrew

---

From: "Paul Quinn (paulq)" <[email-masked]>
Date: Tue, 11 Nov 2014 13:14:58 +0000

Cathy,

We need to be accurate here: there was no “conclusion” to merge drafts, rather your co-author presented some slides that highlighted what you and your co-authors feels are areas of similarity and suggested that a merge should occur.  We — the NSH co-authors — are happy to discuss this with you (and are actively doing so) to see if we can reach an agreement on joint text in order to ensure that we meet the WG goals”

Thanks
Paul

On Nov 10, 2014, at 4:49 PM, Cathy Zhang <[email-masked]<mailto:[email-masked]>> wrote:

Hi Andrew,

Last IETF meeting’s conclusion is to merge the two header drafts----NSH draft and SCH draft.  We have reached out to the NSH authors about doing the merging as well as addressing the comments/opinions voiced in the Toronto IETF meeting and email alias.

Thanks,
SCH authors

From: sfc [mailto:[email-masked]] On Behalf Of Dolganow, Andrew (Andrew)
Sent: Tuesday, November 04, 2014 8:12 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [sfc] draft-quinn-sfc-nsh-03 - " MUST" for Mandatory Context Headers remains the only option for NSH

Andrew

_______________________________________________
sfc mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/sfc

---

From: Henry Fourie <[email-masked]>
Date: Fri, 14 Nov 2014 22:50:40 +0000

Paul,
Ron Parker and I met with Surendra Kumar and Jim Guichard in Honolulu to discuss
the merge of the NSH and SCH drafts.

There was agreement on the base header that contains the SFP ID.

The meeting was productive and the differences between the two drafts were discussed
including options for handling the mandatory fields in the NSH.

Jim stated that he wants the authors of both drafts to work together and reach agreement
on a single merged draft before the next IETF meeting in Dallas. There was agreement
for the authors of both drafts to work together to resolve differences and create
a unified draft.

Surendra, Ron, Jim, please add any further comments.

-          Louis

From: sfc [mailto:[email-masked]] On Behalf Of Paul Quinn (paulq)
Sent: Tuesday, November 11, 2014 5:15 AM
To: Cathy Zhang
Cc: Dolganow, Andrew (Andrew); [email-masked]
Subject: Re: [sfc] draft-quinn-sfc-nsh-03 - " MUST" for Mandatory Context Headers remains the only option for NSH

Cathy,

We need to be accurate here: there was no "conclusion" to merge drafts, rather your co-author presented some slides that highlighted what you and your co-authors feels are areas of similarity and suggested that a merge should occur.  We - the NSH co-authors - are happy to discuss this with you (and are actively doing so) to see if we can reach an agreement on joint text in order to ensure that we meet the WG goals"

Thanks
Paul

Hi Andrew,

Thanks,
SCH authors

Andrew

---

From: "Jim Guichard (jguichar)" <[email-masked]>
Date: Fri, 14 Nov 2014 23:47:01 +0000

Just to clarify the expectation of the chairs; what we want to see is a resolution of any differences so that we can move forward with the SFC encapsulation.

Jim

Sent from my iPhone

On Nov 14, 2014, at 12:51 PM, "Henry Fourie" <[email-masked]<mailto:[email-masked]>> wrote:

Paul,

-          Louis

From: sfc [mailto:[email-masked]] On Behalf Of Paul Quinn (paulq)
Sent: Tuesday, November 11, 2014 5:15 AM
To: Cathy Zhang
Cc: Dolganow, Andrew (Andrew); [email-masked]<mailto:[email-masked]>
Subject: Re: [sfc] draft-quinn-sfc-nsh-03 - " MUST" for Mandatory Context Headers remains the only option for NSH

Cathy,

Thanks
Paul

Hi Andrew,

Thanks,
SCH authors

Andrew

---

From: Ron Parker <[email-masked]>
Date: Sat, 15 Nov 2014 03:37:21 +0000

I'll add that Surendra graciously agreed to re-read the SCH proposal and provide comments back to the SCH authors.

    Ron

From: sfc [mailto:[email-masked]] On Behalf Of Jim Guichard (jguichar)
Sent: Friday, November 14, 2014 6:47 PM
To: Henry Fourie
Cc: Dolganow, Andrew (Andrew); Cathy Zhang; Paul Quinn (paulq); [email-masked]
Subject: Re: [sfc] draft-quinn-sfc-nsh-03 - " MUST" for Mandatory Context Headers remains the only option for NSH

Jim

Sent from my iPhone

-        Louis

Cathy,

Thanks
Paul

Hi Andrew,

Thanks,
SCH authors

Andrew

---

From: Shunsuke Homma <[email-masked]>
Date: Tue, 18 Nov 2014 21:22:50 +0900

Hi,

I think that we should clarify the merits of SFC encapsulation (e.g. 
NSH, SCH) without metadata firstly if the context headers are optional.

There are several methods to achieve Service Chaining, and SFC is one of 
them. As one of SFC users, I would like to clarify the motivation to use 
SFC encapsulation without metadata.

In my opinion, scalability is one of the important point of  SFC 
encapsulation, and I summarized the analysis into the following draft.

https://datatracker.ietf.org/doc/draft-homma-sfc-forwarding-methods-analysis/

If you have any other opinions, please let me know.

Cheers,
Shunsuke

(2014/11/15 12:37), Ron Parker wrote:
> I’ll add that Surendra graciously agreed to re-read the SCH proposal and
> provide comments back to the SCH authors.
>
>      Ron
>
> *From:*sfc [mailto:[email-masked]] *On Behalf Of *Jim Guichard
> (jguichar)
> *Sent:* Friday, November 14, 2014 6:47 PM
> *To:* Henry Fourie
> *Cc:* Dolganow, Andrew (Andrew); Cathy Zhang; Paul Quinn (paulq);
> [email-masked]
> *Subject:* Re: [sfc] draft-quinn-sfc-nsh-03 - " MUST" for Mandatory
> Context Headers remains the only option for NSH
>
> Just to clarify the expectation of the chairs; what we want to see is a
> resolution of any differences so that we can move forward with the SFC
> encapsulation.
>
> Jim
>
> Sent from my iPhone
>
>
>     -Louis
>     *From:*sfc [mailto:[email-masked]] *On Behalf Of *Paul Quinn
>     (paulq)
>     *Sent:* Tuesday, November 11, 2014 5:15 AM
>     *To:* Cathy Zhang
>     *Cc:* Dolganow, Andrew (Andrew); [email-masked] <mailto:[email-masked]>
>     *Subject:* Re: [sfc] draft-quinn-sfc-nsh-03 - " MUST" for Mandatory
>     Context Headers remains the only option for NSH
>
>     Cathy,
>
>     We need to be accurate here: there was no “conclusion” to merge
>     drafts, rather your co-author presented some slides that highlighted
>     what you and your co-authors feels are areas of similarity and
>     suggested that a merge should occur.  We — the NSH co-authors — are
>     happy to discuss this with you (and are actively doing so) to see if
>     we can reach an agreement on joint text in order to ensure that we
>     meet the WG goals”
>
>     Thanks
>     Paul
>
>     On Nov 10, 2014, at 4:49 PM, Cathy Zhang <[email-masked]
>     <mailto:[email-masked]>> wrote:
>
>
>
>
>     Hi Andrew,
>
>     Thanks for bringing this up. As authors of another service chain
>     header draft
>     (https://datatracker.ietf.org/doc/draft-zhang-sfc-sch/), we support
>     your proposal.
>
>     Your proposal is in sync with our service chain header draft, i.e.,
>     besides the base header and path header, all other information can
>     be expressed as optional metadata in TLV format.
>
>     Last IETF meeting’s conclusion is to merge the two header
>     drafts----NSH draft and SCH draft.  We have reached out to the NSH
>     authors about doing the merging as well as addressing the
>     comments/opinions voiced in the Toronto IETF meeting and email alias.
>
>     Thanks,
>
>     SCH authors
>
>     *From:*sfc [mailto:[email-masked]]*On Behalf Of*Dolganow,
>     Andrew (Andrew)
>     *Sent:*Tuesday, November 04, 2014 8:12 AM
>     *To:[email-masked] <mailto:[email-masked]>
>     *Subject:*[sfc] draft-quinn-sfc-nsh-03 - " MUST" for Mandatory
>     Context Headers remains the only option for NSH
>
>     During the last IETF there were several attendees (including myself)
>     who voice strong opinion against mandatory the inclusion of the
>     information beyond based header and service path header. Not all
>     applications require the extra overhead. A discussion on the list
>     followed (see attached email that initiated that discussion) on
>     alternative encodings including mechanisms like use of one of the
>     reserved bit or using another MD Type value to represent header
>     without Mandatory Context Headers.
>
>     Can the authors comment on whether they are strongly opposed to
>     include in their draft a proposal that has an option to encode the
>     NSH without the Mandatory Context Headers? I am OK with an encoding
>     that either:
>
>       * Has two types of NSG MD Type 0x1 - the mandatory context headers
>         are present, 0x2 the mandatory context header are not included
>           (optional variable length metadata could still be used in that
>         type  of header)
>
>     Andrew
>
>     [email-masked] <mailto:[email-masked]>
>     [email-masked] <mailto:[email-masked]>
> [email-masked]

-- 
----------------------------------
Shunsuke Homma
<[email-masked]>
TEL: +81 422 59 3486
FAX: +81 422 60 7460

NTT Network Service System Labs.
Musashino city, Tokyo, Japan
----------------------------------

---

From: Ron Parker <[email-masked]>
Date: Tue, 18 Nov 2014 15:24:53 +0000

Shinsuke-san,

One of the goals of SFC is to create a transport-independent service overlay.   This has the effect of reducing the transport visibility to node-to-node, only (ie classifier to SFF or SFF to SFF).    The SFC header, therefore, must contain a field of fields that are used for the end to end chain/path forwarding decision. 

  Ron

> On Nov 18, 2014, at 7:22 AM, Shunsuke Homma <[email-masked]> wrote:
> 
> Hi,
> 
> I think that we should clarify the merits of SFC encapsulation (e.g. NSH, SCH) without metadata firstly if the context headers are optional.
> 
> There are several methods to achieve Service Chaining, and SFC is one of them. As one of SFC users, I would like to clarify the motivation to use SFC encapsulation without metadata.
> 
> In my opinion, scalability is one of the important point of  SFC encapsulation, and I summarized the analysis into the following draft.
>

---

From: Shunsuke Homma <[email-masked]>
Date: Wed, 19 Nov 2014 12:25:37 +0900

Hi Ron,

Thank you for replying. I agree with your opinion, creating a 
transport-independent service overlay is one of the most important 
factor of SFC.

However, other SDN technologies may also enable to create an overlay 
independent of underlay-networks. For example, a combination of OpenFlow 
and an existing transport  header (e.g. GRE) enables to achieve an overlay.

What are the differences of SFC and the alternatives? IMO, one of the 
differences is that SFC header can convey Service(or Chain) information 
over multiple components as logical information. And, it will lead to 
advantage of scalability.

Shunsuke