Subject: Re: [sfc] [nvo3] Concerns about NVO3 dataplane requirements document +BFD

From: Xuxiaohu <[email-masked]>
Date: Fri, 7 Nov 2014 06:19:15 +0000

> > Meta-Data: I probably missed some discussions (sorry!) but what data
> > would this be?
> 
> As I tried to clarify in my response to Tom the meta-data discussion in the IETF
> was mostly about vendor-specific service meta-data, but perhaps this term is
> being used for more general extensibility?
> 
> I think there should be ways to add better assurance (checksum, keyed
> hashes) for the NVO3 header. But perhaps that can be in fixed fields in a fixed
> length header.
> 
> In terms of the overall architecture there is a desire to carry some service
> meta-data with frames. The sfc WG is thinking about doing that using a separate
> NSH header.

The NSH header pursued in the SFC WG contains not only metadata but also service function chain/path info. I wonder whether the SFC is the only application scenario of metadata. If no, it seems better to decouple metadata and the SFC/SFP info.

Best regards,
Xiaohu

---

From: "Larry Kreeger (kreeger)" <[email-masked]>
Date: Sat, 8 Nov 2014 00:59:24 +0000

Hi Xiaohu,

On 11/6/14 10:19 PM, "Xuxiaohu" <[email-masked]> wrote:

>The NSH header pursued in the SFC WG contains not only metadata but also
>service function chain/path info. I wonder whether the SFC is the only
>application scenario of metadata. If no, it seems better to decouple
>metadata and the SFC/SFP info.
>
>Best regards,
>Xiaohu

draft-quinn-sfc-nsh-03 made it possible to use NSH for applications beyond
SFC by adding a MD Type (MD=Metadata) field (one MD Type is allocated for
SFC).  This opens the door to allow NSH to carry extensions to the Network
Virtualization layer beyond what is built into the base header that all
implementations must support, such as a virtual network ID and OAM flag.

 - Larry

>
>_______________________________________________
>nvo3 mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/nvo3