Subject: [sfc] "Critical" flag in draft-quinn-sfc-nsh-04

From: Dave Dolson <[email-masked]>
Date: Wed, 17 Dec 2014 17:00:58 +0000

Paul et al.,

The NSH base header has a critical "C" flag, which appears to apply to optional context headers.
It isn't clearly defined what "critical" means, but my sense is that the SFF and SF must know the semantics of the meta-data, and must not treat it opaquely. Is this view accurate?

Then, what is the criticality of the Mandatory Context Headers (for MD=1)?
Could an SFF or SF treat the Mandatory Context Headers in an opaque manner, or must it know how to interpret them?

If the latter, then should the "C" flag be set when MD=1 ?

David Dolson
Senior Software Architect, Sandvine Inc.

---

From: "Paul Quinn (paulq)" <[email-masked]>
Date: Fri, 19 Dec 2014 00:21:16 +0000

Hi Dave,

See inline please.

On Dec 17, 2014, at 12:00 PM, Dave Dolson <[email-masked]<mailto:[email-masked]>> wrote:

Paul et al.,

The NSH base header has a critical “C” flag, which appears to apply to optional context headers.
It isn’t clearly defined what “critical” means, but my sense is that the SFF and SF must know the semantics of the meta-data, and must not treat it opaquely. Is this view accurate?

I wouldn’t expect the SFF to know about the semantics of the metadata since they don’t need to interpret metadata.  Rather, an SFF needs to forward the metadata for a SF, which in turn must process the critical TLV.

The SFF does not need to parse metadata, the pathID + index are sufficient to handle SFF forwarding, so, yes, they are opaque to an SFF.  One thing to note, the C bit applies only to TLV metadata.

If the latter, then should the “C” flag be set when MD=1 ?

David Dolson

_______________________________________________
sfc mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/sfc